Latest News: (loading..)

EvilBeeker

Members
  • Content count

    12
  • Joined

  • Last visited

1 Follower

About EvilBeeker

Profile Information

  • Real Name
    Kevin Melka
  1. Hello, I'm getting the following error: 1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'or z2g.zone_id = 0 or z2g.zone_id IS NULL ) SELECT dc2z.geo_zone_id FROM discount_coupons_to_zones dc2z LEFT JOIN zones_to_geo_zones z2g USING( geo_zone_id ) WHERE ( z2g.zone_id= or z2g.zone_id = 0 or z2g.zone_id IS NULL ) AND ( z2g.zone_country_id= or z2g.zone_country_id = 0 ) AND dc2z.coupons_id="FFA9YG" I'm using MySQL v4. Is there a way to get around this? Or do I have to upgrade to v5? Thanks
  2. With my issue I was not able to get the download to work until I deleted all of the items out there that would not download properly. Once I did that and added a new item (with the new settings) it worked fine. It was like the system was treating all of the items the same as the first one I entered, even though when I did that the settings in the config were right for later items. Hope this helps. - Kevin
  3. Starting over on the download items worked Bill. Thanks! Must be something about building them with the wrong setting that prevented it from working if the setting were corrected. Thanks again! Kevin
  4. Thanks for your reply Bill; however, problems remain. Regarding your replies: 1) It turned out I had the right path for the catalog/download define. Thanks. 2) I am on the current version of OSC, and I had no errors or issues during installation. After I did the install I backed up everything under catalog, and I found out last night that I did have a PUB directory at that time. What has happened to is since then is a mystery. I copied over the directory and reset the file permissions on everything. After doing this the link I had been testing with still did not work. Now I have a few more questions please: -- In your setup instructions you mention creating item options for DOWNLOAD/YES for the item properties. Does that do anything that would effect the link, or is it just an identifer for the product? I was just wondering if there was something else that needed to be done with that to make the download work. -- Would it be beneficial to delete the item I've been testing with and just start over from scratch with a new item to test? Or should the link "appear" under the test items if everything is all linked correctly. I really don't want to have to start this process all over again with a new install of OSC, since everything is working properly *except* the download link. Thanks for your help. Kevin
  5. Hello, I am experiencing a similar problem as outlined in this thread ... no download link. I followed the instruction to the letter (so I think), and still nothing. Overall though, I've noticed two things that might be preventing this and was hoping I could get someone (Bill) to confirm if this is my issue: 1) Catalog Path In your above example you have some like this: define('DIR_FS_CATALOG', '/home/sounkel6/public_html/catalog/'); I've had several hosting accounts, all with different types of "paths". When I open up the root of my files in an FTP session I have a path of: /www/www/catalog/ in my Remote Site path. That is what I put in the above define statement, but now I have to question if that is the "exact" path. 2) PUB directory In the same config file there is also: define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); The issue I see here is I have no PUB directory. I created one, but there is not one that I can see and I'm using the "out of box" install of OSC (I've only changed the graphics). Please advise. I can get everything else to work except this. Thanks in advance for the help.