Jump to content

jbbeer

Members
  • Content count

    12
  • Joined

  • Last visited

Profile Information

  • Real Name
    Colin Cameron
  1. jbbeer

    Official PayPal IPN Support Thread

    I believe I have found the solution. The problem has to do with the last update [060817]. I made the suggested changes to both compatibility.php files and that seems to have fixed it (see second page of this topic). http://forums.oscommerce.com/index.php?sho...change&st=0
  2. jbbeer

    Official PayPal IPN Support Thread

    Update - I still can't get it to work. It is now uninstalled and I have deleted all files from the server. On the main admin page under 'Orders' there is still a 'Preparing [PayPal IPN]' line. I would have thought this would disappear?!
  3. jbbeer

    Official PayPal IPN Support Thread

    I am attempting to install v2.2. I previously had v1.1 working. I removed it from the admin panel, uploaded the new files and installed the new version. Here's the problem: I am not able to change any of the IPN settings in the admin panel. When I click the update button any of the changes that I have made are lost.
  4. jbbeer

    Official PayPal IPN Support Thread

    I am having a problem with the way PayPal is working with my site. I am receiving PayPal payments from registered customers, but there are no orders in the administration area. I have tested the site previously, both in sandbox and the live site, without problems. Also, if I login as a customer and prepare a test order (without completing through PayPal) the order does show up in the database. What is going on here? I am currently using IPN v1.1 - will upgrade soon!
  5. I just installed HTC v2.5.9.1 and it seems to be working properly except for the admin section. When I update any of the fields on the Text Control page, any new information I have added disappears upon refresh BUT the info is still written to the DB. Any ideas on what is causing this?
  6. Why doesn't Ultimate SEO URLs work on a Windows localhost? I have Ultimate SEO URLs v2.2 working on my live site (as far as I can tell). I've searched and found other posts from people with similar problems, but no real solutions. I have mod_rewrite enabled and the rewrite directory is the correct one. I am getting a 404 error with the contribution enabled. When the contribution is disabled I get 'cannot find server'. Please help.
  7. jbbeer

    PayPal not a payment option

    ANOTHER UPDATE: Here is the problem! Whenever I select a tax zone in the PayPal IPN setup, PayPal is not a payment option during checkout. In my case the tax zone is a Canadian province. If I leave tax zone set to -none- the PayPal option is available. ?
  8. jbbeer

    PayPal not a payment option

    UPDATE: The problem had nothing to do with the register globals fix because I had already removed this - good thing I'm keeping track of mods! I disabled paypal IPN and replaced the files in the contribution with the originals (v1.1) and it worked. I also applied the tax fix and it appears to still be working. http://www.oscommerce.com/community/contributions,2679 I have recently moved the store to a new server. Could this have caused the problem? (This was supposed to be posted in 'Official PayPal IPN Support Thread')
  9. I have the PayPal IPN module installed and enabled but for some reason during checkout PayPal is not listed in the payment options (Other options are available when they are enabled). If no other payment options are enabled and I confirm the order, I am brought to the PayPal sandbox without an order total. I have seen posts suggesting the register_globals fix (http://www.oscommerce.com/community/contributions,2957/category,all/search,register+globals) is not exactly compatible with PayPal IPN. I had installed this fix to run locally, but I have just realized my server has register globals set to 'on'. Are these things related? Colin
×