Jump to content

KiLLaH

Members
  • Content count

    55
  • Joined

  • Last visited

Everything posted by KiLLaH

  1. Hello everyone, I have currently made an fresh install of Extra Fields. URL: http://www.oscommerce.com/community/contri...ll/search,extra Version: 1.3c Everything went fine until i got this error when i tried to view the product (http://www.url.com/shop/admin/categories.php?cPath=28_30_119&pID=368&action=new_product_preview&read=only) This problem is obviously why i cannot save the data in the fields on each product. Case: --- Error: Line 1492 in admin/categories.php: foreach ($extra_fields_array as $key=>$val) { Entire code: <?php // START: Extra Fields Contribution $extra_fields_names_query = tep_db_query("SELECT * FROM " . TABLE_PRODUCTS_EXTRA_FIELDS); while ($extra_fields_names = tep_db_fetch_array($extra_fields_names_query)) { $extra_field_name[$extra_fields_names['products_extra_fields_id']] = $extra_fields_names['products_extra_fields_name']; } if ($HTTP_GET_VARS['read'] == 'only') { $products_extra_fields_query = tep_db_query("SELECT * FROM " . TABLE_PRODUCTS_TO_PRODUCTS_EXTRA_FIELDS . " WHERE products_id=" . (int)$HTTP_GET_VARS['pID']); while ($products_extra_fields = tep_db_fetch_array($products_extra_fields_query)) { //v1.3b echo "Hi"; $extra_fields_array[$products_extra_fields['products_extra_fields_id']] = $products_extra_fields['products_extra_fields_value']; } } else { $extra_fields_array = $HTTP_POST_VARS['extra_field']; } //v1.3b if ($HTTP_POST_VARS['extra_field']) { // Check to see if there are any need to update extra fields. foreach ($extra_fields_array as $key=>$val) { ?> <b><? echo $extra_field_name[$key];?>:</b> <? echo $val;?><br /> <? } //v1.3b } // Check to see if there are any need to update extra fields. // END: Extra Fields Contribution // echo "<br />" . $pInfo->products_description; ?>
  2. KiLLaH

    [Contribution] STS v4

    Is there a simple way to make a content file for the frontpage (index.php), instead of the system using the default index.php file in oscommerce can be a pain as it detects php between the columns. I tried to create content/index.php.html which failed.
  3. KiLLaH

    [Contribution] STS v4

    I simply disabled the GZip compression and it showed my template. Thanks! :)
  4. KiLLaH

    [Contribution] STS v4

    Something tells me that we might have to make a new thread in order to get a reply or two?
  5. KiLLaH

    [Contribution] STS v4

    I also have the SEO URLS contribution installed, i wonder what may create a conflict, currently everything works when i set the template to false (i wonder why? ;)). But id be glad to hear suggestions for solving the issue!
  6. KiLLaH

    [Contribution] STS v4

    I have finally upgraded my STS v3 to the latest (v4.3). Now as i proceed to test the system i set STS to "true" in the "Default" menu (admin), now i get the problem that nothing appears on catalog index. To be sure i have checked all files over again a few times and i cannot spot the problem. :blink:
  7. KiLLaH

    Enable/Disable categories contribution

    I noticed something strangely when i disabled something inside a category, such as a product or subcategory. Then disabled the entire category and enabled it again. Everything inside the category was also enabled? That seems a dodgy? :blink:
  8. KiLLaH

    RMA Returns error for 2.2 MS2

    Ive got a problem heres the summary: Version: Version 2.4.1 Error: Parse error: parse error in /www/link/shop/account_history_info.php on line 351 Line 351: <?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?> Line 129-197: <?php if (sizeof($order->info['tax_groups']) > 1) { ?> <TR> <TD CLASS="main" COLSPAN="2"><B><?php echo HEADING_PRODUCTS; ?></B></TD> <TD CLASS="smallText" ALIGN="right"><B><?php echo HEADING_TAX; ?></B></TD> <TD CLASS="smallText" ALIGN="right"><B><?php echo HEADING_TOTAL; ?></B></TD> </TR> <?php } else { ?> <TR> <TD CLASS="main" COLSPAN="3"><B><?php echo HEADING_PRODUCTS; ?></B></TD> </TR> <?php } for ($i=0, $n=sizeof($order->products); $i<$n; $i++) { echo ' <tr>' . "\n" . ' <td class="main" align="right" valign="top" width="30">' . $order->products[$i]['qty'] . ' x</td>' . "\n" . ' <td class="main" valign="top">' . $order->products[$i]['name']; if ( (isset($order->products[$i]['attributes'])) && (sizeof($order->products[$i]['attributes']) > 0) ) { for ($j=0, $n2=sizeof($order->products[$i]['attributes']); $j<$n2; $j++) { echo '<br><nobr><small> <i> - ' . $order->products[$i]['attributes'][$j]['option'] . ': ' . $order->products[$i]['attributes'][$j]['value'] . '</i></small></nobr>'; } } echo '</td>' . "\n"; if (sizeof($order->info['tax_groups']) > 1) { // Begin RMA Returns if ($order->products[$i]['return'] == '1') { $rma_query_one = tep_db_query("SELECT returns_id FROM " . TABLE_RETURNS_PRODUCTS_DATA . " where products_id = '" . $order->products[$i]['id'] . "' and order_id = '" . $HTTP_GET_VARS['order_id'] . "'"); $rma_query = tep_db_fetch_array($rma_query_one); $rma_number_query = tep_db_query("SELECT rma_value FROM " . TABLE_RETURNS . " where returns_id = '" . $rma_query['returns_id'] . "'"); $rma_result = tep_db_fetch_array($rma_number_query); $return_link = '<b>' . TEXT_RMA . ' # <u><a href="' . tep_href_link(FILENAME_RETURNS_TRACK, 'action=returns_show&rma=' . $rma_result['rma_value'], 'NONSSL') . '">' . $rma_result['rma_value'] . '</a></u></b>'; } else { $return_link = '<a href="' . tep_href_link(FILENAME_RETURN, 'order_id=' . $HTTP_GET_VARS['order_id'] . '&products_id=' . ($order->products[$i]['id']), 'NONSSL') . '"><b><u>' . TEXT_RETURN_PRODUCT .'</a></u></b>'; } // Don't show Return link if order is still pending or processing // You can change this or comment it out as best fits your store configuration if (($orders_status == '1') OR ($orders_status == '2') ) { $return_link = ''; } echo ' <tr>' . "\n" . ' <td class="main" align="right" valign="top" width="30">' . $order->products[$i]['qty'] . ' x</td>' . "\n" . ' <td class="main" valign="top">' . $order->products[$i]['name']; if ( (isset($order->products[$i]['attributes'])) && (sizeof($order->products[$i]['attributes']) > 0) ) { for ($j=0, $n2=sizeof($order->products[$i]['attributes']); $j<$n2; $j++) { echo '<br><nobr><small> <i> - ' . $order->products[$i]['attributes'][$j]['option'] . ': ' . $order->products[$i]['attributes'][$j]['value'] . '</i></small></nobr>'; } } echo $return_link; // JLM: End RMA Returns echo '</td>' . "\n"; } ?>
  9. KiLLaH

    [Contribution] Extra Fields

    I have tried the diffrent stuff but yet still backed with the same errors and problems i cant really see what is what right now. Would you like to check the categories.php source to see if you can see anything wrong setup? Thanks in advance.
  10. KiLLaH

    [Contribution] Extra Fields

    Im trying to figure out myself but rather lost right now.. :)
  11. KiLLaH

    [Contribution] Extra Fields

    Heres how i added according to your description: case 'update_product': var_dump ($HTTP_POST_VARS); if (isset($HTTP_POST_VARS['edit_x']) || isset($HTTP_POST_VARS['edit_y'])) { $action = 'new_product'; And commented out the tep_redirect line which was in this case.
  12. KiLLaH

    [Contribution] Extra Fields

    This is what it writes on the top when i click the "update" and go back to the product list in admin. And yet it doesnt add the extrafields..
  13. KiLLaH

    [Contribution] Extra Fields

    The code you mention is added as you say: <?php /* Re-Post all POST'ed variables */ reset($HTTP_POST_VARS); while (list($key, $value) = each($HTTP_POST_VARS)) { if (!is_array($HTTP_POST_VARS[$key])) { echo tep_draw_hidden_field($key, htmlspecialchars(stripslashes($value))); } } $languages = tep_get_languages(); for ($i=0, $n=sizeof($languages); $i<$n; $i++) { echo tep_draw_hidden_field('products_name[' . $languages[$i]['id'] . ']', htmlspecialchars(stripslashes($products_name[$languages[$i]['id']]))); echo tep_draw_hidden_field('products_info[' . $languages[$i]['id'] . ']', htmlspecialchars(stripslashes($products_info[$languages[$i]['id']]))); echo tep_draw_hidden_field('products_description[' . $languages[$i]['id'] . ']', htmlspecialchars(stripslashes($products_description[$languages[$i]['id']]))); echo tep_draw_hidden_field('products_url[' . $languages[$i]['id'] . ']', htmlspecialchars(stripslashes($products_url[$languages[$i]['id']]))); } // START: Extra Fields Contribution if ($HTTP_POST_VARS['extra_field']) { // Check to see if there are any need to update extra fields. foreach ($HTTP_POST_VARS['extra_field'] as $key=>$val) { // reset ($extra_fields_array); // while (list ($key, $val) = each ($extra_fields_array)) { echo tep_draw_hidden_field('extra_field['.$key.']', stripslashes($val)); } } // Check to see if there are any need to update extra fields. // END: Extra Fields Contribution ................................ and so on..
  14. KiLLaH

    [Contribution] Extra Fields

    Hello Chris, I tried replacing the line: <?php // START: Extra Fields Contribution $extra_fields_names_query = tep_db_query("SELECT * FROM " . TABLE_PRODUCTS_EXTRA_FIELDS); while ($extra_fields_names = tep_db_fetch_array($extra_fields_names_query)) { $extra_field_name[$extra_fields_names['products_extra_fields_id']] = $extra_fields_names['products_extra_fields_name']; } if ($HTTP_GET_VARS['read'] == 'only') { $products_extra_fields_query = tep_db_query("SELECT * FROM " . TABLE_PRODUCTS_TO_PRODUCTS_EXTRA_FIELDS . " WHERE products_id=" . (int)$HTTP_GET_VARS['pID']); while ($products_extra_fields = tep_db_fetch_array($products_extra_fields_query)) { //v1.3b echo "Hi"; $extra_fields_array[$products_extra_fields['products_extra_fields_id']] = $products_extra_fields['products_extra_fields_value']; } } else { $extra_fields_array = $HTTP_POST_VARS['extra_field']; } // if ($HTTP_POST_VARS['extra_field']) { // Check to see if there are any need to update extra fields. // foreach ($extra_fields_array as $key=>$val) { reset ($extra_fields_array); while (list ($key, $val) = each ($extra_fields_array)) { ?> <b><? echo $extra_field_name[$key];?>:</b> <? echo $val;?><br /> <? } // } // Check to see if there are any need to update extra fields. // END: Extra Fields Contribution // echo "<br />" . $pInfo->products_description; ?> I got this error when i viewed a product again: Although i also noticed something else that when i typed in a value when editing a product it shows the value on the viewing page where you can click "update", but it doesnt save the value of the extra field? I think the problem is still because of this? Thanks for the reply.
  15. KiLLaH

    Products Properties v1.0

    For some reason i cannot pick the properties in the popup menu? Nor can i specify the properties to a category? Somethings wrong, the old 1.00 worked fine.. :unsure:
  16. Hello, Since im using a importing system and the product names are long they have to be inside a "quote", how can i make it generate the CSV files like this? Thanks in advance.
  17. osCommerce has to set a few admins to clean the contribution section, cause its a mixed up crazy place. I could not get one of these contribution to work without changing the code COMPLETELY. I have no clue and or dont have any patience to install something nonworking.
  18. Im currently using 2.2MS2 and i have an problem with Price Breaks, i have installed it and went it through a few times, but when i add something to cart it shows 0.00 in total? Anyone have a clue whats wrong? Thanks in advance for all replies.
  19. Great solution for the "buy it now" buttons without it leaving the product as it did on link buttons. I have combined the code with my "no stock, no purchase" system, quite simple thing if anyone is interested i can paste the code here for use! :-)
  20. Hi all, I have currently tried to install this module: http://www.oscommerce.com/community/contributions,1242 The latest update "02/14/2004 - File by File MS2 Installation" But theres a slight problem with the price update in the cart, it just shows 0.00 even though theres something there. This is how my shopping_cart.php looks like: http://nopaste.php-q.net/43745 If anyone know what i have missed out or have a clue what it is please let me know, ive checked it through alot of times now. Thanks in advance.
  21. Hello all, I have tried to modify my xsell_products.php by removing the (annoying) arrays because of the insufficient use of tables. Problem is that the code gives no error at all and it doesnt view anything either, but be aware that i have added 'xsell' products to the following product im viewing. This is how it looks like [catalog/modules/xsell_products.php]: <?php /* $Id: xsell_products.php, v1 2002/09/11 osCommerce, Open Source E-Commerce Solutions <http://www.oscommerce.com> Copyright © 2002 osCommerce Released under the GNU General Public License */ if ($HTTP_GET_VARS['products_id']) { $products_to_products_query = tep_db_query("select distinct p.products_id, p.products_image, pd.products_name from " . TABLE_PRODUCTS_XSELL . " xp, " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where xp.products_id = '" . $HTTP_GET_VARS['products_id'] . "' and xp.xsell_id = p.products_id and p.products_id = pd.products_id and pd.language_id = '" . $languages_id . "' and p.products_status = '1' and pd.products_name > '' order by xp.products_id asc limit " . MAX_DISPLAY_ALSO_PURCHASED); $products_to_products_count_query = tep_db_query("select count(*) as count from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd, " . TABLE_PRODUCTS_XSELL . " pa where pa.products_id = '" . $HTTP_GET_VARS['products_id'] . "' and pa.xsell_id = p.products_id and p.products_id = pd.products_id and pd.language_id = '" . $languages_id . "' and pd.products_name > '' and p.products_status = '1'"); $products_count = tep_db_fetch_array($products_to_products_count_query); } ?> <!-- xsell_products //--> <?php if ($products_count['count'] > 0) { echo '<table> '; while ($xsell = tep_db_fetch_array($xsell_query)) { $rows++; $products_to_products_list = ' <tr><td><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $xsell['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $xsell['products_image'], $xsell['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a></td><td valign="top"><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $xsell['products_id']) . '">' . $xsell['products_name'] .'</a></td><td valign="top">' . $xsell_price. '</td><td valign="top"><a href="' . tep_href_link(FILENAME_DEFAULT, tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . $xsell['products_id'], 'NONSSL') . '">' . tep_image_button('button_buy_now.gif', TEXT_BUY . $xsell['products_name'] . TEXT_NOW) .'</a></td></tr> '; $boxContent = $products_to_products_list; echo $boxContent; } echo '</table>'; } ?>
  22. KiLLaH

    XSELL - Updated Product Listing

    I can add and remove products but i cant use that special admin interface to edit and see which products are added.
  23. KiLLaH

    X-Sell

    I have the exact same problem.. And i dont know whats wrong. Theres too many updates and half of them doesnt even work..
  24. KiLLaH

    XSELL - Updated Product Listing

    Neither do i theres way too many updates and the system doesnt even work right, the admin is totally ***** up to say it lightly..
  25. I installed WYSIWYG and it seem to work right now.. Although theres another problem now which is with the Ultra Pics contribution.. When i use the additional images system i add an picture of same size in Small and XL as i use the thumbnail system to resize the pictures automatically.. Although when i have added same file in the fields and then goto the product, i see the product as a small picture. Although when i click the picture and it pop-up's it shows the products main picture instead of the XL.
×