Jump to content

leezzard

Members
  • Content count

    176
  • Joined

  • Last visited

Everything posted by leezzard

  1. leezzard

    PayPal IPN v0.97 released

    I am having several problems tyring to get this to work. My first occurs when I enable PayPal IPN in admin>modules>payment, I get this error: Warning: call_user_func(tep_get_order_status_name) [function.call-user-func]: First argument is expected to be a valid callback in /catalog/admin/includes/functions/general.php on line 1232 If I try to edit my PayPal IPN information in admin>modules>payment, I get this error: Fatal error: Call to undefined function: tep_cfg_pull_down_order_statuses() in /catalog/admin/modules.php(204) : eval()'d code on line 1 And it won't let me edit anything. The third problem I see, is when I go to admin>paypalipn>transactions, I get several errors: Warning: session_start() [function.session-start]: The session id contains illegal characters, valid characters are only a-z, A-Z and 0-9 in /catalog/admin/includes/functions/sessions.php on line 67 Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /catalog/admin/includes/functions/sessions.php:67) in /catalog/admin/includes/functions/sessions.php on line 67 Warning: Unknown(): The session id contains illegal characters, valid characters are only a-z, A-Z and 0-9 in Unknown on line 0 Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0 Does anybody have any idea what I did wrong? I did an overwriteandrun installation, and successfully added all database requirements. I am using paypalipn_v0971. All help is appreciated. Thanks
  2. I must admit, you know every aspect of this module and how it interacts with OS. :D That worked great, I appreciate your help. I had played around with that earlier and it didn't work, but it could be that my shipping size was set to high. Thanks again.
  3. I am having a problem getting my shipping weights. This is displayed at the top of my shipping page. Warning: Division by zero in /home/thevinyl/public_html/shop/includes/classes/shipping.php on line 56 Warning: Division by zero in /home/thevinyl/public_html/shop/includes/classes/shipping.php on line 57 Warning: Division by zero in /home/thevinyl/public_html/shop/includes/modules/shipping/fedex1.php on line 63 I do have weights set for all my products, I doubled checked using phpAdmin and they are in mySQL database as products_weight. Also when people shop, down on the status bar, it will display the cart contents, including the weight of the product. The weight of the product is showing up there, but not for the fedex module. I have a product that weighs 23 pounds, I add it to my cart, in my status bar it says "Cart: 1 Items $49.36 23lbs". But when I go to checkout this is what I get "Federal Express (0 x 5lbs)". 5lbs is the weight I added for shipping material. Any help or advice is appreciated. [/code]
×