Jump to content

rowena

Members
  • Content count

    9
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Rowena
  1. rowena

    [Contribution] SEO-G

    Ah - solved it... was missing part of one of my files as when I reuploaded my backups it all suddenly worked again! Thank you for your help, this is a fantastic contribution! :rolleyes:
  2. rowena

    [Contribution] SEO-G

    Also, wierdly - if I search for the words - red dog - it does not appear in the search results... but it is there as I can access and view it in the admin section. The quantity is more than 0 and it is set to in stock... :blink: Any ideas?
  3. rowena

    [Contribution] SEO-G

    Hi, thanks for your reply. I have moved the SEO-G section to the end of the .htaccess file. I have checked the SEO-G reports page - the product link is converted there, but neither the SEO link nor the original link work... both return 'product not found' :'( The store is live, the product with the problem is the one in this category: http://www.equinecaninefeline.com/catalog/..._dog-leads.html Any suggestions appreciated!
  4. rowena

    [Contribution] SEO-G

    Hi, I have installed this contribution, and all is working fine except when I try to add a new product... it appears in the product list on the category page but when clicked on it returns "product not found". I have pasted my .htaccess and configure.php below, if anyone can see any glaring errors I would be most grateful! .htaccess: # $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $ # # This is used with Apache WebServers # # For this to work, you must include the parameter 'Options' to # the AllowOverride configuration # # Example: # # <Directory "/usr/local/apache/htdocs"> # AllowOverride Options # </Directory> # # 'All' with also work. (This configuration is in the # apache/conf/httpd.conf file) #-MS- SEO-G Added Options +FollowSymLinks RewriteEngine On # Next line must be changed to match your osCommerce folder - the relative path RewriteBase /catalog/ RewriteRule ^(.*).html$ root.php?$1.html&%{QUERY_STRING} #-MS- SEO-G Added EOM <IfModule mod_setenvif.c> <IfDefine SSL> SetEnvIf User-Agent ".*MSIE.*" \ nokeepalive ssl-unclean-shutdown \ downgrade-1.0 force-response-1.0 </IfDefine> </IfModule> # Fix certain PHP values <IfModule mod_php5.c> php_value session.use_trans_sid 0 php_value register_globals 1 </IfModule> configure.php /* osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003 osCommerce Released under the GNU General Public License */ // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'http://www.mysite.com'); // eg, http://localhost - should not be empty for productive servers define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', false); // secure webserver for checkout procedure? define('HTTP_COOKIE_DOMAIN', 'www.mysite.com'); define('HTTPS_COOKIE_DOMAIN', ''); define('HTTP_COOKIE_PATH', '/catalog/'); define('HTTPS_COOKIE_PATH', ''); define('DIR_WS_HTTP_CATALOG', '/catalog/'); define('DIR_WS_HTTPS_CATALOG', ''); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', '/home/equineca/public_html/catalog/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); //added for thumbnailer define('DIR_WS_HTTP_CATALOG', '/catalog/'); define('DIR_WS_HTTPS_CATALOG', '/catalog/'); define('DIR_WS_IMAGES', 'images/'); //added for thumbnailer // define our database connection define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', 'myusername'); define('DB_SERVER_PASSWORD', 'mypassword'); define('DB_DATABASE', 'mydatabase'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql' // STS: ADD: Define Simple Template System files define('STS_START_CAPTURE', DIR_WS_INCLUDES . 'sts_start_capture.php'); define('STS_STOP_CAPTURE', DIR_WS_INCLUDES . 'sts_stop_capture.php'); define('STS_RESTART_CAPTURE', DIR_WS_INCLUDES . 'sts_restart_capture.php'); define('STS_TEMPLATE_DIR', DIR_WS_INCLUDES . 'sts_templates/'); define('STS_DEFAULT_TEMPLATE', DIR_WS_INCLUDES . 'sts_template.html'); define('STS_DISPLAY_OUTPUT', DIR_WS_INCLUDES . 'sts_display_output.php'); define('STS_USER_CODE', DIR_WS_INCLUDES . 'sts_user_code.php'); define('STS_PRODUCT_INFO', DIR_WS_INCLUDES . 'sts_product_info.php'); // STS: EOADD ?> Thank you :blush:
  5. rowena

    [Contribution] SEO-G

    Fab, all sorted (duh, silly me!) Thank you so much :blush:
  6. rowena

    [Contribution] SEO-G

    Hi, I installed this contribution & it was working perfectly (fantastic contribution btw!) However, I added the dynamenu to my store and now all the seo-g admin pages have db errors on them. Nothing has been changed with the database with the installation of dynamenu and I have verified that all the tables are present and correct (which they are). I am getting the following errors: On seo_types.php: 1146 - Table 'equineca_database.TABLE_SEO_TYPES' doesn't exist select at.* from TABLE_SEO_TYPES at order by at.sort_order [TEP STOP] seo_zones.php: 1146 - Table 'equineca_database.TABLE_SEO_TYPES' doesn't exist select count(*) as total from TABLE_SEO_TYPES at where seo_types_status='1' [TEP STOP] seo_exclude.php: 1146 - Table 'equineca_database.TABLE_SEO_EXCLUDE' doesn't exist select count(*) as total from TABLE_SEO_EXCLUDE [TEP STOP] seo_reports.php: 1146 - Table 'equineca_database.TABLE_SEO_URL' doesn't exist select count(*) as total from TABLE_SEO_URL su left join TABLE_SEO_FREQUENCY sf on (sf.seo_frequency_id=su.seo_frequency_id) [TEP STOP] seo_redirects.php: 1146 - Table 'equineca_database.TABLE_SEO_REDIRECT' doesn't exist select count(*) as total from TABLE_SEO_REDIRECT [TEP STOP] The tables and database DO exist, I have tried repairing the database but that makes no difference. Any suggestions would be appreciated ;)
  7. rowena

    QBI Quickbooks Import

    Hi, Just installed V2.10c, looks fantastic. One slight problem (which I cant find the solution for anywhere on the forums) - on attempting to upload the lists.IIF file I get a SETUP_FAIL message. The file I am attempting to import is the one straight from my Quickbooks export. Initially I thought the problem was to do with the fact that some products are grouped into group 'packs' as the SETUP_FAIL message appeared with the group 'product' listed and the sub-products appearing in name with "Item does not exist. Error" afterwards. No product was not part of a group appeared anywhere. I removed all groups and associations and tried to reupload the new IIF file but then I only get a SETUP_FAIL message and no products added I really hope someone can help me :) Thanks Rowena
  8. This comntribution is fantatic, however I have one small problem. On the checkout_confirmation.php page the following error occurs: 1146 - Table 'database1.TABLE_DISCOUNT_COUPONS' doesn't exist SELECT coupons_discount_percent, coupons_description, coupons_max_use, coupons_min_order, coupons_max_order, coupons_number_available FROM TABLE_DISCOUNT_COUPONS WHERE coupons_id = 'testcoupon' AND ( coupons_date_start <= CURDATE() OR coupons_date_start IS NULL ) AND ( coupons_date_end >= CURDATE() OR coupons_date_end IS NULL ) [TEP STOP] However, the table IS in the DB. I have also checked that everything is declared in both /includes/filenames.php and admin/includes/filenames.php I have also resubmitted the SQL statements and rechecked all the files, but still no ideas.... anyone have any idea what might be causing this? TIA! :rolleyes:
×