T1RBO

Members
  • Content count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About T1RBO

Profile Information

  • Real Name
    Mark
  1. Hi Robert Still trying to fathom this one out and, here's where I am... Using the reporting tool I can see that it runs the [products_id] => Array code from the page modules but not the category one. I'd say that rather than running the code in page_modules/index.php and getting errored back to the standard tep_href_link() that in my instance there is something preventing the index.php page module being run at all - I presume that I would see this in the error reporting. I did think that I had found a sliver of hope in a hard-coded reference to root/index.php in the changes to catalog/includes/application_top.php // Some odd server set ups return / for SCRIPT_NAME and PHP_SELF when accessed as mysite.com (no index.php) where they usually return /index.php if ( ( $_SERVER['SCRIPT_NAME'] == '/' ) || ( $_SERVER['PHP_SELF'] == '/' ) ) { return 'index.php'; } As my index page is catalog.php I thought that I may have an 'odd server set up' but as the products are working fine, I think that is a red herring. Is there some significance in the page modules being named after their normal namesakes and that somewhere page_modules/index.php can't match up with catalog.php? I'm so close that I'd really rather not give up! Mark
  2. Still no luck understanding this one - my replacements all look ok and only the categories don't get replaced. Is there a 'setting' that I am missing here as I can add and subtract detail from the product listing with gay abandon but category is always represented as cPath=216 even is I append it to the product. I checked my configuration files and hta files and all refer to catalog.php as FILENAME_DEFAULT - the only one that is different is FILENAME_HOME which refers to index.php as that is where the 'real' homepage is located. Rather than make this our life's mission, I've read others requesting to leave the category pages unchanged - is that perceived to have some seo benefit - in which case, shall I just stop driving everyone mad?!! Thanks for the great work.
  3. Hi Robert Thanks for the suggestion but I have reset the cache after each change of setting. I wasn't aware that I could separate category caching from product caching but when I add cPath to product URLs in the settings, the category path is still numeric despite the product being SEO'd. Mark
  4. Hi All I've installed USU5 on 2.3 having used Chemo's original on my original, recently hacked, site (as if life isn't difficult enough without these twerps :angry: ). The product pages are working as before and my htaccess seems ok as products are like this: www.mysite.com/product-p-1234.html My category pages, however, steadfastly refuse to play ball and are like this: www.mysite.com/catalog.php?cPath=216 index.php is renamed to catalog.php in my install and my htaccess reflects this. I'm sure that it is a dumb mistake on my part but I'd be grateful for any pointers to stem the tears......... Keep up the good work everyone.