Jump to content

excession

Members
  • Content count

    66
  • Joined

  • Last visited

Profile Information

  • Real Name
    Gary Butler
  1. excession

    Urgent Help Needed with ePDQ Payments

    I've just checked our setup and we get a slightly different result - we get a confirmation email AND an email saying the payment was declined! Will try and look into it.
  2. excession

    Urgent Help Needed with ePDQ Payments

    don't ask why that posted twice...
  3. excession

    Urgent Help Needed with ePDQ Payments

    This is a common problem. It's down to the payment variable not being set correctly on the checkout payments page. I can't tell you the exact cause or solution as on my site ePDQ is the only payment method so I just fundged the issue by manually setting the variable in the code I added this line echo tep_draw_hidden_field('payment', 'ePDQ'); here if (sizeof($selection) > 1) { ... ... } else { echo tep_draw_hidden_field('payment', 'ePDQ'); } this forces the payment vaiable to be set. If you have more than one payment method you will need to locate the actual problem.
  4. excession

    Urgent Help Needed with ePDQ Payments

    This is a common problem. It's down to the payment variable not being set correctly on the checkout payments page. I can't tell you the exact cause or solution as on my site ePDQ is the only payment method so I just fundged the issue by manually setting the variable in the code I added this line echo tep_draw_hidden_field('payment', 'ePDQ'); here if (sizeof($selection) > 1) { ... ... } else { echo tep_draw_hidden_field('payment', 'ePDQ'); } this forces the payment vaiable to be set. If you have more than one payment method you will need to locate the actual problem.
  5. excession

    Urgent Help Needed with ePDQ Payments

    Thats the cause of the problem. On my version it's around line 270 but will probably be different on your's as I've a few extra modules. The problem will be near where the HTTP POST variable payment is set.
  6. excession

    Urgent Help Needed with ePDQ Payments

    A few of us have had that problem - have a look around the checkout payment page and make sure the payment method is being set correctly. I can't remember the variable name off hand but I found that it wasn't set and I had no encrypted data.
  7. excession

    Urgent Help Needed with ePDQ Payments

    perhaps it's one of the code remnants that was left from some previous release? I must admit, I haven't really looked too deep into the inner workings of it all - too busy with everything else lol
  8. excession

    Urgent Help Needed with ePDQ Payments

    isn't the cartID there to "avoid hack attempts". Sure I saw a comment somewhere.
  9. excession

    Urgent Help Needed with ePDQ Payments

    Joe, I wonder if this is whats causes the problem I had with the payments array not being set correct?
  10. excession

    Urgent Help Needed with ePDQ Payments

    Matt, Thats basically the same solution as I used although I did it in a different place. Just force the selection of the ePDQ module since it's the only ojne used it won't cause a problem. Gary
  11. excession

    Urgent Help Needed with ePDQ Payments

    This is exactly the same problem as I had, on my installation it turned out to be a problem in checkout_payment. The hidden field containing the chosen payment method wasn't being written. I fudged it by manually adding that hidden field since my store only takes payments using the epdq module. I added the line echo tep_draw_hidden_field('payment', 'ePDQ'); you can check this by addeding these lines in checkout_confirmation around line 390 where you see if (is_array($payment_modules->modules)) { add these few line to print a diag on screen echo '<pre>'; Print_r($payment_modules); echo '</pre>';
  12. excession

    Urgent Help Needed with ePDQ Payments

    The ePDQ guru (Johan) is off for a week or two I believe. The ePDQ module (and osCommerce) do not use CURl so that cannot be the problem. If there is no continue button, have a look and see if there is anything after where it would be on the screen. One thing that happens a lot with PHP is that if a script fails due to a typo or compilation error, you don't see anything on the screen - no error reports or anything. Looking at my version of checkout_confirmation.php I can see there are calls to the payent_modules class just before the line which displays the button. I would suggest rechecking all the modifications you have done to the files - it's so easy to miss a semi-colon or a closing brace (done it myself a million times) and without any error messages it can be hard to track down. If you can't see anything, replace all the files you changed to install the ePQD module (saving copies of the modified ones) and trying again. Hope this is of some help.
  13. excession

    Urgent Help Needed with ePDQ Payments

    Hey Joe, The new contrib sounds cool. We're just setting up a new site at the mo, not got as far as getting the ePDQ bit running yet - still waiting for Barclays. I suspect you'd have got it all tested before we get our new store account but if not then I'd be happy to help (assuming boss give permission for accessing our CPI and server etc) otherwise would love a copy of the code. Have you still got my email address? Gary
  14. excession

    Urgent Help Needed with ePDQ Payments

    hey joe, Just reading the comments about orders not showing up and we've had a few here. Not many - probably about 4 in the several hundred orders we've had to date. We get exactly the same symptoms as mac - barclays have recorded the details but there is nothing in the osc database. Currently i've got all the diagnostic emails on and i'm waiting to see it happen again. I think it's when a customer gets as far as barclays showing them the trasaction accepted screen and then closng the browser or using the back button- but this is only a guess. gary
  15. excession

    Urgent Help Needed with ePDQ Payments

    i know - i'm trying to document what i'm doing now as I do it - but as with any small programming project the code and the docs get out of sync. It's like the promotions module I wrote, the one you expressed an interest in - I've had a look about seperating it from the store and making it into a contrib but there are so many lines of code that need modifying and I've forgotton where half of them are. And the store code is totally different from the 2.2 snap shot, it's got so many mods and contibs etc. I have had some success with just copying the whole file set, then running the install again to get the configuration details set. This usually results in a working site. All that remains then is to change the images, product/site specific text etc. A lot easier that doing a 100% fresh install. Talking about CPI/ePDQ I better get the boss to get that sorted for the new site. Do you actually need a different account for each store or can you run them all on one account?
×