Jump to content

deeman001

Members
  • Content count

    17
  • Joined

  • Last visited

1 Follower

About deeman001

  • Birthday 02/09/1971

Profile Information

  1. deeman001

    USPS (SSL) Implemented for Web Tool APIs

    I called USPS and they said that the url is only changing for the listed api's. So if you are using the USPS rate calculation then this does not affect you because that module calles a dll named "ShippingAPITest.dll" the production and testing urls stay the same and are not changing.
  2. deeman001

    Actual Attribute Price V1.0

    Barbara, What is the prefix (-,+ or '') for the attribute that you are having trouble with?
  3. deeman001

    Actual Attribute Price V1.0

    Don't change that line, keep it the way it is. I'd like to see your the code for your function. Can you send me the code snippet for the function that looks like this: function attributes_price($products_id, $prod_price) {
  4. deeman001

    Actual Attribute Price V1.0

    Barbara, Do a find(search) on your code for: final_price' => $products[$i]['price'] + $cart->attributes_price($products[$i]['id']), Only update the files that ARE NOT in the ADMIN section of the site, since I did not update the similar function in the admin files. Replace the lines of code you find from your above search, with this line: 'final_price' => $products[$i]['price'] + $cart->attributes_price($products[$i]['id'],$products[$i]['price']), Let me know what happens. darren
  5. deeman001

    Actual Attribute Price V1.0

    I was able to fix the problem of the attribute item being added to the product price in the product details and totals of checkout_confirmation.php for the ActualAttributesPrices_refreshed contrib. I updated two files. /////////// FIRST FILE UPDATED /////////////// In the first file I updated the function "attributes_price()" in catalog\includes\classes\shopping_cart.php at approx line 293 (see my code at the bottom of this post): Updates to the function: My new function now accepts a second variable (product price $prod_price) which is then subtracted from the attribute price if the price_prefix == '' **code below This is what step 2 of the AAP_Install.txt instructions for the ActualAttributesPrices_refreshed contrib said to do but it didn't work for me so (DONT DO THIS): DO THIS TO catalog\includes\classes\shopping_cart.php This is the new code I used to replace the instructions above: //PHPMOM.COM AAP function attributes_price($products_id, $prod_price) { $attributes_price = 0; if (isset($this->contents[$products_id]['attributes'])) { reset($this->contents[$products_id]['attributes']); while (list($option, $value) = each($this->contents[$products_id]['attributes'])) { $attribute_price_query = tep_db_query("select options_values_price, price_prefix from " . TABLE_PRODUCTS_ATTRIBUTES . " where products_id = '" . (int)$products_id . "' and options_id = '" . (int)$option . "' and options_values_id = '" . (int)$value . "'"); $attribute_price = tep_db_fetch_array($attribute_price_query); if ($attribute_price['price_prefix'] == '+') { $attributes_price += $attribute_price['options_values_price']; } elseif ($attribute_price['price_prefix'] == '-') { $attributes_price -= $attribute_price['options_values_price']; } elseif ($attribute_price['price_prefix'] == '') { $attributes_price += $attribute_price['options_values_price'] - $prod_price; } } } return $attributes_price; } /////////// SECOND FILE UPDATED /////////////// I made 1 update to the array in catalog\includes\classes\order.php: My update to the array now passes a second variable (product price $prod_price) into the updated function **code below There were no instructions in the original install document for this DO THIS TO catalog\includes\classes\order.php This is the updated line of code I used for the second file catalog\includes\classes\order.php: SEARCH FOR THIS 'final_price' => $products[$i]['price'] + $cart->attributes_price($products[$i]['id']), REPLACE WITH THIS 'final_price' => $products[$i]['price'] + $cart->attributes_price($products[$i]['id'],$products[$i]['price']), It seems to work fine for me now. Let me know if you find any bugs. Darren
  6. deeman001

    Payflowlink not getting enabled?!?!?

    I have added install instructions for adding a Sort Order feature to the Masked PayFlow Link contrib. It will most likely work with all of the PayFlow Link contribs that do not have the Sort Order feature enabled. You can find the install instructions here: http://www.oscommerce.com/community/contributions,2892
  7. deeman001

    Payflow Link Contrib problem

    I have added install instructions for adding a Sort Order feature to the Masked PayFlow Link contrib. It will most likely work with all of the PayFlow Link contribs that do not have the Sort Order feature enabled. You can find the install instructions here: http://www.oscommerce.com/community/contributions,2892
  8. deeman001

    Error with CCGV

    Did anyone figure out why you are getting this error? I am getting the same error when using discounts.
  9. I've been tracking this issue all the way from 2003, but can't find a solution. Does anyone know of a solution to this problem? There are two payment options, a Credit Card (Authorize.net) and a gift voucher balance. The gift voucher balance is greater than the total, so I check the box that says "Tick to use Gift Voucher account balance" and I then click continue. A Credit Card error is returned that says "The first four digits of the number entered are: If that number is correct, we do not accept that type of credit card. If it is wrong, please try again." I get the Credit Card error because I didn't enter a CC number, but I am paying the total with my Voucher balance and not the Credit Card. Any Help would be appreciated.
  10. deeman001

    Credit Gift Voucher Displays $0 in cart

    I unistalled and reinstalled the CCVG contribution and found that I had missed several code blocks. This issue was resolved after performing this action.
  11. Here is how you fix it. 1. Get the Rigadin's Full Package 5.13 dated, April 22, 2005. 2. Open the "catalog\includes\modules\order_total\ot_gv.php" file. 3. Copy the function and code for "function install (...)" (approx line# 321) 4. Replace the french "function install ()" lines on your web server file "catalog\includes\modules\order_total\ot_gv.php" with the ones copied from version 5.13. There is also a SQL fix for the French Database config data. 1. Search for "CCGV v5.14 addon with French - English SQL fix" author aarondwyer dated 28 Jul 2005 2. Run the SQL query against your database or manually update the data with the appropriate cell information. Hope this helps, deeman.
  12. I hope someone else has had this problem, because I haven't been able to find any posts about it. My problem is that all Gift Vouchers show up with a $0 in the cart, during checkout and in the subsequent emails. I originally installed CCGV v5.13d and then today maticulously went line by line using the new "Credit Class & Gift Voucher v5.14" package. When I setup the "GIFT_25" product within a "Gift Certificate" Category, the admin tool displays the product and price correctly: gv_25.gif Price: $25.00 Quantity: 1000 Though when I attempt to purchase the $25 Gift Voucher the cart displays an amount of $0. It lets me checkout but the email it sends me says: ... ---------------------------------------------------------------------------------------- Congratulations, You have received a Gift Certificate worth 0 ---------------------------------------------------------------------------------------- ... I've checked all of the DB tables and they show the correct $25.00 value. Any suggestions or thoughts on how I can get this working?
  13. deeman001

    bluepay 2.0

    Keenanj, I will begin a OC - BP2.0 integration later this month. Would you share the solution to your question with me? I would appreciate your insight. thanks.
×