Jump to content

SHANX6336

Members
  • Content count

    44
  • Joined

  • Last visited

1 Follower

Profile Information

  1. SHANX6336

    PayPal Sending to checkout_success.php

    Can this problem be related to how my configure.php file was configured? I am having great difficulty finding the source of the problem. Here is my configure.php file: // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'http://www.mydomain.net'); // eg, http://localhost - should not be empty for productive servers define('HTTPS_SERVER', 'https://www.mydomain.net'); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', true); // secure webserver for checkout procedure? define('HTTP_COOKIE_DOMAIN', 'www.mydomain.net'); define('HTTPS_COOKIE_DOMAIN', 'www.mydomain.net'); define('HTTP_COOKIE_PATH', '/'); define('HTTPS_COOKIE_PATH', '/'); define('DIR_WS_HTTP_CATALOG', '/'); define('DIR_WS_HTTPS_CATALOG', '/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', '/home/content/S/p/e/mydomain/html/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
  2. SHANX6336

    PayPal Sending to checkout_success.php

    Hey everybody, I am experiencing a strange problem. Recently I moved one of my clients' web site from http://www.domain.com/catalog/ to just http://www.domain.com/, and now I am receiving PayPal module problems. Customers are selecting to pay with PayPal as their payment method on the checkout_payment.php page. Once they click on the Continue button, checkout_confirmation.php page, where they can view their order. Then the user needs to click on Confirm Order, at which time they are forwarded to the PayPal site to send payment. After they are done sending payment from the PayPal site, they go to a success page at the PayPal site which says you are not going to automatically be forwarded by to [Company Name], or click here if you are not forwarded in 10 seconds. PayPal is forwarding customers to the checkout_success.php page which just says thank you for your order on my client's site. But if the customer does not click on that Confirm Order button there is no way for the shopping cart to know that the payment went through. If the customer clicks on the link that also forwards them back to my client's site, it does not take them to checkout_success.php, but it takes them to checkout_process.php, which gives them the opportunity to click on the Confirm Order button so that the shopping cart can record the order in the admin backend. The customers are receiving order invoices via email, but the order is not showing up in the admin backend. What is going on with this site? Everything else on the site seems to be working smoothly except for this. Someone please help. Your assistance is greatly appreciated. Thank you!
  3. Thank you for the reply Gary! The strange thing is that the cart is recording the data, because if I update the shipping price and try to purchase that product, it is giving me the proper individual shipping price during checkout. For some reason, the textbox is not remembering what data is entered for that specific field any time I go back to edit the product again. I'm sure it has something to do with my database. As for your problem, I wish I could help you out but I can't. I am just getting around to working with this contribution and I don't think I will be attempting to add any additional shipping options for some time. Good luck!
  4. I just noticed something that I believe to be related to the contribution. Originally, my osCommerce product page would show 0 for weight when I do not enter any value for weight when adding or editing a product. Now, just like the individual shipping field, there is no value in the textbox. Anybody have similar experience or believe they can help me out? Thanks!
  5. Hey everybody, First off I want to say I LOVE the contribution and it has really helped me out, but... I am having problems with the contribution. I installed it and it calculates and includes shipping perfectly, but for some reason after I add the individual shipping price into a product, after I save it and reopen it there is no price there in the textbox. It is recording it though in a sense that the shopping cart knows what amount to charge the customer for shipping when they purchase that product, but the textbox remains blank. The main problem is that if I reopen a product and make a different change to it (i.e. update a picture) and not enter the shipping charge AGAIN, it will assume shipping is $0 since it is blank and will overwrite the old price. I'm sure I missed a line in modifying my two files, categories.php and shopping_cart.php, but I was hoping someone can tell me where I should look. Thanks!
  6. Hey everybody, I am having difficulty using the ECHO Payment Module. A customer can go through the entire checkout process, select pay via credit card, enter their credit card information, but once they click Continue they are given the following error: Fatal error: Call to undefined function: changedatain() in /home/monkey/gifted-monkey-www/catalog/includes/modules/payment/echo_cc.php on line 255 I installed ECHO Payment Module version 1.7.3, which is located at: http://www.oscommerce.com/community/contributions,8/page,3 Here is my echo_cc.php file as a text document for you all to view online: http://www.lainterweb.com/echo_cc.txt I opened up the echo_cc.php file but I could not find what exactly was causing the error message. The weird thing is that the order shows in the Admin Panel and the customer is emailed an order confirmation email, but it just doesn't continue through the process on the screen and it generates that error message. Any suggestions? I'm hoping some of you more experienced users can take a look and help me out if possible. It was a pretty easy contribution to install, mostly just adding these files untouched, so I don't know where the problem started. Thank you very much for your time!
  7. I installed the contribution and it was successful on every page but the product_info.php page. Once I change the < head > information to show as <?php // BOF: WebMakers.com Changed: Header Tag Controller v1.0 // Replaced by header_tags.php if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) { ?require(DIR_WS_INCLUDES . 'header_tags.php'); } else { ?> ?<title><?php echo TITLE ?></title> <?php } // EOF: WebMakers.com Changed: Header Tag Controller v1.0 ?> Once I change that on the product_info.php file, I receive the following error: Fatal error: Call to undefined function: clean_html_comments() in /home/monkey/gifted-monkey-www/catalog/includes/header_tags.php on line 79 Here is my header_tags.php file: 74 ? ?if (empty($the_product_info['products_head_title_tag'])) { 75 ? ? ?$the_title= HEAD_TITLE_TAG_ALL; 79 ? ?} else { 80 ? ? ?if ( HTTA_PRODUCT_INFO_ON=='1' ) { ? ? ? ?$the_title= HEAD_TITLE_TAG_ALL . ' ' . clean_html_comments($the_product_info['products_head_title_tag']); ? ? ?} else { ? ? ? ?$the_title= clean_html_comments($the_product_info['products_head_title_tag']); ? ? ?} ? ?} 89 ? ?break; Anybody see anything that has been done incorrectly? (the numbers are just so you see where the error message is coming from. Thanks for your assistance! It is greatly appreciated.
×