Jump to content

olsonsp4c

Members
  • Content count

    545
  • Joined

  • Last visited

Everything posted by olsonsp4c

  1. did you verify that the logo name you uploaded is in the catalog/images file and that the name is EXACTLY the same in the Admin as the file you uploaded - i.e. logo.jpg NOT logo.JPG that there are no spaces in the name of the logo: my_logo.jpg NOT my logo.jpg ? Scott
  2. olsonsp4c

    USPS Priority Mail Flat Rate Shipping

    New version 1.5 out: http://addons.oscommerce.com/info/5783 Changes since v1.4 ----------------- * Added catalog and admin functions to general.php * Added an edit that was missing from all previous versions in modules.php * Recoded the entire module to display all USPS domestic and international flat rate shipping methods * Updated the Priority Mail Flat Rate Shipping rates links at the top of the admin panel * Updated instructions * Updated screenshots Scott
  3. olsonsp4c

    Live Support phpOnline

    the easiest way is to just change it in the infobox file... change popupWindow to livesupportpopupWindow and see if that fixes it Scott
  4. olsonsp4c

    Live Support phpOnline

    In should read like this with no line break after "res" or after "lef": <script language="javascript"><!-- function phpOnlinePopupWindow() { var url = "<?php echo $phpOnline_base_url.'/client.php';?>"; window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res izable=no,copyhistory=no,width=650,height=450,screenX=150,screenY=150,top=1 50,le f t=150') } //--></script> in this example you gave, the width is 650 and height 450 you might check your index.php to see if there is another popup script with the same name "popupWindow" - if so, rename that part. Scott
  5. The changes I wrote are in admin/product_attributes.php Fortunately, v1.6 has step by step instruction; however, what I wrote above must replace one of those steps. Thanks for the kind offer - if I wasn't in Portland, OR, I'd take you up on it. Also, the instructions for 1.6 make the file changes more clear. Also, the database insert is correct in 1.6; however, 1.6 does not include the attribute cloner. Scott
  6. olsonsp4c

    [Contribution] - USPS Methods

    I hate to mention this, but exactly how to fix the parse error mentioned above is mentioned in the "troubleshooting" section of 3.0.2 - it says exactly what Jan mentioned above. I usually try to include this info in an addon installation doc if I know of a particular issue. Thank you to Jan for answering it anyways and providing the SQL statement. Scott
  7. I have this same problem... I think this is the solution: case 'add_product_attributes': $products_id = tep_db_prepare_input($HTTP_POST_VARS['products_id']); $options_id = tep_db_prepare_input($HTTP_POST_VARS['options_id']); $values_id = tep_db_prepare_input($HTTP_POST_VARS['values_id']); $value_price = tep_db_prepare_input($HTTP_POST_VARS['value_price']); $price_prefix = tep_db_prepare_input($HTTP_POST_VARS['price_prefix']); $attributes_sort = tep_db_prepare_input($HTTP_POST_VARS['attributes_sort']); tep_db_query("insert into " . TABLE_PRODUCTS_ATTRIBUTES . " values (null, '" . (int)$products_id . "', '" . (int)$options_id . "', '" . (int)$values_id . "', '" . (float)tep_db_input($value_price) . "', '" . tep_db_input($price_prefix) . "', '" . (int)$attributes_sort . "')"); The last line was not correct in the fileset... I think this one in correct. catalog/admin/product_attributes.php ALSO, I think the Database SQL in incorrect - you only need the following line: NOT this: ALTER TABLE products_attributes ADD sort_order INT DEFAULT '50' NOT NULL; ALTER TABLE products_attributes ADD COLUMN attribute_sort INT UNSIGNED NOT NULL DEFAULT '0'; BUT this: ALTER TABLE products_attributes ADD COLUMN attribute_sort INT UNSIGNED NOT NULL DEFAULT '0'; Scott
  8. olsonsp4c

    osC reCaptcha

    Please replace: lang : '<?php if (in_array($language_id['code'] ,array('en', 'nl', 'fr', 'de', 'pt', 'ru', 'es', 'tr'))) {echo $language_id['code']; } else {echo 'en'; } ?>', }; with: lang : '<?php if (in_array($language_id['code'] ,array('en', 'nl', 'fr', 'de', 'pt', 'ru', 'es', 'tr'))) {echo $language_id['code']; } else {echo 'en'; } ?>'; } and let me know the results... Scott
  9. olsonsp4c

    osC reCaptcha

    I don't see an error, so I'm wondering if IE is counting lines differently that the program you are using that counts them... Scott
  10. Look in the file - there are many lines that will look almost just like it in the array. Just make sure that is is NOT the last line in the array and you'll be fine. Scott
  11. the link is fixed in 1.72 - issue 2 is addressed in 1.72 - i've sometimes seen formatting issues IF you don't either have the product name, manufacturer, or model number before the description - one of them must be selected... don't know why it doesn't include part of the description... Scott
  12. olsonsp4c

    Official PayPal IPN Support Thread

    OK, I don't know if anybody (besides me) is getting the above error AFTER changing: include(DIR_WS_CLASSES . 'order_total.php'); to require_once(DIR_WS_CLASSES . 'order_total.php'); to avoid the "Fatal error: Cannot redeclare class ot_subtotal in /home/.../includes/classes/order_total.php" in PayPal IPN v1.4 However, I tracked down the problem... it is in catalog/includes/classes/order_total.php Find this: include(DIR_WS_LANGUAGES . $language . '/modules/order_total/' . $value); include(DIR_WS_MODULES . 'order_total/' . $value); Change to: require_once(DIR_WS_LANGUAGES . $language . '/modules/order_total/' . $value); require_once(DIR_WS_MODULES . 'order_total/' . $value); Now, the emails send, the order is recorded, etc... HOWEVER, the order status will not change from "Preparing [Paypal IPN]" to "Pending" anymore... Any thoughts out there in the community? Scott
  13. olsonsp4c

    Store Mode (Open | Closed | Maintenance)

    I would guess that you will run into problems... I have not toyed with the addon, so can't give a conclusive answer... this might be an opportunity for you to learn for the benefit of the whole community and post the results... thanks for using my addon. Scott
  14. olsonsp4c

    Live Support phpOnline

    Thanks... 2 of those suggestion could just go directly to dynahost that wrote the actual software at http://www.dayanahost.com/forum2/index.php...SF&f=8& (I just ported it to osCommerce and customized it a bit) The popup in the catalog and admin can be changed in size. Just look at the javascript in the infobox file and in the admin/includes/header.php and look for the height width settings which are large numbers like 500, 450 or something like that... Scott
  15. Here is the fix in catalog/product_info.php replace this: <td align="center" valign="middle" class="main"><?php echo '<a href="' . tep_href_link(FILENAME_PDF_DATASHEET, 'products_id=' . $product_info['products_id']) .'" target="_blank"><table border="0" cellspacing="0" cellpadding="0"><tr><td valign="middle">' . TEXT_PDF_DOWNLOAD1 . ' <td><td valign="middle">' . tep_image('images/pdf.png',TEXT_PDF_DOWNLOAD2) .'</td></tr></table></a>'; ?></td> with this: <td align="center" valign="middle" class="main"><?php echo '<table border="0" cellspacing="0" cellpadding="0"><tr><td valign="middle"><a href="' . tep_href_link(FILENAME_PDF_DATASHEET, 'products_id=' . $product_info['products_id']) .'" target="_blank">' . TEXT_PDF_DOWNLOAD1 . '</a> <td><td valign="middle"><a href="' . tep_href_link(FILENAME_PDF_DATASHEET, 'products_id=' . $product_info['products_id']) .'" target="_blank">' . tep_image('images/pdf.png',TEXT_PDF_DOWNLOAD2) .'</a></td></tr></table>'; ?></td> Scott
  16. Your correct - I looked at it too... I'll look into it. Scott
  17. I have a new version out 1.7: http://addons.oscommerce.com/info/1077 Since v1.6.4 ------------ * Added most available options to the admin * Added a few options to the Admin that didn't exist * Eliminated unnecessary options from config file * Multi-lingual ready * Patched the "Divide by Zero" error when no image exists and "Keep Image Proportions" is set to "Yes" * Further streamlined product_info link * Streamlined and updated the code * Removed the previously integrated code for the "options as images" addon; placed it in a separate folder * Cleaned up the installation doc * Added update doc * Added screenshots Scott
  18. olsonsp4c

    [contribution] PDF data_sheet maker v.1

    I have a new version out 1.7: http://addons.oscommerce.com/info/1077 Since v1.6.4 ------------ * Added most available options to the admin * Added a few options to the Admin that didn't exist * Eliminated unnecessary options from config file * Multi-lingual ready * Patched the "Divide by Zero" error when no image exists and "Keep Image Proportions" is set to "Yes" * Further streamlined product_info link * Streamlined and updated the code * Removed the previously integrated code for the "options as images" addon; placed it in a separate folder * Cleaned up the installation doc * Added update doc * Added screenshots Scott
  19. olsonsp4c

    Live Support phpOnline

    Glad you got it working Mark. Scott
  20. Steven, my last guess is that there is some sort of server software requirement that your server has not installed... you might look into that and inquire with your hosting support team... often they can install packages for you for free... Scott
  21. Have you tried re-uploading your fileset - one of them may have been corrupted during upload... Scott
  22. The only suggestion I have is to verify that you actually uploaded the files to the correct directories because it sounds like it is trying to find a file that isn't there... Scott
  23. I have the next ten button working on 3 different sites, so I'm not sure why it doesn't for others - possibly it requires something installed on your server? it is an easy fix though - just revert the button code to the old code and you'll be fine: in catalog/admin/supertracker.php Find this: <br><strong><a href="supertracker.php?special=last_ten&offset=<?php echo $offset + 10;?>&filter=<?php echo $filter;?>&refer_match=<?php echo $refer_match;?>"><input type="submit" value="<?php echo TABLE_TEXT_NEXT_TEN_RESULTS; ?>"></a></strong> Replace with this: <br><strong><a href="supertracker.php?special=last_ten&offset=<?php echo $offset + 10;?>&filter=<?php echo $filter;?>&refer_match=<?php echo $refer_match;?>"><?php echo TABLE_TEXT_NEXT_TEN_RESULTS; ?></a></strong> Scott
  24. olsonsp4c

    Live Support phpOnline

    I don't understand what you mean by blank screen. please post screenshots. The sql is automatically added. there is no sql to upload. Scott
×