Jump to content

yodergraphics

Members
  • Content count

    59
  • Joined

  • Last visited

Everything posted by yodergraphics

  1. yodergraphics

    Automatically send data feed to Froogle

    My osCommerce Admin/error_log states... [09-Aug-2007 07:03:15] PHP Warning: ftp_put() [<a href='function.ftp-put'>function.ftp-put</a>]: base_products.txt: Permission denied on server. (Overwrite) in /home/stitchpi/public_html/catalog/admin/googlefeeder.php on line 364 More later if I fix....
  2. yodergraphics

    Automatically send data feed to Froogle

    Running: Google Base / Froogle Data Feeder v1.20 Date: February 25, 2006 PHP version 5.1.4 MySQL version 5.0.27-standard Hello, and thanks for the contrib. Problem: The script says it has uploaded... File completed: base_products.txt Connected to uploads.google.com, for user *** Uploaded ../feeds/base_products.txt to uploads.google.com as base_products.txt ...but the file never shows up on the Google Base website under "Bulk upload files>My Items" or at uploads.google.com when I ftp manually. No error messages are generated either. I've tried to both comment & uncomment the following line 362 in admin/googlefeeder.php, and this has not made anything appear on Google's end or on the ftp server: //ftp_pasv ( $conn_id, true ); What else can I try to get my server to relay the ftp file? Thanks in advance.
  3. yodergraphics

    JUST RELEASED! Printable Catalog

    The above fix works for Printable Catalog V 35 Sept 11-2005 when catalog_products_with_images.php and catalog_products_with_images_full.php are both getting the 1054 MySQL 5.0 error. In Catalog/catalog_products_with_images.php around line 344, replace with the above code posted by weerd. In Catalog/catalog_products_with_images_full.php around line 347, replace with the same code above. This should really be posted as an offical fix at the Contribution page
  4. NO - this error was not related to CCGV code. It turns out the offending code was a custom breadcrumb code in catalog/includes/application_top.php that removed the model number and replaced it with the product name instead.
  5. My version that worked with MySQL 4.0/PHP4 is heavily modified, but I will say my order_total.php doesn't have any of this ###CGV JONYO ### code. May try to roll back away from that if that's an update or go back to to 5.13d
  6. Hi, I'm getting the below error and I'm wondering if it's related to any code found in catalog/includes/add_ccgvdc_application_top.php. We upgraded to MySQL 4.1.21-standard and php 5.0.4 Error at top of any product page (only product detail pages): Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/stitchpi/public_html/catalog/includes/functions/database.php on line 103 Suspect code from catalog/includes/add_ccgvdc_application_top.php: //// // Create a Coupon Code. length may be between 1 and 16 Characters // $salt needs some thought. function create_coupon_code($salt="secret", $length = SECURITY_CODE_LENGTH) { $ccid = md5(uniqid("","salt")); $ccid .= md5(uniqid("","salt")); $ccid .= md5(uniqid("","salt")); $ccid .= md5(uniqid("","salt")); srand((double)microtime()*1000000); // seed the random number generator $random_start = @rand(0, (128-$length)); $good_result = 0; while ($good_result == 0) { $id1=substr($ccid, $random_start,$length); $query = tep_db_query("select coupon_code from " . TABLE_COUPONS . " where coupon_code = '" . $id1 . "'"); if (tep_db_num_rows($query) == 0) $good_result = 1; } return $id1; } //// // Update the Customers GV account function tep_gv_account_update($customer_id, $gv_id) { $customer_gv_query = tep_db_query("select amount from " . TABLE_COUPON_GV_CUSTOMER . " where customer_id = '" . $customer_id . "'"); $coupon_gv_query = tep_db_query("select coupon_amount from " . TABLE_COUPONS . " where coupon_id = '" . $gv_id . "'"); $coupon_gv = tep_db_fetch_array($coupon_gv_query); if (tep_db_num_rows($customer_gv_query) > 0) { $customer_gv = tep_db_fetch_array($customer_gv_query); $new_gv_amount = $customer_gv['amount'] + $coupon_gv['coupon_amount']; // new code bugfix $gv_query = tep_db_query("update " . TABLE_COUPON_GV_CUSTOMER . " set amount = '" . $new_gv_amount . "' where customer_id = '" . $customer_id . "'"); // original code $gv_query = tep_db_query("update " . TABLE_COUPON_GV_CUSTOMER . " set amount = '" . $new_gv_amount . "'"); } else { $gv_query = tep_db_query("insert into " . TABLE_COUPON_GV_CUSTOMER . " (customer_id, amount) values ('" . $customer_id . "', '" . $coupon_gv['coupon_amount'] . "')"); } } //// My catalog/includes/functions/database.php line 103 area function tep_db_num_rows($db_query) { return mysql_num_rows($db_query); } Any clues or help is appreciated!
  7. I seem to have this exact error msg "mysql_num_rows():...database.php on line 103" I am also running the CC/GV contribution. If anyone can post how they fixed this, it would be very helpful.
  8. yodergraphics

    coolMenu

    Only in Mac Netscape 7.2, the Categories box is wider than it should be. (It's not shrinking to the size of the overlayed menu) Unlike some of the code posted around here, I have this code controlling the height of my Categories box: catalog/includes/boxes/coolmenu.php: <?php // get height of menu $height_query = tep_db_query("select count(*) as count from " . TABLE_CATEGORIES . " where parent_id = '0'"); $heightarray = tep_db_fetch_array($height_query); $height =($heightarray['count'] * 29.75); Like what you see above, is there a similar code to control the width for Netscape? (Like a $width=) Again, the width of the category box is working fine in Mac I.E. 5.2 and Safari If you are using Mac Net. 7.2, you can see the problem here: http://www.stitchpiecenpurl.com/catalog/ Thanks for your help!
  9. Wow, HeaderTags 2.5.5 version solved all of my previous bugs all at once that I had with the previous version.
  10. I've installed Paul Barrera's latest Call For Pricing / Negotiable Pricing. Call For Pricing / Negotiable Pricing I've installed your most recent contribution, less your latest update July 2. The problem file is catalog/includes/modules/new_products.php It is making my osCommerce homepage loose it's entire footer and right-side boxes such as shopping cart and New Items box, and the center box "New Products for Month". (All other content says) It also effects the main category pages the same way, but product pages themselves are unaffected. Please see if there is an obvious (to you) PHP writing error here, if you would: <?php /* $Id: new_products.php,v 1.34 2003/06/09 22:49:58 hpdl Exp $ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003 osCommerce Released under the GNU General Public License */ ?> <!-- new_products //--> <?php $info_box_contents = array(); $info_box_contents[] = array('text' => sprintf(TABLE_HEADING_NEW_PRODUCTS, strftime('%B'))); new contentBoxHeading($info_box_contents); if ( (!isset($new_products_category_id)) || ($new_products_category_id == '0') ) { $new_products_query = tep_db_query("select p.products_id, p.products_image, p.products_tax_class_id, if(s.status, s.specials_new_products_price, p.products_price) as products_price from " . TABLE_PRODUCTS . " p left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id where products_status = '1' order by p.products_date_added desc limit " . MAX_DISPLAY_NEW_PRODUCTS); } else { $new_products_query = tep_db_query("select distinct p.products_id, p.products_image, p.products_tax_class_id, if(s.status, s.specials_new_products_price, p.products_price) as products_price from " . TABLE_PRODUCTS . " p left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c, " . TABLE_CATEGORIES . " c where p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and c.parent_id = '" . (int)$new_products_category_id . "' and p.products_status = '1' order by p.products_date_added desc limit " . MAX_DISPLAY_NEW_PRODUCTS); } $row = 0; $col = 0; $info_box_contents = array(); while ($new_products = tep_db_fetch_array($new_products_query)) { $new_products['products_name'] = tep_get_products_name($new_products['products_id']); if ($new_products['products_price'] == 999999){ $info_box_contents[$row][$col] = array('align' => 'center', 'params' => 'class="smallText" width="33%" valign="top"', 'text' => '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $new_products['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $new_products['products_image'], $new_products['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a><br><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $new_products['products_id']) . '">' . $new_products['products_name'] . '</a><br>'TEXT_CALL_FOR_PRICE); }else{ $info_box_contents[$row][$col] = array('align' => 'center', 'params' => 'class="smallText" width="33%" valign="top"', 'text' => '<a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $new_products['products_id']) . '">' . tep_image(DIR_WS_IMAGES . $new_products['products_image'], $new_products['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT) . '</a><br><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $new_products['products_id']) . '">' . $new_products['products_name'] . '</a><br>' . $currencies->display_price($new_products['products_price'], tep_get_tax_rate($new_products['products_tax_class_id']))); } $col ++; if ($col > 2) { $col = 0; $row ++; } } new contentBox($info_box_contents); ?> <!-- new_products_eof //-->
  11. I had this same problem, caused by deleting any meta-content using the admin drop down menu. Something is causing that feature to truncating the top off of english/header_tags.php, spilling code all over the pages. I've started another post on this, next page.
  12. Bug 3: the edited catalog/product_info.php does not allow the product pages to appear. I do have a heavily modified product_info.php, but it's just a little snippet of code to add?? Here's what I have that crashes the product pages with the Header Tags Controller snippet added: <?php /* $Id: product_info.php,v 1.97 2003/07/01 14:34:54 hpdl Exp $ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003 osCommerce Released under the GNU General Public License */ require('includes/application_top.php'); require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_PRODUCT_INFO); $product_check_query = tep_db_query("select count(*) as total from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'"); $product_check = tep_db_fetch_array($product_check_query); ?> <!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN"> <html <?php echo HTML_PARAMS; ?>> <head> <?php // BOF: WebMakers.com Changed: Header Tag Controller v2.5.2 // Replaced by header_tags.php if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) { require(DIR_WS_INCLUDES . 'header_tags.php'); } else { ?> <title><?php echo TITLE; ?></title> <?php } // EOF: WebMakers.com Changed: Header Tag Controller v2.5.2 ?> <base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>"> <link rel="stylesheet" type="text/css" href="stylesheet.css"> <script language="javascript"><!-- function popupWindow(url) { window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,res izable=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,le ft=150') } //--></script> Jack_mcs, thanks for the advice on Bug 1 & 2
  13. Bug 1: When you delete meta content pages, it does not translate the code correctly in the process and resaves english/header_tags.php with a truncated start, and displays PHP code all over the pages. Everything above "WebMakers.com" in the below header_tags.php file is deleted. This is what is being deleted automatically: <?php // /catalog/includes/languages/english/header_tags.php // (catalog/includes/languages/english/header_tags.php error) Bug 2: When creating a new meta-content page (in this case, for shipping.php), the page will not appear. The correct code seems to be writing to catalog/includes/header_tags.php. Here's the code it doesn't like: // shipping.php case (strstr($_SERVER['PHP_SELF'],FILENAME_SHIPPING) or strstr($PHP_SELF, FILENAME_SHIPPING) ): $tags_array = tep_header_tag_page(HTTA_SHIPPING, HEAD_TITLE_TAG_SHIPPING, HTDA_SHIPPING, HEAD_DESC_TAG_SHIPPING, HTKA_SHIPPING, HEAD_KEY_TAG_SHIPPING ); break; If I take the above code out of catalog/includes/header_tags.php, the page will reapper, but of course, will only draw from the Default meta content. Both of these files set to chmod 777. If these fixes have been posted, please provide the link! Thanks.
  14. yodergraphics

    Skipjack Geotrust Teanas~ error fix?

    The Problem: The word Teanas~ is transferred to the Skipjack credit card processor instead of a list of what was ordered. The word Teanas is hardcoded into the script, and apparently shouldn't be. This is a common posted problem, but no answers yet. Here's the bad code from Orderstring area of catalog/includes/modules/payment/geotrust.php: $process_button_string = tep_draw_hidden_field('Month', $this->cc_expiry_month) . tep_draw_hidden_field('Year', substr($this->cc_expiry_year, -2)) . tep_draw_hidden_field('Accountnumber', $this->cc_card_number) . tep_draw_hidden_field('Serialnumber', MODULE_PAYMENT_GEOTRUST_MERCHANT_ID) . tep_draw_hidden_field('Ordernumber', STORE_NAME . date('YmdHis')) . tep_draw_hidden_field('Transactionamount', number_format($order->info['total'], 2, '', '')) . tep_draw_hidden_field('Orderstring', 'Teanas~' . date('YmdHis') . '~' . number_format($order->info['total'], 2, '', '') . '~1~Y||') . tep_draw_hidden_field('cvv2', $HTTP_POST_VARS['geotrust_cc_cvv2']) . tep_draw_hidden_field('sjname', $HTTP_POST_VARS['geotrust_cc_owner_firstname'] . ' ' . $HTTP_POST_VARS['geotrust_cc_owner_lastname']) . tep_draw_hidden_field('Streetaddress', $order->billing['street_address']) . tep_draw_hidden_field('Streetaddress2', $order->billing['suburb']) . tep_draw_hidden_field('City', $order->billing['city']) . tep_draw_hidden_field('State', $order->billing['state']) . tep_draw_hidden_field('Zipcode', $order->billing['postcode']) . tep_draw_hidden_field('Country', $order->billing['country']['title']) . tep_draw_hidden_field('Shiptophone', $order->customer['telephone']) . tep_draw_hidden_field('Email', $order->customer['email_address']) . tep_draw_hidden_field('Shiptoname', $order->delivery['firstname'] . ' ' . $order->delivery['lastname']) . tep_draw_hidden_field('Shiptostreetaddress', $order->delivery['street_address']) . tep_draw_hidden_field('Shiptostreetaddress2', $order->delivery['suburb']) . tep_draw_hidden_field('Shiptocity', $order->delivery['city']) . tep_draw_hidden_field('Shiptostate', $order->delivery['state']) . tep_draw_hidden_field('Shiptozipcode', $order->delivery['postcode']) . tep_draw_hidden_field('Shiptocountry', $order->delivery['country']['title']); return $process_button_string; } Here's some tips from Skipjack on Orderstring variables that might be to you: Skipjack Integration Guide link Thanks for your help!
  15. yodergraphics

    [Support] Category Fields

    Would Category Fields work to specify a deep link URL for a single sub category, so that when you click on that specific category, you are forwarded out of the osCommerce invironment to a 3rd party link. I am looking for a solution to do this. Please let me know, and thanks.
  16. I believe it is designed to have those appearing in Configuration>My Store area, separate from the other functions. Roll back prior to 5.13d to get files that have english. Do a search in this topic for french or topics posted by MzBeanz because it has been talked about a lot.
  17. If anyone has solved the Teanas~ error within the orderstring area of catalog/includes/modules/payment/geotrust.php please post what you replaced the following bad line with: tep_draw_hidden_field('Orderstring', 'Teanas~' . date('YmdHis') . '~' . number_format($order->info['total'], 2, '', '') . '~1~Y||') . If I figure it out, I'll keep you posted.
  18. Yes, I had that problem, and it is explain in this topic somewhere. Basically the french is included in one of the php files in 5.13d and 5.13e. I grabbed a file from an earlier version and I also deleted the french out of the mySQL database, and that fixed it. But there is hard french written in the php files....one of the modules I think.
  19. Invoice not showing GV/not clearing. Two problems: The osCommerce invoice does not show the Gift certificate amount and the Gift Voucher amount is not cleared. However, the correct amount is deducted by the credit card processor (GeoTrust) I have gotten this to react correctly once, but I changed the settings before I realised, and can't get it back to "working". I think the answer is in the sort order, or a combination of sort order and Gift Voucher/Discount Coupon settings. I have tried various sort orders, including the original ones in the 5.13 instructions. My settings are consistent with the instructions. I have tried clearing my Gift Voucher amount on my account (by sending it to someone) and applying a fresh code: Didn't help. I am running 5.13d. I did install 5.13e, but rolled it back, thinking it was the problem. If you have any suggestions, even a hunch, please post! What is your working sort order and settings?
  20. Invoice not showing GV/not clearing. The osCommerce invoice does not show the Gift certificate amount and the Gift Voucher amount is not cleared. However, the correct amount is deducted by the credit card processor (GeoTrust) I have gotten this to react correctly once, but I changed the settings before I realised, and can't get it back to "working". I think the answer is in the sort order, or a combination of sort order and Gift Voucher/Discount Coupon settings. I have tried various sort orders, including the original ones in the 5.13 instructions. My settings are consistent with the instructions. I have tried clearing my Gift Voucher amount on my account (by sending it to someone) and applying a fresh code: Didn't help. If you have any suggestions, even a hunch, please post!
  21. No shipping only with no-weight products. So far this is what I know. Because we were using table-rate shipping, we did not put a weight on any of our products. Products with drop down options (color, size, etc.) were routed to the Delivery confirmation page, but Products without options with NO weight (Weight of 0) were bypassing the delivery confirmation page as "virtual items" which they were not. Is there a setting that will allow for the gift cerifiates (weightless items) to continue to be virtual, but other no-weight items to draw from the table.php table weight settings? Otherwise, it looks like we will just have to had "1 lb." to every product. I'll probably use the contribution 'easy populate' to do that. Any suggestions? A setting that fixes this without adding weight?
  22. Ripping this baby out completely and rolling my store back about a month! Hopefully Table Rate shipping will return at checkout!
  23. Shipping not showing. Shipping method and cost are not showing up anywhere in the ordering process. Does anyone know how to get the shipping method (Table Rate in my case) to reappear? This is in addition to the above problems that I'm still having. I'm playing with various sort orders and settings.
  24. yodergraphics

    Option Type Feature v1.6 (for osc 2.2 MS2)

    Fractional Decimal text area for fabric? Is anyone using the text field part of this contribution to create a text area where the customer could enter decimal increments like 1.25 or 1.5, and then have that number multiplied to the base price for a final price. Is that possible with this contribution? If you are, please reply & let me know what you did.
  25. More details on errors. Please advise. This is related to my previous posts a few posts above. Here's the symptoms: If the Gift Certificate makes the entire sale amount to $0.00 (because the credit was greater than the item price), order will not process and I get a osCommerce generated "Credit Card error" messege. If the total is a positive amount (anthing greater than $0.00), the order processes! But, after that, more errors: The Certificate balance does not clear/reset, as if it was not used. The Cart does clear fine. The e-mail invoice does not show the gift cert. applied. But they were charged correctly, with the gift cert. amount applied. Any suggestions? I am running the CCGV 5.13e, no paypal fix, using Geotrust Skipjack as a payment processor.
×