Jump to content

aejeffor

Members
  • Content count

    69
  • Joined

  • Last visited

Everything posted by aejeffor

  1. Hi all, I am searching for a way to add a one page survey to the checkout process, between checkout shipping, and checkoutpayment. The survey will write to the db, append the order number to the results, and email the admin the results. I have seen it done on another oscommerce site, but I cannot find a working contribution for it anywhere. I have looked throught he contributions listed when i searched 'survey' and one is an emailed survey, another is an incomplete contribution. Has anyone successfully accomplished this? If so, any pointers or breadcrumbs would be appreciated. Thanks!!
  2. aejeffor

    Featured Product Support v1.5.4

    Bill/Anyone, I have been 'trial and erroring' with this contribution now for a month, and I cannot get it work as designed. I have installed and reinstalled it several times now just in case I was missing something but it still gives me the same problem. The featured product appears on every page, that I add the $featuredbox tag to. However, it will not show the proper category. It keeps showing a random one. I have debugged it to the point where, I can get it to show the proper featured product, ONLY if I am in a category that has just categories below it. As soon as I add an item to the top level category, the featured box begins to output random products again. Here is an example: Main category - Oils Sub Category - Nut Oils Sub Category - Olive Oils Sub Category - Other Oils If I have the above structure, the contribution will work correctly for the Top Level Oils Page. However, the moment I add a regular item to the Oils category (not the subcategories) then the contribution reverts back to random products. And the subcategories, which also have subcategories,and items within them, always have a random product. Im pulling my hair out on this one. If anyone has ideas, please let me know. Thank you in advance
  3. aejeffor

    Featured Product Support v1.5.4

    Before anyone berates me for not reading the forum, I have already tried the nested subcategories featured.php page. It works, but pulls random products instead of products in that category. It seems to me that it is almost there, just one small edit and it would work, but unfortunately, I dont know where to make that edit. Any ideas or thoughts would be appreciated.
  4. aejeffor

    Featured Product Support v1.5.4

    Bill, I have figured out my issue for the most part. I have never used a stock OSC site without some sort of template system, so I was not distinguishing properly between the infobox for the featured product and the featured product box that appears on the bottom of the page in the middle of the content. The infobox always shows a random product. I have created an STS tag per your instructions for this on the homepage of my site before anyone goes into any category. There will always be a rotating random product there. That works fine. For the interior pages, I needed to take the code that creates the main featured product box and create an sts tag for that. My reasoning is that I want a featured product for each category to appear within the area of the product listings on the index.php pages. I want each category to only show products from that category while the user is browsing the categories. So, I added an STS tag for that using the code in /includes/modules/featured.php After upload, to my surprise, it worked. However, All of my categories are at least two levels deep, i.e. index.php?cpath=3_232_384 The featured product module only appears when the user is browsing the index.php?cpath=3 category, and not the subcategories within it like index.php?cpath=3_232 , etc.. My question after all of that, is ... is there a way to make the module work for the subcategories also. I took a look at the SQL queries at the top of the module itself, and Im not knowledgeable enough to be able to figure this one out. Does this make sense to you? Thank you again for your time.
  5. i had installed product thumbnail listing v 1.1 to serve my purposes, but realized there was no page settings for x number of results on a page. I asked spooks, and he said that i should upgrade to product listin enhancements, thumbnails, and manufacturer headings v 1.8. He told me that i could run the update file and that would be it. The old version worked perfectly minus the page issue, now that i have upgraded, i have distorted thumbnails, some are enlarged, and others are shrunk. i have the following admin settings: and the following results (first two are distorted and enlarged way bigger than 110 pixels wide and second one is shrunken...all images are the exact same original size) I am running the on the fly thumbnailer contribution, but it worked fine with the original product thumbnail listing 1.1 contribution, so im not sure if there were changes made in how the product_listing.php gets the thumbnail from that version to this? Anyone with an idea or clue on where to start looking, I would thoroughly appreciate the time.
  6. aejeffor

    Featured Product Support v1.5.4

    Bill, I appreciate your response. Please know I am not trying to waste anyones time here. I have followed your instructions to the letter and am still only producing the infobox for the featured products which is random, not the categorized ones. I am using the $content tag as well as a new tag created per your instructions. No worries though. I wont take up any more of your time. Ill either figure it out or use another contribution. Thanks again
  7. aejeffor

    Featured Product Support v1.5.4

    i have done a little more digging and debugging with the sts system turned off, and have discovered the following in regards to why the products displayed are random no matter what category the user is in: the sts instructions tell you to use the $featuredbox tag where you want the featured item to appear. However, this tag is the info box that appears in the left column on a non-templated store's main index page. And this box is always random. So, I need to figure out how to call the featured product that appears on the main category page into the template. Ive looked thoroughly and for the life of me, cannot figure out how to make this work. Anyone have any ideas?
  8. aejeffor

    Featured Product Support v1.5.4

    Hey Mindtwist, I understand that this is how the contribution is designed to work, however I am getting different results, and really dont know where to start looking for the reason. I am using STS templates per the documentation, and have the following templates structure for all of my categories: index.php.html index.php_213.html index.php_210.html index.php_215.html etc. etc. etc. Im putting items in the featured products admin, and they all still appear randomly no matter what category the user is in. I was hoping someone else had run into this and could advise me where to start debugging. Im not much more than a cutter and paster when it comes to PHP, but I could certainly use any advice anyone has. Thanks
  9. aejeffor

    Featured Product Support v1.5.4

    has anyone successfully been able to show category specific featured products? ie, only the featured products in the salt category appear when the user is browsing in the salt category, etc.? i have read this entire post and cant seem to find anyone with the answer or the same problem, so im thinking I may have some small peice of code messed up somehow. Any suggestions or help would be appreciated greatly! :blush:
  10. aejeffor

    Featured Product Support v1.5.4

    Also, Has anyone successfully been able to use the product description in the featured box? Id like the item picture witha description to appear rather than just the picture and item name. Thanks
  11. aejeffor

    Featured Product Support v1.5.4

    Has anyone experienced the issue I raised above, where the product appearing in thefeatured box, continues to be random no matter what category you are in? I need each category to have its own featured product. Am I misinformed that this contribution will accomplish this? Thank you all for your time, in advance.
  12. aejeffor

    Featured Product Support v1.5.4

    Hello all, I have searched all 13 pages of this thread and have yet to see a similar question or answer, so if I missed it, my apologies. I am using 1.61 with STS. I have separate index.php templates for each category. On each template I am calling the $featuredbox tag at the top of the page to show a featured product in each category. Everything works with the installation with the exception of the products displaying. I was under the impression that the product displayed in the $featuredbox would be only a product from the category passed in the URL. However, I get a random featured product no matter what category Im in. Im positive this is a small edit needed on my part, or an incorrect configuration, but I cant for the life of me figure out how to repair this. If anyone has suggestions, it would be greatly appreciated.
  13. Lil dog I fixed the error I think, but im not sure that it is permanent, if that makes sense. Basically, this error was appearing when a customer was selected in the admin that was created before I made the edits to the $guestaccount=null to $guestaccount=0 line. So this customer was still in the db, but had null for an address. When the function tried to merge the columns for that customer, I got the error. So, I went into the db and deleted this customer, and the error disappeared. Im just hoping that it is permanent. Does this make sense to you? LilDog you are great, and I appreciate the excellent advice you have supplied so far. Im learning slowly, but its members like you that help us less experienced coders to learn. Thank you again!
  14. Thank you for your help lildog, you were right, it was a missing table in the db from another contribution. I added the tables, and all is good now, except one thing, and I think this is a PWA issue. Nafri had the same issue from June 1, 2008 and posted on here, but i never saw a response from anyone. When I am in the admin panel and click on customers...i get the customers screen, but i also have the following warnings at the top of the page.... Anyone else seen this...LilDog?
  15. I thought I had all of my issues worked out, but apparently not. Lil dog, I made the edits that you suggested yesterday in the private message, and it seemed to fix everything. Now when I try to login as a registered user, Im getting this unknown column error. Any ideas why or where to start looking for a fix?
  16. dun i had the same issue as you from your post. if you havent figured it out by now, heres the answer: you have run the sql query to insert two new lines into the configure table twice. You simply told the database twice to add these lines. Just go into phpmyadmin and search the configure table. Do a browse, and youll see the two extra rows in that table. You should be able to delete them from there. I hope that answers your question. And by the way LilDog, I wiped my store started from scratch, and have only installed the Register Globals contribution and the Master Products Contribution, then I added PWA2.0b and I still get the guest account cannot be null error, even though its a new install, and the column in the db is not set to null. Im on a tight deadline with this store, and this is the only thing holding us up. Anyone with ideas, Id greatly appreciate them! Thanks
  17. Im getting the same errors you are with the null settings. I just checked the tables in the DB and the only difference was mine was set at Tiny(4) and not Tiny(3) but I dont think that has anything to do with the errors. Lildog, if you have seen this before, please let me know.
  18. i have installed this contribution and it works fine when i try to pruchse without an account, however, if i try to create an account i get the following error: has anyone ever run across this?
  19. aejeffor

    Faq Desk

    i got it working, as i had replaced only one instance of the max display search results code, and there were three instances in the admin/faq.php file. I still have a javascript error when trying to preview the answer, i can only preview the question. I must say, I have been dealing with oscommerce for about 4 years now, and this is by far the worst coded contribution I have ever dealt with. Why release a cont. if you know if has "multiple issues" and if you discover the issues, update the contribution for goodness sakes. I have had to modify twice as many files as the documentation recommends just to get the thing working, not to mention the image calls are all wrong, the javascript has issues with the preview, the install documentation has typos, and incorrectly referenced files to edit, and the functionality, is at best, mediocre. Folks, if you have a contribution that you feel needs sharing, make sure it works and you will be here to support it. This should be removed from the library all together in my opinion.
  20. aejeffor

    Faq Desk

    i have applied all the code fixes and all the patches listed in the documentation for this contribution, and I have still got a division by zero error appearing on my admin page. the part in the support forum that tells you to change code in the split pages.php was doable for the catalog/includes/classes/splitpages.php however, this code that the author says to change was not even in the admin/includes/classes/split_pages.php file. Anyone run across this yet?
  21. aejeffor

    Master Products - MS2

    Thanks tracy, that did it. All I did was copy and paste that particular funtion into the currencies.php file. Why wouldnt that function be in there already, though as part of the package?
  22. aejeffor

    Master Products - MS2

    I recently installed OSC using fantastico through my cPanel. I tested it everything works fine. Then I installed Master Products 1.2 on to this fresh OSC install. Now, anywhere that requires a price total calculation (shopping cart, infor box, etc) I get the following error: i read on another post that the currencies.php file may be the wrong version? How do I fix that? I know it is something conflicting with the Master Product contribution, because I have a completely clean OSC install that works, then when i install MP, I get this error every time. I have uninstalled and installed the whole store 3 times now and still get the same issue every time. Any ideas would be greatly appreciated.
  23. <edited to move to correct thread>
  24. I have installed the QBI module release 2.10b on a clean oscommerce install. When i go to the catalog configuration, i clicked the button that said click here to update the database. It was a success. It says click here to go to complete the install. When i click it the page just loads and loads and loads. Never gives me an error, but it never loads either. Its referencing the qbi_create.php page which i know is in there and is a clean copy of the file (i have uploaded it three times now) I can see the file on FTP, but when OSC tries to load that to complete the setup, it basically freezes. THe status bar on IE or FIrefox slowly moves across the bottom of the scren to indicate that it is loading, but even aftger 20 minutes or so it still will not load. I have tried loggin out and back in. I have tried it several times throughout the day. My connection is fine and my files are there, but for some reason it just wont go any further. ANY help or advice would greatly be appreciated. Edwin
  25. i am using the attitude simple manual order entry mod to allow the admin to place an order through the store for phone or fax orders. however when the main product list appears for the admin to select quanitieis of each item to order, there are no prices listed. Anyone know a way to have the sql query retrieve prodcut prices along side the product name>? here is the code from the product list page, it should be very simple for someone who knows Mysql and PHP, (not me, i know just enough to get me in trouble). ANy advice would be greatly appreciated. thanks in advance! <?php /* Attitude Simple Manual Order Entry for osCommerce v0.3 by Geoff Ford - Attitude Group Ltd - 28 February 2004 http://www.oscommerce.co.nz/ Contact Details available on website Copyright (c) 2004 Attitude Group Ltd Released under the GNU General Public License */ require('includes/application_top.php'); require('includes/configure_simple_order_entry.php'); if (MANUAL_ORDER_ENTRY_LARGE_CAT) tep_redirect(tep_href_link(FILENAME_ADMIN,'','SSL')); require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_ADMIN_LIST_PRODUCTS); $breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_ADMIN_LIST_PRODUCTS, '', 'SSL')); ?> <!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN"> <html <?php echo HTML_PARAMS; ?>> <head> <meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>"> <base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>"> <title><?php echo TITLE; ?></title> <link rel="stylesheet" type="text/css" href="stylesheet.css"> </head> <body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0"> <!-- header //--> <?php require(DIR_WS_INCLUDES . 'header.php'); ?> <!-- header_eof //--> <!-- body //--> <table border="0" width="100%" cellspacing="3" cellpadding="3"> <tr> <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2"> <!-- left_navigation //--> <?php require(DIR_WS_INCLUDES . 'column_left.php'); ?> <!-- left_navigation_eof //--> </table></td> <!-- body_text //--> <td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr> <td><table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr> <td class="pageHeading"><?php echo HEADING_TITLE; ?></td> <td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . 'table_background_browse.gif', HEADING_TITLE_2, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td> </tr> </table></td> </tr> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> <tr> <td> <!-- customer_orders //--> <?php unset($info_box_contents); $customer_orders_string = '<table border="0" width="100%" cellspacing="0" cellpadding="1">' . "\n" .' <form name="cart_quantity" method="post" action="'.tep_href_link(FILENAME_SHOPPING_CART, 'action=update_product', 'NONSSL').'">'; $products_query = tep_db_query("select pd.products_id, pd.products_name from " . TABLE_PRODUCTS . " p ," . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_id = pd.products_id and language_id = '" . $languages_id . "' order by products_name"); while ($products = tep_db_fetch_array($products_query)) { $customer_orders_string .= ' <tr>' . "\n" . //' <td class="infoBoxContents"><a href="' . tep_href_link(FILENAME_PRODUCT_INFO, 'products_id=' . $products['products_id']) . '">' . $products['products_name'] . '</a></td>' . "\n" . ' <td class="infoBoxContents">' . $products['products_name'] .'</td>' . "\n" . ' <input type="hidden" name="products_id[]" value="' . $products['products_id'] . '">'. ' <td class="infoBoxContents" align="right" valign="top"><input type="text" name="cart_quantity[]" value="' . $products_quantity[$products['products_id']] . '" size="4"></td>' . "\n" . //' <td class="infoBoxContents" align="right" valign="top"><a href="' . tep_href_link(basename($PHP_SELF), tep_get_all_get_params(array('action')) . 'action=cust_order&pid=' . $products['products_id'], 'NONSSL') . '">' . tep_image(DIR_WS_ICONS . 'cart.gif', ICON_CART) . '</a></td>' . "\n" . ' </tr>' . "\n"; } $customer_orders_string .= '<tr><td colspan="2" align="right">'.tep_image_submit('button_in_cart.gif', IMAGE_BUTTON_IN_CART).'</td></form></table>'; $info_box_contents[] = array('align' => 'left', 'text' => $customer_orders_string); new infoBox($info_box_contents); ?> <!-- customer_orders_eof //--> </td> </tr> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td> </tr> </table></td> <!-- body_text_eof //--> <td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2"> <!-- right_navigation //--> <?php require(DIR_WS_INCLUDES . 'column_right.php'); ?> <!-- right_navigation_eof //--> </table></td> </tr> </table> <!-- body_eof //--> <!-- footer //--> <?php require(DIR_WS_INCLUDES . 'footer.php'); ?> <!-- footer_eof //--> </body> </html> <?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>
×