Jump to content

AirGrinder

Members
  • Content count

    20
  • Joined

  • Last visited

Posts posted by AirGrinder


  1. One more other thing I noticed, since the fix fir the images I seem to be getting this error fairly frequently:

    ERROR: FedEx Return Error FFF0 : FedEx Ground Parameter Validation System Failure

     

    Once it was the ground address was too long, another the phone # has extra characters, but it is so vague the others I had to give up on. It seems like before we got specific error messages not just this vague one. Has anyone else experienced this?

     

    I haven't had a chance yet to chat with FedEx on this issue - but when I spoke to them about not getting a valid data stream back from them they acknowledged a problem on their end with Ground shipping as well, which remains unresolved to date. Their temporary solution was to regenerate a meter id which has helped but now it seems more has been "fixed" by them.

     

    Rayzak: Are you manually changing the weight of the individual boxes? Make sure that they all add up to the original weight. For instance, with 5 packages weighing a total of 100 lbs, make sure that the individual packages have the correct quantities totalling 100 lbs. I get this error only when I miscalculate the weight after manually changing the amount of packages.

     

    cdi-buy.com: So far the error is with all Express methods. Hopefully I can get some answers soon. It seems the WIS servers/code on FedEx' end is undergoing more changes which is messing things up :(


  2. Question: Everything with regular shipping seems to be working fine now, and I don't know if this caused mod the problem, or if it possibly existed before with the base install. But I cannot ship multiple packages 2 Day Air, I get this error message:

     

    ERROR: FedEx Return Error 1219 : Invalid package count or package sequence

    exceeds package count.

     

    Has anyone else experienced this?

     

    I've gone through every bit of relevant code and just can't see where the problem is. Running a multiple package shipment in debug mode shows everything in sequence and order. The next step is to have another chat with the fedex dev guys and see if anything's missing.

     

    In the mean time if anyone has more info on this (or a fix), please do share :)


  3. Thanks for the broken image fix!!  I still have two concerns regarding other stuff.

     

    #1  I want to change my default delivery type to "Drop Off At BSC".  I change that in the Fedex Control panel by setting that value to 4, but when I go to print the label, it has "Regular Pickup" as the default and I have to manually change that for each label.  How do I change the default when the control panel setting makes no difference/doesn't seem to work?

     

    #2  How do I set the default shipping date to tomorrow's date instead of today's date, so I don't have to manually type in tomorrow's date every time?

     

    Thanks for all the help everyone does with this mod!  I love it!!

     

    Charlie

     

     

    #1 Remember, you are trying to modify another contributions settings; The Fedex rates admin side does not affect the FedEx labels contribution. If you do not intend on using the other dropoff/pickup options simply uncomment the ones you do not need in the ship_fedex.php file (around line 549 in the dropoff array) or you can always hardcode "dropoff_type = 4"

     

    #2 Simplest way:

     

    change

    $default_pickup_date = date('m-d-Y',strtotime('today'));

    to

    $default_pickup_date = date('m-d-Y',strtotime('tomorrow'));


  4. Thanks for the input. The part that threw me off was their last statement: "This field is not applicable to the FedEx Home Delivery service."

     

    Just a question now: According to FedEx, there's no need to set Home D's to "Y" because the surcharge will already be factored in. And IF we ship with ground (92) which was delivered to a residential address which should have been 90 they'll simply charge the shipper extra automatically. Where I'm trying to get at is this: since it's all done automagically is there really a need for that code bit?


  5. Question for spoot/michael and others:

     

    According to the FedEx Tag. Transaction listings, the 440 field is not applicable to home deliveries and may even cost the shippers more. But in the ship_fedex.php code there's this specific set:

     

    // if it's home delivery (90), add the "residential delivery flag" (440)
                   if ($HTTP_POST_VARS['service_type'] == 90) {
                           $shipData[440] = 'Y';
                           }
                   else {
                           $shipData[440] = 'N';
                           }

     

    Was there a specific reason for adding this?

     

     

    From FedEx: "Y if shipment is Residential Delivery. If Recipient Address is in a rural area (defined by table lookup), additional charge will be applied. This field is not applicable to the FedEx Home Delivery service."

     

    The Tagtransguide for others to peak at is listed here:

    http://fedex.com/us/solutions/wis/pdf/TagT...uide.pdf?link=4

     

    I'm just asking because if it does not apply to home deliveries, and if it costs us extra to use it, why use it? I'm probably missing something here but any help/insight would be appreiciated.


  6. Question: Everything with regular shipping seems to be working fine now, and I don't know if this caused mod the problem, or if it possibly existed before with the base install. But I cannot ship multiple packages 2 Day Air, I get this error message:

     

    ERROR: FedEx Return Error 1219 : Invalid package count or package sequence

    exceeds package count.

     

    Has anyone else experienced this?

     

     

    Good catch - I guess we've never had to ship multiples using 2day/etc. It also seems that this problem existed before the signature mod.

     

    I'll try to figure out what's going on with it tonight and report back with a solution/fix if any.


  7. CDI-BUY and others who wanted the sign on delivery options created with the labels:

     

    Simply add those changes I've posted a couple of posts above. All seems to go well as since my last post we've had 44 packages successfully accepted and shipped through FedEx :)

     

    That new addition gives you the option to select those 4 types of signature options:

     

    0 = no signature required (select for none)

    2 = Can be signed by anyone

    3 = Can ONLY be signed by the recipient (on the label)

    4 = Requires adult signature.

     

    These options (if you follow those installation instructions) will give you a drop down box etc with the specified signature code on the printed label.

     

    Don't use it blindly, as there is a small surcharge ($0.90 for us, might be more or less for you) per signature option (except 0). These rates can be negotiated with your Fedex sales person if need be.

     

    Perfect for eBay or wherever sigs are required for the different options.

     

     

    All is well now plus that little addition. If anyone cares to package it in the next release, feel free to do so.

     

    I hope that helps anyone.

     

    Over and out.


  8. Ok.... finally getting somewhere. Again, not sure how this will affect label printing, but some big changes where made to some of the field tags.

     

    New field tags:

     

    2399 (in regards to signatures)

     

    0 = non specified

    2 = indirect signature permitted

    3 = direct signature required

    4 = adult signature required

    2402 = signature surcharge

     

    2403 = listing of surcharge/gop surcharge

    The first one (2399) is the biggest one that we have to pay attention to. We're in the process of updating ship_fedex.php to add the boxes/array, but at least one value should be posted to FedEx from what I understand. E.g. if you do not need a signature, you need to post 0 and so on.... That's where the problem is (I think).

     

    Hope this helps you guys out there.

     

     

    Around line 126

    find

            0=>     $transaction_code // transaction code

    add

          ,2399=> $HTTP_POST_VARS['signature_type'] // signature type

     

     

    Add your arrays around line 505:

     

    // arrays for signature services
                   $signature_type = array();
                   $signature_type[] = array('id' => '0', 'text' => 'None Required');
                   $signature_type[] = array('id' => '2', 'text' => 'Anyone can sign');
                   $signature_type[] = array('id' => '3', 'text' => 'Signature Required');
                   $signature_type[] = array('id' => '4', 'text' => 'Adult Signature');

     

     

    Around line 700 add drop down box:

              <tr>
                           <td class="main" align="right">Signature Options</td>
                          <td class="main"> </td>
                          <td class="main"><?php echo tep_draw_pull_down_menu('signature_type',$signature_type); ?></td>
            </tr>

     

    Around line 820 add the hidden text field for signatures

     

    <input type="hidden" name="signature_type" value="<?php echo $HTTP_POST_VARS['signature_type']; ?>" />

     

    I think that's it. This is on the latest ship_fedex.php file. Some other failover changes were made not related to this change, just an external call to our local servers to be able to generate labels regardless if this is down or not; either way,the above should give you a head start.


  9. Ok.... finally getting somewhere. Again, not sure how this will affect label printing, but some big changes where made to some of the field tags.

     

    New field tags:

     

    2399 (in regards to signatures)

     

    0 = non specified

    2 = indirect signature permitted

    3 = direct signature required

    4 = adult signature required

     

     

    2402 = signature surcharge

     

    2403 = listing of surcharge/gop surcharge

     

     

    The first one (2399) is the biggest one that we have to pay attention to. We're in the process of updating ship_fedex.php to add the boxes/array, but at least one value should be posted to FedEx from what I understand. E.g. if you do not need a signature, you need to post 0 and so on.... That's where the problem is (I think).

     

    Hope this helps you guys out there.


  10. Still on the phone with the FedEx dev team and the only changes made over the weekend (which could possibly affect us) is the addition of "Signature services". I do not see how this can affect the label priting part, but we're both working on a solution as we speak.

     

    While I'm at it, signature services sounds like a welcome addition so it might as well be added. Depending on my time, I might report back with a solution and maybe even a sig. addon.

     

    Ok, so Im' getting a little ahead of myself here; the signature part as previously mentioned in posts by spoot are a simple addon (tag id 1208 I think it was). But how this affects label generation is still unknown. Anyone?


  11. Still on the phone with the FedEx dev team and the only changes made over the weekend (which could possibly affect us) is the addition of "Signature services". I do not see how this can affect the label priting part, but we're both working on a solution as we speak.

     

    While I'm at it, signature services sounds like a welcome addition so it might as well be added. Depending on my time, I might report back with a solution and maybe even a sig. addon.


  12. RE: Broken Image Error.

     

    I to now am experiencing this broken image error.  I have all the latest updates.  I've been running Fedex Labels for months now, and all of a sudden today I get broken png images.  I am on the Production Server and have been for months.  I have made absolutely NO changes to any of my files in weeks and it was working perfectly until today.  I last successfully printed labels on Thursday evening.

     

    I can tell you this:  It is not a browser problem, because when I go into my saved Fedex label files and export the png file (the fedex label) and then try to open it with Adobe Photoshop, it is a blank image....nothing on it.  Also, if I go to display my old Fedex Labels, they do display WITHOUT problems.

     

    Soooo, Fedex must have changed something in the last few days that has created a communication problem in the Fedex Automated Labels mod.

     

    Please help!!!

     

    Exact same issue here. I'm just hoping that nothing too complicated has changed on FedEx' end since this contrib is as simple as it can get without major points of failure. I'll try to get a hold of the dev guys at fedex in the morning to see what's going on as we kind of depend on it being up. (It would be nice if something was posted or sent ou to their users though)


  13. Hello,

     

    Did anyone find a solution to this? Deleting any product renders the same problem above, even if it does not have AS set to them. Just wondering if anyone got a workaround for this.

     

    It actually deletes the products etc, but the error still persists.

     

    Thanks a lot guys/gals!

     

     

    Never mind, used the post_vars for products_id instead, now it works... Great mod btw Joey!


  14. I have just installed the attribute sets contribution and the rest of it seem to be working fine, but when I try to delete an item, I get the screen. Can you tell me how to correct it please?

     

     

    Hello,

     

    Did anyone find a solution to this? Deleting any product renders the same problem above, even if it does not have AS set to them. Just wondering if anyone got a workaround for this.

     

    It actually deletes the products etc, but the error still persists.

     

    Thanks a lot guys/gals!


  15. I must commend you on your efforts! I've gone through the installation file and looked at the code and it looks all good. Can't wait to get this installed on some shops! Definitely an awesome addon/contribution you've provided here.

     

    Looks simple enough to install especially with the provided installation text file. Lots of details which should help even the php newcomers if they follow it step by step.

     

    I'll report in later...

     

    Excellent job DS!


  16. This is the dirty way, but if you MUST have it now here goes.. There are better ways to do all this such as using proper TEP coding standards for forms etc. (BTW this is only for the update function to work. The add, delete, edit functions work fine.

     

    This is all to gift_add.php in admin.

     

    After case 'delete'' add

     

     

     case 'update' :
                   $id = $HTTP_GET_VARS['ID'];
                   $newthreshold = $HTTP_GET_VARS['newthreshold'];
    
                   if ($id && $newthreshold) {
                           tep_db_query("update free_gifts set threshold ='".$newthreshold."' where products_id = '".$id."'");
                   } else {
                           $message = '<font color="red">FORM ERROR</font>';
                   }
                   tep_redirect('gift_add.php');
           break;

     

     

    For ease sake (not the good way, just being lazy right now) replace the whole "while" section that starts on line 92

     

    while ($gift = tep_db_fetch_array($gift_query)) {
    
                                   echo '<form action="gift_add.php" method="GET"><tr>
                                   <td class="smallText">$<input type="text" size="4" name="threshold"
    value="'.$gift['threshold'].'"></td>
                                   <td class="smallText">'.$gift['products_id'].'</td>
                                   <td class="smallText">'.$gift['products_name'].'</td>
                                   <td class="smallText">'.tep_image_submit('button_update.gif', IMAGE_SEARCH).'
      <a href="gift_add.php?ID='.$gift['products_id'].'&action=delete">'.tep_image_submit('button_delete.gif',
    'Delete').'</a>   <a
    href="categories.php?pID='.$gift['products_id'].'&action=new_product">'.tep_image_submit('button_edit.gif',
    'Edit').'</a> </td>
                                   </tr></form>';
                           }

     

    with

     

                            while ($gift = tep_db_fetch_array($gift_query)) {
                                   echo '<form action="gift_add.php" method="GET"><tr>
                                   <td class="smallText">$<input type="text" size="4" name="newthreshold" value="'.$gift['threshold'].'"></td>
                  <td class="smallText">'.$gift['products_id'].'</td>
                  <td class="smallText">'.$gift['products_name'].'</td>
                  <input type="hidden" name="ID" value="'.$gift['products_id'].'">
                  <input type="hidden" name="action" value="update">
                  <td class="smallText">'.tep_image_submit('button_update.gif', IMAGE_BUTTON_SUBMIT).'</form>
                     <a href="gift_add.php?ID='.$gift['products_id'].'&action=delete">'.tep_image_submit
    ('button_delete.gif', 'Delete').'</a>   <a href="categories.php?pID='.$gift['products_id'].'&action=
    new_product">'.tep_image_submit('button_edit.gif', 'Edit').'</a> </td>
                           </tr>';
                           }

     

    ps, backup just in case, it works here and I'll update it in the morning since I've been up for 32 hours straight working on other stuff...


  17. Not wanting to spam the board with my BS, but I just wanted to report in:

     

    Some of the contribs installed:

     

    Gv/Coupons

    Multiple Pricing + discount/customer

    an inhouse contrib for rewards based on total sales for set period

    Paypal shopping cart

    Hide/Show categories

    and some others that can not affect Dangling carrot or other checkout/payment functions.

     

    Using 2.0 of Dangling carrot went without any problems and all aspects have been tested with 23 orders over the last hour after installation.

     

    Not sure if I missed something but I have to set the gift product to in stock, but because I have that show/hide contrib installed it works out fine that way (it does not show up for customers even if they search for it)

     

    So no code or parse errors with 2.0;  Job well done Jack!!

     

     

    Oops, spoke to soon: The update button in admin is missing the actual update function/case in the code. The delete or edit links/functions work fine. I'll post the case "update" code here in a few...


  18. Not wanting to spam the board with my BS, but I just wanted to report in:

     

    Some of the contribs installed:

     

    Gv/Coupons

    Multiple Pricing + discount/customer

    an inhouse contrib for rewards based on total sales for set period

    Paypal shopping cart

    Hide/Show categories

    and some others that can not affect Dangling carrot or other checkout/payment functions.

     

    Using 2.0 of Dangling carrot went without any problems and all aspects have been tested with 23 orders over the last hour after installation.

     

    Not sure if I missed something but I have to set the gift product to in stock, but because I have that show/hide contrib installed it works out fine that way (it does not show up for customers even if they search for it)

     

    So no code or parse errors with 2.0; Job well done Jack!!


  19. Thanks Jack and others for all the work put into this contrib! Just a quick note on those with the multiple pricing contribution installed since I've seen a few questions about it.

     

    In step 6 (from instructions for v2.0 of Dangling Carrot) when it comes to the query modification, you'll have to modify your catalog/includes/classes/PriceFormatter.php file instead.

     

    Find the loadProduct function:

     

    function loadProduct($product_id, $language_id=1)
     {
    $sql="select pd.products_name, p.products_model, p.products_image,  p.products_id," .
    " p.manufacturers_id, p.products_price, p.products_weight, p.products_carrot," .

     

    Note the p.products_carrot addition to that line above... That's about it. Everything else seems to work at this point as far as the 2.0 update.

     

    Again, thanks to Jack and other Carrot contributors :) Awesome job.

     

     

    --Wlad

×