Jump to content

sidewinder

Members
  • Content count

    36
  • Joined

  • Last visited

1 Follower

Profile Information

  1. Yeah I see the code, however, to stop major image distortion on the thumbs I have left the Height blank within the setup of the store config, this displays the thumbs with 'as said' les distortion, probably due to keeping aspect ratio, if I put a number in there, the same as the width, say 100 and 100, it does work, blast!!!, but you end up with the images looking like square / retangular distored images naffff... can you think of a fix for this Surfalot ?, is their some image resizing contrib I can use where it helps with this issue?? btw.. cheers for the quick reply, I appreciate it...
  2. firstly this contrib is great! it works fine, or seems to... Anyway I have 2 questions, the 1st is regarding the code in catalog\admin\includes\functions\general.php at approx. line 882 (on mine anyway) I think I noticed a bug, I amended the code and it seems to work, but I would appreciate surfalot if you could confirm what I did... the code previously was (this is a chopped version, only showing the lines necessary to explain) if ($duplicate_subimage1['total'] < 2) { if (file_exists(DIR_FS_CATALOG_IMAGES . $product_subimage1['products_subimage1'])) { @unlink(DIR_FS_CATALOG_IMAGES . $product_subimage1['products_subimage1']); } } if ($duplicate_subimage2['total'] < 2) { if (file_exists(DIR_FS_CATALOG_IMAGES . $product_subimage2['products_subimage2'])) { @unlink(DIR_FS_CATALOG_IMAGES . $product_subimage2['products_subimage2']); } } if ($duplicate_subimage3['total'] < 3) { if (file_exists(DIR_FS_CATALOG_IMAGES . $product_subimage3['products_subimage3'])) { @unlink(DIR_FS_CATALOG_IMAGES . $product_subimage3['products_subimage3']); } } if ($duplicate_subimage4['total'] < 5) { if (file_exists(DIR_FS_CATALOG_IMAGES . $product_subimage4['products_subimage4'])) { @unlink(DIR_FS_CATALOG_IMAGES . $product_subimage4['products_subimage4']); } } if ($duplicate_subimage5['total'] < 5) { if (file_exists(DIR_FS_CATALOG_IMAGES . $product_subimage5['products_subimage5'])) { @unlink(DIR_FS_CATALOG_IMAGES . $product_subimage5['products_subimage5']); } } if ($duplicate_subimage6['total'] < 6) { if (file_exists(DIR_FS_CATALOG_IMAGES . $product_subimage6['products_subimage6'])) { @unlink(DIR_FS_CATALOG_IMAGES . $product_subimage6['products_subimage6']); } } I believe this code is checking for duplicate images?, so I would expect the code on all the subimages to say '($duplicate_subimageX'total'] < 2)', however they seem incorrect, am I right to amend all these to say < 2 ???,, I have anyway, and as said, it seems to work okay... 2nd question is.... Is it possible to have the images in product setup to adhere to the image restrictions?, as the images I am using are 800px wide for each of the images I upload, this throws the product admin page into huge proportions, any assistance with that would be greatly appreciated, I have looked at the code to try to find where to add in SMALL_IMAGE_WIDTH, and SMALL_IMAGE_HEIGHT, but I have not managed to see it as yet, probably because I am looking in the wrong places. thanks in advance.. regards John. regardless, like I said, this is a great contrib as it stands, something I feel should have been part of oscommerce from the start, 1 image is just not enough, when all you have are images to display a product, the more the better...
  3. sidewinder

    [Contribution]Paypal IPN - Devosc

    just tried your site got this error Fatal error: Call to undefined function: require() in /home/vinnielola/domains/vinnieandlola.co.uk/public_html/catalog/includes/application_top.php on line 126 which points to a problem with 'probably' this line require(DIR_WS_MODULES . 'payment/paypal/classes/osC/osC.class.php'); I had an issue with this paypal contribution a while ago, and it turned out that some of the php files were not there, instead of say osC.class.php there was a folder with that name, so re-check all your files are there, and in the correct places, I can vouch for this contrib, it is fantastic work from Devosc re-check, yes I know it's a lot of files, but trust me, if you find the offender, you will be happy... good luck, heading off to bed... work tomorrow :(
  4. sidewinder

    [Contribution]Paypal IPN - Devosc

    hmmmmmmmm... I think you need to check through your setup files, mine is exactly that, and I am not getting that error... //begin PayPal_Shopping_Cart_IPN define('FILENAME_PAYPAL', 'paypal.php'); //end PayPal_Shopping_Cart_IPN actually looking at your error, it mentions line 59, is this on line 59 ??
  5. sidewinder

    [Contribution]Paypal IPN - Devosc

    Hi, I am having a problem with the return of the customer back to my website from completing the transaction at paypal, I have tested on sandbox, and it works perfectly, although on sandbox I am paying with a paypal account, and on the real paypal I made a transaction using a credit card, but that shouldn't really matter, should it? added: :angry: forgot to mention, that on the 'sandbox' paypal, the auto return feature works perfect also, on the 'real' paypal I have to use a button to return to merchant!!! dammit... the user is returned back to index, when they press the 'return to merchant' button on paypal, it shows them as logged out, but if you then click 'Account', you are still logged in, and the basket is empty, all the IPN info is present in the admin side.. so the only problem appears to be it reutrns to the wrong page from paypal... I have the settings set exactly as Devosc explains in his contrib info, and also the sandbox settings matched with my 'real' paypal account... I have noticed tho' that the forums on sandbox are saying that the funcitionality in the sandbox side of paypal has problems, for example they say to create a 'dummy' bank account for the sandbox users, use these settings, and then when you try those settings, it returns an error due to the fictious bank details 'provided by sandbox' are invalid, so lotsa people giving grief about that, although it appears paypal is doing little about the problem.. mayeb cos they are making too mush loot out of other areas to worry about assisting the developers... strange business view to take... but anyway.. I am moving away from my actual isseu here hehehehe I would appreciate any help anyone can provide, I have seen another user who had the same problem, I messaged them, but hold no hope of hearing anything, cos they have not been active here for some time, given their last activity on their profile... cheers. John.
  6. sidewinder

    [Contribution]Paypal IPN - Devosc

    :'( I have installed the paypal 3.15 contribution, and it seems to be working great except for one thing.... 'paypal orders that are not completed, are shown as pending in the customers history.. quite confusing...' if a customer orders something, then progresses through to confirm the order, this then jumps to paypal, and thats great, the info is there of the customer, they can view cart contents etc, however, if the customer aborts at this stage, or carries through and cancels the transcation properly through paypal, then they can return to the merchant, which is great, they return to the checkout stage again, but.... osc has the order in the customers history, it does say pending, is this normal behaviour ? or not ?, I would think if this was a popular ecommerce website, and a few orders were coming in per day, then this would become quite confusing and time consuming to keep having to remove orders, that were cancelled before being paid for through paypal, not only confusing for the owner of the website, but also for the customer as they could be thinking, 'I am sure I cancelled this, but it shows in my order history as pending'.... I think I need some clarity on thta aspect... cheers.. John.
  7. gawddd.. I am gonna get some sleep now.. 3am yesterday, after 1am today, and probably gonna be 2am... uugghhhh.. but.. another question on the redeem aspect of this great contribution.. anyone know how to show a redeem box on the left/right column ?, I have seen it on a site which is so using oscommerce, so it is possible, I am too tired to look at that tonight.. so anyone who has managed that, I would appreciate the help.. here is the site with the box http://www.inkcycle.co.uk/ regards John.
  8. as you can tell, I am new to this.. the file this code is in is... catalog\includes\boxes\shopping_cart.php around line 34 actually you had a point about the code.. adding the period makes that line, and the line below identical, unless I need sleep drastically.. too many late nights, I tried swapping the line with the period, and the line without the period around, and the more info link still failed to popup the info when the cart was empty, so I took out completely the line without the period.. and it worked with items in the cart, and with no items in the cart... my code now works like this // ############ Added CCGV Contribution ########## $cart_contents_string .= '<table border="0" width="100%" cellspacing="0" cellpadding="0">'; //$cart_contents_string = '<table border="0" width="100%" cellspacing="0" cellpadding="0">'; // Modified in v5.13 by Rigadin for STS compatibility // ############ End Added CCGV Contribution ########## as you can see, I have totally commented out the second line, as adding the period makes both lines identical.. I too wonder if the line that originally was without a period was for a purpose, or tired eyes.. logically you would assume it is there for a reason.. the modifier mentions STS compatibility, but seeing as I dont use STS, I am not too concerned...
  9. The javascript was not the problem, it was the code of the IF statement below which missed a period... even your javascript with the quote, which I assumed it was, didn't fix the issue, it just doesn't work if there is something in the cart, the reason for this was the incorrect syntax of the IF statement.. nothing to do with the javascript! John.
  10. Also.... did anyone find how to remove the INACTIVE COUPONS ? if you hit delete, it jumps to the active coupons to confirm, I will look at the logic, and try to get my head around the code, otherwise for quickness, I guess I will just dump the inactive coupons from the database backend manually... not ideal.. but... regards John.
  11. I think I have the problem sorted with the more info link for the shopping cart, looking at the code with fresh eye's this morning, I noticed that there is an error in the code, or at least, there seemed to be (I'm not up to speed woth PHP)... look just below the javascript code, there is an IF statement... this is the original code: // $cart_contents_string = ''; // ############ End Added CCGV Contribution ########## if ($cart->count_contents() > 0) { // ############ Added CCGV Contribution ########## $cart_contents_string = '<table border="0" width="100%" cellspacing="0" cellpadding="0">'; $cart_contents_string .= '<table border="0" width="100%" cellspacing="0" cellpadding="0">'; // Modified in v5.13 by Rigadin for STS compatibility // ############ End Added CCGV Contribution ########## Notice any difference between the two lines after the IF ? I changed it to this: // $cart_contents_string = ''; // ############ End Added CCGV Contribution ########## if ($cart->count_contents() > 0) { // ############ Added CCGV Contribution ########## $cart_contents_string .= '<table border="0" width="100%" cellspacing="0" cellpadding="0">'; $cart_contents_string .= '<table border="0" width="100%" cellspacing="0" cellpadding="0">'; // Modified in v5.13 by Rigadin for STS compatibility // ############ End Added CCGV Contribution ########## Notice the period ? (( $cart_contents_string .= )) This worked for me... hopefully it will work for you guys too..
  12. Also, forgot about the other issue... how do you delete inactive coupons ???? regards John.
  13. Hey Jan, I know I was telling you how to remove the french info from the configuration table, I just read the forum incorrectly... sorry 'bout that... ermmm... I have an issue hopefully someone can help me with... in the forum there is a post that say replace the javascript code for the popup window, and it will fix the error and the fact that nothing happens.. well the 'fix' didn't fix that problem for me... this is what I had originally $cart_contents_string =" <script language=\"javascript\"> function couponpopupWindow(url) { window.open(url,'popupWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=yes,re sizable=yes,copyhistory=no,width=450,height=280,screenX=150,screenY=150,top=150,l eft=150') } //--></script>"; I tried replacing that with <!-- shopping_cart //--> <script language="javascript"><!-- function couponpopupWindow(url) { window.open(url,'popupWindow',& #39;toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=yes,re sizable=yes,copyhistory=no,width=450,height=280,screenX=150,screenY=150,top=150,l eft=150') } //--></script> but this didn't work, I noticed that the 2nd line of the fix was <script language="javascript"><!-- when in fact to get around a string error showing onscreen, it should've been <script language=\"javascript\"><!-- however.. even this did not work.. the error of T_STRING disappeared, but the coupon more info popup still did nothing, and error showed in IE... hmmmmmmmmmmm... anyone ?
  14. hey Jan, did you manage to correct the extra lines in the configuration section that were in french ? If not then you are probably going to have to use SQLAdmin through your host control panel, or whatever else you can use to edit the database, of course BACKUP; your database first, if you are a little unsure of how to do that, if you browse the configuration table, and REMOVE the french entries from there, then you should be fine... regards John.
  15. sidewinder

    individual weights of items calculated?

    sorry new to posting, I meant to post this to another topic - MultiGeoZone MultiTable Shipping Module I hear what you are saying, and believe me, after loosing my weekend to this shipping issue that a 'friend' wants me to help setup his website, I am about ready to throw in the towel... this is complicated in that he wants to have individual shipping per item, which is per zone, well, UK, EU, and the rest of the world.. so I thought hmmmm.. use a multizone table based on weight, use the weight field in the product to enter a 'number ref' and when the item was added to cart it would look at the table, get the 'weight' cost applied, and hey presto, he has what he wants, apart from it going wrong when you have multiple items, the way the table works is it adds the items weights together, then looks to the table for the cost of shipping, what I need it to do is look at the table for each item, then total that, then that is the true shipping cost... uuggghhh.. I am sure there must be an easier way, maybe I have blinkers on right now.. I know that I am going to call it a day for now.. maybe look at it later tonight... if I feel up to it... thanks anyway. <_<
×