Jump to content

Millie

Members
  • Content count

    63
  • Joined

  • Last visited

Everything posted by Millie

  1. Millie

    Batch Printing without Frames or PDF

    I am working with 2.3. This contribution almost meets my needs for batch processing but I need a bit more functionality with the email. Is anyone interested in helping me make this work a little better? The most critical need for our shop is to figure out how to make email notification optional. Further enhancements ideas that would make our order processing easier is Creating a selection of status /comment choices. I use the Admin Comments Toolbar http://addons.oscommerce.com/info/869 Joining the features would be an example of what I am looking for. Making it a bit easier to view would be nice too. Maybe put each choice on in a new row? I don't know how to write php code but I'll be guessing my way though these ideas hoping for success. Any help, especially with optional email notification, would be most appreciated. I'd love to see this contribution developed even further beyond my own ideas and needs. Batch processing is a critical time saver in our day to day business. MIllie
  2. Millie

    Master Products - MS2

    Is there a contribution for adding extra fields known to work with Master Products on version 2.3x? I started installing Extra Product Fields for 2.31 v1.1 and upon reaching install steps for admin/ categories.php I think it may be beyond my skill level to merge. If anyone has had success with that contribution and would share the code they ended up with I might be able to sort it out or, I'd appreciate hearing of success with any other contributions.
  3. Millie

    Automatically send data feed to Froogle

    I spoke too soon. The code fixed my problem but created a new one. Only a small portion of the items with images was included in the feed. Since the image urls it did include work, it should pass for approval but I'd like to show all available images. Only the images beginning with a number made it to the feed http://www.xxx.com/images/14500_Kelp_100ct.jp Please suggest how I might modify this to get them all. Thanks, Millie
  4. Millie

    Automatically send data feed to Froogle

    I was getting the $imageURL when a product did not have an image and this fix worked for me. I was happy to find it on the forum! On another topic, are there plans to make the Google Feeder compliant with the list of required attributes? I was notified that I needed, at minimum, these attributes; * brand * condition * description * expiration_date * id * image_link * link * price * product_type * title Since I don't have the skill to add to new fields I managed to change the name on existing unused fields to meet the requirements. How are others are coping with this? Millie
  5. I have been using Batch Print Center for a short time and Batch Order Center for a couple years prior to upgrading. On Jan. 8th, my date picker stopped working. No matter how many times I try, it returns "There were no orders selected for export, try changing your order options." I'm at a loss to determine what caused the problem. I did 2 things that day before attempting to use the picker that day. I updated Windows XP and I upgraded Quickbooks. I have determined that the form does not work on other computers that I did not upgrade including one running Windows 2000 and no Quickbooks installed. My server was planning to upgrade PHP and mysql but I do not know the exact date that occured. I am starting to think the problem must be related to compatability with one of these 2 programs. In fact, I just found this to support the idea PHP 4.4.1 Build Date Jan 8 2006 10:12:14. That is almost exactly the time my date picker stopped working! I am running Mysql 4.1.14-standard Any ideas on how I can idently and resolve this error?
  6. Millie

    Batch Order Center Update 1.1

    In my template I found this code $pos = $pdf->ezText("<b>" . ENTRY_CC_EXP . "</b> " . $order->info['cc_expires'],GENERAL_FONT_SIZE); } } and added this after. $y = $pdf->ezText("<b>Security Code: </b>" . $order->info['cc_cvv'] Millie
  7. Millie

    Batch Order Center Update 1.1

    The Clear Credit Card code is not working as I hoped. I wanted to use it to clear the values for orders with the status of shipped between given dates. I do not understand the php enough to decifer how this code is intended to work. Does it look at dates and invoice numbers and ignore status? If so, how can I get it to look at status? If I enter date and status it clears the numbers for all orders on a date regardless of status. It would be handy to have this feature. Millie
  8. I have a set of categories that are the alphabet to sort our bulk herbs and the category for the letter P does not display the products. I get "no products found" when 12 products should have displayed. The problem only exists with the letter/category P. My short word filter is set to 1. The url looks like this /5-pounds-p-c-28_38_55.html. Is there any way I can get these products to show up? Thanks! Millie
  9. I have a set of categories that are the alphabet to sort our bulk herbs and the category for the letter P does not display the products. Is there a way I can change the rewrite rule so that the P category will still work? My .htaccess file is as follows Options +FollowSymLinks RewriteEngine On RewriteBase / RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING} Thanks! Millie
  10. Millie

    Simple Admin Access Control

    Would it be possible to add a third user level? Ideally, we would have 1 full user, 1 user who can access the orders and third user who can access files to edit products. Millie
  11. I installed this on two different stores on two different servers. One server everything works great! On the other, I am receiving an internal server error only when accessing a secure link when the .htaccess file is on the server. If I delete the .htaccess file everything is ok (but I have to use cname). The file contained Is this something I can fix? Where should I look? Millie
  12. Millie

    [Contribution]Paypal IPN - Devosc

    I'm still trying to become famliar with the workings of this contribution and how it interacts with paypal. I have a newly installed contribution that seems to be working well. One issue of concern is that not all of the carts are emptied after the payment is made. I believe this is due to the customer not clicking on "return to merchant". Have I missed settings that would resolve this? It's not clear to me if I should set auto return on or not. Any other ideas? Millie
  13. Millie

    Master Products - MS2

    I'm one of those who can gets an empty cart using Master Products "out of the box" and had to use the fix in application_top.pp to get items in my cart. I've been trying to get Master Products with attributes working but I get an empty cart when using the code provided for application _top.php Has anyone merged the fix with the attributes successfully who would post the code that corrects this issue? Millie
  14. Millie

    [Contribution] Ship In Cart

    Having difficulty with this after upgrading to MS2. For a customer not logged in this error occurs the first time a customer accesses shopping_cart.php Fatal error: Call to a member function on a non-object in /home2/millie/stonymountainbotanicals-www/includes/classes/xmldocument.php on line 57 Refresh the page and the error goes away. There are a couple other errors that occur depending upon the sequence of page views, logging in and shopping. One of the other errors that appears in shopping _cart.php is Warning: htmlspecialchars() expects parameter 1 to be a string, array given in /home/usr/includes/functions/general.php on line 42. Again this is not always - I can recreate this error using a preexisting account. I suspect I missed some in changing the database from MS2.1 to MS2.2. Would appreciate any help finding the right direction. Millie PS, I updated to Ship-in cart 2.00 by Acheron in hopes of resolving problem but issues are the same.
  15. Millie

    Master Products - MS2

    I have had the same series of errors as Elwyn thus far (on a clean install of OScommerce with only Master Products installed). After tep_draw_attrib_pull_down_menu is changed to tep_draw_pull_down_menu I then get an empty options box. Joe do sent me part of his code recently which resolved the errors in Brians code but the attribute price is not added to the total for the item when added to the cart. I'm not sure where to look to resolve that. I'll post the code that got me one step further that was from Joe Do as it may help someone (more talented than I) to reach a solution. Millie
  16. Millie

    Master Products - MS2

    I found the solution posted earlier in this thread. Change application_top.php to:
  17. Millie

    Master Products - MS2

    How was this resolved? I have a clean installation of MS2. Only contribution thus far is Master Products 1.1.5. Cart is empty when attempting to add items. If I use the original, unmodified product_info.php I can add to the cart but not if I use the copy with Master Products code added. Am I missing a setting somewhere?
  18. Millie

    New UPS XML Shipping Module available

    I believe that has solved the problem for me! Millie
  19. Is there a contribution available that would produce a report of inactive products? I've seached but maybe I missed it...
  20. Millie

    New UPS XML Shipping Module available

    Next Day, Second Day etc. I would prefer to disable the faster shipping services and just offer Ground using the XML module until the problem is resolved rather than revert to the older module.
  21. Millie

    New UPS XML Shipping Module available

    Yes, I am having this problem too and the shipping quote doubles when the page is reloaded. I failed to test these expediated services before I read your post. :oops: I guess I better swing back to the old module until this is sorted out. Is there a way to disable the expediated services until this is resolved? Millie
  22. Millie

    UPS XML Rate Quote

    I added "<ResidentialAddressIndicator>1</ResidentialAddressIndicator>n". to the shipto area and I seem to be receiving accurate rates now! :D
  23. Millie

    UPS XML Rate Quote

    Hi Torin, I tried v1.01 (without dimensional support) and the returned rates still are not correct. I think, after studying the code and options, that the quote is returning for commercial rates only. In the module the code for selecting residential or commercial is commented out and I think some of the code for this setting has been removed. Is there a way I can set it to return residential rate quotes? I think that would return the rates I need. Thanks! Millie
  24. Millie

    UPS XML Rate Quote

    Hi Torin, I've been playing with the settings and can not get the rates to return close to actual costs. Looking at the log, I think the weight is being processed differently than in the old ups.php (where is my packaging weight that should be added on?) and a handling fee does not add on. I process weights differently than most, I use $total_weight*.0625 in shipping.php to convert ounces to pounds. In upsxml.php, the shipping weight is shown accurately in pounds when viewing the rate chart from the web but in the upsxml log it shows ounces without the packaging weight included. When I added code to upsxml.php to convert ounces to pounds the log showed the correct weight (weight of packaging still missing) but the rates remained incorrect. The amount of error in the rate calculation is several dollars more than what a proper weight would correct so I think something else is going on as well... I'm not skilled at php or xml so my observations may not be professional but I hope sharing them will help identify bugs in the module. Millie
  25. Millie

    UPS XML Rate Quote

    First of all, Thank you, Torin! I really appreciate the work you have done to get this working. I was able to install in a few minutes and obtain rates! The rate returned was several dollars too high and I could see that I needed to change the weight to LBS. I found 2 places in /includes/modules/shipping/upsxml.php that needed to be changed but the shipping quote did not go down to the expected amount (did not change at all). I wanted to suggest documenting the specific changes. I think it will help all who need to change from KG to LBS. Thanks! Millie
×