Jump to content

elv1s

Members
  • Content count

    60
  • Joined

  • Last visited

Everything posted by elv1s

  1. Hello, i?v got the Master Products contribution and the Attribute Sets installed. When i use the Attribute sets for a product the Product Option-Name is not shown. There is only the standard text "TABLE_HEADING_OPTIONS" which is defined in "includes/languages/english/master_products.php". How can i get the product option name to show up for each option. So; when the following option is there: Color: blue green yellow it should show up as Color: blue green yellow and not like "TABLE_HEADING_OPTIONS": blue green yellow The Product Option name should show up like i edited it in the admin section. Can someone help me out!? thanks gr. Kasper
  2. elv1s

    PC Pro Creator

    Hi there Patrick! thanks for your work and your reply.. Does the Dependencies work again? thanks a lot! gr. Kasper
  3. Well then where 2! I would like to use this contrib also. Please Contrib or by PM. thanks Gr Kasper
  4. elv1s

    PC Pro Creator

    Hello... sorry... it?s me again... :blush: i found a oscommerce page where you can see what i mean... https://www.sportspirit.de/product_info.php...roducts_id=2657 thanks again, gr. kasper
  5. elv1s

    PC Pro Creator

    Hello, ohh men i?m sorry... wrote everything in german... sorry... well, i?m just wondering if i can use this extension for the following thing: I have a Product (some kind of Masterproduct) On the product-info page this extension will load. The products wich are loaden in the selectbox have to depend on the "master" product. So wenn i have let?s say: Main product 1 - product_info.php - PC Pro Creater selectbox will show following options: -- Product 1a -- Product 1b -- Product 5a -- Product 5b Main product 2 - product_info.php - PC Pro Creater selectbox will show following options: -- Product 2a -- Product 2b -- Product 4a -- Product 4b -- Product 4c -- Product 7a -- Product 7b Product 1 & 5 are shown in the selectbox for Main product 1 but not for Main product 2. Product 2, 4 & 7 are shown in the selectbox for Main product 2 and not ffor Main product 1 Would be verry nice if someone can help me out. thanks! gracias greetzz Kasper
  6. elv1s

    PC Pro Creator

    Hallo, habe mal kurz eine Frage... Kann man diese tolle Extension auch folgende ma?e einsetzen. Produkt (hauptprodukt) Auf Produktseite wird dan diese Extension geladen. Wichtig: Die m?gliche Produkte sind abh?ngig vom Hauptprodukt. Hauptprodukt 1 - product_info.php - PC Pro Creater Produkten: -- Produkt 1a -- Produkt 1b -- Produkt 5a -- Produkt 5b Hauptprodukt 2 - product_info.php - PC Pro Creater Produkten: -- Produkt 2a -- Produkt 2b -- Produkt 4a -- Produkt 4b -- Produkt 4c -- Produkt 7a -- Produkt 7b Produkt 1 & 5 erscheinen also nicht beim Hauptprodukt 2 in der Auswahlliste, und 2, 4 & 7 erscheinen nicht bei Hauptprodukt 1 in der Auswahlliste... W?re echt klasse wenn ihr da vielleicht weiterhelfen k?nnt! vielen Dank Gruss Kasper
  7. Hi again, well thanks anyway! I know it?s an old version.. but my provider didn?t make the update to a newer version.. So i guess i?ve to try and play with the code! Thanks again man! gr. kasper
  8. Hi again! well i?m using MySQL 3.23.57 ***** i will try the code.... and... i?m sorry doesn?t work... Error: 1064 - You have an error in your SQL syntax near 'ORDER by tracking_id ASC LIMIT 95' at line 1 DELETE from supertracker WHERE tracking_id>0 ORDER by tracking_id ASC LIMIT 95 [TEP STOP] any ideas? thanks gr. kasper
  9. Hi there, well there were about 380 rows in the table and i tried it with 200, 100 and 1. None of them worked.. Thanks again! gr. kasper
  10. Hi Equilla, ok it worked..! nex problem! :blush: When i want to delete the oldest data and enter the nr. of rows i want to delete i get this error... 1064 - You have an error in your SQL syntax near 'ORDER by tracking_id ASC LIMIT 1' at line 1 DELETE from supertracker ORDER by tracking_id ASC LIMIT 1 [TEP STOP] any ideas? thanks gr. kasper
  11. Hi Equillia, Well, i just got online again and i saw that the flags for the new visits were not there. The old visits - from yesterday - were there. Than when i ran the update_supertracker.php they are there again. There is something wrong with that, isn?t it? What can i do to show the flags right away and not having to run the update_supertracker.php first.? thanks gr. kasper
  12. Hi there, thanks a lot! it worked.. just one more question for the moment. i had the "geo" files in my admin folder the first time i installed your contrib. then it worked. now i have to put them in the catalog/includes .... is that correct? gr. kasper
  13. Hi there, super contrib. the only thing... The flags don?t load anymore with the latest version. With the older version ("the white / old design") it worked.. What is wrong? thanks gr. kasper
  14. elv1s

    Cancelled Orders Contribution Support

    Hi, for those of you who are interested in how this can be done... please send a pm to me! gr. kasper
  15. Hello, so for everybody who has the same problem... I have the german (2) language as default... in the sql of the installation the is following line. INSERT INTO orders_status (orders_status_id, language_id, orders_status_name) VALUES ('2099', '1', 'Cancelled by Admin'); if your default language is not english (1), but for ex. german (2) change the '1' in '2' Thats it! gr. kasper
  16. Hi there, no one having the same problems!? please, please help me / us! :'( thanks gr. kasper
  17. elv1s

    Master Products - MS2

    Hi Matt, i just tried your codes... Now only products with slaves are displayed! Products without slaves are not shown anymore... What is wrong with the code.... what should i do. Thanx Gr. kasper
  18. Hi there Nate and everybody who helped making this contrib such a good thing! :D **** for all those of you who had problems with this contrib.. please, be sure you replace the whole function in html_output.php so, **************** // The HTML image wrapper function function tep_image($src, $alt = '', $width = '', $height = '', $parameters = '') { if ( (empty($src) || ($src == DIR_WS_IMAGES)) && (IMAGE_REQUIRED == 'false') ) { return false; } // alt is added to the img tag even if it is null to prevent browsers from outputting // the image filename as default $image = '<img src="' . tep_output_string($src) . '" border="0" alt="' . tep_output_string($alt) . '"'; if (tep_not_null($alt)) { $image .= ' title=" ' . tep_output_string($alt) . ' "'; } if ( (CONFIG_CALCULATE_IMAGE_SIZE == 'true') && (empty($width) || empty($height)) ) { if ($image_size = @getimagesize($src)) { if (empty($width) && tep_not_null($height)) { $ratio = $height / $image_size[1]; $width = $image_size[0] * $ratio; } elseif (tep_not_null($width) && empty($height)) { $ratio = $width / $image_size[0]; $height = $image_size[1] * $ratio; } elseif (empty($width) && empty($height)) { $width = $image_size[0]; $height = $image_size[1]; } } elseif (IMAGE_REQUIRED == 'false') { return false; } } if (tep_not_null($width) && tep_not_null($height)) { $image .= ' width="' . tep_output_string($width) . '" height="' . tep_output_string($height) . '"'; } if (tep_not_null($parameters)) $image .= ' ' . $parameters; $image .= '>'; return $image; } **************** should replaced with the code fomr the readme file from the contrib-package.. so, ****************** // "On the Fly" Auto Thumbnailer using GD Library originally Nate Welch (v1.5) Updated by various contributors (v1.7.1) // Scales product images dynamically, resulting in smaller file sizes, and keeps // proper image ratio. Used in conjunction with product_thumb.php t/n generator. function tep_image($src, $alt = '', $width = '', $height = '', $params = '') { // Set default image variable and code $image = '<img src="' . $src . '"'; // Don't calculate if the image is set to a "%" width if (strstr($width,'%') == false || strstr($height,'%') == false) { $dont_calculate = 0; } else { $dont_calculate = 1; } // Dont calculate if a pixel image is being passed (hope you dont have pixels for sale) if (!strstr($image, 'pixel')) { $dont_calculate = 0; } else { $dont_calculate = 1; } // Do we calculate the image size? if (CONFIG_CALCULATE_IMAGE_SIZE && !$dont_calculate) { // Get the image's information if ($image_size = @getimagesize($src)) { $ratio = $image_size[1] / $image_size[0]; // Set the width and height to the proper ratio if (!$width && $height) { $ratio = $height / $image_size[1]; $width = intval($image_size[0] * $ratio); } elseif ($width && !$height) { $ratio = $width / $image_size[0]; $height = intval($image_size[1] * $ratio); } elseif (!$width && !$height) { $width = $image_size[0]; $height = $image_size[1]; } // Scale the image if not the original size if ($image_size[0] != $width || $image_size[1] != $height) { $rx = $image_size[0] / $width; $ry = $image_size[1] / $height; if ($rx < $ry) { $width = intval($height / $ratio); } else { $height = intval($width * $ratio); } $image = '<img src="product_thumb.php?img='.$src.'&w='.tep_output_string($width).'&h='.tep_output_string($height).'"'; } } elseif (IMAGE_REQUIRED == 'false') { return ''; } } // Add remaining image parameters if they exist if ($width) { $image .= ' width="' . tep_output_string($width) . '"'; } if ($height) { $image .= ' height="' . tep_output_string($height) . '"'; } if (tep_not_null($params)) $image .= ' ' . $params; $image .= ' border="0" alt="' . tep_output_string($alt) . '"'; if (tep_not_null($alt)) { $image .= ' title="' . tep_output_string($alt) . '"'; } $image .= '>'; return $image; } ***************** This was the problem i was having for a second, that i only replaced the code ******** function tep_image($src, $alt = '', $width = '', $height = '', $parameters = '') { if ( (empty($src) || ($src == DIR_WS_IMAGES)) && (IMAGE_REQUIRED == 'false') ) { return false; } ************** SO please check!! Best regards Kasper
  19. Well, i?ve got it running so far without errors.. the only problem i have.... wehn i cancelled an order and click on the link cancelled orders (on the left side menu) no cancelled orders are listed. when i search for a specific order it is being found--- what did i do wrong . is this maybe a bug i n"cancelled_orders.php" thanks Gr. kasper
  20. elv1s

    Who's Online Enhancement 1.4

    Yeah you did a good job! Wanne try it in the dutch language now??? :D Just one question i have... Now the Sessions are saved in the place i told them to do so! That?s great, but are those sessions deleted automaticaly sometime... or do i have to do this manually? :blink: ps.... maybe i have something hanging before my eyes... but i couldn?t find the answer to my question and i still would like to hear from you what is the best way to deal with the sessions.... Mysql or files? >_< Thanks again to everybody and to ed for giving us a great contribution! cheers Kasper
  21. elv1s

    Who's Online Enhancement 1.4

    Sorry to bother again!! what is the differents between Sessions options to "mysql" or "files" What is better? thanks again! Kasper
  22. elv1s

    Who's Online Enhancement 1.4

    Hi, first of all, sorry for writing in the german language... :blush: i installed the latest version and put everything like it?s written in the forum.. In configure i don?t have the session thing on mysql? Is this a problem... i get the following error... Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /www/webseiten/domain/shop/oscommerce/catalog/admin/includes/functions/database.php on line 45 0 - select p.products_id, pd.products_name, p.products_model, p.products_price, p.products_cost, p.products_weight, p.products_tax_class_id from products p, products_description pd where p.products_id='38' and pd.products_id = p.products_id and pd.language_id = '2' [TEP STOP] It seems to be a sessions-proble... This online appears when someone puts something in his basket. Anyone an idea? thanks Gr. Kasper
  23. elv1s

    Who's Online Enhancement 1.4

    Hallo, also ich habe das alles installiert. bekomme aber folgende fehlermeldung. Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /www/webseiten/domain/shop/oscommerce/catalog/admin/includes/functions/database.php on line 45 0 - select p.products_id, pd.products_name, p.products_model, p.products_price, p.products_cost, p.products_weight, p.products_tax_class_id from products p, products_description pd where p.products_id='38' and pd.products_id = p.products_id and pd.language_id = '2' [TEP STOP] Dies ist sicherlich ein Sessions Problem, oder.. Habe Sessions Pfad in Admin eine direkte Pfad angegeben so wie beschrieben, aber.. leider. Ich glaube das dieses Problem dann auftaucht wenn jemanden ein Produkt im Warenkorb reingelegt hat. Kann jemanden da bitte helfen!! Danke gruss Kasper
  24. Hi, well, i have also the same problem... With the version 2.0b it worked. now with the new 2.1 version i get the cPath-thing. but only if i use the categories on the left site to get to a product. Wenn i click on a product in "what?s new this month" this problem doesn?t show up. What is the big difference between version 2.0b and 2.1? What makes the version 2.1 better? What is the advantice? :blink: Thanks Yours Kasper
×