Jump to content

kgt

Members
  • Content count

    2,878
  • Joined

  • Last visited

  • Days Won

    2

Posts posted by kgt


  1. Issue with % discounts and non existent discountcodes.

     

    I am experiencing some bugs with the contribution that I wondered if anyone could advise me on.

     

    1. the development shop is - http://www.totalfx.webserverworld.co.uk/catalog/index.php

     

    at checkout when i apply a fixed number code (e.g. CTY5V) however if I try a % discount (e.g. RTKZQU) it fails and re-routes to the cart page.

     

    Also, if I oput in a non existent code it simply ignores it, whereas I expected to be getting a message saying something like - 'that is not a real discount code'

     

    Can anyone help me to solve this?

     

    Thanks!

    John.

     

     

     

    See the README for help getting error messages to display on templated stores.

     

    A redirect to the shopping cart is not really something DCC normally does. If this happens, I suspect it's the result of incompatible/conflicting contributions. I'd need more information and a copy of your checkout_confirmation.php to know more.


  2. Can you give an example of the small errors that would show up?

     

    What I'm looking for:

    Subtotal: $100.00 +

    14% tax: $14.00 +

    Gift Certificate: $20.00 -

    Total Due: $94.00 =

     

    What I expect to see based on the manual:

    Subtotal: $100 +

    Gift Certificate: $20 -

    14% tax: $11.20 +

    Total Due: $91.20 =

     

    Is this the FULL extent of the errors, or is there more I should know about?

     

     

    This is exactly the kind of discrepancy you can expect. (In the US, sales taxes are generally much smaller percentages, so the difference can usually be considered a "small error" for store owners who are trying to do this).


  3. Hi,

     

    First of all I would like to thank you for writing this great contribution. I've installed it this week. I'm working with tax applaid and fixed discounts. At first I didn't get the right value but commenting out line 116 of includes/classes/discount_coupon.php fixed that.

     

    However I'm having a problem with the Max Use number. I've set it to 1 but I can use it over and over again. In the reports the Global Number Available Remaining is -4 because it's used 5 times.

     

    I hope you can help me out here. I'm using the latest 3.3 version.

    Thanks in advance.

     

     

    If you're using version 3.3, what did comment out? The line that would have been commented out on line 116 was from version 2. Did you upgrade? If so, make sure you uploaded the new version of the discount_coupon.php class file.


  4. This is a followup to my earlier post about the problem I am having on my order total page. The following should be self explanatory. I went diving into my database:

     

    As you can see, it looks as if the debug stuff got inserted into the database. WHOO WHOO!! I'm going to go try to extract it.

     

    update orders_total set text='-$7.40' where orders_total_id=809

     

    The line above fixed the problem. I'll have to wait until I get another customer to see if this fixes it for good. I'm guessing the only reason it got stuffed in there was because I was in debug mode. *SHRUG* I'm just happy to be able to edit my invoices again!

     

    --Brett

     

     

    I think you are correct. Now that you have debug off, you shouldn't run into this again. Good work figuring the problem out and solving it.

     

    Just to clarify for everyone:

    Debug Mode should NOT be left on in production stores. It really is only for debugging. It's one of those things you should be turning on just to get the information and either look at it or send it to me, and then turning off again right away. It interferes with normal operation of DCC and osCommerce in more than one way.


  5. This is what I have:

    $contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CATEGORIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_REVIEWS . '</a><br>' .

    '<a href="' . tep_href_link(FILENAME_SPECIALS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_SPECIALS . '</a><br>' .

    //kgt - discount coupons

    '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a><br>'

    '<a href="' . tep_href_link(FILENAME_DISCOUNT_COUPONS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_DISCOUNT_COUPONS . '</a>' );

    /***************

    '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a>' );

    ***************/

    //end kgt - discount coupons

     

    This should be due to an error in the install instructions. Make it:

     

    $contents[] = array('text' => '<a href="' . tep_href_link(FILENAME_CATEGORIES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS . '</a><br>' .
    '<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .
    '<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' .
    '<a href="' . tep_href_link(FILENAME_REVIEWS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_REVIEWS . '</a><br>' .
    '<a href="' . tep_href_link(FILENAME_SPECIALS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_SPECIALS . '</a><br>' .
    //kgt - discount coupons
    '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a><br>' .
    '<a href="' . tep_href_link(FILENAME_DISCOUNT_COUPONS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_DISCOUNT_COUPONS . '</a>' );
    /***************
    '<a href="' . tep_href_link(FILENAME_PRODUCTS_EXPECTED, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_PRODUCTS_EXPECTED . '</a>' );
    ***************/
    //end kgt - discount coupons


  6. I could use a little help.

     

    I have installed Discount Coupon Codes 3.3 + bug fixes

    Windows Server

    PHP 5.2

     

    Once I installed the Contribution and added a New Coupon, everything appeared to be great. However, when I clicked on the hyperlink 'online catalog' in the top right hand corner of the /admin screen to take me to my web site it opened a version of my admin Screen in a very basic/ diluted way. It was a mix between the /admin index.php, and my catalog index.php. If I click the refresh button many times it would eventually open the catalog Index.php file cleanly.

    However, as I would walk a test order through it would give me various errors and fatal errors, but if I clicked refresh once it would usually clean that up. And after alot of refreshing and errors I could walk the order through. Once the coupon had been used it I would not expreince this problem anymore. But if I completed a New Coupon, I would get the same issue all over again. Even if I typed my URL into the address bar I would get the same issue on my index.php file.

     

    I have moved my Catalog folder to my root folder, would this cause any issues? I also contacted my hosting company, but they are never really any help.

     

    Can anyone point me in the right direction with this issue? Or has anyone experienced this issue.

     

    This is highly suspicious behavior that I would attribute to a general problem rather than something you might have done installing Discount Coupon Codes.

     

    The text of the errors you're getting is important. Always provide the error message.

     

    A link to your site may also help debug the problem.


  7. I just did a first time install. I used the version 3.3 download. I didn't use the 2 later fixes listed on that screen as I wasn't sure that they were required. The install went relatively smooth. I did get one of the common sql errors that a lot of people get.... something with the '-20,20' bit. But a quick read of the common problems got that fixed. So now I've got the module set up and created a coupon. That all went smoothly. Unfortunately when I went to do a test transaction, when I enter the discount code and click the Continue button I get a red bar across the top of the store with the message "The coupon code you have entered is not valid". I've tried several times, I'm even copying and pasting the code from the coupon creation screen. But I constantly get that message.

     

     

    "The coupon code you have entered is not valid" message displays when:

     

    1. No coupons could be found with a date range that matches today

    2. No coupon could be found that matches the given code

    3. A customer-level exclusion was found

     

    Double check none of the above is true. Also TRIPLE CHECK that your dates are REAL DATES. Make sure they're "9/22/2007" and not "9/22/0007".


  8. The contrib documentation says the discount will be applied before tax, BUT....

     

    I see many recent posts that indicate the discount is being applied AFTER tax. Since this is what I'm looking for... a gift certificate that will apply as a payment, not a change to the original sale calculation. Is there a certain version of the contribution I should be downloading? Or certain 'errors' I should make during the installation?

     

     

    It's more like fudging. Unless you're giving a 100% discount, the tax will always be calculated against the discounted price. People who try to use these as gift certificates (applied after tax) are fudging and accepting the small errors that can crop up trying to do it that way. Or they just don't understand what the difference is.


  9. Hi,

     

    I just installed this mod yesterday, and now I get doubled subtotals on all orders. Anybody else experienced this? As far as I know I added all the code correctly.

     

    Thanks.

     

     

    Double check the changes made to includes/classes/order.php. Most calculation and display problems originate from missing/duplicate code in that file.


  10. Hi,

     

    Just made sure I had saved the changes. Yes I had made the changes.

     

    Tom

     

     

    If you do not want this check to even occur, you can comment out line 85 of includes/classes/discount_coupon.php:

     

    //if( discount_coupon::is_recalc_shipping() ) tep_redirect( tep_href_link( FILENAME_CHECKOUT_SHIPPING, 'error_message=' . urlencode( ENTRY_DISCOUNT_COUPON_SHIPPING_CALC_ERROR ), 'SSL' ) ); //redirect to the shipping page to reselect the shipping method

     

    Otherwise, it looks like it actually depends on "Display subtotal with applied discount?" being set to true? Do you have this set to false?


  11. If this is somewhere in the 76 pages of posts, let me know and I'll go hunt it down.

     

    My goal is to offer 50 & 100 $ gift cards. I thought I could do this by offering a fixed discount (50) on a min value of 50 and a max value of 50. The problem is that depending on the final value I get results of a discount (credit) of anything from 45 to other odd amounts.

     

    The problem amplifies with the 100 credit as well. 100 discount comes up as $92 discount

     

    Is this part of the rounding issue?

     

    Are you going to tell me that I should use the CCGV module?

     

    Thanks much!

     

    --Brett

     

     

    It sounds like you have an older version. If so, try the newest version. There are some calculation changes between version 2 and 3 that makes 3 much more reliable.


  12. Hi,

     

    I just installed 3.3 and things were ok if I shipped by weight. When I use a Price table to lookup shipping charges, if the coupon (% discount) lowers the cost of the items "down" to the next table level, when i click continue, OS Commerce goes "back" to the shipping page with a "bar" accross the top of the screen telling me my shipping charges have changed. When I click continue I get the payment selection and coupon page again. I cant get out of the "loop"

     

    Anyone have any ideas?

     

    Tom

     

     

    Did you make the changes to includes/modules/shipping/table.php?


  13. Is there any way possible to add the data entry of the coupon code in the shopping cart?

     

    I would like to give 100% discount on some things, enabling the customer to bypass the payment page.

     

    Thanks

     

     

    Yes, but not without fairly significant changes. The shopping cart is 100% different from the order process. It's an ENTIRELY different set of code.


  14. I got a problem.

     

    Few days ago I installed the contribution without any problem, and it is working fine after testing.

     

    However, today, after upgrading PERL from 5.8.7 to 5.8.8, I notice that there are now some problem with the discount coupon. The TOTAL is not right, discount coupon is not being deducted. Eg.:

     

    Sub-Total: RM349.50

    PosLaju / EMS Shipping (1~2 business days to arrive): RM0.00

    Discount Coupon SHASHINKI-01 applied:: -RM5.00

    Total: RM349.50 (Should be RM344.00)

     

    I am not sure if this is due to PERL upgrade or not, but can anybody help me or teach me what I should check? :'(

     

     

    The PERL upgrade should not affect anything. Please see the README for help generating a debug output.


  15. Hi guys/girls,

     

    I'm having an issue getting the discount coupons offering a postage cost reduction to work. They just don't seem to ammend the price at all?

     

    Sorry if this has been questioned before. I scanned through and searched but I may well have missed it!

     

    Thanks

     

    :)

     

     

     

    Please see the README for help generating debug output.


  16. I recently installed v 3.3 but I am getting wacky results. At first I thought it wasn't working. Everything works fine on the admin side. However, on the customer side, they can enter the code, but it doesn't always apply the discount.

     

    1) Discount only works with the "shipping discount" and will not work with "percentage discount" or "fixed amount"

    2) If there is a minimum requirement for product quantity or price total, it will not work and results in an error message, even though the requirement is met.

    Any help would be greatly appreciated!

     

     

    See the README for help getting debug output.


  17. The "Display subtotal with applied discount?" when set to FALSE is not working. Subtotal still showing the discounted price. Is there a way to make this works?

     

    I asked because I have shipping based on price. For order above $50, I give free shipping. If below that, I charged $10 shipping.

     

    When a customer purchased a $70 product and use a $30 discount coupon, the subtotal becomes $40 and there will still be $10 shipping charged to it. This is wrong and I do not want to charge customer shipping based on subtotal after discount. It should be FREE SHIPPING as the original purchase is already over $50.

     

    How to solve this?

     

     

    The "Display subtotal with applied discount?" is not there for fun. It's supposed to work. If it's not, then I don't know what to tell you. Try getting a debug output and send that to me for review.


  18. Hello,

    Great contribution by the way. I only have one problem, Im using the latest OSC and have managed to pretty much get the whole contribution working. The only file giving me problems is order.php in classes. As when I try to update this file using the instructions the order total automatically goes to 0.

     

    My order.php shows the following code

            $shown_price = $currencies->calculate_price($this->products[$index]['final_price'], $this->products[$index]['tax'], $this->products[$index]['qty']);
           $this->info['subtotal'] += $shown_price;

     

    Where as the instructions ask me to edit the following code

            $shown_price = tep_add_tax($this->products[$index]['final_price'], $this->products[$index]['tax']) * $this->products[$index]['qty'];
           $this->info['subtotal'] += $shown_price;

     

    The contribution code does not have $currencies->calculate_price, I dont know if this is the only issue. I am using 2.2 RC1, if anyone knows a workaround it would be greatly appreciated it.

     

    Kind regards

     

    M PArmar

     

    That's the right line. Replace it with the code provided in the install instructions. It should work fine.


  19. When I check out using PayPal, and have a discount applied, checkout_confirmation incorrectly calculates the "amount" output to PayPal.

     

    $1.00 Price

    $1.00 Sub Total

    $2.25 Shipping

    -$2.25 Shipping Discount Applied

     

    $1.00 Total

     

     

    Is your coupon set up as a shipping discount or an item discount? If it's an item discount, you need to make it a shipping discount. Otherwise the item price really is -1.25.


  20. OK, i have found a problem with this contribute when using in 2.2RC1

     

    In admin/includes/database_tables.php and /filenames.php there is no reference to define:administrators

     

    insert this into /database_tables.php (line 16) define('TABLE_ADMINISTRATORS', 'administrators');

     

    and

     

    insert this into /filenames.php (line 14) define('FILENAME_ADMINISTRATORS', 'administrators.php');

    that should do it!

    The only prob i still have is getting PayPal IPN to recognise the discount in the total.

     

    any help on this would be appreciated.

     

     

    For all:

     

    PLEASE NOTE RC1 was released AFTER the latest version of Discount Coupon Codes. Though it should work if you do an manual installation, DO NOT COPY OVER EXISTING FILES with the files from the installation zip if you have RC1.


  21. I had this "Discount Coupons" contribution working the other day, but I noticed that my order totals were being doubled during the checkout process. So I had to make sure that I did not have any duplicates of a piece of code in my catalog/includes/classes/order.php file. I did have a duplicate, so I deleted one of them. I also accidentally dropped an index from my PHP Admin database, and I didn't know how to recover it. But anyway, after I did these things, I no longer see the discount amount showing up in the Order Confirmation page. I have everything else in tact. I am able to enter the discount code on the Payment Confirmation page. I have tried to uninstall the contribution and SQL database tables and reinstall it from the beginning, but I'm getting the same problem. Can you please help me. This contribution is exactly what I need for my store, and I really don't want to give up yet. Thanks a lot. I have browsed the forum, and I didn't see any solution for my problem. I have a unique sort order under Modules>Order Total. PLEASE HELP!! I've been trying to solve this problem for 3 days now. I'm going crazy. Thanks.

     

     

    Double check the code you have in includes/classes/order.php with the installation instructions. Most likely that is where the error is.

×