Jump to content

RGStephens

Members
  • Content count

    50
  • Joined

  • Last visited

Everything posted by RGStephens

  1. RGStephens

    PayPal WPP Direct Payments & Express Checkout Support

    Can anybody help with this? Thanks Rick
  2. RGStephens

    PayPal WPP Direct Payments & Express Checkout Support

    Hi graysonhobby, We just resolved this issue about one page back. Look towards the bottom of Page 185 for your answer. Rick
  3. RGStephens

    PayPal WPP Direct Payments & Express Checkout Support

    Well, I hate to post this because I am sure someone else has had this issue before but I can not find a specific solution to it so here goes. I can process a complete transaction with PayPal Direct and Express checkout. All works fine except that anytime I charge tax (USD) it is recorded as a Total Order Discrepancy" in the PayPal Module. My total is correct, shipping displays properly but tax shows up as the "Total Order Discrepancy" I have seen other posts where coupons are being used or currency conversion is rounding funny and this happens, but no one that I see is having this with a simple tax computation. Is there a simple solution to this one? Thanks for the help. Rick
  4. RGStephens

    PayPal WPP Direct Payments & Express Checkout Support

    Yep - Thanks a bunch - That fixes the issue for me as well- Now on to the next one !!!!! I appreciate the response.
  5. RGStephens

    PayPal WPP Direct Payments & Express Checkout Support

    Hi Marcella, (and Glen) I've been following this thread as I too have this exact issue with EC. It is also a problem in the live mode. (Same result as you defined in the sandbox mode). You indicated that you were adjusting your includes/config file - Which parm did you fiddle with and how did you change it? Have you gotten through the problem yet? Looking forward to getting this resolved. I was wondering - My hosting provider recently made a few changes to the PHP config at the server level (Specifically to disable magic quotes) presumably to get ready for PHP 6. Could any of these changes have affected the functionality of EC? Thanks, Rick
  6. RGStephens

    Purchase Limiter

    Thanks for leading me in the right direction Jack. It turns out that with Fast Easy Checkout, the module that needs the Limiter code is in catalog/includes/fec/payment_box.php. The fec Checkout Shipping module makes an include (Actually a PHP require) for the fec payment_box.php which almost exactly replaces the OSC version of the Checkout Payment module. The only piece that does not go into the fec payment_box.php module is the very first entry in your instruction sheet. That code still goes into the fec Shipping Checkout module. Its working now and I hope this little dialog will help someone else in the future. Thanks again for your help. Rick
  7. RGStephens

    Purchase Limiter

    Thanks Jack, OK - So that clears that up. Is there an easy way to incorporate the Limiter into Fast Easy Checkout - Has someone done that yet? Are you familiar with No Account? Apparently it will also combine the payment / shipping page. Do you think Limiter would work with that? (I also have PWA installed, so No Account my be an alternative to that as well) Rick
  8. RGStephens

    Purchase Limiter

    Thanks for the quick response Jack_mcs but that is not making the Limiter work either. I have installed Fast Easy Checkout. Could that be causing the limiter to not recognize the module? Rick
  9. RGStephens

    Purchase Limiter

    I just installed This Mod and I can not figure out what I should put in the Module Name for ECHO Credit Cards or the Standards PayPay module. Can any one advise here? Does this mod work with RC2a?. Any help?
  10. All of my images work in the main store just fine but none of them work in my admin areas. Any idea why or how to fix this? Rick
  11. RGStephens

    User Tracking with Admin 1.31 Released

    This is driving me nuts!! I have had this tracking system on my site for about 4 months and all was fine. Then around the 1st of the year it stopped recording all activity except mine, and then only if I don't put in my exclude IP address. I have looked at the code from about 3 months ago and compared it with the code today. No Change. I have check permissions but I don't think there is a file other than the SQL file that it logs to. If I am wrong then that could be a problem. I have re-examined all of my configuration settings and recreated the database file. Still not recording anyone else's activity. Obviously I have changed something somewhere that is affecting this contribution but for the life of me I cannot figure it out. I know I am getting activity because I can see it in Supertracker, which is also a good contribution but it doesn't track the session like this one does. Any clues as to why I cannot get it to record activity? HELP!!!!
  12. Thanks Brian - I hope moving the checkbox on the voucher fix happens soon. Rick
  13. Thanks Brian - You da man! It works like a champ. Now I also like the idea of moving the check boxes/radio buttons to the left also. I'll keep watching this thread until someone gets it done. Was it difficult to move the Radio Buttons? Thanks Again, Rick
  14. Hi - I would like to see how you changed the code to move the voucher to the top. I am not much with code. I would appreciate your assistance. Thanks. Rick
  15. What a nice contribution and as clean of an install as I have seen. Nice job aarondwyer. Because I am not a programmer I can't answer this question myself, but I would like to see the gift voucher redeem option as the first payment choice on the payment screen. Can you advise how to move it to the top of the list. It we be much appreciated. :) Rick
  16. I'm not sure if this is the right place for this question. If not someone can advise as to where I should look/post. Does anyone know where and how to place the Bizrate survey code into checkout success so that it only pops up after the customer hits the continue button? Any help would be appreciated.
  17. RGStephens

    Free Shipping plus other Ship methods + UPS

    Nope - No one else seems to be interested. But for me the mod just did not work so I uninstalled it. When I find someone who has it working then I'll put it back. To bad too, its a good contribution idea. I would like for it to be available to my site but I refuse to put stuff in that doesn't work right. If I can't figure out how to fix it, it goes. Understand, that I appreciate all the hard work that folks do to make these contributions available, and I also know that there are many mods that in some ways conflict with each other, and I feel as a participant and user of these mods I must first understand that there is no obligation on anyone's part to make my site work....that responsibility is mine. So when problems happen, and they will, I try to do all of my due dilligence before I start jumping on the forum and expecting a knight in shinning armor to come to my rescue. I just appreciate that there are people out there that have good ideas and are willing to share them. If their ideas and code work for me, then great, if not, then oh well! Sorry for being on my soap box, but I spend lots of time paging through comments in these forums from people who have an expectation of someone else fixing their problems and they have not spent the due diligence on their own to justify asking the forum for help. You and I have a problem with this mod, and I would sure like to fix it and of course it is good to have another helping to locate the solution, and I know there is one, but until then, I pulled it. I am still waiting as you are, and if someone reads this that knows why out code doesn't work, I hope they will offer help. But my expectations are not high with regard to this. I had hoped that the author of the mod would have dropped by and offered an idea but I guess he has moved on too. Again, it is not my expectation that he/she has to fix my problem. Anyway stay in touch and I will too. If I get a solution I will certainly respond here or PM you. Sorry - Its been a long day and I'm ready to hit it for the night. Hope your site does well! Rick
  18. Does anyone know why some customers would receive the error message "No Payment method selected" when they have a voucher blalance greater than their purchase and others would not? :huh: Rick
  19. Yep - It sounds like it's hard but actullay it is not. I did not have to install the "point rewards" mod to get this to work. It has to do with, as ALX said, settings in Admin and MOSTLY understnding of how the redeem button at checkout is to be used. After thinking this through, I have (will complete today) done several things. to make sure that the client is not confused during checkout and with the Voucher process. 1. (and this is just a preference thing for me) I went through and renamed all my displays from saying "Credit Voucher" to "Gift Certificate". 2. I renamed the Redeem Button at check out to say something like "Apply Discount". 3. In the Voucher (Now Gift Certificate e-mail sent to the client) I removed the reference to being able to use the checkout process to redeem your "Gift Certificate" as well as the link to the web sites home page. Instead I want to force the customer to use the "Redeem" link in the e-mail to get back to the web site. By doing so, I have also added language to the Redeem Gift Certificate screen that refers to the fact that he/she now has been given a CREDIT in his/her shopping cart for the "Gift Certificate" instead of you have redeemed a voucher tye language. 4. Which is the other thing I changed (again only as a preference to me). I removed references to "Redeeming" and replaced it with "Credit Balance". To me when I redeem something I immediately get something for it....ie, "here is a coupon that I want to redeem for 10% off the product" I know that technically the customer is redeeming his/her "Voucher" (Again Gift Certificate) but nothing is really given in return until a purchase is made which could be sometime later. That is why I opted to call it a credit balance on his/her account. 5. At checkout, I changed the reference to the Voucher/Discount input area to refer only to redeeming a discount. I did not change any logic in the code so it can still be used as designed to redeem a voucher, but that is going to be my little secret (or back door if you will). Now that I am forcing the customer to return to the site by going through the reedem confirmation screen, there is really no need for this as a Voucher redemtion area. So the result is this. A Gift Certificate is sent to a customer, the customer must use the return link in the e-mail sent out to gain credit for the gift certificate. The confirmation screen tells the customer that there is a credit balance now in his/her account. All references to redeeming a voucher is now gone. When the couster checks out, the "Tick" box now saya "Apply Credit Balance to Purchase". The other box referes to applying a discount to the purchase and most of the confusion is eliminated. Most people who shop on the internet understand how to apply a discount code at check out and this presentation is a little more familiar to them. One of the real drivers for me was when I asked my wife, who does not do a lot of internet shopping to test the original process. I painstakenly placed a lot of explanation in every spot I could to make sure the customer (in this case my wife) understood how to make the Voucher work. After all of the detailed explanations at every step of the way, she still did it wrong. When I asked her what I could say in the explanation to get people to do it right her response was "I did not even read that stuff!" And neither will the customer. I felt the best thing to do was to hold their hand and force them to do it a single way. Of course all of this is basically presentation and not code changes, so if you find these ideas helpful, I glad. If you disagree with me that's ok too. However, please don't ask me to supply you with my changes. I simply did a search and replace in all of my cde for the language changes. If you have installed this mod, you know there are about a trillion places and modules that must be changed. You are on your own here. I really appreciate the exchanges from ALX to help clarify why it was not working for me. It is that kind of support that makes this project valuable. Thanks ALX!!! Rick
  20. Thanks for your help. Turns out that it is a sort issue - Voucher Must be higher than the discount coupon or the tick box does not appear. Thanks again, Rick Ps. There is also some misunderstanding going on as to when to use the redeem button on checkout. I had a few e-mail exchanges with Alx and he corrected my misunderstanding on that point. The redeem button is only used to move the amount of the gift voucher to your shopping cart as available funds, not to use it as a payment option. You must only use the Voucher Tick box to apply funds to the purchase, without htting the redeem button. When you check out it works fine that way. Thanks to Alx for setting me straight on that!! Rick
  21. Still Trying to figure this one out. Are you having any luck? No one seems interested in helping on this issue....don't know why. Question: Does your checkout screen have a tick radio button across from the gift/discount Voucher line? Mine does not, but when I point to that line it highlights just like it does when I am about to select another payment method. I am thinking the error in my install has to do with getting this radio button to appear so I can check it. Rick
  22. RGStephens

    Free Shipping plus other Ship methods + UPS

    Thanks for keeping me up to date. I have not gotten it to work either. So until Someone gives us a solution I have uninstalled it. Lets keep communicating on this. Thanks
  23. RGStephens

    [Contribution]Paypal IPN - Devosc

    I still can not correct the issue in my order_total.php file giving me the error Fatal error: Cannot redeclare class .... catalog/includes/classes/order_total.php on line 15. when returning from paypal. I have tried all of the suggestions from the beginning of this forum with no change in the results. Can someone offer to help? Thanks, Rick
  24. It doesn't look like anyone else is having this problem so it must be something I did. But I don't know where to start lookin or for what. Problem: I can create a gift voucher, release it from the queue, the recipient gets the e-mail, recipient can sign on and send voucher to friend, friend clicks link in e-mail and it takes him directly to "Congratulations you have redeemed a Voucher" page and he loses the voucher as it is considerd used. Also if I enter a voucher in the redeem field at checkout it says it is accepting it, but it does not subtract the value from the purchase price. Has anyone experienced these issue before. Does anyone know where I should look for a fix? Thanks, Rick
  25. RGStephens

    Free Shipping plus other Ship methods + UPS

    Tabula - I have this same issue and have searching around for an answer for a couple of days. Would you please let me know via PM or another post if you find an answer to this. Its holding me up also. Thanks. (I'll do the same for you) Rick
×