Jump to content

misterbling

Members
  • Content count

    136
  • Joined

  • Last visited

Posts posted by misterbling


  1. Robert,

     

    Upgraded to your Pro version.

     

    Am getting an odd issue with forcing cookies on. If you clear out cookies in a browser, everything is fine until your second click the site redirects you to the index page. Assuming its a session issue since once this happens if you keep the cookie there are no further issues. Wondering if this has happened to someone before? Tried in html_output

     

     function tep_href_link( $page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = true, $search_engine_safe = true ) {
       return Usu_Main::i()->hrefLink( $page, $parameters, $connection, $add_session_id, $search_engine_safe );
     }
    

     

     function tep_href_link( $page = '', $parameters = '', $connection = 'NONSSL', $add_session_id = false, $search_engine_safe = true ) {
       return Usu_Main::i()->hrefLink( $page, $parameters, $connection, $add_session_id, $search_engine_safe );
     }
    

     

    But still experiencing the issue. This is a long thread and haven't seen this issue, please if I could be pointed in the right direction.

     

    Thanks


  2. OK I'm honestly very impressed by this system.

     

    The reason for switching over was due to urls going to a file system other than database requirements by others. Had no idea memcache was also an option. Kudos.

     

    DO you see any complications with eaccelerator and memcache?

     

    Thanks


  3. ROFL .. just admit you cocked up for gods sake instead of trying to justify yourself by suggesting USU5 needs corrections.

     

    These extremely difficult instructions amounted to ..

     

    Upload the uploads directory

     

    Upload the drop on top directory

     

    Run installer.

     

    If you can't do that perhaps you shouldn't be installing mods.

     

     

    WOW

     

    OK here it is

     

    Line from instructions

     

    Drop on Top is what it suggests .. you simply drop the files on top of your osCommerce installation maintaining the directory structure.

     

    Well no. There are additional files to upload, you could have put in "drop on top", you didn't. probably an oversight...whatever. Not a big deal, and hopefully others will be helped by this.


  4. No corrections are needed, USU5 has no current issues.

     

    Drop on Top is just the osCommerce files which are overwritten . .you also have to upload the USU5 files in the "uploads" directory.

     

     

    FWR,

     

    Just did and that fixed it.

     

    BTW instructions DID NOT mention this and for a true "drop on top" should have included includes/modules/ultimate_seo_urls5/*

     

    Hopefully this will help others and possibly you could fix on next package.

     

    Thanks


  5. \ULTIMATE_Seo_Urls_5_r141_stable\drop_on_top\catalog\includes\functions\html_output.php

     

     

    Line 20

    include_once DIR_WS_MODULES . 'ultimate_seo_urls5' . DIRECTORY_SEPARATOR . 'classes' . DIRECTORY_SEPARATOR . 'usu.php';

     

     

    Where is this file? usu.php

     

    \drop_on_top\catalog\includes\modules\

     

    Just has product_listing.php


  6. Put the files in the right place and it will work.

     

    I expect a bit more too .. like people following the instructions when I have taken great pains to make them clear.

     

     

    FWR,

     

    Downloaded latest version. unzipped uploaded includes and admin folders into the root. Created over 50 oscommerce stores. I'll look further into it... but out of the box "drop on top" does not work or files are in the wrong places in your actual mod.

     

    Will look into it and post corrections.

     

    Thanks


  7. Well,

     

    Was expecting a bit more due to the hype

     

    Warning: include_once(includes/modules/ultimate_seo_urls5/classes/usu.php) [function.include-once]: failed to open stream: No such file or directory in /home/user/testsite.com/includes/functions/html_output.php on line 20
    

     

    And yes vanilla install "drop on top"

     

    uploaded admin and includes folders into root.

     

    And no not the wrong (admin) folder literally in there double checked, line 20 in html_output.php

     

    Latest download.


  8. I've chosen this contribution over the other ones for 'store closed' type contributions due to the added maintenance option, yet I seem to have encountered a problem.

     

    When I put the store into a 'Closed' status, rather than getting the message advising that the store is closed, my page displays the following:

     

    CLOSED_MESSAGEDate and Time

     

    Now, here is the PHP code from the index.php file

     

    <?php
    // BOF: Store Mode  -  CRC
     if (STORE_MODE == 'Closed') {
    ?>
         <tr>
           <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
         </tr>
         <tr>
           <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
         </tr>
         <tr>
           <td class="storeClosed" align="center"><?php echo CLOSED_MESSAGE . ONLINE_DATE_TIME ?></td>
         </tr>
         <tr>
           <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
         </tr>
    <?php
     }
    // EOF: Store Mode
    ?>

     

    Please, if someone could help me with this, I'd be most grateful.

     

    Naloomi

     

     

    It's not defined. The "CLOSED_MESSAGED" That is. You could simply define it there if you wanted ie;

     

    define('CLOSED_MESSAGED', 'We are temporarily closed');

     

    before it.

     

    What you missed in the instructions was this

     

    **********

    * STEP 2 *

    **********

     

    in catalog/includes/languages/english/index.php

     

    Find the ENDING:

     

    ?>

     

    Insert this BEFORE:

     

    define('CLOSED_MESSAGE', STORE_NAME . ' is temporarily <u>closed</u>. You may create a ' . STORE_NAME . ' account, login to your ' . STORE_NAME . ' account, and add products to your shopping cart. Your shopping cart will be saved for delayed checkout.<br><br>We plan to reopen: ');


  9. Possible Bug?

     

    Found out when a subcategory is 301'd it doesn't redirect with the full url.

     

    ie subs have 2 sets of numbers -c-11_22.html

     

    http://www.misterbling.com/bling-cross-watches-c-11_27.html

     

    Correct url

     

    But try an incorrect

     

    http://www.misterbling.com/notcorrect-c-11_27.html

     

    Redirects but goes here

     

    http://www.misterbling.com/bling-cross-watches-c-27.html

    instead of

    http://www.misterbling.com/bling-cross-watches-c-11_27.html

     

    Can someone verify on their site on a sub?

     

    Thanks


  10. Here's the Fix for Zones

     

    Replace

     

    	  if ( ($this->enabled == true) && ((int)MODULE_SHIPPING_RFQ_ZONE > 0) ) {
    	$check_flag = false;
    	$check_query = tep_db_query("select zone_id from " . TABLE_ZONES_TO_GEO_ZONES . " where geo_zone_id <> '" . MODULE_SHIPPING_RQF_ZONE . "' and zone_country_id <> '" . $order->delivery['country']['id'] . "' order by zone_id");
    	while ($check = tep_db_fetch_array($check_query)) {
    	  if ($check['zone_id'] < 1) {
    		$check_flag = true;
    		break;
    	  } elseif ($check['zone_id'] == $order->delivery['zone_id']) {
    		$check_flag = true;
    		break;
    	  }
    	}
    
    	if ($check_flag == false) {
    	  $this->enabled = false;
    	}
      }
    }

     

    	  if ( ($this->enabled == true) && ((int)MODULE_SHIPPING_RFQ_ZONE > 0) ) {
    	$check_flag = false;
    	$check_query = tep_db_query("select zone_id from " . TABLE_ZONES_TO_GEO_ZONES . " where geo_zone_id = '" . MODULE_SHIPPING_RFQ_ZONE . "' and zone_country_id = '" . $order->delivery['country']['id'] . "' order by zone_id");
     // $check_query = tep_db_query("select zone_id from " . TABLE_ZONES_TO_GEO_ZONES . " where geo_zone_id <> '" . MODULE_SHIPPING_RQF_ZONE . "' and zone_country_id <> '" . $order->delivery['country']['id'] . "' order by zone_id");
    	while ($check = tep_db_fetch_array($check_query)) {
    	  if ($check['zone_id'] == $order->delivery['zone_id']) {
    		$check_flag = true;
    		break;
    	  } elseif ($check['zone_id'] == $order->delivery['zone_id']) {
    		$check_flag = true;
    		break;
    	  }
    	}
    
    	if ($check_flag == true) {
    	  $this->enabled = false;
    	}
      }
    }


  11. In includes/application_top.php

     

    Change

    // BOF: Store Mode
    if (OFFLINE_IP_ADDRESS != getenv('REMOTE_ADDR')){
     if (STORE_MODE == 'Maintenance' and !strstr($PHP_SELF,MAINTENANCE_FILENAME)) {
    tep_redirect(tep_href_link(MAINTENANCE_FILENAME)); }
     }
    // do not let people get to down for maintenance page if not turned on
    if (STORE_MODE != 'Maintenance' and strstr($PHP_SELF,MAINTENANCE_FILENAME)) {
     tep_redirect(tep_href_link(FILENAME_DEFAULT));
    }
    // EOF: Store Mode

     

    to

     

    // BOF: Store Mode
    if (OFFLINE_IP_ADDRESS != getenv('REMOTE_ADDR')){
     if (STORE_MODE == 'Maintenance' and !strstr($PHP_SELF,MAINTENANCE_FILENAME)) {
    header("HTTP/1.0 307 Temporary Redirect"); 
    tep_redirect(tep_href_link(MAINTENANCE_FILENAME)); }
     }
    // do not let people get to down for maintenance page if not turned on
    if (STORE_MODE != 'Maintenance' and strstr($PHP_SELF,MAINTENANCE_FILENAME)) {
     tep_redirect(tep_href_link(FILENAME_DEFAULT));
    }
    // EOF: Store Mode

     

    It's an SEO thing.


  12. Figured it out for BTS, so for those whom are struggling.

     

    1) when categories are not showing up, but products are. Or vice versa uninstall HTC database tables then reinstall.

     

    2) for individual pages to show up don't touch the templates, in the /catalog folder or / if in your root in each file you'd like to define add;

     

    //*** Header Tags SEO ***//

     

    Before

    require('includes/application_top.php');

     

    Oh and the only one place to put;

     

    /*** Begin Header Tags SEO ***/
    if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {
     require(DIR_WS_INCLUDES . 'header_tags.php');
    } else {
    ?>
     <title><?php echo TITLE; ?></title>
    <?php
    }
    /*** End Header Tags SEO ***/

     

    is in the header of;

     

    /templates/'yourtemplate'/main_page.tpl.php


  13. It works fine on BTS systems. I've installed it on several myself. Granted, there aren't any instructions for it, but it will work.

     

    Jack

     

    Jack,

     

    I'll do a complete writeup for BTS install, if you would set me in the right direction. Please check your PM.


  14. After some searching and some painstakingly long time trying to install this module with a BTS template can anyone else confirm that;

     

    1) This is NOT compatible with BTS

    2) There are no instructions for BTS implementation (BTS is NOT STS)

     

    As far as categories and content pages, this is incompatible?

     

    Great contribution, however if you're on BTS I don't see this happening for you and even though it explicitly says it does, there is no documentation or compatibility that I've seen.

     

    That said, Awesome modification and essential SEO.

     

    Please Jack change description to not include BTS compatibility if this is so.


  15. Jack,

     

    I'm having some trouble here. Great contrib BTW.

     

    I changed,

     

    	  $tags_array['keywords']= $the_product_info['products_head_keywords_tag'];
      if (HTPA_DEFAULT_ON=='1') {
    	$tags_array['keywords'] .= $cat['cat_name'] . ' - ';		 //display cat name too

     

    To this

     

    	  $tags_array['keywords']= $the_product_info['products_head_keywords_tag'];
      if (HTPA_DEFAULT_ON=='1') {
    	$tags_array['keywords'] .= $cat['cat_name'] . ',';		 //display cat name too

     

    So that in the keywords it displays properly but it's still off on the spacing as it needs a space before just not 100% sure on how to.

     

    here's an example page;

     

    http://www.misterbling.com/spinning-duo-to...atch-p-116.html

     

    Notice the "Spinning Rim Watches" being the category. Before it had a - now it's a , but the space is still needed.

     

    Thanks


  16. The php.ini file is a control file that is not accessilble on shared hosts, which I am assuming you are on. You will need to contact your host if there is an option you want changed in it. Most will not change them though.

     

    Jack

     

    Jack;

     

    Just an FYI, on a shared host you can compile your own PHP and in the htaccess;

     

    Example

    AddHandler php-cgi .php 
    Action php-cgi /cgi-bin/php.cgi

     

    Whalah you're in charge.

×