Jump to content

lewisqic

Members
  • Content count

    109
  • Joined

  • Last visited

Everything posted by lewisqic

  1. I would love to have your copy of osc 2.2rc2a to table less css. Would it be possible for you to post a link to download it? Thanks so much.
  2. lewisqic

    Quantity Price Breaks

    Hi, I was wondering if there is any way to modify this contribution to enable someone to assign the same price break level to multiple products. For example, I have a store that has 100 products, all of which are the same price. I want to set up quantity price break levels for these products, but I do not want to have to go into each product individually and set up the price break levels. I want to be able to assign the exact same price break level set up to all 100 products at the same time. Does anyone know if this is possible or what it would take to have this type of functionality? Has it been done before? Thanks! Warm Regards, Devin
  3. lewisqic

    Seperate Pricing Per Customer v3.5

    Hi Jan, I have a little problem, I was hoping you could help me out or point me in the right direction... I have successfully installed the separate pricing per customer v4.2.2 on my website, and am now attempting to install the quantity price breaks per product for separate pricing per customer v2.0. I got all the way done, down to editing the last file, which is my product_info.php file, and that is where I have run into a problem, let me explain it in detail below... The instructions say that I'm supposed to replace this code... if ($new_price = tep_get_products_special_price($product_info['products_id'])) { // BOF Separate Pricing per Customer if ($customer_group_id > 0) { // only need to check products_groups if customer is not retail $scustomer_group_price_query = tep_db_query("select customers_group_price from " . TABLE_PRODUCTS_GROUPS . " where products_id = '" . (int)$HTTP_GET_VARS['products_id']. "' and customers_group_id = '" . $customer_group_id . "'"); if ($scustomer_group_price = tep_db_fetch_array($scustomer_group_price_query)) { $product_info['products_price']= $scustomer_group_price['customers_group_price']; } } // end if ($customer_group_id > 0) // EOF Separate Pricing per Customer $products_price = '<s>' . $currencies->display_price($product_info['products_price'], tep_get_tax_rate($product_info['products_tax_class_id'])) . '</s> <span class="productSpecialPrice">' . $currencies->display_price($new_price, tep_get_tax_rate($product_info['products_tax_class_id'])) . '</span>'; } else { // BOF Separate Pricing per Customer if ($customer_group_id > 0) { // only need to check products_groups if customer is not retail $scustomer_group_price_query = tep_db_query("select customers_group_price from " . TABLE_PRODUCTS_GROUPS . " where products_id = '" . (int)$HTTP_GET_VARS['products_id']. "' and customers_group_id = '" . $customer_group_id . "'"); if ($scustomer_group_price = tep_db_fetch_array($scustomer_group_price_query)) { $product_info['products_price']= $scustomer_group_price['customers_group_price']; } } // end if ($customer_group_id > 0) // EOF Separate Pricing per Customer $products_price = $currencies->display_price($product_info['products_price'], tep_get_tax_rate($product_info['products_tax_class_id'])); } with this code... // BOF QPBPP for SPPC $pf->loadProduct((int)$_GET['products_id'], (int)$languages_id); $products_price = $pf->getPriceString(); // EOF QPBPP for SPPC And when I do that, it does work correctly. At least the quantity price break works correctly, as the quantity price break table shows up and displays the correct pricing breakdowns. However, the special pricing per customer wholesale price is no longer displayed on the product_info.php page, instead the retail price is shown even though I am logged into a wholesale account. for example, If i DON'T make the code change that I have shown above, and I view a product page, then I will see the wholesale price if i am logged into a wholesale account, or else I will see a retail price if I am logged into a retail account. I do not see the quantity price break table at all, whether in a wholesale or retail account. But, if I DO make the code change above, then when I view a product page, I am shown the retail price of the product whether I am logged into a wholesale account or a retail account. I do see the quantity price break table if I am viewing a product that has been set up with quantity price breaks. So the problem is, if I make the code change that the instructions say, then I will be shown the quantity price break table, but I will no longer be shown the wholesale price of a product even if I am logged into a wholesale account. Can you please help me with this issue? Perhaps you may know what I'm doing wrong or maybe you know of some coding work around that will solve this problem for me. Any help at all would be greatly appreciated, thanks! Devin
  4. Hi All, I've searched around the forums as well as the contributions and so far I have not been able to find what i've been looking for. I've had complaints from customers that when they add a product to their shopping cart, they do not like the fact that they have to register for an account or type in all of their information just to obtain a shipping price. They would like to see the shipping price displayed on the shopping_cart.php page or something like that. I realize that in order to obtain a shipping price, there must first be at least a zip code entered, but i don't think that this would be too hard of a thing to accomplish. I have created two images in photoshop which illustrates what i have in mind. The first image simply shows how my current shopping_cart.php page looks after a customer adds a product to their cart, and the second image shows the same page with the same product but it also shows an example of allowing the customer to view the shipping price before they proceed to register for an account. Now, has anyone ever seen any contributions that will actually allow me to do this? If not, does anyone have any idea on how difficult it would be to create a contribution that would accomplish this? Any feedback or advice would be greatly appreciated! First Image: Second Image:
  5. lewisqic

    Multi_Vendor_Shipping new thread

    Hi all, I've got a question regarding the email that MVS sends out to the vendors, which includes the customer info, shipping method, and such. I've tested it and sent a test vendor email to myself and this is what it looks like when i receive it... To: Chad Lewis Cylinder Stovesdevin@lewisqic.com1400 North MainCedar City, UT 84720 United States------------------------------------------------------Special Comments or Instructions: ------------------------------------------------------From: Outfitter WarehouseOutfitter Warehouse 664 North 4275 West Cedar City, UT 84720Accnt #: ------------------------------------------------------Order Number: 9------------------------------------------------------------------------------------------------------------ Shipping Method: ups -- Ground------------------------------------------------------Dropship deliver to:Devin Lewis774 North 2275 WestCedar City, Utah 84720 Qty:Product Name:Item Code/Number:Product Model:Per Unit Price:Item Comments: 1 Hunter Stove 170.0000 I don't think this is normal, can anyone help me out and help me figure out how to get the email to appear correctly? thanks a bunch. lewisqic
  6. lewisqic

    Multi_Vendor_Shipping new thread

    Okay, i solved the problem by following what you said, i'm glad it was something so simple, thanks.
  7. lewisqic

    Multi_Vendor_Shipping new thread

    Sorry if this issue has already been addressed in the past, but i have not been able to find a solution to my problem. I have just installed MVS 1.1 on a clean, unmodified version of oscommerce, and everything seemed to go fine, but i've encountered a problem when i attempt to place a test order. After i click on "confirm order", it displays this error message... Warning: Invalid argument supplied for foreach() in /hsphere/local/home/lewisqic/outfitterwarehouse.com/catalog/checkout_process.php on line 125 Warning: Cannot modify header information - headers already sent by (output started at /hsphere/local/home/lewisqic/outfitterwarehouse.com/catalog/checkout_process.php:125) in /hsphere/local/home/lewisqic/outfitterwarehouse.com/catalog/includes/functions/general.php on line 29 Does anyone have any advice on how i can fix this problem? Any help would be greatly appreciated, thanks. -lewisqic
  8. Hi all, I have just installed the authorize.net AIM module on my webstore, and am now testing to see if it is up and running correctly. The module AND my authorize.net account are both in test mode. I just placed a test order using the test credit card numbers that came with the module, and everything went just fine, saying that my order had been processed successfully. Problem is, i can not find any evidence of an order coming in on my authorize.net online account. Am i looking in the wrong place? do i just need to wait longer for the test payment to show up in authorize.net? any help at all would be greatly appreciated. lewisqic
  9. lewisqic

    [Contribution] STS v4

    Your probably right... i'm not too sure what to look for in my configure files so i'll just post them here and hopefully you can help me out. Admin/includes/configure.php <?php /* osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2002 osCommerce Released under the GNU General Public License */ // define our webserver variables // FS = Filesystem (physical) // WS = Webserver (virtual) define('HTTP_SERVER', 'https://www.outfitterwarehouse.com'); // eg, http://localhost or - https://localhost should not be NULL for productive servers define('HTTP_CATALOG_SERVER', 'https://www.outfitterwarehouse.com'); define('HTTPS_CATALOG_SERVER', 'https://www.outfitterwarehouse.com'); define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs) define('DIR_WS_ADMIN', '/admin/'); define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN); define('DIR_WS_CATALOG', '/catalog/'); define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); // define our database connection define('DB_SERVER', ''); define('DB_SERVER_USERNAME', 'mysql'); define('DB_SERVER_PASSWORD', ''); define('DB_DATABASE', 'osCommerce'); define('USE_PCONNECT', 'false'); define('STORE_SESSIONS', ''); ?> includes/configure.php <?php /* $Id: configure.php,v 1.14 2003/07/09 01:15:48 hpdl Exp $ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003 osCommerce Released under the GNU General Public License */ // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'http://www.outfitterwarehouse.com'); // eg, http://localhost - should not be empty for productive servers define('HTTPS_SERVER', 'https://www.outfitterwarehouse.com'); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', true); // secure webserver for checkout procedure? define('HTTP_COOKIE_DOMAIN', '.outfitterwarehouse.com'); define('HTTPS_COOKIE_DOMAIN', '.outfitterwarehouse.com'); define('HTTP_COOKIE_PATH', ''); define('HTTPS_COOKIE_PATH', ''); define('DIR_WS_HTTP_CATALOG', '/catalog/'); define('DIR_WS_HTTPS_CATALOG', '/catalog/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME'])); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); // define our database connection define('DB_SERVER', ''); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', ''); define('DB_SERVER_PASSWORD', ''); define('DB_DATABASE', 'osCommerce'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql' ?> Thanks for the help.
  10. lewisqic

    [Contribution] STS v4

    yeah, i've tried 755 as well, doesn't work. And i can change file permissions. any other ideas? anyone?
  11. lewisqic

    [Contribution] STS v4

    Hi all, I need a little bit of help. I just installed STS v4.3.2 with Header Tags Controller v2.6.0, and everything went fine during the install, and it appears to be working, but i'm having problems with the permission settings on the two files of includes/header_tags.php and includes/languages/english/header_tabs.php. I set the permission for these two files as 777, and i thought that would solve the problem, but i contine to get this error message at the top of the window when i access header tags from my admin.... Can anyone please offer any help or advice on how to fix this problem? thanks.
  12. here is the code in the file for line 1235: $contents[] = array('text' => '<br>' . TEXT_PRODUCTS_PRICE_INFO . '<b> ' . $currencies->format($pInfo->products_price) . '<br>' . TEXT_PRODUCTS_RETAIL_PRICE_INFO . ' ' . $currencies->format($pInfo->products_retail_price) . '<br>''</b><br> Vendor: <b>' . $current_vendor_name . '</b><br>' . TEXT_VENDORS_PRODUCT_PRICE_INFO . '<b>' . $currencies->format($pInfo->vendors_product_price) . '</b><br>' . TEXT_PRODUCTS_QUANTITY_INFO . ' <b>' . $pInfo->products_quantity . '</b>');
  13. Hi All, I'm not sure if this is the right thread for this post, so forgive me if i'm mistaken. I need some major help with some of my files. I just installed the EZ Fields contribution which required an edit of the admin/categories.php file, and i've messed something up that i don't know how to fix. When i access my admin, and then click on categories/products, it brings up a page with this error message on it: "Parse error: parse error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /hsphere/local/home/lewisqic/outfitterwarehouse.com/admin/categories.php on line 1235" Can someone please advise on how i might fix this little issue, thanks.
  14. Hi all, I just installed the Links Manager For OSC v0.20 on my store and everything went fine during the installation. Everything looks great on my store now on the catalog side of things, the links link shows up and i can access it and even submit links. The problem i'm having is on the admin side of links manager. When i go the the links manager link on the admin side, it brings up this error message.... "1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-20, 20' at line 1 select l.links_id, l.links_url, l.links_image_url, l.links_date_added, l.links_last_modified, l.links_status, l.links_clicked, ld.links_title, ld.links_description, l.links_contact_name, l.links_contact_email, l.links_reciprocal_url, l.links_status from links l left join links_description ld on l.links_id = ld.links_id order by ld.links_title limit -20, 20 [TEP STOP]" I'm not sure what this means, but it appears to be the onlyl problem i'm having, any help with this would be greatly appreciated.
  15. lewisqic

    problem with Links Manager v0.20

    alright, i just uploaded the split_page_results.php file to my admin side and it seems to have fixed the problem, thank you!
  16. lewisqic

    problem with Links Manager v0.20

    Well, i tried, but i don't really know where to look for it or what it would be if i found it. any other direction? thanks.
  17. lewisqic

    problem with Links Manager v0.20

    Okay, i downloaded the package and unzipped it but i'm not too sure which part i should install. I don't suppose that it is anything in the catalog or admin folder. do i run an sql query with the info contained in the update text document?
  18. I have successfully installed header tags controller on my site and now i need to know how to configure it and to add titles, keywords, and descriptions to my pages. How do i do this? what page names do i use for each individual category and product? can anyone please help me understand how i do this? thanks.
  19. Hi all, I just installed chemo's Ultimate SEO URL's on my website and i'm having some trouble. Everything on the admin side works fine, and i can also access my home page(index.php) just fine. But when i click on any category or product then it gives me a page that says "The requested URL /directory/index.php was not found on this server." The URL of the page displays "http://cylinderstoves.com/catalog/tents-c-22.html" I need help with how to fix this error so that i can access my pages without the 404 error. thanks.
  20. I just installed this contribution on my web site and i'm having some trouble with it. I can access my homepage just fine, but if i click on a category or any product, it will bring me to an error page that says, "Not Found The requested URL /directory/product_info.php was not found on this server. Apache/1.3.31 Server at cylinderstoves.com Port 80". Also, when i go to my Admin panel, it displays like normal, except it has these error messages at the top of the page... "// Function to reset SEO URLs database cache entries // Ultimate SEO URLs v2.1 function tep_reset_cache_data_seo_urls($action){ switch ($action){ case 'reset': tep_db_query("DELETE FROM cache WHERE cache_name LIKE '%seo_urls%'"); tep_db_query("UPDATE configuration SET configuration_value='false' WHERE configuration_key='SEO_URLS_CACHE_RESET'"); break; default: break; } # The return value is used to set the value upon viewing # It's NOT returining a false to indicate failure!! return 'false'; } Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /hsphere/local/home/cylinder/cylinderstoves.com/admin/includes/functions/general.php:1323) in /hsphere/local/home/cylinder/cylinderstoves.com/admin/includes/functions/sessions.php on line 67 Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /hsphere/local/home/cylinder/cylinderstoves.com/admin/includes/functions/general.php:1323) in /hsphere/local/home/cylinder/cylinderstoves.com/admin/includes/functions/sessions.php on line 67". Can someone please help me figure this problem out.
  21. lewisqic

    CVV2 Number not showing in Admin

    I'm also having this same problem, what did you do to fix the problem?
  22. I would like to remove all of the default oscommerce gifs from my store, i have downloaded the remove default images file form the contibutions part of oscommerce but i need help with what to do next, can anyone please give me some further instruction on what to do once you have downloaded the remove default images file?
×