Jump to content

Anathema

Members
  • Content count

    12
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Ulrike Guennel
  1. Thx for that. The problems with the names ist - that they are not unique. The cPath variable is very important if you have the same products stored as links in many categories.
  2. Now I found a solution for the problem. I had the cPath parameter already in my link and wondered why it was not in my seo link. I debugged the seo code and found an error in the function is_product_string (in my version line 1744. original function is: function is_product_string($params){ if ( is_numeric(strpos('products_id',$params )) ){ return true; } else { return false; } } # end function corrected function is (in strpos twist the parameters!) function is_product_string($params){ if ( is_numeric(strpos($params,'products_id' )) ){ return true; } else { return false; } } # end function @Jack_mcs: perhaps you can change this in the official contribution. My problem was the following: I choosed a category with the menu. And then if I changed from product listing to the product page, the category changed to the first category of the product (in the menu, in the breadcrumb and in the link to the next/prev product) - so cPath had the wrong value. And it is solved now! Yippieh. Anathema
  3. Hi, I activated SEO_ADD_CPATH_TO_PRODUCT_URLS (Add category parent to product URLs?) in the admin. Is this the same parameter as the following? (copied from the install page) Add cPath to product URLs? *NEW* Default Setting: false This setting enables/disables the option of adding the cPath parameter to the end of product pages. Example: some-product-p-1.html?cPath=xx Because I never see the cPath parameter - instead I see the name of the category. Ciao Anathema
  4. Anathema

    ULTIMATE Seo Urls 5 - by FWR Media

    I use Ultimate SEO 2-2.2d-4. I know this is the wrong topic, but before I change the contribution, I want to know, that this contribution can solve my problem. I have the following problem. Some of my products are stored in two categories. I choose a category with the menu. And then if I change from product listing to the product page, the category changes to the first category of the product (in the menu, in the breadcrumb and in the link to the next/prev product) - so cPath has the wrong value. Will this problem also occure in Seo URL 5? Anathema
  5. First of all - thanks for this great contribution! I use Ultimate SEO 2-2.2d-4. I have the following problem. Some of my products are stored in two categories. I choose a category with the menu. And then if I change from product listing to the product page, the category changes to the first category of the product (in the menu, in the breadcrumb and in the link to the next/prev product) - so cPath has the wrong value. Does anybody know how I can solve this problem? Thanks in advance for tipps. Anathema
  6. Anathema

    Official PayPal IPN Support Thread

    Hello, First of all I want to say Thank you for this great contribution (beside the great oscommerce shop as a whole). Second, I have a question. I changed my version of oscommerce, so that the user can change the comment on the confirmation page and so that the user has to check two boxes to accept the shop-conditions (AGB) and the privacy statement. If I use PayPal as payment module - the user will be send direct to the PayPal site and I have no possibility to check the values of the shop-conditions and the privacy statement. Is there any other solution except I move the checks (Privacy and condition) to the payment site? Thanks for helping. Anathema
  7. Anathema

    [Contribution] STS v4

    I totally agree that I have to learn how to find the information - and thanks for the tipps. I didn't want to annoy you. I had just hours of searching with no result - so I was annoyed. Sorry. I thought I could use the forum without other search methods like google. Often you have in forums sub-categories for such a big theme lik sts. But it is like it is - I will now use google.
  8. Anathema

    [Contribution] STS v4

    Sorry, if the question was asked already (I used the search, but could not read 255 pages of answers :blink: ) I want to use my own product_info content area. I put my own product_info.php.html in the content directory and I installed the STS product_info module in the admin area. But nothing happend - the default template is shown. Can anybody help me with this question.
  9. Hi all, I have the solution :D for my problem. I just changed the Parameter 'Output W3C valid URLs (parameter string)?' in the admin panel for SEO to 'false'. Then the link is no changed with the function: 'htmlspecialchars(utf8_encode($link));' in the function href_link of the seo class. Hope this help you too. By the way I think that the problem is only if you dont use cookies. Ciao anathema
  10. Hi Chris, I have the same problem with the buy now button. I installed the version 2.1 you mentioned to install. I realized that is has something to do with the URL and the redirect from to shopping_cart. The parameters are normally separated by a &. After the redirection to shopping_cart the & is replaced by & If you use a form than it works correct - like in the product_info page. But in the product list, where you have a normal link, the & is changed to & I don't know where I can change this behavior. Perhaps you have a solution. On my local server does it work. I have the problem only on my provider. If you wanna look, here is the URL of the shop (it is a test shop) http://www.portal.bioversand.net/catalog/ . Thx in advance for helping. I look since some days for a solution of this problem in the different forums for oscommerce. Ciao Anathema
  11. Anathema

    Official PayPal IPN Support Thread

    Hi, just found this thread. I just installed the current oscommerce distribution and the oscommerce_paypal_IPN_v1.3 contribution. In can see the paypal ipn module in the admin part. I can edit it, but I cannot save the changes. Does anbybody cann help me? Thx. Anathema
  12. Anathema

    PayPal settings are not being saved

    hi, I have the same problem with the 'oscommerce paypal IPN v1.3 contribution'. Does anybody solve the problem and could help us? thx in advance. anathema
×