Jump to content

joeldavuk1

Members
  • Content count

    22
  • Joined

  • Last visited

Everything posted by joeldavuk1

  1. joeldavuk1

    paypal

    im using this contribution here : http://www.oscommerce.com/community/contributions,1753 it does list a support thread but the link does not work. anyways all i have a problem with and this happens on every type of paypal contribution that i have tried the checkout page should look like this : but mine looks like this : anyone got any ideas
  2. joeldavuk1

    paypal

    if you go here https://www.paypal.com/cgi-bin/webscr?cmd=_...verview-outside , click on demo and looks at the bit where it says what will my customers see.
  3. joeldavuk1

    paypal

    nope definetly not in test mode unless there is an option within paypal for this?
  4. RESOLVED: on the checkout_payment page i had changed the continue button to a link, so it was probably not posting which payment method i had selected.
  5. i have installed the protx form contribution, and apart from this works fine. when getting to the checkout confirmation page the part where the protx form is supposed to be looks like this: <form name="checkout_confirmation" action="https://ukvps.protx.com/vps2form/submit.asp" method="post"><input type="image" src="includes/languages/english/images/buttons/button_confirm_order.gif" border="0" alt="Confirm Order" title=" Confirm Order "></form> which is incorrect as it's missing the hidden fields such as the crypt etc.. when i refresh the page, (or click submit order get an error from protx click back ) it looks like this: <form name="checkout_confirmation" action="https://ukvps.protx.com/vps2form/submit.asp" method="post"><input type="hidden" name="VPSProtocol" value="2.22"><input type="hidden" name="TxType" value="PAYMENT"><input type="hidden" name="Vendor" value="---- protx data here ----"><input type="hidden" name="Crypt" value="--- protx data here -----"><input type="image" src="includes/languages/english/images/buttons/button_confirm_order.gif" border="0" alt="Confirm Order" title=" Confirm Order "></form> (i have replaced sensitive data with --- protx data here ---) which is correct, i can't understand why it would be doing this, i have tried copying over a default checkout_confirmation.php nothing seems to work i do have a basic knowledge of php. after i refresh the page i can continue with the order and the transaction goes through fine and comes back fine.
  6. joeldavuk1

    HSBC secure-epayment module

    i have spoke to them and they say it's not a problem also in there sample alphabet with the hash key on, it has A-Z and 0-9 the zero has a dot inside it to differentiate between O and 0.
  7. joeldavuk1

    HSBC secure-epayment module

    this is the hash key i put in f9+hMG9vYvZoAgj6jU6ABLwgW74De0Tw the 3rd character from the right is a zero , i also read that they don't use zeros, is this the problem?
  8. joeldavuk1

    HSBC secure-epayment module

    i put some code in the hsbc return to see why i was getting the hack attempt and i got this: Hacking atempt!! - orderHash=LpmOlP/t0KTXGjQd3PAsq/FHIYg= hash=/kunden/homepages/16/d30073812/htdocs/temp/waterworks/hsbc/TestHash.e any ideas?
  9. joeldavuk1

    HSBC secure-epayment module

    would anyone be willing to help me install this contribution i just need some guidance as to what i am doing wrong i can give my site ftp details etc.
  10. joeldavuk1

    HSBC secure-epayment module

    im just getting the hack attempt, ive got to say the instructions are very poor and missing a lot of things mentioned within this thread such as changing the currency code to GBP, it just seems to me utterly pointless to post a contribution without full documentation and a thorough guide. Otherwise it ends up in forum threads like this one where people have to search through for hours and hours trying to find a solution to there problem. 4. Problems -You can't access the payment gateway: hmm let me see there are about several hundred posts in this thread, but yet only one possible problem in the readme. of course you can't take into consideration everyone's setup and the person who made it probably spent a lot of time on it, but if they had just invested a few more hours in the documentation it would have been a whole lot better.
  11. joeldavuk1

    Seach Engine Friendly URL Support

    nice mod if it worked!, i looked through every page in this thread no one seems to have a solution for the tpp problem, but thats not the point the mod should work for an out of the box installation or whats the point..
×