Jump to content

ihatedeskjets

Members
  • Content count

    96
  • Joined

  • Last visited

2 Followers

About ihatedeskjets

  • Birthday 10/07/1972

Profile Information

  1. ihatedeskjets

    Barclays Pingit

    Solved! Hi thanks for the input, I've re-structured it to use the existing comments form so if pingit, re draw the comments form and invite the customer to enter their mobile number. Not perfect as it can be ignored but good enough for now. Cheers Ken
  2. ihatedeskjets

    Barclays Pingit

    Thanks for that Burt, But I dont need anything else doing except this little puzzle as I've already updated other files to show the QR code for pingit and invoicing and stuff and it's not what you'd call a conventional backend anymore as it runs several stores at once. I'm just baffled why $_post isn't working.
  3. ihatedeskjets

    Barclays Pingit

    Can anyone help me get this module working please http://addons.oscommerce.com/info/8345 I've edited some of it but the phone number entered by the customer at checkout is not added to the order comments and I really need this, here's the chunk of code: function confirmation() { $confirmation = array('fields' => array(array('title' => MODULE_PAYMENT_PINGIT_CUSTOMER_MOBILE, 'field' => tep_draw_input_field('mobile_owner')), array('title' => MODULE_PAYMENT_PINGIT_TEXT_DESCRIPTION))); return $confirmation; } function process_button() { return false; } function before_process() { return false; } function after_process() { global $HTTP_POST_VARS, $order, $insert_id; $sql_data_array = array('orders_id' => (int)$insert_id, 'orders_status_id' => (int)$order->info['order_status'], 'date_added' => 'now()', 'customer_notified' => '0', 'comments' => MODULE_PAYMENT_PINGIT_CUSTOMER_MOBILE . ' ' . $HTTP_POST_VARS['mobile_owner']); tep_db_perform(TABLE_ORDERS_STATUS_HISTORY, $sql_data_array); } function get_error() { return false; } The MODULE_PAYMENT_PINGIT_CUSTOMER_MOBILE info is added correctly to the comments but mobile_owner is not, so I am ussuming it is because PHP 5 does not allow $HTTP_POST_VARS, I tried $_POST['mobile_owner']); It didnt work it would appear that mobile_owner is empty All ideas greatly appreciated.
  4. ihatedeskjets

    OSC PDF Catalogue 2.1

    I kinda got it to work by enabling show new products and resize images, it will not run if I disable these, but the images are terrible, mono, opaque, rubbish. after enabling the show new products I also had to fix an sql 1054 error $products_new_query_raw = "select p.products_id, pd.products_name, pd.products_description, p.products_image, p.products_model, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, p.products_date_added, m.manufacturers_name from [color=#FF0000](([/color]" . TABLE_PRODUCTS . " p[color=#FF0000])[/color] left join " . TABLE_MANUFACTURERS . " m on p.manufacturers_id = m.manufacturers_id, " . TABLE_PRODUCTS_DESCRIPTION . " pd[color=#FF0000])[/color] left join " . TABLE_SPECIALS . " s on p.products_id = s.products_id, " . TABLE_CATEGORIES . " c, " . TABLE_PRODUCTS_TO_CATEGORIES . " p2c where products_status = '1' and p.products_id = pd.products_id and pd.language_id = '" . $languages_id . "' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id order by p.products_date_added DESC, pd.products_name";
  5. ihatedeskjets

    OSC PDF Catalogue 2.1

    Hi all, This may be an old addon but I would really like to get it working with my v2.3.1 store as used it with 2.2. I've uploaded everything needed and made the mods to tools.php so the links appear correctly in admin/tools when I click generate catalogs I get the correct screen but after pressing save to start the pdf generation nothing happens, 1 second passes and I am returned to PDF Catalog(s) Generation but nothing else. I thought maybe there was a problem with language id or something so I added print_r($languages); to pdf_catalogue.php around line 775 and now I see the array correctly
  6. Lets just scrap the customers completely ? http://forums.oscommerce.com/index.php?showtopic=298651
  7. ihatedeskjets

    [contribution] Tracking Module

    Your right, I just checked and its ok now, i did wonder as the query timed out too fast before, now theres the usual approx 2 second delay and its getting the info ok again. thanks Chris Ken
  8. ihatedeskjets

    [contribution] Tracking Module

    I can confirm the new rm file does the same on my site, "contacting courier" then close. Are they doing it on purpose I wonder ?
  9. ihatedeskjets

    [contribution] Tracking Module

    guess what ? mines stopped working today but $EndGrab = '<div class="FlexiList null">'; fixed it just fine, Thanks
  10. ihatedeskjets

    [contribution] Tracking Module

    Bingo ! thanks Chris
  11. ihatedeskjets

    [contribution] Tracking Module

    Hi all, My royal mail track and trace 1.3 has stopped contacting royal mail, it just displays contacting courier, then close. It was working fine until about 10 days ago, I havent changed anything in the code or settings. any ideas please ? Ken
  12. If like me you ended up with a blank space in your header and or had the problems with the database file then use the new instructions I uploaded to the contrib, you can see I've got it working properly now at www.fishguardferry.co.uk. This part of the code caused the slider to end up with a 0 width so it did not display so I commented it out if (sliderwidth > <?php echo $totalwidth; ?>) sliderwidth = <?php echo $totalwidth; ?>; Set picture height and width manually $x = 0; $height = 75; $totalwidth = 0; while ( $header_products = tep_db_fetch_array($header_products_query) ) { $width = 50; Set slider height to match picture height //Specify the slider's height var sliderheight="75";
  13. ihatedeskjets

    [contribution] Tracking Module

    Damn Damn Damn, My apologies, I'd forgotten to upload that file :blush: It seems to be working now, although I dont see anywhere to add the tracking number in orders, using royal mail 1.3
  14. ihatedeskjets

    [contribution] Tracking Module

    Thnx Chris Here we go if (tep_not_null($set)) { switch ($set) { case 'shipping': $module_type = 'shipping'; $module_directory = DIR_FS_CATALOG_MODULES . 'shipping/'; $module_key = 'MODULE_SHIPPING_INSTALLED'; define('HEADING_TITLE', HEADING_TITLE_MODULES_SHIPPING); break; case 'ordertotal': $module_type = 'order_total'; $module_directory = DIR_FS_CATALOG_MODULES . 'order_total/'; $module_key = 'MODULE_ORDER_TOTAL_INSTALLED'; define('HEADING_TITLE', HEADING_TITLE_MODULES_ORDER_TOTAL); break; case 'payment': default: $module_type = 'payment'; $module_directory = DIR_FS_CATALOG_MODULES . 'payment/'; $module_key = 'MODULE_PAYMENT_INSTALLED'; define('HEADING_TITLE', HEADING_TITLE_MODULES_PAYMENT); break; // added for tracking module case 'tracking': $module_type = 'tracking'; $module_directory = DIR_FS_CATALOG_MODULES . 'tracking/'; $module_key = 'MODULE_TRACKING_INSTALLED'; define('HEADING_TITLE', HEADING_TITLE_MODULES_TRACKING); break; // end added tracking module } }
  15. ihatedeskjets

    [contribution] Tracking Module

    Hi Chris, I've installed this on my heavily modded store but cannot turn it on ? When I click on tracking in modules I end up back at payments even though the url is showing as http://www.*********.co.uk/admin/modul...hp?set=tracking I've checked all the code changes and I'm sure i've got it correct.
×