Latest News: (loading..)

ocularmagic

Members
  • Content count

    187
  • Joined

  • Last visited

1 Follower

About ocularmagic

Profile Information

  • Real Name
    James Warner
  • Location
    Southern California, USA
  1. Yeah I got it. I have some other projects going on right now so I'm not totally sure when I'll be able to get to it. If you're willing to pay for it (more than just testing fees), maybe post in the seeking commercial help forum. Sorry.
  2. Nope, no word, I quit working on it as I wasn't going to open an account and pay for testing when I wasn't even going to use this processor. I think the only way it's going to get done is if someone that can code, wants to use them as a processor, and is willing to pay for transaction fees that will be incurred during the testing phase will do it. Otherwise, you may want to consider looking elsewhere. Sorry.
  3. You know, this is probably one reason why no one is into testing this payment option. Straight from their site: So you get charged just for testing to see if you can get it to work!! That's got to be one of the dumbest things I've heard of. I don't have an account with them and I don't plan on signing up with them, I'm just trying to get this to work for anyone that wants to use it. Unfortunately, it's going to cost someone some money. I'm not sure what their charges are but with as many times as I've updated code and tried to run an order on previous mods, I would think the charges would start to climb up there no matter what the price. I would feel bad too, oooh, I forgot a comma, that just cost someone $0.35! Kind of a dilemma. Maybe someone with better coding skills and an account could help out?
  4. I seem to have it "somewhat" working for the Smart Screens method. So far you make it through the process to where it takes you to the page on the plugnpay server. There the individual would enter in all of their billing info, or I guess it could be passed via the cart. But the web site documentation only mentions sending the billing address and stuff using the Direct Connect method which uses a secure server. I don't have an account with them or anything so I may just e-mail them to see how I can go about testing this. I don't know if they have test accounts or URL's or what, but at least there has been some progress made. This is all functioning on MS1.
  5. Just to be clear, there are a couple of methods that PlugNpay can get the info from you. This is what I read from their web site. One is via the Smart Screens Method which to me looks like it passes the information from the shopping cart to their sites secure URL and then the customer enters their info on their site. This means you don't need to have SSL setup because you are sending the shopper to their secure site. I believe that is how the current version of the module is set up. It just passes the info to a URL. Another method is called the Direct Method which requires you to have the secure site and all info is collected by you at your shop securely. I'm assuming that you are planning on using the direct Method by your last post. I'm just stating my observations and I'm sure you are already aware of these things, but hopefully someone can jump in a help out also with the additional info. Another thing I noticed on the Plugnpay site is they reference payment URL's like this: https://{your-secure-payment-server-domain}/payment/{publisher-name}pay.cgi This looks to me like the URL you would be using to pass information to is dependant on your account. Whereas the URL in the Plugnpay mod as it is looks like this: https://pay1.plugnpay.com/payment/'.MODULE_PAYMENT_PLUGNPAY_PUBLISHER_NAME.'pay.cgi' So if your payment server is NOT pay1.plugnpay.com then maybe it's not processing correctly. Another reason that I think it is using the Smart Screen method rather than the Direct method is because the URL example to use the Direct Method is slightly different. It looks like this: https://{your-secure-payment-server-domain}/payment/{publisher-name}.cgi Notice that there is no 'pay' on the end. These are just a couple of things that I've noticed so far. I was able to get it to show up in the admin, but not in the actual checkout process using MS1. Did you make any modifications to it to make it work with MS1 or are you using an earlier snapshot? Hopefully this info can help.
  6. Maybe if you give a few more specifics someone will be able to help. For example, what is not working exactly. Does it show up in the cart? Does it just return a bogus URL? What happens when you go through the checkout procedure? Is there a test account so someone can try and fix the mod without having a Plugnpay account? Maybe with a little more info the ball will get rolling. Just a suggestion.
  7. I don't know of any contributions that could do it, but I'm sure it's possible. The way I would do it is add a check box to the customers info page that if checked will allow COD's. By checking that it would set a field in the database to 1 or True. Then when it got to the payment options page, it would check that customers field and if it was true, it would display the COD option, if not, it would leave it out. It's a start at least. HTH
  8. I can tell you right now that it was not written for anything close to MS1. I wrote it for and August 2002 snapshot I think. I'm surprised that it has worked for people past the new November checkout procedure. :shock: My employer has fallen on pretty hard times so they don't have me keep our site or the code updated anymore. I've have to keep turning away people that ask me questions because I just don't know the new OSC code enough to be able to support it. Maybe someone else has worked it to integrate with MS1, but I just haven't been able to do it. Sorry. :(
  9. Maldo, take a look at this, it may help. http://forums.oscommerce.com/viewtopic.php?t=31693
  10. What are the errors that you are getting, that will give us a starting point on what may be happening.
  11. CyberOto http://www.oscommerce.com/community/contri...ions,716/page,8 Frog I can't seem to find the code you mentioned unless you are doing an upgrade from a previous version or something. Here is the installation straight from the "Fresh Install" doc for admin/customers.php admin/customers.php Around line 25 After: case 'update': $customers_id = tep_db_prepare_input($HTTP_GET_VARS['cID']); $customers_firstname = tep_db_prepare_input($HTTP_POST_VARS['customers_firstname']); $customers_lastname = tep_db_prepare_input($HTTP_POST_VARS['customers_lastname']); $customers_email_address = tep_db_prepare_input($HTTP_POST_VARS['customers_email_address']); $customers_telephone = tep_db_prepare_input($HTTP_POST_VARS['customers_telephone']); $customers_fax = tep_db_prepare_input($HTTP_POST_VARS['customers_fax']); $customers_newsletter = tep_db_prepare_input($HTTP_POST_VARS['customers_newsletter']); Add: $multiple_groups_query = tep_db_query("select distinct customers_group_id from " . TABLE_PRODUCTS_GROUPS . " "); while ($group_ids = tep_db_fetch_array($multiple_groups_query)) { $multiple_customers_query = tep_db_query("select distinct customers_group_id from " . TABLE_CUSTOMERS . " where customers_group_id = " . $group_ids['customers_group_id'] . " "); if (!($multiple_groups = tep_db_fetch_array($multiple_customers_query))) { tep_db_query("delete from " . TABLE_PRODUCTS_GROUPS . " where customers_group_id = '" . $group_ids['customers_group_id'] . "'"); } } $customers_group_name = tep_db_prepare_input($HTTP_POST_VARS['customers_group_name']); $counter = 0; $assigned = 0; $customers_group_name_query = tep_db_query("select distinct customers_group_name, customers_group_id from " . TABLE_CUSTOMERS . " order by customers_group_id"); while ($group_name_check = tep_db_fetch_array($customers_group_name_query)) { $counter = $group_name_check['customers_group_id']; if ($group_name_check['customers_group_name'] == $customers_group_name) { $customers_group_id = $group_name_check['customers_group_id']; $assigned = 1; break; } ++$counter; } if ($assigned == 0) { $customers_group_id = $counter; } Around line 55 After: $sql_data_array = array('customers_firstname' => $customers_firstname, 'customers_lastname' => $customers_lastname, 'customers_email_address' => $customers_email_address, 'customers_telephone' => $customers_telephone, 'customers_fax' => $customers_fax, 'customers_newsletter' => $customers_newsletter, Add: 'customers_group_id' => $customers_group_id, 'customers_group_name' => $customers_group_name); BE SURE TO MOVE THE SEMICOLON AND PARENTHESIS FROM AFTER $customers_newsletter AND REPLACE IT WITH A COMMA TO MAKE THE ASSIGNMENT CORRECT!!!! Around line 120 After: if ($HTTP_POST_VARS['delete_reviews'] == 'on') { $reviews_query = tep_db_query("select reviews_id from " . TABLE_REVIEWS . " where customers_id = '" . tep_db_input($customers_id) . "'"); while ($reviews = tep_db_fetch_array($reviews_query)) { tep_db_query("delete from " . TABLE_REVIEWS_DESCRIPTION . " where reviews_id = '" . $reviews['reviews_id'] . "'"); } tep_db_query("delete from " . TABLE_REVIEWS . " where customers_id = '" . tep_db_input($customers_id) . "'"); } else { tep_db_query("update " . TABLE_REVIEWS . " set customers_id = null where customers_id = '" . tep_db_input($customers_id) . "'"); } Add: $multiple_groups_query = tep_db_query("select distinct customers_group_id from " . TABLE_PRODUCTS_GROUPS . " "); while ($group_ids = tep_db_fetch_array($multiple_groups_query)) { $multiple_customers_query = tep_db_query("select distinct customers_group_id from " . TABLE_CUSTOMERS . " where customers_group_id = " . $group_ids['customers_group_id'] . " "); if (!($multiple_groups = tep_db_fetch_array($multiple_customers_query))) { tep_db_query("delete from " . TABLE_PRODUCTS_GROUPS . " where customers_group_id = '" . $group_ids['customers_group_id'] . "'"); } } Around line 275 Find: $customers_query = tep_db_query("select c.customers_gender, c.customers_firstname, c.customers_lastname, c.customers_dob, c.customers_email_address, a.entry_company, a.entry_street_address, a.entry_suburb, a.entry_postcode, a.entry_city, a.entry_state, a.entry_zone_id, a.entry_country_id, c.customers_telephone, c.customers_fax, c.customers_newsletter, c.customers_default_address_id from " . TABLE_CUSTOMERS . " c left join " . TABLE_ADDRESS_BOOK . " a on c.customers_default_address_id = a.address_book_id where a.customers_id = c.customers_id and c.customers_id = '" . $HTTP_GET_VARS['cID'] . "'"); Change to: $customers_query = tep_db_query("select c.customers_gender, c.customers_firstname, c.customers_lastname, c.customers_dob, c.customers_email_address, a.entry_company, a.entry_street_address, a.entry_suburb, a.entry_postcode, a.entry_city, a.entry_state, a.entry_zone_id, a.entry_country_id, c.customers_telephone, c.customers_fax, c.customers_newsletter, c.customers_group_name, c.customers_default_address_id from " . TABLE_CUSTOMERS . " c left join " . TABLE_ADDRESS_BOOK . " a on c.customers_default_address_id = a.address_book_id where a.customers_id = c.customers_id and c.customers_id = '" . $HTTP_GET_VARS['cID'] . "'"); Right after the above line add: $existing_customers_query = tep_db_query("select distinct customers_group_name from " . TABLE_CUSTOMERS . " order by customers_group_id "); Around line 430 After: <tr> <td class="main"><?php echo ENTRY_NEWSLETTER; ?></td> <td class="main"><?php echo tep_draw_pull_down_menu('customers_newsletter', $newsletter_array, $cInfo->customers_newsletter); ?></td> </tr> Add: <tr> <td class="main"><?php echo ENTRY_CUSTOMERS_GROUP_NAME; ?></td> <td class="main"><?php echo tep_draw_input_field('customers_group_name', $cInfo->customers_group_name, 'maxlength="25"'); ?></td> </tr> <tr> <td class="main"><?php $index = 0; echo ("Existing Groups: "); while ($existing_customers = tep_db_fetch_array($existing_customers_query)) { echo ($existing_customers['customers_group_name']); echo (", "); ++$index; if ($index%10 == 0) { echo (" "); } }?> </td> </tr> I can't find the code you posted anywhere in the new docs. Is it from a past version? If so you should upgrade to the latest one as I've screwed up a few things.
  12. frog Without having the code in front of me, I may be wrong, but somewhere in the code when a new group is created, there is a query to the database to see what group_ids there are so far. Then when the new group is made it is assigned a value equal to one plus that value. Make sense? If that's not in there, I screwed up somewhere. I haven't heard anything like this from anyone else that I can remember. Can you tell me what file and lines that code is from? I will compare it to mine and see what the difference is. Kristofor I still haven't been able to look into your problem and I apologize for that. I'm swamped with moving things on my end. I know I ran into your problem before but I thought I had it fixed. I hope it's not something to do with code changes in other files. What snapshot are you using?
  13. I'll definitely do that in future mods. Thanks and sorry for the inconvenience.
  14. Thanks for keeping me posted glen, I appreciate it and hope the mod works out well for you.
  15. Well, to answer my own question, the zones and rates are given in comma delimited text files. That's convenient. Here is a clip of one of the zone files ZONE CHART,,,,,, UPS Ground/UPS 3 Day Select/UPS 2nd Day Air/UPS 2nd Day Air A.M./UPS Next Day Air Saver/UPS Next Day Air,,,,,, For shipments originating in ZIP Codes 926-01 to 929-99. To determine zone,,,,,, take the first three digits of the receiver's ZIP Code and refer to the chart below:,,,,,, ZONES,,,,,, Dest. ZIP,Ground,3 Day Select,2nd Day Air,2nd Day Air A.M.,Next Day Air Saver,Next Day Air 004-005,8,308,208,248,138,108 006-007,-,-,225,-,-,125 8,-,-,[1],-,-,[1] 9,-,-,225,-,-,125 010-089,8,308,208,248,138,108 090-099,-,-,-,-,-,- 100-199,8,308,208,248,138,108 200-299,8,308,208,248,138,108 300-324,8,308,208,248,138,108 325,7,307,207,247,137,107 326-339,8,308,208,248,138,108 340,-,-,-,-,-,- 341-349,8,308,208,248,138,108 350-359,7,307,207,247,137,107 360-363,8,308,208,248,138,108 364-367,7,307,207,247,137,107 368,8,308,208,248,138,108 369-372,7,307,207,247,137,107 Then you can use that information to lookup the rate. Here is a clip from the Rate file for UPS Ground. UPS Ground Commercial,,,,,,, Daily Rates,,,,,,, "EFFECTIVE JANUARY 6, 2003",,,,,,, Rates do not include a fuel surcharge.,,,,,,, Weight Not To Exceed, Zone 2 , Zone 3 , Zone 4 , Zone 5 , Zone 6 , Zone 7 , Zone 8 1,3.39,3.5,3.74,3.82,4.02,4.07,4.18 2,3.46,3.67,4.05,4.16,4.48,4.58,4.87 3,3.57,3.84,4.28,4.46,4.78,4.94,5.39 4,3.69,4.01,4.5,4.73,5.06,5.23,5.74 5,3.85,4.16,4.71,4.96,5.3,5.52,6.09 6,3.96,4.27,4.82,5.13,5.48,5.75,6.32 7,4.12,4.39,4.94,5.31,5.69,5.98,6.6 8,4.27,4.53,5.06,5.44,5.88,6.26,7.06 9,4.42,4.67,5.18,5.57,6.04,6.6,7.52 10,4.56,4.79,5.29,5.73,6.28,7.07,8.04 11,4.71,4.92,5.4,5.89,6.56,7.58,8.61 12,4.86,5.08,5.51,6.05,6.85,8.09,9.24 13,5.01,5.24,5.62,6.18,7.18,8.6,9.86 14,5.12,5.41,5.72,6.32,7.58,9.11,10.48 15,5.25,5.58,5.82,6.47,7.98,9.62,11.1 16,5.32,5.73,5.96,6.65,8.35,10.1,11.69 17,5.4,5.92,6.14,6.93,8.77,10.59,12.3 18,5.5,6.11,6.35,7.27,9.19,11.08,12.92 19,5.62,6.32,6.58,7.61,9.61,11.57,13.55 20,5.75,6.53,6.81,7.96,10.03,12.06,14.18 It's starting to look more plausible to me. Again, any feedback is appreciated.