Jump to content

shenbo

Members
  • Content count

    40
  • Joined

  • Last visited

1 Follower

Profile Information

  1. Sorry about bumping my ow post. I didn't know it's not allowed. Thank you so much for the help! When downloading, I saved it as a file then opened it with Excel. You were right, the problem did come from the Excel. Your suggestion works fine.
  2. Can someone help me on this? I would really appreciate that.
  3. I asked the question a year ago but didn't come back with the needed information for some reason. Sorry about that. Here is the issue again: I use EP to create and upload products to my store. It's been working fine until I tried to use HTML code on the product description to introduce extra images for the products. Here is what I do. I create a table with images and descriptions for the product via dreamweaver, then select the table and copy the source code to the product description cell on Excel. After that, I save the Excel as CSV. When I import the CSV file to my store via EP, there is nothing wrong. The product is added successfully. Problem comes when I export the products from my store to my computer. The downloaded Excel (or CSV) file contains a huge cell that has almost everything on it: the product name, product model, product description. It seems everything is jammed together. It's not possible to read the Excel file, let along updating it and putting it back online. One more thing, when I save the Excel file (with my html code) as CSV, I realize that the CSV file is the same as the one I downloaded via EP. Can someone help here? I really need to fix that. Thanks a lot. Information: Settings & Info EP vers: 2.76g-MS2 osCommerce 2.2-MS2 OS: HTTP: Apache DB: MySQL 5.0.90-msl-usrs-sure2-log PHP: 5.2.12 (Zend: 2.2.0) Temp Directory: /home/char4u/www/gbtest/ep_temp/ Temp Dir is Writable Magic Quotes is: off register_globals is: on Split files on: 300 records Model Num Size: 64 Price with tax: false Calc Precision: 2 Replace quotes: false Field seperator: comma Excel safe output: true Preserve tab/cr/lf: false Category depth: 7 Enable attributes: false SEF Froogle URLS: false Pop Up Images: true More Pics: false Unknown Pics: false HTC: true SPPC: false Extra Fields: false I use Windows XP Professional, Microsoft Excel 2000 Link to the file EP is producing: http://gbtest.char4u.com/ep_temp/EP2010Feb21-2210-dragon.csv Thanks in advance for the help.
  4. shenbo

    PayPal PDT with Oscommerce

    My store uses oscommerce-2.2ms2. The two payment options I have are 2Checkout and PayPal. I am going to join shareasale affiliate network. It's simple to set up 2Checkout to work with shareasale. For PayPal, shareasale requires merchants to setup PayPal's Payment Data Transfer (PDT) before integrating with ShareASale. I have searched the forum and google, trying to find out how to set up PayPal PDT. Many threads here are about PayPal IPN. I found the sample code for PDT on PayPal website: https://www.paypal.com/us/cgi-bin/webscr?cm...cl/rec/pdt-code but I am not sure how I can use the sample code. Which file do I need to change on oscommerce side, the includes/modules/paypal.php? I was wondering if there is a contribution for PayPal PDT? Thanks, Bo
  5. Thank you so much for the response. I have seen the conversation with shelby72 and tried to change the following lines: header("Content-type: application/vnd.ms-excel"); to: header("Content-type: text/x-csv"); or header("Content-type: application/x-msexcel"); but the problem still exists.
  6. I use EP to create and upload products to my store. It's been working fine until I tried to use HTML code on the product description to introduce extra images for the products. Here is what I do. I create a table with images and descriptions for the product via dreamweaver, then select the table and copy the source code to the product description cell on Excel. After that, I save the Excel as CSV. When I import the CSV file to my store via EP, there is nothing wrong. The product is added successfully. Problem comes when I export the products from my store to my computer. The downloaded Excel (or CSV) file contains a huge cell that has almost everything on it: the product name, product model, product description. It seems everything is jammed together. It's not possible to read the Excel file, let along updating it and putting it back online. One more thing, when I save the Excel file (with my html code) as CSV, I realize that the CSV file is the same as the one I downloaded via EP. Can someone help here? I really need to fix that. Thanks a lot.
  7. Hi there, I have installed the contribution "Admin Account with Access Level (v. 2.2a).". It allows me to set access level to different boxes in the admin panel. Great contribution. I am hiring a person to handle the order processing of my store. I just want him to see the most recent orders (say orders received in the last two months), is there a good way to do that? Or could somebody here suggest which file I should start with? Also I may choose to show the order in certain status only (say pending orders), which file do I need to modify? And I prefer not giving the order EDIT, order DELETE, customer EDIT, customer DELETE permission to the person. Is it possible? Thanks in advance for the help. Bo
  8. shenbo

    Recover Cart Sales

    I installed Recover Cart Sales 1.4f in 2005. Great contribution I would say. I just found a strange thing. When I select uncontacted customers from the Recover Cart Sales on Admin Panel, and click the "Send Email" button, the color for the customers I have contacted will change from pink to green. This is good. But in some cases the customers received the email but the color remains pink and the status remains "uncontacted". This happens only to those returned customers. In another word, it happens to the customer that has an account with my store and comes again and have something left in the shopping cart. Could someone help me to fix this bug? Thanks.
  9. shenbo

    Links Manager II

    I am using an old version of Links manager: Links Manager For osC v1 02. It works great excepting one small bug. When I Send Email To one or multiple Link Partners from with the Admin panel, each link partner receives more than 20 duplicate emails. I think it is a bug for Links Manager For OSC v102. Could someone here let me know how I can fix it? I don't plan to upgrade the Links Manager to the most recent version, just wanted to fix the small bug of the version I am using. Thanks in advance for the help.
  10. I installed a different product attributes contribution which is called "Product Attributes - Option Type Feature" back in 2005. Due to the increased number of products, I wish to add the Easy Populate to my current store. But I am not so confident if it will work for me. Also I noticed that Easy Populate itself has Product Attributes as one of its features. So here are things I am not sure: 1. Do I have to remove my current product attributes contribution "Product Attributes - Option Type Feature" to install "Easy Populate & Products Attributes"? 2. There are too many versions of "Easy Populate & Products Attributes" available. Which version is good? 3. My store also has the "additional images" contributes installed on 2004. Do I need to remove it to install "Easy Populate & Products Attributes"? Thanks a lot. Bo
  11. shenbo

    OSC-Affiliate

    Hi there, I have been using this OSC-Affiliate contribution for 2 months. Great contribution, I really love it! Now I have over 5000 clickthroughs in over 500 pages. Anyone knows how to save the Affiliate Clickthroughs data to my computer and then delete them from the database? I don't want the clickthroughs take up my server space. Thanks a lot.
  12. shenbo

    OSC-Affiliate

    I am having exactly the same problem here, with STS (V2.01) & osCaffiliate (V2.5a) installed. Anyone figured out why? Thank you very much.
  13. Hi, I have been using STS V2.01 for a long time, and it's been working fine. This week, I added a contribution (osCAffiliate v2.5a ) to my website, but I got some problem with some popup windows. The question has been asked in the osCAffiliate support thread by someone else, but i didn't see anyone answering the questions there. So I am asking it here in the general board. When I popup the help files by clicking "?" in affiliate_summary.php, there are popup windows coming up. But I cannot see anything in the popup window, except the STS template of my site. Popup windows in affiliate_banners_build.php, etc. have the same problem. An intesting thing is that the affiliate terms and conditions popup (affiliate_terms_pop.php from affiliate_signup.php) does work. If I replace all the codes in affiliate_terms_pop.php with all the codes in other popup window files, such as affiliate_help1.php, the right help popup come up correctly from affiliate_signup.php. I hope i have made the problem clear here. Maybe there are just some small tricks here to solve the problem. But I just didn't find them. Can someone here help me out? Thanks a lot, Bo
×