Jump to content

grayson

Members
  • Content count

    44
  • Joined

  • Last visited

Everything posted by grayson

  1. First: Many thanks for a very nice contribution. This post contains a simple modification to the categories_subtab.php file in this contribution, to highlight the subcategory currently being viewed. Background: Since I removed the categories box and the breadcrumb trail after adding this tabs contribution, I also wanted to have the current subcategory highlighted, so the visitor can still easily see where he/she is in the site. I searched to see if someone had already come up with a solution, but didn't find anything. Turns out it's a much simpler fix than I had envisioned -- in fact, it's the same trick that highlights the current subcategory in the original categories box in categories.php. To add highlighting in the subcategory bar, in the file [store path]/includes/categories_subtab.php, replace (around line 27): // display category name $subcategories_string .= $fooa[$counter]['name']; with if ( ($id) && (in_array($counter, $id)) ) { $subcategories_string .= "<b>"; } // display category name $subcategories_string .= $fooa[$counter]['name']; if ( ($id) && (in_array($counter, $id)) ) { $subcategories_string .= "</b>"; } That's all there is to it! Regards, --Grayson
  2. Here's the documentation (as a PDF, of course :lol: ) for the PDF and ezPDF classes: http://www.ros.co.nz/pdf/readme.pdf
  3. grayson

    Giftwrap option not showing?

    That's too bad, Lisa! I hope you find your gremlin soon ;-). Please do post your fix here when you find one--it'll help folks who have your same problem in the future. Regards, Grayson
  4. grayson

    [contribution] "osC_GiftWrap_v1.0"

    Another fix. PROBLEM: On catalog/checkout_shipping.php when DISPLAY_PRICE_WITH_TAX is true, the gift wrap cost is NOT shown with tax included. (This is the page where the customer chooses via radio buttons whether he or she wants gift wrapping.) REASON: The function process() in ot_giftwrap.php computes and stores the giftwrap cost including tax when DISPLAY_PRICE_WITH_TAX is true; this function is however not called until checkout_confirmation.php. The with-tax value is thus not yet directly available in checkout_shipping.php. SOLUTION: Make the following changes to checkout_shipping.php. Replace with Be sure to enter the giftwrap cost in the Admin panel WITHOUT tax -- for example, if you want to charge EUR 1.25 in total, including tax, you should enter EUR 1.05 in the Admin panel for giftwrap cost. (For those of you who are wondering why you'd want to do this, in many European countries customers are always shown prices including VAT (value-added tax = sales tax); thus all product prices, shipping costs, and other expenses must be shown including VAT rather than having it calculated at the very end and added on.) Regards, --Grayson
  5. grayson

    gift wrapping error?

    The problem is that the "no gift wrap" module is still tied to shipping -- no problem if you have more than one shipping option, but if you have only one, then you only get one gift wrap option. Here's a fix: Fix for missing "no giftwrap" option Regards, Grayson
  6. grayson

    [contribution] "osC_GiftWrap_v1.0"

    To get rid of the parentheses around "(Gift Wrap)" and "(No Gift Wrap)", go into catalago/checkout_shipping.php and find this: if ( (isset($quote1[0]['methods'][0]['title'])) && (isset($quote1[0]['methods'][0]['cost'])) ) { $giftwrap_info = array('id' => $giftwrap_info, 'title' => $quote1[0]['module'] . ' (' . $quote1[0]['methods'][0]['title'] . ')', 'cost' => $quote1[0]['methods'][0]['cost']); change to this: if ( (isset($quote1[0]['methods'][0]['title'])) && (isset($quote1[0]['methods'][0]['cost'])) ) { $giftwrap_info = array('id' => $giftwrap_info, 'title' => $quote1[0]['module'] . ' ' . $quote1[0]['methods'][0]['title'], 'cost' => $quote1[0]['methods'][0]['cost']); The change is on the third line of this snippet. (The same method can be used to get rid of the parentheses around shipping terms by making the same change on the respective line in the shipping modules section in the same file.) Note that you can also replace the single space between 'module' and 'title' with a dash or any other separator, if desired. Regards, --Grayson
  7. grayson

    [contribution] "osC_GiftWrap_v1.0"

    Here's a fix for the problem where you see only the giftwrap option, but not the "no giftwrap" option (i.e. you have no radio buttons): Fix for missing "no giftwrap" option Note that this probably also solves some of the linked-to-shipping-choices problems people have experienced. Regards, --Grayson
  8. grayson

    Giftwrap option not showing?

    Alright, I've found the problem. In catalog/includes/modules/giftwrap, open up giftwrap.php and nogiftwrap.php. You'll see that they're pretty much the same, except that in nogiftwrap.php, a few lines still have "shipping" in them, which is clearly wrong (leftover from the copy-and-change, I presume). Make the following fixes in nogiftwrap.php: Change (about line 25): if ( ($this->enabled == true) && ((int)MODULE_SHIPPING_FLAT_ZONE > 0) ) { to if ( ($this->enabled == true) && ((int)MODULE_GIFT_ZONE > 0) ) { and change (about line 67): tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, use_function, set_function, date_added) values ('NoGiftWrap Zone', 'MODULE_SHIPPING_ZONE', '0', 'If a zone is selected, only enable this giftwrap method for that zone.', '6', '0', 'tep_get_zone_class_title', 'tep_cfg_pull_down_zone_classes(', now())"); to tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, use_function, set_function, date_added) values ('NoGiftWrap Zone', 'MODULE_GIFT_ZONE', '0', 'If a zone is selected, only enable this giftwrap method for that zone.', '6', '0', 'tep_get_zone_class_title', 'tep_cfg_pull_down_zone_classes(', now())"); That should do the trick (it did for me). Regards, Grayson
  9. grayson

    Giftwrap option not showing?

    Lisa, I'm having the same problem and I don't have STS installed, so I don't think that's your problem. I'll let you know when I find an answer. Regards, Grayson
  10. Sorry Serdar, I haven't used Attributes Sets the way you're using it, so I can't help you there. My guess is that AS only covers independent attributes, and that in order to link the choice from the first set to the choices available in the second set, you'll have to do some recoding. But perhaps someone else has better information for you. Good luck! Regards, Grayson
  11. Serdar, take a look at the Attributes Sets contribution. This will allow you to set up attributes for all your different fabric types and colors, then group them in any way you want so that you can set up a group for each product containing only the fabric options relevant to that product. The contribution is here. Regards, --Grayson
  12. grayson

    HelpDesk For osCommerce

    Maybe just add some comments about the use of the name field in the Admin, because as you say, the department title already serves as the name for the account. That makes the name field you specify in the admin ideal for what you're saying (and now I see that this is probably always what it was intended to do), but I think it needs to be commented better so people understand this. My server wants the entire e-mail address (username@domain.nl) for the username, which is why using $emailaddress in the imap_open call works for me (and others?). So maybe a comment in your documentation about those two options (using entire email address vs. just using user name) and that if your server wants just the user name, where to fill that in in the Admin. Then folks can just sort it out for themselves, but at least they know where to look. Regards, --Grayson
  13. grayson

    HelpDesk For osCommerce

    Here's something that might help someone else get this contribution running. Wherever $languages_id is referenced, you might have a problem if you are using a language other than English. I'm using Dutch, and I just discovered that all the database queries for tickets (for example, in admin/helpdesk.php) have been trying to pull out entries where the language_id is 4 (Dutch) while the helpdesk tables in the DB only have entries for language_ids 1, 2, and 3. As a result, I wasn't seeing any tickets even though they're being picked up from the mail server just fine and inserted nicely into the DB. After inserting entries for language_id = 4 into the helpdesk_status and helpdesk_priorities tables in the DB, the contribution is working fine. [specifically, for those who'd like it spelled out: run the following sql queries, replacing the '4' in each one with your language_id -- you can find this in the languages table in the database. You can also change the text values (Low, Open, etc) to whatever you want them to be in your language. In fact, that's exactly what these language entries are designed for: to show you statuses / priorities in your own language. INSERT INTO `helpdesk_priorities` ( `priority_id` , `languages_id` , `title` ) VALUES ('1', '4', 'Medium'); INSERT INTO `helpdesk_priorities` ( `priority_id` , `languages_id` , `title` ) VALUES ('2', '4', 'High'); INSERT INTO `helpdesk_priorities` ( `priority_id` , `languages_id` , `title` ) VALUES ('3', '4', 'Low'); INSERT INTO `helpdesk_statuses` ( `priority_id` , `languages_id` , `title` ) VALUES ('1', '4', 'Pending'); INSERT INTO `helpdesk_statuses` ( `priority_id` , `languages_id` , `title` ) VALUES ('2', '4', 'Open'); INSERT INTO `helpdesk_statuses` ( `priority_id` , `languages_id` , `title` ) VALUES ('3', '4', 'Closed'); Regards, --Grayson
  14. grayson

    HelpDesk For osCommerce

    Lane, Thanks for uploading your changes. There is an error in helpdesk_pop3.php: ON line 62, if ($conn = imap_open("{".DEFAULT_HELPDESK_MAILSERVER.DEFAULT_HELPDESK_PROTOCOL_SPECIFICATION."}".$mailbox, $username, $password, $mode)) should read if ($conn = imap_open("{".DEFAULT_HELPDESK_MAILSERVER.DEFAULT_HELPDESK_PROTOCOL_SPECIFICATION."}".$mailbox, $emailaddress, $password, $mode)) $username in this case holds the text name the user supplied for the account (such as "My Store Customer Service"), not the username to access the server. Regards, --Grayson
  15. grayson

    HelpDesk For osCommerce

    I spoke too soon. I was checking my account in Outlook, not via the admin Helpdesk. Doh! (Of course, this is reassuring, since code that suddenly starts behaving differently without your having done anything to it is a Bad Thing.) So Lane, I'm still avidly awaiting your tales of success! --Grayson
  16. grayson

    HelpDesk For osCommerce

    Despite not having done a thing to my setup, the Helpdesk with POP3 addon is working just fine for me now -- I just tested some e-mails and they came through. Don't know why they didn't yesterday after I installed, but hey....never look a gift horse in the mouth. :-) I've got a problem now with apostrophes in the text the customer enters into the "contact us" box--the mails come through (though with double apostrophes), but the browser chokes on it ("Fatal error: Call to a member function on a non-object in /home/butt1348/butterwing.nl/www/testamoo/includes/application_top.php on line 316"). Not sure if this is Helpdesk-related or just plain contact_us.php-related. Off to try to figure that one out now.... Regards, --Grayson
  17. grayson

    HelpDesk For osCommerce

    This sounds great, because my provider just told me I'd have to pay to get them to configure the mailaliases file for me :-(. I look forward to reading how you got it to work, Lane! Do post soon! :-) --Grayson
  18. grayson

    HelpDesk For osCommerce

    I've installed the Helpdesk for osCommerce contribution with POP3 addon. Like others, I haven't gotten it working yet--all the parts are there, but I'm not receiving the e-mails in the Helpdesk. (They're being picked up fine by the Sync command.) This is probably because I have yet to add in the mail aliases entries; I'm waiting to hear back from my hosting provider about the location and editability of the mail aliases file. Hopefully once I get those entries in, it will all work fine. But this brings me to my question: in the POP3 addon installation text, it says: "The original contribution requires that you use a php binary to execute the osc_mail2db.php script to parse the incoming email into the osCommerce database. This contribution is a ADDON to the existing contribution and involves the following changes: * The emails are retrieved through POP3 following a end-user synch request. [...]" Which sounds to me like you no longer need to do the mail-aliases-entry thing. Is that accurate? (Not that that's good news...then I have an actual problem :-).) Regards, --Grayson
  19. grayson

    Attribute as Images - 2.2MS2

    Mark - I just wanted to say that I installed Options as Images for MS2 today, and it's wonderful. I spent the better part of the past two days trying to get the original Options as Images (MS1) going, and it was a bear. I learned a lot about OSC innards, but there was a lot to fix, both code-wise and in terms of aesthetics, and I wasn't there yet. (I didn't know there was a version for MS2 until Wendy James mentioned it in another thread.) So I am doubly enthusiastic and downright lyrical about your version, because it's WONDERFUL! Many thanks. Regards, --Grayson
  20. Wendy, Boy, am I glad you posted here! Thanks to you, I found the MS2 version of the Options as Images contribution, which is lightyears better than the older (unrelated but similar) version. It installed easy as pie and works like a charm. All the poorly thought-out aesthetics of the MS1 contribution (quite aside from its installation and coding deficiencies) are gone; it looks great. I'm not going to say I wasted all of yesterday afternoon and the evening before that; I learned a lot about the innards of OSC, wrangling with that MS1 contribution, so it was worthwile :-). But oh, I am so glad to have found the MS2 version! Regards, --Grayson
  21. [Apparently I don't have permission to edit my own messages, gotta figure that out later.] I just saw in the contributions section that there's a separate "Options as Images for MS2" contribution--I missed that before, and got the original. That might help to explain many of my installation headaches :-). --Grayson
  22. Hi Wendy, I don't have the attribute sets contribution installed (it's probably overkill for my site, which basically only has one option, Color). My problems installing Options as Images are due to having to find and copy the right snippets of code into product_info.php, admin/categories.php, admin/product_attributes.php and so forth. I've installed several other contributions and don't want to overwrite any of them by just copying up the Options as Images files. Moreover, Options as Images looks like it was written for a prior-to-MS2 version of OSC, and there's been some conflict with names as a result of splicing in the code instead of copying the whole file lock, stock, and barrel (e.g. $products_name in OaI code is used for a different entity than in MS2 code in the same file). But that's neither here nor there, as I'm sure I could get all that sorted out (and largely have). The stopper for me is that OaI assigns one thumb (and one larger image) per option value, NOT per product attribute. So if I have red t-shirts and red racecars, they'll have to use the same uploaded thumb and larger image for the option red. What I want is a red t-shirt image for t-shirts, and a red racecar image for racecars. Sure, I could set up different options, such as Car Color and T-shirt Color, and assign each of those the values Red, Blue, Green et al, with the proper images for each. But what a proliferation of options, values, and attributes. I'd rather keep it simpler (also because I'm using Easy Populate and don't want to hit the 256-column spreadsheet maximum). In addition, I really like the dynamic aspect of Dynamic MoPics; if an image is there, it gets used, and otherwise there's no text or broken images to indicate that something is missing. So if I can manage to associate unique text with the extra images (such as the color name), and then stick radio buttons right beside them instead of using the drop-down list, I'll be one happy camper. Regards, --Grayson
  23. Still plugging along on the Options as Images Contribution, and I've got it running fairly well. A few issues left to iron out on the admin side in particular. That said....I just realized this contribution only allows one thumbnail image (and one larger image) per option value. What I want, however, is a distinct image for each product with that option. If I have the option Color: Red, for example, I want to show a red t-shirt when the customer is looking at my t-shirt product, and a red racecar when the customer is looking at my racecar product. This means I'm going stop on this contribution now and go back to Dynamic MoPics, which installed and worked like a dream, only without the select-directly-from-the-images aspect. I'll try to add in distinct titles for each MoPic, and I might just try to select directly from the MoPic images....now that I've learned so much about this aspect of OSC while trying to decipher Options as Images. So that's the state of things, for the two of you who'll ever read this ;-). Regards, --Grayson
  24. I've tried it. It's got a lot of potential, but it's a bear to install, and I have yet to get it running. The commenting in the code is sketchy, which makes it hard to find and splice in the contribution to your existing (already modified) OSC files. There also appear to be a number of errors in the syntax, though those may just be the result of my own attempts to splice the code in. I'll keep working on it, and if I manage to get it running, I'll upload a commented version with clear install instructions. Not sure when that will be; I'm about to go on vacation for a month. Regards, --Grayson
  25. This is an exceedingly old thread, but the topic is exactly what I was searching for, and surely I can't be the only one. So I thought I'd add a reply based on what I've found. Contribution: Options as Images I haven't tried it yet, and will add a post here when I have. Regards, --Grayson
×