Jump to content

idolcemia

Members
  • Content count

    11
  • Joined

  • Last visited

Profile Information

  • Real Name
    Alexander Mountjoy
  1. Does anyone have a recommendation on how to deal with the problem of inserting 301 redirects on an old site to transition to Ultimate SEO? I have version Ultimate_SEO_URLSv22d_7 installed on a new site and it is working great and now want to install it on an existing site, but my seo guy says I need to redirect all the old product URL's. I found this post referencing Ultimate SEO which suggests dynamically rewriting page requests that use the old format: About half way down this page is a discussion by Gtech: http://forums.digitalpoint.com/showthread.php?t=136032 Seach the page for the "1) Ultimate SEO is what you want. This is a great contribution and I use it myself." to jump right to it. But I wanted a second opinion from this forum. What's the best solution to the 301 problem for a user of Ultimate SEO on an established osCommerce site?
  2. Answered my own question finally, and I'll post it here in case it'll help someone else out one day. The issue was commas in text attribute fields being interepreted as separators between product ID's in the shopping_cart class. This is the rewrite for the member function get_product_id_list() in the file catalog/includes/classes/shopping_cart.php: function get_product_id_list() { $product_id_list = ''; if (is_array($this->contents)) { reset($this->contents); while (list($products_id, ) = each($this->contents)) { // Begin DM Mod. Take only that portion of the products_id string that is to the left of // "{". This is the true product id. The rest is product string attribute information, // which can cause failure elsewhere if it contains commas. $product_id_list .= ', ' . tep_get_prid($products_id ); // End DM Mod. } } return substr($product_id_list, 2); }
  3. I'm having a heck of a time solving this one and am hoping someone can help me out: When a text attribute contains a comma character, as in "April 21, 2009" I get an SQL error in shopping_cart.php because the explode function is breaking up the list of product options based on commas. I figure the solution is to change the separator from the comma to something such as "|", but I can't figure out where to change it. application_top.php seems to be where the list is exploded on ",". But where is the list created? Searched the forum and was surprised to find that no one seems to have run into this before. Or is this a known bug, the fix for which I am just missing?
  4. I was getting the same error. Changed tep_draw_hidden_field('authorizenet_aim_cc_expires_month', $_POST['authorizenet_aim_expires_month']) . tep_draw_hidden_field('authorizenet_aim_cc_expires_year', $_POST['authorizenet_aim_expires_year'], -2) . to tep_draw_hidden_field('authorizenet_aim_cc_expires_month', $this->cc_expiry_month) . tep_draw_hidden_field('authorizenet_aim_cc_expires_year', substr($this->cc_expiry_year, -2)) . around line 180 in modules/payment/authorizenet_aim.php And that solved the problem. (Not sure why $_POST['authorizenet_aim_expires_month'] is null at this point in the code whereas $this->cc_expiry_month is not, but that was the case.)
  5. idolcemia

    NEW! Complete Order Editing Tool!

    I need to validate the credit card expiration date during the "edit order" process, to enforce the MMYY format. The problem is that our operators in Edit Order are entering things like "12/12" for December/ 2012. Such an entry would get saved as "12/1" to the database. Can anyone get me started adding field content verification to Edit Orders, in particular for the CC expiration field?
  6. idolcemia

    "Dynamenu" for osCommerce

    I have another question regarding the operation of Dynamenu: I'm using the tree menu feature to show my product categories. When my page first displays, I see for an instant the entire menu, including all collapsed branches. Then the pages settles down, showing the menu the way it should be, with collapsed branches hidden. Is there any way to correct this behavior?
  7. idolcemia

    "Dynamenu" for osCommerce

    I'm using the setting $menu_use_titles=true to display titles for my tree menu items, but it isn't much benefit to my users as the titles are identical to the menu text. That is, the menu item "Picture Frame" shows a title "Picture Frame" when the mouse pointer is above it. Is there a way to get these "title" texts pulled from somewhere else? I have installed the Mod "Header Tags Controller" which allows you to store a page title for each category. Maybe this could be retrieved?
  8. idolcemia

    Seperate Pricing Per Customer v3.5

    Looks like that should do the trick. Thanks a lot. :thumbsup:
  9. idolcemia

    Seperate Pricing Per Customer v3.5

    In reply to JanZ's post of May 5 2005, 09:27 AM, thanks! Your mod enabling the proper handling of "%" format specials pricing in Admin seems to work. Once I'm sure it's bug-free, I'll post it to SPPC's Mod area (right?), with credits to you, of course. Also, I took a look at your suggestion as to how to go about making the Attributes feature group-aware. Looks correct to me, and not too hard :) . (Add to table products_attributes a new field customers_group_id, then change the code where necessary.) I'll work on it when I have a moment. In a related issue, I find myself needing to show certain products only to certain customer groups >_< . Retail customers need to see a certain subset of the products, wholesale customers another subset. There will be overlap, but each category would see products that were invisible to the other. Anybody have any ideas as to how to go about adding this feature?
  10. idolcemia

    Seperate Pricing Per Customer v3.5

    Thanks a lot. That works, in the case where it's a new special. When modifying an existing special (the other branch of the "case" statement), however, the price is still drawn from the the retail price. The wrong price is displayed and the % discount is applied to the wrong price. I looked at the code for about ten minutes this morning without being able to perceived a solution. I'd get it eventually. But if you can spot it, I'd appreciate it. I'll also get into the "product attributes" issues when I have time. Thanks for the reply on that.
  11. idolcemia

    Seperate Pricing Per Customer v3.5

    There seems to be a bug in the Admin feature. File: catalog/admin/specials.php When a % special is entered for any customer category other than retail, the % is applied to the retail price. The problem is in the following code block if (substr($specials_price, -1) == '%') { $new_special_insert_query = tep_db_query("select products_id, products_price from " . TABLE_PRODUCTS . " where products_id = '" . (int)$products_id . "'"); $new_special_insert = tep_db_fetch_array($new_special_insert_query); $products_price = $new_special_insert['products_price']; $specials_price = ($products_price - (($specials_price / 100) * $products_price)); } $products_price, retrieved from TABLE_PRODUCTS, will always be the base or "retail" price for the item. Being new to this, I'm not sure how to fix the problem. The correct product price for the customer type has already been retrieved. It's just a matter of using that price in the % calculation rather than the retail price. Can someone suggest a fix? In another topic related to "Separate Pricing per Customer", is there a provision for allowing separate pricing by "product attribute" admin/products_attributes.php) to be made customer-type aware? For example, our 4x6 picture frame retails for $26. The 5*7 size is +$6. But for a wholesale customer, the frame is $12.50, and the 5x7 size is + $3. Put simply, is the Product Attributes feature aware of the Separate Pricing per Customer mod?
×