Jump to content

GLWalker

♥Ambassador
  • Content count

    842
  • Joined

  • Last visited

  • Days Won

    37

Posts posted by GLWalker


  1. What I had done previous to header tags SEO, was redo all the original articles header tags controller to format the same as the latest version of header tags controller. So there was no seperate header tags function for articles. When the header tags SEO was released, I just went through out it and duplicated categories into topics, products into articles, and manufacturers into authors. Then placed it all under the original functions.

    In admin/header_tags_seo I added the extra check boxs for topics and authors. I added the extra defines into the database table. Think it was a total of 4 more.

    And I did make a seperate file for filling the topics, articles and authors at once. I didnt have any problems with having to add any extra code to application top, as I already had it running as part of header tags 2.6 with no seperation between it and articles.

    I did at first get a blank page though, in the code for includes/header_tags.php i wrote some new code a p.articles_ instead of a.articles I found that and it works great.

    You can see it in action here:

    http://stopscabies.com

    It reflects all the topic and article info great.


  2. First of all nice one Jack another great contribution.

    Maybe a small bug report any comments on this would be appreciated.

    Installed HeaderTags_SEO_V_3.0.1 on a modified store everything seemed fine, in admin header tags working great but when I inserted a few new articles ( article manager 1.5) I found I was getting a blank page when clicking on

    New Articles links on index page and only seeing the latest article after clicking on all articles instead of 3 _ 4. I first checked article manager for bugs but found none after running the SEO 3.0 install again

    I found that in application top.php towards the end about line: 585

     

    8) Find and remove the following in catalog/includes/application_top.php

     

    // BOF: Header Tags Controller v2.6.3

    require(DIR_WS_FUNCTIONS . 'header_tags.php');

    // Clean out HTML comments from ALT tags etc.

    require(DIR_WS_FUNCTIONS . 'clean_html_comments.php');

    // EOF: Added: Header Tags Controller v2.6.3

     

    if I left the.... require(DIR_WS_FUNCTIONS . 'clean_html_comments.php');....... untouched everything works fine...

    still checking the effect on HeaderTags_SEO but at the minute the links on the index page for the articles are working again and the HeaderTags SEO seems to be unaffected.


  3. Well - I'm stumped. I have Ultimate SEO URL's that was updated by FWR Media (2.1d Original with Independent SEO URL Validation installed as well)

     

    At one point things were working correctly and I was not seeing the osCsid in the URL or in the XML Sitemap that is automatically generated weekly for google and yahoo. Now, all of the sudden, I have the osCsid's back in both places - not good.

     

    So I am trying to find any reason why this is the case.

     

    I do have this underneath of the fwrmedia code in applicaiton_top.php

    if ( $spider_flag == true ){
     if ( eregi(tep_session_name(), $_SERVER['REQUEST_URI']) ){
      $location = tep_href_link(basename($_SERVER['SCRIPT_NAME']), tep_get_all_get_params(array(tep_session_name())), 'NONSSL', false);
      header("HTTP/1.0 301 Moved Permanently"); 
      header("Location: $location"); // redirect...bye bye  
     }
    }

     

    I commented out the above code, and now the pages load without showing me the osCsid in the URL - good progress.

     

    However, when I use this tool:

    http://www.webconfs.com/search-engine-spider-simulator.php

     

    It shows all of the links with osCsid in them :huh:

     

     

    Currently the Validate URL's feature is turned on

     

    Do you have prevent spider sessions set to true in the admin under sessions?


  4. Just wanted to say,this is truely an awesome piece ofwork! Definitely a must have.

    Ive been tweaking on it a couple days and have been able to integrate it with article manager, creating a seperate file for filling in the articles info just as you do the product info. All other files and databases only had to have the extra functions added to them.

    I use page manager to add text to several pages in mysite, and this mod even pulls the descriptions and keywords out of there too.

    I was really impressed to see it also pulled some of my footer text. This is probally one of the most important mods you could have for your shop.

    The search engines just have to love this.

    I bet if you wanted to pay someone for a mod like this you would have to drop at least a couple hundred.

    Excellent work Jack. Thank you! :thumbsup:


  5. Hi,

     

    I copied all your files and updated the SQL file..

     

    But when I started to edit the code.. In index.php the second code change says..

     

    FIND (Around line 78)

     

    <td class="pageHeading"><?php echo HEADING_TITLE; ?></td>
    <td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . $category['categories_image'], $category['categories_name'], HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
      </tr>

     

    I am using a template from templatemonster . com and hence I am not able find any of those code in my index.php and also the following changes after that code mentioned in that file aren't there in my index.php.

    Any help ? I am desperately seeking help because I really want that mod.

     

    Regards,

     

    Anand

     

    Your going to have to search for bits and peices and put it together from there, whatever changes you see were made with the original code, you should try to format to your new code on anything you addon. Its the price you pay for one of "those" templates. And you will more than likely have to do this kind of code search for anything you want to install. But dont give up, itcan be done with justa bit of double checking.

    I would start by searching for :

    $category['categories_image'], $category['categories_name'],

    Then work your way around it.

    Unfortunately these "template factorys" rape osc users, they apply templates in the easiest, quickest way possible, overwrite the stylesheet, and leave a horrible mess of code. And in doing that they leave the end user with just a basic oscommerce shop that is a pain in the but to update becuase of their trivial changes that do not follow any of the osc code standards. What makes it really so bad is the fact that with just a few changes to the main body table and columns and boxes, you can have prctically any template design you want and still keep your core code intact.


  6. Wnated to confirm this block of code:

    In catalog/includes/header_tags.php

    Lines 65 & 66 read:

    case (basename($PHP_SELF)==FILENAME_PRODUCT_REVIEWS_INFO):  $filename = FILENAME_PRODUCT_REVIEWS; break; 
     case (basename($PHP_SELF)==FILENAME_PRODUCT_REVIEWS_WRITE): $filename = FILENAME_PRODUCT_WRITE;   break;

     

    Is that correct? Or should it be:

    case (basename($PHP_SELF)==FILENAME_PRODUCT_REVIEWS_INFO):  $filename = FILENAME_PRODUCT_REVIEWS_INFO; break; 
     case (basename($PHP_SELF)==FILENAME_PRODUCT_REVIEWS_WRITE): $filename = FILENAME_PRODUCT_REVIEWS_WRITE;   break;


  7. As always, Great work Jack.

    I installed this from the update file last night, everything went smooth. This thing is awesome!

    However, you did leave out a few things in the upgrade instructions --- uploading the social bookmark module and overwriting the includes/headertags.php and includes/functions headertags.php

    Nothing anyone thats already installed the previous version cant figure out.

    Thanks


  8. Thanks for the reply but, and I may just be blind as a bat, I see no table called "anti_robotreg" or anything remotely similar? :blink:

    Crap, just realized your using a different version. Im using anti-robot reg. Sorry, maybe it works simular though, is there a database table that works with yours that stores a session id?


  9. Not sure that this will work for you, but I once had a problemwithit not showing, and this is what I did.

     

    Go to your phpMyadmin, click on the table for anti_robotreg and delete the contents, not the table, just the contents.

     

    Let me know if that works. Your getting an image at least, when I had a problem before I wasnt even getting that, so I dont know if the same solution will work.


  10. I want to know how to ascertain the product link for each product. Hopefully, if I'm interpretting the osCommerce admin stuff correctly, there is a way to click on "add to cart" and not have the customer transferred to the shopping cart until check out. There has to be a way to use those links in with our products pages, without sending the customer offsite and into the shopping cart. If it can be done from within the cart, it can be done from our html pages with php links.

     

    Or...I can create the product pages in php, just want to know what the "order" link would be for each product which will add that product into the shopping cart. but allow the customer to only go to the shopping cart if they want to "view the cart" or "checkout."

     

    Thanks.

    In the admin under configuration/my store, there is a switch for displaying cart after adding product


  11. Apparently no one in the entire OSC community knows anything about XML Sitmaps....I posted the original question almost a week ago, no one has yet to respond, then my thread gets sabotoged by "Jan Zonjee", so anyone who read the thread and all of "Jans" crap lost total interest in what the thread was about to begin with and decided to move along.

     

    I was under the impression that this was the "Support Forum", wheres the "support"....is it "paid" support, do I need to offer cash for support?

     

    If anyone could enlighten me (except for you "Jan") on how come no one has responded, this is unbelievable, most every other thread gets some kind of response. Had it not been for this "Jan" invading my thread maybe I would've had an answer to my request.

     

    I've gone back and read my 1st post on this thread, sounds like a usual request for assistance, polite/respectful....Post #2 I made an "observation" that 24hrs later not 1 response out of the hundreds of OSC experts in this community....then of course came this disease and invaded my thread and scared everyone away.

     

    Can anyone offer some kind of "support" to the original question regarding XML Sitemap Contributions?

    There are literally hundreds of post in this forum that address exactly what you inquire of. Why don't you search the forums rather than post redundant questions in such a demanding way.

    Maybe your whole point of this topic was to find someone to pick a fight with?

    The obvious is not hard to see.


  12. This is an html email contribution for osCommerce Online Merchant [2.2rc2]. It will replace the standard emails with emails that have more advanced layout and design. The contribution allows you to have different "html email layouts" installed at the same time. New layouts can easily be created and installed. You can easily change between the different "html email layouts" from a dropdown menu, "E-Mail Options"->"Html Email Layout", in the admin panel.

    I just looked at this and Its a very nice addon. It really will add a professional touch to any store. I like that it doesnt have to create any extra database table like some other one does.

    Thanks for giving us this.


  13. Yesterday I installed ver 2.7.1

    Everything went fine for the most part, I added the sort order functions and then followed all the instances of price to use for a guide to add weight as well. It all worked great, untill I went to create a template, no price or weight updates with the template, they do insert into the database, but they dont get called back to the product page.

    So luckily ver 2.8 came out last night with a fix for this issue and the price. I used a compare program to find the differences then merged them over,

    for your reference if your having these problems, I found the changes to be located in includes/attributeManagerUpdateAtomic.inc.php and javascript/attributeManager.js

    Just a couple lines in each file.

    I also had a problem with it originally trying to write to the am_attributes_to_templates table so I just wrote the SQL and inserted it manually to avoid that problem, here is that bit of code in case it helps, you may have to modify the weight and sort order to match what you already use, or just drop them completly if you dont use those:

     

    DROP TABLE IF EXISTS `am_attributes_to_templates`;
    CREATE TABLE IF NOT EXISTS `am_attributes_to_templates` (
     `template_id` int(5) unsigned NOT NULL,
     `options_id` int(5) unsigned NOT NULL,
     `option_values_id` int(5) unsigned NOT NULL,
     `price_prefix` char(1) NOT NULL default '',
     `options_values_price` decimal(15,4) NOT NULL default '0.0000',
     `options_values_weight` decimal(5,3) NOT NULL default '0.000',
     `attribute_sort` int(10) unsigned NOT NULL default '0',
     KEY `template_id` (`template_id`)
    ) ENGINE=MyISAM DEFAULT CHARSET=latin1;


  14. I had many problems with the edit order page showing up completly blank when you go to edit an order with an existing product, or if you create a new order the page would go blank after you add the product. The problem was coming from the free shipping for xxxx amount shipping module (not the order total module). I turned it off and now the editor works fine.


  15. toyicebear I appreciate your concern. That wasn't my question. I'm not interested in your robotic answer to PCI compliance in this matter.

     

    The question was about a fix for the contribution mentioned in my initial post. If you have nothing to offer in the aspect of code then you are wasting my thread space where real answers could be added.

    Hows this for wasting your thread space?

    Now maybe you should try to reinstall from the beginning or choose another contribution that does this.

    And what site are you doing this on?

    Let us see so we may help you. ;)

    Dont worry no one here would turn you in.


  16. if you ever go on another online shop you get things like

     

    people who brought this also brought

    and then shows products ??/

    also what contrib ( if one ) would put like a

     

    would u like extended warrentee with that on the checkout page ??

     

    thanks

    mike

    Thats the also purchased module. Its already installed by defualt.

    Im not sure right off hand about adding an extended warranty at checkout. You could use the gift wrap mod and reword it for warrenties, or you could add the warrentee as a products attribute.


  17. This is for Links Manager

     

     

    I had this error in my links page when I would click on a link category:

     

    Warning: constant() [function.constant]: Couldn't find constant in /home/blablabla/includes/functions/general.php on line 8462

    Error!

    Unable to determine the page link!

     

    Its an easy fix though.

     

    in the code that goes into includes/functions/general.php

    find:

     

    ( strpos($_SERVER['REQUEST_URI'], '-i-') ? ($querytype = 'filename_information-info_id=' . $HTTP_GET_VARS['info_id']) :

     

    Add under:

     

    ( strpos($_SERVER['REQUEST_URI'], '-links-') ? ($querytype = 'filename_links-lPath=' . $HTTP_GET_VARS['lPath']) :

     

    Then under that where it has:

     

    false ))))))))) );

     

    Add 1 more ) so its:

     

    false )))))))))) );

     

    Thats it!

    Ive tested products, categories, articles, articles_info, info_pages, manufactures, and now links.

    Works Fantastic! Thank you Babygurgles. This is going to help a lot. Whether some people believe it or not. I never even realized my urls were GARBAGE untill the other day when I was reading your post.

×