Jump to content

chobo10

Members
  • Content count

    41
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    cynthia
  1. Found that I needed to add to my database: INSERT INTO `configuration` (`configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES ('Fancybox Title Position', 'FBTITLE_POSITION', 'outside', 'The position of title. Can be set to Outside, Inside or Over.', 4, 32, NULL, now(), '', 'tep_cfg_select_option(array(\'outside\', \'inside\', \'over\'),'); Went into admin, and changed title to "inside". Still no change. What am I missing?
  2. Thanks for this contrib! Simple and elegant, works well. How do you change title position from "outside" to "inside"? I prefer the look of it (saw it at fancybox.net) but can't find where to edit. Thanks!
  3. Hi Bobby, Could my issue be SEO URL related? It started happening after the contrib install. I've run it past several people and we can't figure it out. Running oscommerce v2.2 rc2. My cart and everything seems to work fine in general, but I believe after seo install I have lost my capabillity on the admin side to upload images in "add product" in one step. Now I must upload as usual, (I see the name and small image thumbnail before preview), but image does not show in preview or on site. I then have the new step to do of manually dropping the image into my server's image folder. Can live with the additional step but it's a pain. The great news is there is definitely more traffic to my site since! My bigger problem is I cannot move, delete, duplicate products in my catalog. I get no errors when doing so, it appears like it's working but no change happens. I've tried various permissions including 777 with no change. I repaired the database which had a bunch of table related errors, no change. Any thoughts? My seo settings are as follows: Enable SEO URLs? true Add cPath to product URLs? false Add category parent to begining of URLs? true Filter Short Words 3 Output W3C valid URLs (parameter string)? true Enable SEO cache to save queries? true Enable product cache? true Enable categories cache? true Enable manufacturers cache? true Enable articles cache? true Enable topics cache? true Enable information cache? true Enable link directory cache? true Enable automatic redirects? true Choose URL Rewrite Type Rewrite Enter special character conversions Remove all non-alphanumeric characters? false Reset SEO URLs Cache false Any advice appreciated. Especially if anyone can point me in the right place to troubleshoot. Cynthia
  4. Hi, I supspect my problem is SEO URL related cause it started happening after the contrib install. Running oscommerce v2.2 rc2. My cart and everything seems to work fine in general, but I believe after seo install I have lost my capabillity on the admin side to upload images in "add product" in one step. Now I must upload as usual, (I see the name and small image thumbnail before preview), but image does not show in preview or on site. I then have the new step to do of manually dropping the image into my server's image folder. Can live with the additional step but it's a pain. The great news is there is definitely more traffic to my site! My bigger problem is I cannot move, delete, duplicate products in my catalog. I get no errors when doing so, it appears like it's working but no change happens. I've tried various permissions including 777 with no change. I repaired the database which had a bunch of table related errors, no change. Any thoughts? My seo settings are as follows: SEO URLs Enable SEO URLs? true Add cPath to product URLs? false Add category parent to begining of URLs? true Filter Short Words 3 Output W3C valid URLs (parameter string)? true Enable SEO cache to save queries? true Enable product cache? true Enable categories cache? true Enable manufacturers cache? true Enable articles cache? true Enable topics cache? true Enable information cache? true Enable link directory cache? true Enable automatic redirects? true Choose URL Rewrite Type Rewrite Enter special character conversions Remove all non-alphanumeric characters? false Reset SEO URLs Cache false Any advice appreciated. Especially if anyone can point me in the right place to troubleshoot. Cynthia
  5. chobo10

    Cc Validation Fix?

    Can anyone PLEASE help? Or point me in the right direction? My cart is now inoperable until I work this out. I have edited so many pages I'm completely confused now.
  6. chobo10

    Cc Validation Fix?

    Hello, newbie here. Just installed contribution for cvv code input. When testing, I get the error message at my checkout confirmation page: Warning: Missing argument 4 for validate() in /home/fusion13/public_html/catalog/includes/classes/cc_validation.php on line 16 Warning: Cannot modify header information - headers already sent by (output started at /home/fusion13/public_html/catalog/includes/classes/cc_validation.php:16) in /home/fusion13/public_html/catalog/includes/functions/general.php on line 33 I am assuming there are errors somewhere on my cc_validation page, but can't figure them out. I do not have any whitespace at the beginning or end of the page. Advice much appreciated, page below... <?php /* $Id: cc_validation.php,v 1.3 2003/02/12 20:43:41 hpdl Exp $ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright © 2003 osCommerce Released under the GNU General Public License */ class cc_validation { var $cc_type, $cc_number, $cc_expiry_month, $cc_expiry_year, $cc_cvv2; function validate($number, $expiry_m, $expiry_y, $cvv2) { $this->cc_number = ereg_replace('[^0-9]', '', $number); if (ereg('^4[0-9]{12}([0-9]{3})?$', $this->cc_number)) { $this->cc_type = 'Visa'; } elseif (ereg('^5[1-5][0-9]{14}$', $this->cc_number)) { $this->cc_type = 'Master Card'; } elseif (ereg('^3[47][0-9]{13}$', $this->cc_number)) { $this->cc_type = 'American Express'; } elseif (ereg('^3(0[0-5]|[68][0-9])[0-9]{11}$', $this->cc_number)) { $this->cc_type = 'Diners Club'; } elseif (ereg('^6011[0-9]{12}$', $this->cc_number)) { $this->cc_type = 'Discover'; } elseif (ereg('^(3[0-9]{4}|2131|1800)[0-9]{11}$', $this->cc_number)) { $this->cc_type = 'JCB'; } elseif (ereg('^5610[0-9]{12}$', $this->cc_number)) { $this->cc_type = 'Australian BankCard'; } else { return -1; } if (is_numeric($expiry_m) && ($expiry_m > 0) && ($expiry_m < 13)) { $this->cc_expiry_month = $expiry_m; } else { return -2; } $current_year = date('Y'); $expiry_y = substr($current_year, 0, 2) . $expiry_y; if (is_numeric($expiry_y) && ($expiry_y >= $current_year) && ($expiry_y <= ($current_year + 10))) { $this->cc_expiry_year = $expiry_y; } else { return -3; } if ($expiry_y == $current_year) { if ($expiry_m < date('n')) { return -4; } } if ( (strlen($cvv2) < 3) or (strlen($cvv2) > 4)) { return -5; } return $this->is_valid(); } function is_valid() { $cardNumber = strrev($this->cc_number); $numSum = 0; for ($i=0; $i<strlen($cardNumber); $i++) { $currentNum = substr($cardNumber, $i, 1); // Double every second digit if ($i % 2 == 1) { $currentNum *= 2; } // Add digits of 2-digit numbers together if ($currentNum > 9) { $firstNum = $currentNum % 10; $secondNum = ($currentNum - $firstNum) / 10; $currentNum = $firstNum + $secondNum; } $numSum += $currentNum; } // If the total has no remainder it's OK return ($numSum % 10 == 0); } } ?>
  7. chobo10

    Help With This Error Message

    Anyone? For error 2, I have checked the cc verification file. I definitely don't have any invisible white space at the beginning or end.
  8. chobo10

    Help With This Error Message

    Oh! The code reads in cc_validation.php: class cc_validation { var $cc_type, $cc_number, $cc_expiry_month, $cc_expiry_year, $cc_cvv2; function validate($number, $expiry_m, $expiry_y, $cvv2) { $this->cc_number = ereg_replace('[^0-9]', '', $number); and in general.php around line 33: if ( (ENABLE_SSL == true) && (getenv('HTTPS') == 'on') ) { // We are loading an SSL page if (substr($url, 0, strlen(HTTP_SERVER)) == HTTP_SERVER) { // NONSSL url $url = HTTPS_SERVER . substr($url, strlen(HTTP_SERVER)); // Change it to SSL } } header('Location: ' . $url); tep_exit();
  9. chobo10

    Help With This Error Message

    Hi, I just installed module cvv2_version2_1. Upon testing it, I am getting the following error Warning: Missing argument 4 for validate() in /home/fusion13/public_html/catalog/includes/classes/cc_validation.php on line 16 Warning: Cannot modify header information - headers already sent by (output started at /home/fusion13/public_html/catalog/includes/classes/cc_validation.php:16) in /home/fusion13/public_html/catalog/includes/functions/general.php on line 33 I'm a newbie and am not sure how to fix this. thanks!
  10. Newbie here, Have read a few postings. Is this ready to go or are there lots of things to tinker with to get it to work still?
  11. Hello, Newbie here... I currently offer table rate shipping. Many local customers want to order online, prepay and pick up their products from our retail store to save on shipping. How can I offer at check out the option of table rate and "will call" which does not charge shipping, just actual product cost/sales tax? This would also be helpful for customers using their own Fedex/UPS accounts. Thanks!
×