Jump to content

Chadduck

Members
  • Content count

    129
  • Joined

  • Last visited

Everything posted by Chadduck

  1. Chadduck

    OSC CE 1.0.2.1 - Item Display

    SOLVED Well, I now have images. The issue was what puddlec pointed out. WITHOUT that being in the database nothing displayed. Here is the SQL that I found in the initial barebones OSC 1.0.2.1 oscommerce.sql and inserted into the converted database. INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Product Card Layout', 'IS_PRODUCT_PRODUCTS_LAYOUT', 'card-deck', 'What Layout suits your shop? See https://getbootstrap.com/docs/4.3/components/card/#card-layout <div class="secWarning">card-columns is a special use case that will not suit most shops as card-columns is very difficult to layout and sort by...</div>', '8', '100', 'tep_cfg_select_option(array(\'card-group\', \'card-deck\', \'card-columns\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (SM)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_SM', '2', 'How many products should display per Row in SM (Small) viewport?', '8', '110', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (MD)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_MD', '3', 'How many products should display per Row in MD (Medium) viewport?', '8', '120', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (LG)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_LG', '4', 'How many products should display per Row in LG (Large) viewport?', '8', '130', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (XL)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_XL', '4', 'How many products should display per Row in XL (Large) viewport?', '8', '140', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Manufacturer Name (0=disable; 1=enable)','PRODUCT_LIST_MANUFACTURER', '0', 'Allow sorting by Manufacturer Name?', '8', '200', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Model (0=disable; 1=enable)', 'PRODUCT_LIST_MODEL', '0', 'Allow sorting by Product Model?', '8', '210', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Name (0=disable; 1=enable)', 'PRODUCT_LIST_NAME', '1', 'Allow sorting by Product Name?', '8', '220', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Price (0=disable; 1=enable)', 'PRODUCT_LIST_PRICE', '1', 'Allow sorting by Product Price', '8', '230', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Stock (0=disable; 1=enable)', 'PRODUCT_LIST_QUANTITY', '0', 'Allow sorting by Product Quantity (Stock)?', '8', '240', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Weight (0=disable; 1=enable)', 'PRODUCT_LIST_WEIGHT', '0', 'Allow sorting by Product Weight?', '8', '250', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Latest Added (0=disable; 1=enable)', 'PRODUCT_LIST_ID', '1', 'Allow sorting by Latest Added?', '8', '260', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Sales (0=disable; 1=enable)', 'PRODUCT_LIST_ORDERED', '1', 'Allow sorting by Number of Sales?', '8', '270', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Product Image (defunct)', 'PRODUCT_LIST_IMAGE', '0', 'This is a defunct setting.', '8', '280', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Buy Now column (defunct)', 'PRODUCT_LIST_BUY_NOW', '0', 'This is a defunct setting.', '8', '290', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Display Category/Manufacturer Filter (0=disable; 1=enable)', 'PRODUCT_LIST_FILTER', '1', 'Do you want to display the Category/Manufacturer Filter?', '8', '300', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Location of Prev/Next Navigation Bar (1-top, 2-bottom, 3-both)', 'PREV_NEXT_BAR_LOCATION', '2', 'Sets the location of the Prev/Next Navigation Bar (1-top, 2-bottom, 3-both)', '8', '310', now()); When I ran that in phpMyAdmin and the variable were available the front end displayed the items and images. THANK YOU to Lee Foster and puddlec for your assistance.
  2. Chadduck

    OSC CE 1.0.2.1 - Item Display

    HOW do I get to what it is supposed to be?
  3. Chadduck

    OSC CE 1.0.2.1 - Item Display

    I just found that I CAN NOT... In fact I was just coming to ask what happened... Here is what the CONVERTED DB has
  4. Chadduck

    OSC CE 1.0.2.1 - Item Display

    It is LOCAL Thankfully I am not doing this on a LIVE site I just do not understand WHY the items do not show up. I even moved one from a category to "top" and still no display. It is fairly obvious (at least to me) that I have missed enabling something somewhere. I have pdf'd every basic configuration page of the administration on the ORIG DB. I am now comparing with the CONVERTED DB settings to see if I can locate my error. BTW Lee Thank you for your assistance.
  5. Chadduck

    OSC CE 1.0.2.1 - Item Display

    I also noticed that the SEARCH returns the CORRECT item count but does not display items. Search ORIG DB is the ORIGINAL Database Search Converted DB is the CONVERTED batabase
  6. Chadduck

    OSC CE 1.0.2.1 - Item Display

    I have not yet gotten that far. IF I can not see the products in either the categories or the sub categories it does not make sense to add more clutter to the basic installation which this is. Simply changing to the DEFAULT database everything displays fine. It is obviously a toggle or something that I have NOT enabled.
  7. This is simply a heads up about the Apache 2.4 directive changes that may be needed throughout the .htaccess files utilized by OSCommerce CE to remove this error.log entry AH01797: client denied by server configuration: vsn 1.0.1.x vsn 1.0.2.x These contained lines <Files *> Order allow,deny Allow from all </Files> will cause the error AH01797: client denied by server configuration: To stop the error and work properly with Apache 2.4 I edited the affected files with this <Files *> # v2.2 Order allow,deny # v2.2 Allow from all Require all granted </Files> For those unfamiliar the # indicates a comment The .htaccess files are in these locations (This is a list of ALL .htaccess files - NOT all will require editting) /apache/vhosts/store/chadmin/.htaccess /apache/vhosts/store/chadmin/backups/.htaccess /apache/vhosts/store/chadmin/images/.htaccess /apache/vhosts/store/chadmin/includes/.htaccess /apache/vhosts/store/download/.htaccess /apache/vhosts/store/ext/.htaccess /apache/vhosts/store/images/.htaccess /apache/vhosts/store/includes/.htaccess /apache/vhosts/store/includes/work/.htaccess /apache/vhosts/store/pub/.htaccess
  8. I figured I gave a relatively bland answer - on Ubuntu to check the apache version on the server command line you can issue apache2 -v Every server I have running 3 different versions of Ubuntu are showing Apache/2.4.xx (Ubuntu) If you can not find it on your own you should check with your ISP / host
  9. I really have no idea - Last week I installed a CLEAN Phoenix-v1.0.1.1 to take a look and start the upgrading process from 2.3.4.x One of the first things I do is ensure that the basics are working, in other words a CLEAN error.log which is when I discovered the AH01797 error. Researching it is when I discovered the change in the directives. The fix to remove that error was as I indicated above. I simply commented out the existing lines and added what was indicated by the various replies on the "fix" sites - stackexchange, askubuntu, etc
  10. Hello all I have decided that since I am setting up a NEW server that I should move to the new OSC Responsive. It is a CLEAN NEW installation of OSC CE no database nothing. The server operating environment Ubuntu 18.04.2 LTS PHP version: 7.2.19-0ubuntu0.18.04.1 mysql Ver 14.14 Distrib 5.7.27 The OSC CE install is CE Phoenix v 1.0.1.1 I have included pictures of the Install start, Install finish, Customer side, and the admin side below. There has been NO CHANGES to anything. As stated it is a CLEAN UNMODIFED install. Any ideas as to the redirect issue? It is untouched from the install. BJ
  11. Chadduck

    OSC CE Phoenix installation issue

    SOLVED The redirect has been solved. Installed a locally generated temporary OpenSSL cert. The admin login now loads.
  12. Chadduck

    OSC CE Phoenix installation issue

    I figure someone will ask for this. It is the admin configure.php <?php define('HTTP_SERVER', 'http://newstore.militarywives.com'); define('HTTPS_SERVER', 'http://newstore.militarywives.com'); define('ENABLE_SSL', false); define('HTTP_COOKIE_DOMAIN', ''); define('HTTPS_COOKIE_DOMAIN', ''); define('HTTP_COOKIE_PATH', '/chadmin'); define('HTTPS_COOKIE_PATH', '/chadmin'); define('HTTP_CATALOG_SERVER', 'http://newstore.militarywives.com'); define('HTTPS_CATALOG_SERVER', 'http://newstore.militarywives.com'); define('ENABLE_SSL_CATALOG', 'false'); define('DIR_FS_DOCUMENT_ROOT', '/apache/vhosts/store/'); define('DIR_WS_ADMIN', '/chadmin/'); define('DIR_WS_HTTPS_ADMIN', '/chadmin/'); define('DIR_FS_ADMIN', '/apache/vhosts/store/chadmin/'); define('DIR_WS_CATALOG', '/'); define('DIR_WS_HTTPS_CATALOG', '/'); define('DIR_FS_CATALOG', '/apache/vhosts/store/'); define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/'); define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DB_SERVER', 'localhost'); define('DB_SERVER_USERNAME', 'root'); define('DB_SERVER_PASSWORD', 'chad2495'); define('DB_DATABASE', 'OSC_CE'); define('USE_PCONNECT', 'false'); define('STORE_SESSIONS', 'mysql'); define('CFG_TIME_ZONE', 'America/Los_Angeles'); It is as was created by the installation. BTW - this is a TEST server and not viewable to the outside world. BJ
  13. Chadduck

    OSC and .htaccess

    I am moving my store to a new server - My NEW SYSTEM operating environment Ubuntu 18.04.2 LTS PHP version: 7.2.19-0ubuntu0.18.04.1 mysql Ver 14.14 Distrib 5.7.27 OSCommerce 2.3.4 Before anyone points out that the OSC bootstrap version is better - I am simply moving the store from one server to another. My question involves the usage of .htaccess to password protect the access to the admin section ASSUME OSC admin username is CharlesDuncan OSC admin password is Duncan2345 WHY is it if those are entered in the .htpasswd file that the OSC login screen is bypassed and the user is placed on the administration screen of OSC? ANY OTHER user name and password combination for .htaccess puts the user on the login screen called by login.php?action=process To verifiy this I went to my existing production server and tested it. The production server operates with older versions of Ubuntu, php, and MySql but the same OSC version. It does the same thing. Obviously I immediately removed the new entry in .htpasswd BUT I was wondering if others have ran into this.
  14. Chadduck

    OSC and .htaccess

    Thank you Jack_mcs
  15. Chadduck

    OSC and .htaccess

    Thank You Ruden
  16. Mr Ponce de Leon

    Good day.

    At this point in time, I am quite happy with OSC 2.3.4 however I know that it has been sunsetted.  Therein lies the source of my question - My ultimate goal is to use OSC version 3x when it becomes available.

    HOW is the best way to be prepared for migration to V3x?

    Is it going to be a necessity to first go to OSC CE then to V3x or will there be an update made available to move from the version I am currently using?

    BJ Chadduck

  17. Chadduck

    UPS Choice 1.8.3

    Thank you Jack
  18. Chadduck

    UPS Choice 1.8.3

    Jack Not to sound like an idiot on my part but could you kinda walk me through it? I created the UPS user account but didn't know what, or where to go ,to acquire what I needed. I am sure it is quite easy but when I was attempting to do it - I was a little stressed since 1.8.3 was not working and I needed UPS quotes. Thanks in advance BJ
  19. Chadduck

    UPS Choice 1.8.3

    Is there a cost for the UPS access KEY?
  20. Chadduck

    UPS Choice 1.8.3

    OldPete In regards to the XML install - is there a cost for the access key? I started to move over to it UPS XML 1.7 but when I went to create the access key I got the impression that there was a charge. I stopped because of it. BJ
  21. Hello Everyone A few days ago I questioned whether UPS was having a problem, I also questioned whether UPS Choice 1.8.3 was still a viable shipping module. I have reached the conclusion that it may be time to consider a new module for obtaining UPS rates. Up front, I dislike change and I live by the adage "if it ain't broke - don't fix it" however it is apparent that it is broke and I need to resolve it. Having said that - I really have no idea what is the simplest way to resolve my issue. I am open to any and all suggestions. I simply need to pull and display the rates. I do NOT need to print UPS labels. I do NOT need to schedule UPS Pickups. I do NOT need to acquire UPS tracking. I do NOT need to get anything BUT the rate quotes. I have looked at UPS XML but when I went to UPS to acquire the needed UPS access key - I could not determine whether or not there was a cost associated with it as the questioning was implying that I was applying for my own UPS number which I do NOT have a requirement for. Again any suggestion and/or explanation about the UPS access key would be deeply appreciated. BJ
  22. Chadduck

    Is there a SIMPLE UPS module?

    My issue with UPS 1.8.3 is RESOLVED... THANK YOU REPETE.. For others that may be experiencing a similar issue here is the fix provided by repete... Modify /includes/modules/shipping/ups.php changing line 267 from... if ($http->Connect('www.ups.com', 80)) { To.... if ($http->Connect('ssl://www.ups.com', 443?)) { AGAIN THANK YOU REPETE
  23. Chadduck

    UPS Choice 1.8.3

    THANK YOU!!! THANK YOU!!! THANK YOU!!! that is all I can say... WORKS LIKE A DREAM!!!
  24. Chadduck

    UPS Choice 1.8.3

    Thanks Jack I did NOT believe it was just me - BUT strange things happen within the magical world of the internet. BJ
×