Jump to content

Chadduck

Members
  • Content count

    108
  • Joined

  • Last visited

Everything posted by Chadduck

  1. Chadduck

    USPS Rate V4, Intl Rate V2 (official support thread)

    Thank you Jim. I added the line where indicated and it SOLVED the problem. Beyond that little change - everything went as advertised. Comparing the LIVE store vs the Local store - the rates were pulled correctly. The array now works. Attached is a text file containing your code for addition in the download file. THANKS again - onward and upward. Any suggestions for the UPS shipping method? Phoenix.txt
  2. Chadduck

    USPS Rate V4, Intl Rate V2 (official support thread)

    Hello all I am moving from OSC 2.3.4.1 to OSC Phoenix. The specific module and vsn is USPS Rate V4 Intl Rate V2_r1.8 Per kymation's reply in the topic - Which USPS add-on to use?!? https://forums.oscommerce.com/topic/412353-which-usps-add-on-to-use/?tab=comments#comment-1764332 Since it was a CLEAN install I copied the files as directed. This resulted in error code 500 server misconfiguration. Putting back the ORIGINAL admin/modules.php returned me to normal. So I began MANUAL modification. When I attempted to incorporate the admin/modules.php modifications the identified FIND code does not appear in the module.. Since this is the case not incorporating the stated replace/add code is the cause for this issue. Since ALL of the identified FIND code does NOT exist in the Phoenix module.php The beginning portion does exist if (tep_not_null($action)) { switch ($action) { case 'save': However after that the coding is radically different. Additionally I checked modules_actions.php modules_content.php modules_hooks.php modules_content.php also contains if (tep_not_null($action)) { switch ($action) { case 'save': But yet again after that the coding is radically different. As the attached screens show the module DOES install and is read by the PHOENIX code. the first image is the initial screen BEFORE any edit the second is after editing and saving just the User ID However, I have isolated it the fact that as soon as any value is edited and saved the Shipping Methods Extra Services (domestic) Extra Services (International) simply show ARRAY Since this is being setup on a LOCAL testing platform - I used phpAdmin to locate the values in my live store - copied and pasted them into the appropriate areas and the Front end does display the value albeit the amount is incorrect. Additionally AFTER I did the copy and paste I noticed that the columns seemed to be off in the Admin as the TEXT from the values actually partially appears in the max weight value of the selected method. In the db the configuration Table the field configuration_key and these values are the ones copied MODULE_SHIPPING_USPS_TYPES MODULE_SHIPPING_USPS_DMST_SERVICES MODULE_SHIPPING_USPS_INTL_SERVICES The third graphic show the values after the copy and paste. HAS ANYONE SUCCEEDED in this endeavor? BJ
  3. OK I have obviously missed something with my converting of OSC 2.3.4.1 to OSC CE 1.0.2.1 No category product display I can see the textual categories - no items I can see the sub categories - no items Clicking on whatever item is displayed in the Specials box displays the item description and pic Add to Cart puts the item into the cart and display the item name and pic SO - what have I missed?
  4. Chadduck

    OSC CE 1.0.2.1 - Item Display

    @Mikepo I followed the instructions by Jack_MCS in his post Upgrading to the latest version https://forums.oscommerce.com/topic/408979-upgrading-to-the-latest-version/ then did as directed by his post which took me to Burt's posting about database conversion here 2.3.4(normal) to 2.3.4(responsive) database conversion script https://forums.oscommerce.com/topic/399678-234normal-to-234responsive-database-conversion-script/ As of this point - everything seems to be working BUT as with any migration this extensive - what remains is still unknown. Obviously this is a work in progress. As all who know me by my postings - I am not afraid to ask for help and then posting HOW I solved the issue.
  5. Chadduck

    OSC CE 1.0.2.1 - Item Display

    SOLVED Well, I now have images. The issue was what puddlec pointed out. WITHOUT that being in the database nothing displayed. Here is the SQL that I found in the initial barebones OSC 1.0.2.1 oscommerce.sql and inserted into the converted database. INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Product Card Layout', 'IS_PRODUCT_PRODUCTS_LAYOUT', 'card-deck', 'What Layout suits your shop? See https://getbootstrap.com/docs/4.3/components/card/#card-layout <div class="secWarning">card-columns is a special use case that will not suit most shops as card-columns is very difficult to layout and sort by...</div>', '8', '100', 'tep_cfg_select_option(array(\'card-group\', \'card-deck\', \'card-columns\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (SM)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_SM', '2', 'How many products should display per Row in SM (Small) viewport?', '8', '110', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (MD)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_MD', '3', 'How many products should display per Row in MD (Medium) viewport?', '8', '120', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (LG)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_LG', '4', 'How many products should display per Row in LG (Large) viewport?', '8', '130', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (XL)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_XL', '4', 'How many products should display per Row in XL (Large) viewport?', '8', '140', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Manufacturer Name (0=disable; 1=enable)','PRODUCT_LIST_MANUFACTURER', '0', 'Allow sorting by Manufacturer Name?', '8', '200', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Model (0=disable; 1=enable)', 'PRODUCT_LIST_MODEL', '0', 'Allow sorting by Product Model?', '8', '210', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Name (0=disable; 1=enable)', 'PRODUCT_LIST_NAME', '1', 'Allow sorting by Product Name?', '8', '220', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Price (0=disable; 1=enable)', 'PRODUCT_LIST_PRICE', '1', 'Allow sorting by Product Price', '8', '230', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Stock (0=disable; 1=enable)', 'PRODUCT_LIST_QUANTITY', '0', 'Allow sorting by Product Quantity (Stock)?', '8', '240', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Weight (0=disable; 1=enable)', 'PRODUCT_LIST_WEIGHT', '0', 'Allow sorting by Product Weight?', '8', '250', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Latest Added (0=disable; 1=enable)', 'PRODUCT_LIST_ID', '1', 'Allow sorting by Latest Added?', '8', '260', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Sales (0=disable; 1=enable)', 'PRODUCT_LIST_ORDERED', '1', 'Allow sorting by Number of Sales?', '8', '270', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Product Image (defunct)', 'PRODUCT_LIST_IMAGE', '0', 'This is a defunct setting.', '8', '280', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Buy Now column (defunct)', 'PRODUCT_LIST_BUY_NOW', '0', 'This is a defunct setting.', '8', '290', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Display Category/Manufacturer Filter (0=disable; 1=enable)', 'PRODUCT_LIST_FILTER', '1', 'Do you want to display the Category/Manufacturer Filter?', '8', '300', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Location of Prev/Next Navigation Bar (1-top, 2-bottom, 3-both)', 'PREV_NEXT_BAR_LOCATION', '2', 'Sets the location of the Prev/Next Navigation Bar (1-top, 2-bottom, 3-both)', '8', '310', now()); When I ran that in phpMyAdmin and the variable were available the front end displayed the items and images. THANK YOU to Lee Foster and puddlec for your assistance.
  6. Chadduck

    OSC CE 1.0.2.1 - Item Display

    HOW do I get to what it is supposed to be?
  7. Chadduck

    OSC CE 1.0.2.1 - Item Display

    I just found that I CAN NOT... In fact I was just coming to ask what happened... Here is what the CONVERTED DB has
  8. Chadduck

    OSC CE 1.0.2.1 - Item Display

    It is LOCAL Thankfully I am not doing this on a LIVE site I just do not understand WHY the items do not show up. I even moved one from a category to "top" and still no display. It is fairly obvious (at least to me) that I have missed enabling something somewhere. I have pdf'd every basic configuration page of the administration on the ORIG DB. I am now comparing with the CONVERTED DB settings to see if I can locate my error. BTW Lee Thank you for your assistance.
  9. Chadduck

    OSC CE 1.0.2.1 - Item Display

    I also noticed that the SEARCH returns the CORRECT item count but does not display items. Search ORIG DB is the ORIGINAL Database Search Converted DB is the CONVERTED batabase
  10. Chadduck

    OSC CE 1.0.2.1 - Item Display

    I have not yet gotten that far. IF I can not see the products in either the categories or the sub categories it does not make sense to add more clutter to the basic installation which this is. Simply changing to the DEFAULT database everything displays fine. It is obviously a toggle or something that I have NOT enabled.
  11. This is simply a heads up about the Apache 2.4 directive changes that may be needed throughout the .htaccess files utilized by OSCommerce CE to remove this error.log entry AH01797: client denied by server configuration: vsn 1.0.1.x vsn 1.0.2.x These contained lines <Files *> Order allow,deny Allow from all </Files> will cause the error AH01797: client denied by server configuration: To stop the error and work properly with Apache 2.4 I edited the affected files with this <Files *> # v2.2 Order allow,deny # v2.2 Allow from all Require all granted </Files> For those unfamiliar the # indicates a comment The .htaccess files are in these locations (This is a list of ALL .htaccess files - NOT all will require editting) /apache/vhosts/store/chadmin/.htaccess /apache/vhosts/store/chadmin/backups/.htaccess /apache/vhosts/store/chadmin/images/.htaccess /apache/vhosts/store/chadmin/includes/.htaccess /apache/vhosts/store/download/.htaccess /apache/vhosts/store/ext/.htaccess /apache/vhosts/store/images/.htaccess /apache/vhosts/store/includes/.htaccess /apache/vhosts/store/includes/work/.htaccess /apache/vhosts/store/pub/.htaccess
  12. I figured I gave a relatively bland answer - on Ubuntu to check the apache version on the server command line you can issue apache2 -v Every server I have running 3 different versions of Ubuntu are showing Apache/2.4.xx (Ubuntu) If you can not find it on your own you should check with your ISP / host
  13. I really have no idea - Last week I installed a CLEAN Phoenix-v1.0.1.1 to take a look and start the upgrading process from 2.3.4.x One of the first things I do is ensure that the basics are working, in other words a CLEAN error.log which is when I discovered the AH01797 error. Researching it is when I discovered the change in the directives. The fix to remove that error was as I indicated above. I simply commented out the existing lines and added what was indicated by the various replies on the "fix" sites - stackexchange, askubuntu, etc
  14. Hello all I have decided that since I am setting up a NEW server that I should move to the new OSC Responsive. It is a CLEAN NEW installation of OSC CE no database nothing. The server operating environment Ubuntu 18.04.2 LTS PHP version: 7.2.19-0ubuntu0.18.04.1 mysql Ver 14.14 Distrib 5.7.27 The OSC CE install is CE Phoenix v 1.0.1.1 I have included pictures of the Install start, Install finish, Customer side, and the admin side below. There has been NO CHANGES to anything. As stated it is a CLEAN UNMODIFED install. Any ideas as to the redirect issue? It is untouched from the install. BJ
  15. Chadduck

    OSC CE Phoenix installation issue

    SOLVED The redirect has been solved. Installed a locally generated temporary OpenSSL cert. The admin login now loads.
  16. Chadduck

    OSC CE Phoenix installation issue

    I figure someone will ask for this. It is the admin configure.php <?php define('HTTP_SERVER', 'http://newstore.militarywives.com'); define('HTTPS_SERVER', 'http://newstore.militarywives.com'); define('ENABLE_SSL', false); define('HTTP_COOKIE_DOMAIN', ''); define('HTTPS_COOKIE_DOMAIN', ''); define('HTTP_COOKIE_PATH', '/chadmin'); define('HTTPS_COOKIE_PATH', '/chadmin'); define('HTTP_CATALOG_SERVER', 'http://newstore.militarywives.com'); define('HTTPS_CATALOG_SERVER', 'http://newstore.militarywives.com'); define('ENABLE_SSL_CATALOG', 'false'); define('DIR_FS_DOCUMENT_ROOT', '/apache/vhosts/store/'); define('DIR_WS_ADMIN', '/chadmin/'); define('DIR_WS_HTTPS_ADMIN', '/chadmin/'); define('DIR_FS_ADMIN', '/apache/vhosts/store/chadmin/'); define('DIR_WS_CATALOG', '/'); define('DIR_WS_HTTPS_CATALOG', '/'); define('DIR_FS_CATALOG', '/apache/vhosts/store/'); define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/'); define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DB_SERVER', 'localhost'); define('DB_SERVER_USERNAME', 'root'); define('DB_SERVER_PASSWORD', 'chad2495'); define('DB_DATABASE', 'OSC_CE'); define('USE_PCONNECT', 'false'); define('STORE_SESSIONS', 'mysql'); define('CFG_TIME_ZONE', 'America/Los_Angeles'); It is as was created by the installation. BTW - this is a TEST server and not viewable to the outside world. BJ
  17. Chadduck

    OSC and .htaccess

    I am moving my store to a new server - My NEW SYSTEM operating environment Ubuntu 18.04.2 LTS PHP version: 7.2.19-0ubuntu0.18.04.1 mysql Ver 14.14 Distrib 5.7.27 OSCommerce 2.3.4 Before anyone points out that the OSC bootstrap version is better - I am simply moving the store from one server to another. My question involves the usage of .htaccess to password protect the access to the admin section ASSUME OSC admin username is CharlesDuncan OSC admin password is Duncan2345 WHY is it if those are entered in the .htpasswd file that the OSC login screen is bypassed and the user is placed on the administration screen of OSC? ANY OTHER user name and password combination for .htaccess puts the user on the login screen called by login.php?action=process To verifiy this I went to my existing production server and tested it. The production server operates with older versions of Ubuntu, php, and MySql but the same OSC version. It does the same thing. Obviously I immediately removed the new entry in .htpasswd BUT I was wondering if others have ran into this.
  18. Chadduck

    OSC and .htaccess

    Thank you Jack_mcs
  19. Chadduck

    OSC and .htaccess

    Thank You Ruden
  20. Mr Ponce de Leon

    Good day.

    At this point in time, I am quite happy with OSC 2.3.4 however I know that it has been sunsetted.  Therein lies the source of my question - My ultimate goal is to use OSC version 3x when it becomes available.

    HOW is the best way to be prepared for migration to V3x?

    Is it going to be a necessity to first go to OSC CE then to V3x or will there be an update made available to move from the version I am currently using?

    BJ Chadduck

  21. Chadduck

    UPS Choice 1.8.3

    Thank you Jack
  22. Chadduck

    UPS Choice 1.8.3

    Jack Not to sound like an idiot on my part but could you kinda walk me through it? I created the UPS user account but didn't know what, or where to go ,to acquire what I needed. I am sure it is quite easy but when I was attempting to do it - I was a little stressed since 1.8.3 was not working and I needed UPS quotes. Thanks in advance BJ
  23. Chadduck

    UPS Choice 1.8.3

    Is there a cost for the UPS access KEY?
  24. Chadduck

    UPS Choice 1.8.3

    OldPete In regards to the XML install - is there a cost for the access key? I started to move over to it UPS XML 1.7 but when I went to create the access key I got the impression that there was a charge. I stopped because of it. BJ
×