Jump to content

Chadduck

Members
  • Content count

    89
  • Joined

  • Last visited

4 Followers

Profile Information

  • Real Name
    BJ Chadduck

Recent Profile Visitors

13,603 profile views
  1. Chadduck

    New UPS XML Shipping Module available

    Trying to install this module on a CLEAN Frozen install Operating System I included a crop of the installation screen The OSC is CE-Phoenix-2341-Frozen The module is UPSXML version 1.7 THIS INSTALL IS RUNNING ON A LOCAL SERVER I do not understand exactly what is happening. When I place the upsxml.php in the includes/modules/shipping directory the shipping modules installation screen fails to load completely. NO there is no other UPS module there, as shown on the BEFORE placing portion of the graphic. After placing the module shows the screen after the upsxml.php is placed. Solutions? Recommendations?
  2. Chadduck

    USPS Rate V4, Intl Rate V2 (official support thread)

    @ArtcoInc THANK YOU... Although I have it installed and working your extra information about HOW the PHOENIX code works is valuable.
  3. Hello All; At this point, in my migration to OSC Phoenix, I am slowly adding shipping and payment methods. I currently have these modules installed and working Master_Password_v3.1 - INSTALLED USPS Rate V4 Intl Rate V2 r1.8 - INSTALLED (thank you @Kymation) I am now needing to install an UPS Shipping method. On my LIVE store I currently use UPS CHOICE 1.8.3.1. While I understand that XML is the wave of the future and I have the needed keys etc for install I would truly prefer simple rather than complex. Also from what I have read in the forums the module UPSXML version 1.7 does not like php 7.2 or php 7.3. I am currently running under php 7.3. WHICH UPS module WORKS with Phoenix? I have reviewed the forum and there does not seem to be an identified module (old or new) that is recommended. Suggestions? and do you have it operational? BJ
  4. Chadduck

    USPS Rate V4, Intl Rate V2 (official support thread)

    Appreciate this but I have one from the LIVE store I run. But others may not.
  5. Chadduck

    USPS Rate V4, Intl Rate V2 (official support thread)

    Jim I was so excited that the array issue was resolved I was NOT paying attention on the Front End. In the module includes/modules/shipping/usps.php on line 32 is this $this->icon = DIR_WS_ICONS . 'shipping_usps.gif'; First there is NO icon in the package and secondly when Phoenix installs there is not a directory created. Additionally there is no define set up in the configure.php for them. As it appears there is a broken graphic that appears. simply commenting that line out removes the broken graphic. BJ
  6. Chadduck

    USPS Rate V4, Intl Rate V2 (official support thread)

    Thank you Jim. I added the line where indicated and it SOLVED the problem. Beyond that little change - everything went as advertised. Comparing the LIVE store vs the Local store - the rates were pulled correctly. The array now works. Attached is a text file containing your code for addition in the download file. THANKS again - onward and upward. Any suggestions for the UPS shipping method? Phoenix.txt
  7. Chadduck

    USPS Rate V4, Intl Rate V2 (official support thread)

    Hello all I am moving from OSC 2.3.4.1 to OSC Phoenix. The specific module and vsn is USPS Rate V4 Intl Rate V2_r1.8 Per kymation's reply in the topic - Which USPS add-on to use?!? https://forums.oscommerce.com/topic/412353-which-usps-add-on-to-use/?tab=comments#comment-1764332 Since it was a CLEAN install I copied the files as directed. This resulted in error code 500 server misconfiguration. Putting back the ORIGINAL admin/modules.php returned me to normal. So I began MANUAL modification. When I attempted to incorporate the admin/modules.php modifications the identified FIND code does not appear in the module.. Since this is the case not incorporating the stated replace/add code is the cause for this issue. Since ALL of the identified FIND code does NOT exist in the Phoenix module.php The beginning portion does exist if (tep_not_null($action)) { switch ($action) { case 'save': However after that the coding is radically different. Additionally I checked modules_actions.php modules_content.php modules_hooks.php modules_content.php also contains if (tep_not_null($action)) { switch ($action) { case 'save': But yet again after that the coding is radically different. As the attached screens show the module DOES install and is read by the PHOENIX code. the first image is the initial screen BEFORE any edit the second is after editing and saving just the User ID However, I have isolated it the fact that as soon as any value is edited and saved the Shipping Methods Extra Services (domestic) Extra Services (International) simply show ARRAY Since this is being setup on a LOCAL testing platform - I used phpAdmin to locate the values in my live store - copied and pasted them into the appropriate areas and the Front end does display the value albeit the amount is incorrect. Additionally AFTER I did the copy and paste I noticed that the columns seemed to be off in the Admin as the TEXT from the values actually partially appears in the max weight value of the selected method. In the db the configuration Table the field configuration_key and these values are the ones copied MODULE_SHIPPING_USPS_TYPES MODULE_SHIPPING_USPS_DMST_SERVICES MODULE_SHIPPING_USPS_INTL_SERVICES The third graphic show the values after the copy and paste. HAS ANYONE SUCCEEDED in this endeavor? BJ
  8. Chadduck

    OSC CE 1.0.2.1 - Item Display

    @Mikepo I followed the instructions by Jack_MCS in his post Upgrading to the latest version https://forums.oscommerce.com/topic/408979-upgrading-to-the-latest-version/ then did as directed by his post which took me to Burt's posting about database conversion here 2.3.4(normal) to 2.3.4(responsive) database conversion script https://forums.oscommerce.com/topic/399678-234normal-to-234responsive-database-conversion-script/ As of this point - everything seems to be working BUT as with any migration this extensive - what remains is still unknown. Obviously this is a work in progress. As all who know me by my postings - I am not afraid to ask for help and then posting HOW I solved the issue.
  9. Chadduck

    OSC CE 1.0.2.1 - Item Display

    SOLVED Well, I now have images. The issue was what puddlec pointed out. WITHOUT that being in the database nothing displayed. Here is the SQL that I found in the initial barebones OSC 1.0.2.1 oscommerce.sql and inserted into the converted database. INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Product Card Layout', 'IS_PRODUCT_PRODUCTS_LAYOUT', 'card-deck', 'What Layout suits your shop? See https://getbootstrap.com/docs/4.3/components/card/#card-layout <div class="secWarning">card-columns is a special use case that will not suit most shops as card-columns is very difficult to layout and sort by...</div>', '8', '100', 'tep_cfg_select_option(array(\'card-group\', \'card-deck\', \'card-columns\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (SM)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_SM', '2', 'How many products should display per Row in SM (Small) viewport?', '8', '110', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (MD)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_MD', '3', 'How many products should display per Row in MD (Medium) viewport?', '8', '120', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (LG)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_LG', '4', 'How many products should display per Row in LG (Large) viewport?', '8', '130', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (XL)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_XL', '4', 'How many products should display per Row in XL (Large) viewport?', '8', '140', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Manufacturer Name (0=disable; 1=enable)','PRODUCT_LIST_MANUFACTURER', '0', 'Allow sorting by Manufacturer Name?', '8', '200', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Model (0=disable; 1=enable)', 'PRODUCT_LIST_MODEL', '0', 'Allow sorting by Product Model?', '8', '210', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Name (0=disable; 1=enable)', 'PRODUCT_LIST_NAME', '1', 'Allow sorting by Product Name?', '8', '220', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Price (0=disable; 1=enable)', 'PRODUCT_LIST_PRICE', '1', 'Allow sorting by Product Price', '8', '230', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Stock (0=disable; 1=enable)', 'PRODUCT_LIST_QUANTITY', '0', 'Allow sorting by Product Quantity (Stock)?', '8', '240', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Weight (0=disable; 1=enable)', 'PRODUCT_LIST_WEIGHT', '0', 'Allow sorting by Product Weight?', '8', '250', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Latest Added (0=disable; 1=enable)', 'PRODUCT_LIST_ID', '1', 'Allow sorting by Latest Added?', '8', '260', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Sales (0=disable; 1=enable)', 'PRODUCT_LIST_ORDERED', '1', 'Allow sorting by Number of Sales?', '8', '270', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Product Image (defunct)', 'PRODUCT_LIST_IMAGE', '0', 'This is a defunct setting.', '8', '280', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Buy Now column (defunct)', 'PRODUCT_LIST_BUY_NOW', '0', 'This is a defunct setting.', '8', '290', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Display Category/Manufacturer Filter (0=disable; 1=enable)', 'PRODUCT_LIST_FILTER', '1', 'Do you want to display the Category/Manufacturer Filter?', '8', '300', now()); INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Location of Prev/Next Navigation Bar (1-top, 2-bottom, 3-both)', 'PREV_NEXT_BAR_LOCATION', '2', 'Sets the location of the Prev/Next Navigation Bar (1-top, 2-bottom, 3-both)', '8', '310', now()); When I ran that in phpMyAdmin and the variable were available the front end displayed the items and images. THANK YOU to Lee Foster and puddlec for your assistance.
  10. Chadduck

    OSC CE 1.0.2.1 - Item Display

    HOW do I get to what it is supposed to be?
  11. Chadduck

    OSC CE 1.0.2.1 - Item Display

    I just found that I CAN NOT... In fact I was just coming to ask what happened... Here is what the CONVERTED DB has
  12. Chadduck

    OSC CE 1.0.2.1 - Item Display

    It is LOCAL Thankfully I am not doing this on a LIVE site I just do not understand WHY the items do not show up. I even moved one from a category to "top" and still no display. It is fairly obvious (at least to me) that I have missed enabling something somewhere. I have pdf'd every basic configuration page of the administration on the ORIG DB. I am now comparing with the CONVERTED DB settings to see if I can locate my error. BTW Lee Thank you for your assistance.
  13. Chadduck

    OSC CE 1.0.2.1 - Item Display

    I also noticed that the SEARCH returns the CORRECT item count but does not display items. Search ORIG DB is the ORIGINAL Database Search Converted DB is the CONVERTED batabase
  14. Chadduck

    OSC CE 1.0.2.1 - Item Display

    I have not yet gotten that far. IF I can not see the products in either the categories or the sub categories it does not make sense to add more clutter to the basic installation which this is. Simply changing to the DEFAULT database everything displays fine. It is obviously a toggle or something that I have NOT enabled.
  15. OK I have obviously missed something with my converting of OSC 2.3.4.1 to OSC CE 1.0.2.1 No category product display I can see the textual categories - no items I can see the sub categories - no items Clicking on whatever item is displayed in the Specials box displays the item description and pic Add to Cart puts the item into the cart and display the item name and pic SO - what have I missed?
×