Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

loki

Members
  • Content count

    19
  • Joined

  • Last visited

About loki

  • Birthday 10/16/1981

Profile Information

  1. loki

    Canada Post Module Postal Code Illegal

    Ok, good news to report, I have this mod fully working. :) mtbkanata I had the same problem and it turned out I didn't install something in the correct directory. Make sure you have installed everything in the correct directories. On top of that make sure that you call Canada post and set the IP to the new one on their production server they give you. It sounds like you've set yourself up otherwise. soulspinr what you're looking for is in the in your admin control panel , shipping config, and set the tare or default weight values to that of your most average sized box (or whatever you're using for packing). As far as I know you aren't able to eliminate the shipping options, but they've been dead accurate for me so far, and since the customer picks shipping off of the time frame they see they understand how long it may take to get to them from purchase. Now you got some help so would you mind deleting two of those posts to keep this thread more readable ;) ?
  2. loki

    Canada Post Module Postal Code Illegal

    I second that, after some trial and error I come over here and find this post, bam, 10 min later I have a working Canadapost shipping mod :-" Bob hurst gets demi-god status for the day, heck i'll even go for two. Now that i'm working with it and changing all of my descriptions from the zone rate calculator calculating LBS to the canadapost KGS. As I already have listed over 300+ items in my paint category alone I think it would be better for me to find a way to make the module weight in LBS. Is there a way to change the weight from KGS to LBS within the module without me hand converting? My other question is the default weight that I seem to be set in is KGS. That is fine, I guess I can convert my whole store if I had to, but I get a wierd display. I enter the weight as 1 KG to a item, and the canadapost shipping mod automatically calculates it to be 4 KGS. I guess I could figure out the fraction ratio, but i'd rater type in the weight and have it spit the same number back out to the end user. Any ideas on this one?
  3. Hello, I have installed the Canadapost shipping module to a dummy store that isn't my live shopping cart. First I should tell you how I installed and what I did to the code: I placed the 16k canadapost.php in install directory\includes\modules\shipping Then the smaller 557 byte canadapost.php in install directory\includes\languages\english\modules\shipping after that you have to go in to your admin module and install it in Configuration - Modules - Shipping The go to Configuration - Shipping/Packaging and insure your country of origin and postal code are set up properly. And then I added this to the code thanks to a tip found on this forum from Bob Hurst: Find this line in: includes/modules/shipping/canadapost.php $this->_canadapostOrigin(STORE_ORIGIN_ZIP, $country_name['countries_iso_code_2']); and replace it with $this->_canadapostOrigin('T3J4A1', $country_name['countries_iso_code_2']); Of course the T3J4A1 got replaced with my own postal code. Now I recieve two seperate errors when checking out on my test store. The first being this warning message: Warning: shipping(includes/languages/english/modules/shipping/canadapost.php): failed to open stream: No such file or directory in /mnt/web_d/d16/s36/b022fd41/www/store2/nfoscomm/catalog/includes/classes/shipping.php on line 36 Warning: shipping(): Failed opening 'includes/languages/english/modules/shipping/canadapost.php' for inclusion (include_path='.:/usr/local/nf/lib/php') in /mnt/web_d/d16/s36/b022fd41/www/store2/nfoscomm/catalog/includes/classes/shipping.php on line 36 It shows at the top of the page and doesn't allow the process to go further. My second problem is in the shipping field the header also displays: MODULE_SHIPPING_CANADAPOST_TEXT_TITLE With a broken JPG saying the same thing, is there any way to fix this? I'd prefer to use Canadapost rather than the zone location calculator. Thanks for any help in advance :thumbsup:
×