Jump to content

discxpress

Members
  • Content count

    796
  • Joined

  • Last visited

  • Days Won

    6

Everything posted by discxpress

  1. @ Here's a screenshot of the error with those settings in place that you suggested: Thanks for your support
  2. @ Flat rate shipping is the method that I wish to use. It works perfectly it's just Paypal doesn't accept that class on line 116 in the separate.php file. If that issue can be resolved, then this contribution would be awesome. Thank you for working with me on this issue
  3. @ Here's the screen shot: I will see what you think about my setting before I edit the file. I'm using OSC version 2.3.3 Thank you
  4. @ I'm sorry it didn't work. You can try looking at these 2 files: includes/classes/shipping.php and includes/modules/payment/paypal_express.php It works fine on regular flat rate shipping and free shipping. I hope that helps narrow down the issue.
  5. @ Now I have a real issue. This module doesn't work with Paypal Express payment module. When I attempt to checkout with Paypal on checkout_payment.php I get this error: Fatal error: Class 'objectInfo' not found in /home/elgxvqtc/public_html/includes/modules/shipping/separate.php on line 116 That line in separate.php reads: $sInfo = new objectInfo($sRate); I hope this help you track down the bug. Thanks again
  6. @ Never mind I figured it out
  7. @ I've found one issue. The flate rate shipping isn't applied to the total in checkout_shipping AND it doesn't populate in the database. If you fix that bug, I believe you would be good to go. Thanks again
  8. @ Please look at the SQL files. Do we change the database line near the top to match our database? Thanks for this module.
  9. discxpress

    Add More Fields

    Thanks Jack. I had did that already but it wasn't working. So I guess the cache wasnt cleared in Chrome. I gave up on it for a while and we had a power outage and decided to try again. Now everything seems ok.
  10. discxpress

    Add More Fields

    Hello @@Jack_mcs, I want to display the values of the custom fields to the product page. For example, if I want the model number to show up on the product page, I would simply place <?php echo ($product_info['products_model']); ?> anywhere on the page. I am trying to get the value of the field "Platform" to appear on the product page by using <?php echo ($product_info['products_platform']); ?> since it's in the same table as products_model. Everything shows up in the database and store admin just fine but I'm having difficulty getting the values to show up on the shop side. Thanks in advance for your help
  11. discxpress

    Header Tags SEO

    @@Jack_mcs @@joli1811 Problem Solved! The problem was indeed the difference in the .js file names referenced in includes/template_top.php. I changed the jquery file numbers and voila! It works
  12. discxpress

    Header Tags SEO

    Thanks for the reply I'm running my shop with version 2.3.3 and here's what I have in includes/template_top.php: <script type="text/javascript" src="ext/jquery/jquery-1.8.0.min.js"></script> <script type="text/javascript" src="ext/jquery/ui/jquery-ui-1.8.22.min.js"></script> When I used the file from the Header Tags obviously those .js files were different. So I switched back to the original file and it works. Maybe I should changed the files that came with HT to see if it works
  13. discxpress

    Header Tags SEO

    Hello Jack, I installed the Latest version for OSC version 2.3.3 and my CSS buttons are missing. I hope all controls to .css buttons are in the stylesheet.css. Please tell me what other files to check. Here's a page to look at:http://btownmedia.com/product_info.php?products_id=21 Thanks
  14. discxpress

    OSC-Affiliate

    Ok. I'm a little tied up at the moment but give me a few days to upload the files. It'll be my very first contribution so bare with me. :)
  15. I found the problem. zlib wasn't enabled. I enabled it on the server and the pages display! Now i need to upgrade the version of PHP. Thanks
  16. Jack, The suggestions you made didn't work but I did find something interesting. I turned off SEO Urls in admin. The categories now work but when I click on a product instead of going to the product's page, a downloaded file of product_info.php is sent to my computer. Go to my site www.discxpress.com, click on a product. You'll see what I'm talking about. I believe it's the way the server interacts with PHP or the way it generates links.
  17. Thanks for your reply. I believe the Options +FollowSymLinks command is commented out in the httpd.conf file on the server. I know that command can be removed from the .htaccess file. Now your second suggestion, I will have to find it in the server's admin area, right?
  18. I checked the path through the server's admin area and through FTP. It's correct unless the root begins before '/var'. Do you think maybe it's a configuration in Apache? I used the same files and database from the old server. Is it possible something got shifted around when I uploaded the database? The only thing I can think to do is to empty the products and categories tables, then re-populate them. Also, here's what is actually on the 404 page itself: Not Found The requested URL /blu-ray-c-309.html was not found on this server. Apache/2.2.3 (CentOS) Server at www.discxpress.com Port 80 The domain isn't appearing before '/blu-ray-c-309.html' Thanks
  19. I forgot to mention. When i look in the server's error log, I get these errors: [sun Feb 19 01:00:30 2012] [error] [client 66.249.71.44] File does not exist: /var/www/html/ultimate-alien-pr-3092.html [sun Feb 19 01:00:31 2012] [error] [client 66.249.66.149] File does not exist: /var/www/html/business-finance-c-204_219.html [sun Feb 19 01:00:34 2012] [error] [client 66.249.71.44] File does not exist: /var/www/html/califone-ergoguys-m-18.html So instead of placing the site's domain in the url, it's placing the path to the file there. Thanks.
  20. Jack, I just moved my site to a new server. I uploaded the files to the new server using FTP. When I click on a product page or category, I get a 404 error. When I turn SEO urls off in admin, the pages load. Please help. Here's my configure.php: <?php define('HTTP_SERVER', 'http://www.discxpress.com'); define('HTTPS_SERVER', 'https://www.discxpress.com'); define('ENABLE_SSL', true); define('HTTP_COOKIE_DOMAIN', '/'); define('HTTPS_COOKIE_DOMAIN', '/'); define('HTTP_COOKIE_PATH', '/'); define('HTTPS_COOKIE_PATH', '/'); define('DIR_WS_HTTP_CATALOG', '/'); define('DIR_WS_HTTPS_CATALOG', '/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', '/var/www/html/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); Here's my .htaccess: # $Id$ # # This is used with Apache WebServers # # For this to work, you must include the parameter 'Options' to # the AllowOverride configuration # # Example: # # <Directory "/usr/local/apache/htdocs"> # AllowOverride Options # </Directory> # # 'All' with also work. (This configuration is in the # apache/conf/httpd.conf file) # The following makes adjustments to the SSL protocol for Internet # Explorer browsers #<IfModule mod_setenvif.c> # <IfDefine SSL> # SetEnvIf User-Agent ".*MSIE.*" \ # nokeepalive ssl-unclean-shutdown \ # downgrade-1.0 force-response-1.0 # </IfDefine> #</IfModule> # If Search Engine Friendly URLs do not work, try enabling the # following Apache configuration parameter # AcceptPathInfo On # Fix certain PHP values # (commented out by default to prevent errors occuring on certain # servers) # php_value session.use_trans_sid 0 # php_value register_globals 1 # Begin Ultimate SEO V2.2d Options +FollowSymLinks RewriteEngine On # RewriteBase instructions # Change RewriteBase dependent on how your shop is accessed as below. # http://www.mysite.com = RewriteBase / # http://www.mysite.com/catalog/ = RewriteBase /catalog/ # http://www.mysite.com/catalog/shop/ = RewriteBase /catalog/shop/ # Change the following line using the instructions above RewriteBase / RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-m-(.*).html$ index.php?manufacturers_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pi-(.*).html$ popup_image.php?pID=$2&%{QUERY_STRING} RewriteRule ^(.*)-by-(.*).html$ all-products.php?fl=$2&%{QUERY_STRING} RewriteRule ^(.*)-t-(.*).html$ articles.php?tPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-a-(.*).html$ article_info.php?articles_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-au-(.*).html$ articles.php?authors_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pr-(.*).html$ product_reviews.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-pri-(.*).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-f-(.*).html$ faqdesk_info.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-fc-(.*).html$ faqdesk_index.php?faqPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-fri-(.*).html$ faqdesk_reviews_info.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-fra-(.*).html$ faqdesk_reviews_article.php?faqdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-i-(.*).html$ information.php?info_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-pm-([0-9]+).html$ info_pages.php?pages_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-n-(.*).html$ newsdesk_info.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-nc-(.*).html$ newsdesk_index.php?newsPath=$2&%{QUERY_STRING} RewriteRule ^(.*)-nri-(.*).html$ newsdesk_reviews_info.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-nra-(.*).html$ newsdesk_reviews_article.php?newsdesk_id=$2&%{QUERY_STRING} RewriteRule ^(.*)-po-([0-9]+).html$ pollbooth.php?pollid=$2&%{QUERY_STRING} # End Ultimate SEO V2.2d My site is in the root directory. If the above files are correct, where should I check? Thanks
  21. discxpress

    Google XML Sitemap SEO

    Jack, Help me understand this. While I was trying resolve an issue with Google XML Sitemap SEO, my server's host had began migrating my server to a new company. Now my site won't load. They blamed it on a script being called twice and blocking two ports. Also, they say it's something to do with httpd. Here's what the tech said in a support ticket: Since this contrib and Configuration Cache was the last scripts I attempted to run (if it's a script), I decided to start here so I can began to see if they're trying to avoid blame. Thanks for reading.
  22. discxpress

    Header Tags SEO

    Jack, I'm experiencing a problem getting all my header tags filled. Remember, I'm the one with the huge shop with about 300k products. I ran a test and here's the results: Permissions Error: explain Permissions settings for the /var/www/html/includes/header_tags.php file appear to be incorrect. Change to 755. NOTE: Disregard if on Windows server. I'm on a linux server Duplicate title found: explain for English exists more than once. Duplicate meta description found: explain for English exists more than once. Missing Title and/or descriptions: explain Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 53315585 bytes) in /var/www/html/admin/header_tags_test.php on line 871 As for the last one, I have 740MB real memory (I'm using a little over half) and virtual memory I'm using 334MB out of 7.81GB. I have 268MB allocated in php.ini. Thanks again.
  23. discxpress

    Google XML Sitemap SEO

    Jack, Thanks for your reply. I checked the permissions of all sitemap files and they're set to 777, the same as the images folder. You mentioned my host. The last time my site was that size, I was kicked off because it was consuming too many resources. Now I'm on a dedicated server. When I was on a shared server, the sitemaps generated with no problem. So maybe it's how the server is setup. What can I check on my server that would cause this problem? Thanks for your time.
  24. discxpress

    Google XML Sitemap SEO

    Hi Jack, The latest version worked fine until I added a couple hundred thousand products :- . I guess my problem comes when the script has to generate multiple sitemapproducts.xml files. The below snippet is from the referenced file, sitemap.class.php: if (GOOGLE_XML_SITEMAP_SHOW_DIAGNOSTIC == 'true') echo 'Opening '.$filename. '<br>FS_CAT '.DIR_FS_CATALOG. '<br>Server ' . HTTP_SERVER . '<br>Save Path '. $this->savepath . '<br>WS_CAT '. DIR_WS_HTTP_CATALOG.' <br>'; if ($fp = fopen($filename, 'w+')){ echo 'Write '.$filename.'<br>'; fwrite($fp, $data); fclose($fp); $this->debug['SAVE_FILE_XML'][] = array('file' => $filename, 'status' => 'success', 'file_exists' => 'true'); return true; } else { $file_check = file_exists($filename) ? 'true' : 'false'; $this->debug['SAVE_FILE_XML'][] = array('file' => $filename, 'status' => 'failure', 'file_exists' => $file_check); return false; } break; Below is a sample of the output in the error log: PHP Warning: fopen(/var/www/html/sitemapproducts1.xml) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in /var/www/html/googlesitemap/sitemap.class.php on line 344 File does not exist: /var/www/html/sitemapindex.html PHP Warning: fopen(/var/www/html/sitemapproducts2.xml) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in /var/www/html/googlesitemap/sitemap.class.php on line 344 PHP Warning: fopen(/var/www/html/sitemapproducts3.xml) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in /var/www/html/googlesitemap/sitemap.class.php on line 344 PHP Warning: fopen(/var/www/html/sitemapproducts4.xml) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in /var/www/html/googlesitemap/sitemap.class.php on line 344 I've tried adjusting the resources in the php.ini file because I was getting 'exhaustion' errors but the above errors persist even on the alternate state. I searched this thread but don't really understand the solutions others had. Thanks for your help.
  25. discxpress

    OSC-Affiliate

    Hello, I've gotten this to fit in version 2.3.1! Here's what I did: 1. followed a tutorial by kymation http://forums.oscommerce.com/topic/368538-guide-to-converting-addons-from-22x-to-23x/ 2. recoded admin/includes/modules/boxes/affiliates.php 3. then correct the 'TABLE_AFFILIATE doesn't exist' database errors. Several files in admin produce that error. In those files change all instances of TABLE_AFFILIATE to: TABLE_AFFILIATE_AFFILIATE All that I believe that needs to be done is to recode the buttons and test functioning. Also, an operational manual needs to be written so shop owners can operate this. I think the right contributors can really debug this mod. Thanks for reading
×