Jump to content

Pixy

Members
  • Content count

    136
  • Joined

  • Last visited

Everything posted by Pixy

  1. Okay - I had a quick look through the forum has anyone found a solution yet to the register globals issue?
  2. Pixy

    [contribution] Total B2B

    I am going through all my files and I just can not seem to find the link between b2b files and the object_info.php. If anyone can shed some light on this it will be appreciated
  3. Pixy

    [contribution] Total B2B

    Hi I am getting this error: Warning: reset(): Passed variable is not an array or object in /usr/www/users/paperc/catalog/admin/includes/classes/object_info.php on line 17 Warning: Variable passed to each() is not an array or object in /usr/www/users/paperc/catalog/admin/includes/classes/object_info.php on line 18 osCommerce This error only appears when I follow the link that was sent to me via e-mail to look at the clients profile, I looked at all the B2B files that I uploaded and I can not see why this error appears I also compared my object_info.php with a clean one from OsC and it is excactly the same. any ideas?
  4. Pixy

    Contribution Issue

    Hi I had the sam error and once I got my register globals enabled by my services provider it went away.
  5. Pixy

    Contribution Issue

    I have gone through the install ! I can not see where the problem is
  6. Pixy

    Contribution Issue

    Okay I installed it and I made all the changes to all the files but I keep looking at this page and I have NO IDEA what to do? I think I am missing something here
  7. Has anyone been able to get EP working with register globals? I have tried everything I could think of but for the life of me it wont upload any files I can download the tab deliminated files but I can not upload anything. Please help me!
  8. Pixy

    Contribution Issue

    yes it works on product pages - I think it might be b/c I am on PHP5?
  9. Pixy

    Contribution Issue

    I downloaded the entire folder - what am I missing? With all the catalog files and I made the changes as per the install instructions
  10. Pixy

    Contribution Issue

    I am getting this error: Fatal error: Call to undefined function: tep_draw_fckeditor() in /usr/www/users/webassi/admin/extra_info_pages.php on line 508 Please help
  11. Mibble It is still not working still giving the same response!
  12. Brilliant I was so busy looking for a scritping error that I did not remember about the apostrophes - thanks
  13. // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'http://scrappingsa.co.za'); // eg, http://localhost - should not be empty for productive servers define('HTTP_CATALOG_SERVER', 'http://scrappingsa.co.za'); define('HTTPS_CATALOG_SERVER', ''); define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module define('DIR_FS_DOCUMENT_ROOT',$DOCUMENT_ROOT); // where the pages are located on the server define('DIR_WS_ADMIN', '/catalog/admin/'); // absolute path required define('DIR_FS_ADMIN', '/home/httpd/vhosts/scrappingsa.co.za/httpdocs/catalog/admin/'); // absolute pate required define('DIR_WS_CATALOG', '/catalog/'); // absolute path required define('DIR_FS_CATALOG', '/home/httpd/vhosts/scrappingsa.co.za/httpdocs/catalog/'); // absolute path required define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); // define our database connection My temp setting is 777 and it is in catalog/temp PHP - 4.3.11
  14. I fixed the problem with the register globals and now I can download the tab del file but when I upload it show this: File uploaded. Temporary filename: /tmp/phpXO7aAW User filename: EP2006Jan12-1604.txt Size: But there is NO products uploaded. Where must I look for the error?
  15. Pixy

    Register Globals Question

    Cathy I had the sam problem with Easy Populate I found this solution for the EP problem but I have NO idea what the QBI contribution does - I hope this might help or at least point you in the right directionEP
  16. Could it be that becuase I had to use this http://www.oscommerce.com/community/contri...egister_globals to disable register_globals? I installed EP on another site and it worked 100% the only diff between the two site are the register_globals.
  17. I read through it and I changed admin/includes/config file I changed the document_root as you suggested but it is still not working everything else on the site works 100% . Is there maybe something else I am missing?
  18. I uploaded EP created a temp directory and everything is looking fine but when I select "Download a complete Tab Deliminated File" NOTHING happens. Can you please help?
  19. Pixy

    [contribution] Total B2B

    Okay I made the recommened changes and I get this error: Warning: Missing argument 2 for tep_get_zone_name() in /usr/www/users/webassi/catalog/admin/includes/functions/general.php on line 283 Warning: Missing argument 3 for tep_get_zone_name() in /usr/www/users/webassi/catalog/admin/includes/functions/general.php on line 283 That is in my config And if I go to the online shop it gives me this: Fatal error: Cannot redeclare tep_parse_input_field_data() (previously declared in /usr/www/users/webassi/catalog/includes/functions/general.php:36) in /usr/www/users/webassi/catalog/includes/functions/html_output.php on line 15
  20. Pixy

    [contribution] Total B2B

    And tell us what all you have running from osCommerce: which osCommerce package, which contributions from where etc. I only have Os Commerce running I deleted everything and re-loaded the new one from here the 2.2 Milestone.
  21. Pixy

    [contribution] Total B2B

    Okay I replaced that and now I have this error: Warning: Missing argument 2 for tep_get_zone_name() in /usr/www/users/webassi/catalog/admin/includes/functions/general.php on line 270 Warning: Missing argument 3 for tep_get_zone_name() in /usr/www/users/webassi/catalog/admin/includes/functions/general.php on line 270 this is what is on line 270 - 278 function tep_get_zone_name($country_id, $zone_id, $default_zone) { $zone_query = tep_db_query("select zone_name from " . TABLE_ZONES . " where zone_country_id = '" . (int)$country_id . "' and zone_id = '" . (int)$zone_id . "'"); if (tep_db_num_rows($zone_query)) { $zone = tep_db_fetch_array($zone_query); return $zone['zone_name']; } else { return $default_zone; } }
  22. Pixy

    [contribution] Total B2B

    Okay I replaced that and now I have this error: Warning: Missing argument 2 for tep_get_zone_name() in /usr/www/users/webassi/catalog/admin/includes/functions/general.php on line 270 Warning: Missing argument 3 for tep_get_zone_name() in /usr/www/users/webassi/catalog/admin/includes/functions/general.php on line 270 this is what is on line 270 - 278 function tep_get_zone_name($country_id, $zone_id, $default_zone) { $zone_query = tep_db_query("select zone_name from " . TABLE_ZONES . " where zone_country_id = '" . (int)$country_id . "' and zone_id = '" . (int)$zone_id . "'"); if (tep_db_num_rows($zone_query)) { $zone = tep_db_fetch_array($zone_query); return $zone['zone_name']; } else { return $default_zone; } }
  23. Pixy

    [contribution] Total B2B

    Okay one more error: This is my config: Action Fatal error: Call to undefined function: tep_array_merge() in /usr/www/users/webassi/catalog/admin/configuration.php on line 93
  24. Pixy

    [contribution] Total B2B

    Great - I am still going ahead with this! Thanks for your help - but I will probably need more help soon :blush:
  25. Okay I am STILL STRUGGLING I am getting this error but the Table is there! 1146 - Table 'webassi_oscommerce.TABLE_CUSTOMERS_GROUPS' doesn't exist select customers_group_id, customers_group_name from TABLE_CUSTOMERS_GROUPS order by customers_group_id
×