tdiaz

Members
  • Content count

    18
  • Joined

  • Last visited

Community Reputation

1 Neutral

1 Follower

About tdiaz

Profile Information

  • Real Name
    Tony Diaz
  1. I've had multi-stores running for several years now, started in 2005. I am trying to figure out how to keep the products from one storesID from being checked out, or even added via the other. Whats happening is Google is parsing the results and putting them on the alternate domain, so while osC can't find the products using it's own searches, but customers are able to somehow hve the products in the cart and use the other store to check out. The issue is pricing, one store sells for less, requires a resale card and $100 min. the other does not have the min. order amount.
  2. during checkout, at checkout_shipping.php, if I have 5 shipping modules selected, I only see 4 options. I can remove any one of the others and the missing one will show up. I can't find any reference to amount of options to display anywhere in admin either. Any clues here? This is 2.2ms2, I believe. It was downloaded in 2006.
  3. I think we're in holding until someone else picks up an interest in this contribution, the last major contributor seems to have gone missing. I'm having issues where it's not totaling orders no matter what, if I remove the order_total.php it errors, so that means it's touching it, but it's not doing a thing with it. The onscreen totals never change, the database data never changes- it will add in things that you ad with hitting a plus sign entering a title and amount, but it will not reflect them in the total either. I looked at permissions, it's all set to 755 as everything else is. No dice.
  4. I'm still unable to get any recalculation on an order. I can edit all I want, add negative values. change quantity, prices, etc. The order totals section just never changes. Ever. I verified all the permissions on everything uploaded too, it's all 755- the issue seems to be the order_editor/order_totals.php is just not doing anything, well, mostly. If you add a misc. item in the totals section, it will end up in the order_totals table, but no calculation is done. ...so the emails go out with wrong info, the invoices print with wrong info. .. etc.
  5. To the poster earlier about adding/substracting by changing stock, you can add all you want to the line- but if you want to remove stock quantity from the line it seems you need to delete the item and add it again as it does not keep track of what the variable used to be. Or something like that. Where I have a problem is with the CVV2 value and the order total. The CVV2, I just added the needed items, but the order total in V5.0.5 is not working. Anything you do is reflected fine except in the actual order total at the bottom of the order. It never changes. You can add, subtract, put in negative numbers, etc. No matter. It does not update. ..and it emails them out wrong too. It's not just a screen refresh issue. Someone earlier said something similar about a totaling issue and said they had to click the update button. I'll presume thats not with the ajax version. But the result here seems to be the same. Perhaps it's in order_editor/order_total.php?
  6. I installed this Contribution into a pretty heavily modded (Contributed) installation without any real issues except those noted here. The tagging <br><br> that caught my eye when moving the text and I thought, "those shouldn't be there" anyway. The documentation is infact 'missing' thhe bit about what you may need to do to actually use the thing afterwards, like using File Access and adding the thing to the appropriate spot on the menu. But otherwise it works as advertised. PHP is not forgiving. You need to follow, step by step. Some of the ($error = false statements that you can't find may be because your installation has BTS installed and in that case you will actually need to look in the associated *content* file for your module, which is found in 'catalog/templates/xxx/content' and named similarly to the module name you were looking for. This does work, my install is a MS2.2 derivative. My advice, print out the installation file with a browser, not a text editor, place a comment next to each of your additions as you do them, // Extra Fields - Customers, at the beginning and end of your additions. In those parts of the code that are in between the </td><td> (table data) tags, you can include an inline comment in the <? php /* Extra Fields - Customer */ code here; ?> otherwise your // Extra Fields - Customers comment will show on your page output. If you are just to add to the file, add at the end, always before the ?> In a few cases you may need to make an adjustment , pay close attention to anything you are placing beyond, in some syntax, the last statement may end differently. If you are instructed to place code segments before/after/etc, those are 'as is', and generally don't require changes to be made to surrounding code, but be very explicit where you place it as 'depth' in the code matters and how many } and { are before and after your placement depend on it working or not. If you have other contributions installed in like areas of the code you *MAY* need to do some reading over things if you have an 'unexpected <, ', T branch, { or whatever' error in your php. Errors in PHP that are reported at say, line 75, may actually, and mostly are, the line before, if not several lines before. It's just that by the time it got to 75, it was 'all screwed up'. Anyhow, print the docs out, use a pen, mark off each section as you do it. Period. In most of the reading here, I can see peoples problems are that where they skipped an entire chunk. MAKE SURE YOUR SURROUNDING CODE is EXACT in function to what you see, an extra spaces here and there mostly don't matter. A semicolon is the END of a statement, a period is a break to a new part. Missing semicolons and periods ca cause major headaches. If in doubt, look at surrounding code. Use a color coding text editor, if your stuff is not the same color scheming as surrounding stuff, of the same nature, then you have improper syntax, spacing, etc, leading up to your added code. IE, all the <?php and ?> should be the same color, all the occurances of 'echo', should always be the same, etc.
  7. Where I'm having problems with "Unauthorized Payment" is in the admin/customers.php area - to be able to add/change the payment types. The customer edit screen is just wonked up. It appears that I can still check out, as no payment types are restricted from any customers.
  8. I have tried to work with the "Unauthorized Payment" contribution and it's not quite working. Says something about if you have Load 5, do this instead of that- and I can't even tell what Load 5 is, appears to be something from MS1 and not available anywhere anymore. But none the less, I need to be able to restrict payment types by customers. IE, I do not want to offer Net 30, COD, etc to just everyone. Any ideas?
  9. I am also getting a blank page at the checkout_shipping.php point; the Amazon cURL 'test' works for me. I have uncommented the upsxml.log file, created a blank, chmod 777'ed it, changed the path additionally so that there is no confusion. My empty file stays exactly that way, empty. (It has one word in it that I put there) I tried to enable display errors- that is, I edited php.ini, the one that using the <php info ?> command would generate ... turns out- I forgot to apachectl restart .. Low and behold, xmldoument.php was not in it's proper place, I have a wack-ass multi store setup thats largely different than any other install. Symbolic-link-central. Anyhow- in closing; The answer is in the forum, other than that, the hardest thing was getting the access key from UPS because the link to get it is not obvious. The deal there is; Sign up for UPS Online Tools, pick XML rate information, and agree to several different licenses along the way, three form submittals later, a developer key will show up in your email. Do it one more time to get the access key. ..... The question here is now, test or production server. If i'm using a UPS World Ship terminal, do I care if I leave it on Test since i'm not doing any manifesting with it anyway?