Jump to content

linuxdave

Members
  • Content count

    45
  • Joined

  • Last visited

1 Follower

About linuxdave

  • Birthday 03/27/1979

Profile Information

  1. linuxdave

    PayPal WPP Direct Payments & Express Checkout Support

    Does someone happen to have a live site that I could look at with this installed?
  2. linuxdave

    Wishlist 3.0 Support Thread

    This change: </form> </table> <?php /******************************************************************* *********** CODE TO SPECIFY HOW MANY EMAILS TO DISPLAY ************* *******************************************************************/ is not applicable. My mistake.
  3. linuxdave

    Wishlist 3.0 Support Thread

    Nice rewrite. The wishlist.php was breaking my layout, and by putting the <form> tags inside of the <table> tags, I fixed this. I also added a missing </td> and updated the install.txt file and posted it as a full package. Changes: In wishlist.php: <!-- body_text //--> <td width="100%" valign="top"> <?php echo tep_draw_form('wishlist_form', tep_href_link(FILENAME_WISHLIST)); ?><table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr> <td> [CODE] changes to [CODE] <!-- body_text //--> <table border="0" width="100%" cellspacing="0" cellpadding="0"> <?php echo tep_draw_form('wishlist_form', tep_href_link(FILENAME_WISHLIST)); <tr> <td> ?> This: </table></form> <?php /******************************************************************* *********** CODE TO SPECIFY HOW MANY EMAILS TO DISPLAY ************* *******************************************************************/ changed to this: </form> </table> <?php /******************************************************************* *********** CODE TO SPECIFY HOW MANY EMAILS TO DISPLAY ************* *******************************************************************/ and I added an extra </td> ABOVE these lines: <td valign="top" class="productListing-data"><?php echo $products_price; ?></td> <td valign="top" class="productListing-data" align="center"><?php echo tep_draw_checkbox_field('add_wishprod[]',$wishlist['products_id']); ?></td> so it looked like this: </td> <td valign="top" class="productListing-data"><?php echo $products_price; ?></td> <td valign="top" class="productListing-data" align="center"><?php echo tep_draw_checkbox_field('add_wishprod[]',$wishlist['products_id']); ?></td> Your mileage may vary.
  4. linuxdave

    [contribution] Simple Template System (sts)

    I am having this exact problem. Was there a fix for this? I read almost every one of these 125 pages, and didn't see it. Thanks for the contrib, btw. I look forward to trying out v3
  5. linuxdave

    [Contribution] Admin Specials by Category

    Just wanted to say thanks for this. It was just what I was looking for and everything worked perfectly.
  6. linuxdave

    Problems with editing existing product

    Sounds like you forgot some steps installing: make sure all your defines are right. From the install file: Hope this helps.
  7. linuxdave

    Attribute Sets Contribution

    Sorry... there was an extra line break in there messing things up... this line: $products_attributes_sets_query_sql = "select products_attributes_sets_id from ".TABLE_PRODUCTS_ATTRIBUTES_SETS_TO_PRODUCTS." where products_ id =".$products_ids['products_id']; should actually be this: $products_attributes_sets_query_sql = "select products_attributes_sets_id from ".TABLE_PRODUCTS_ATTRIBUTES_SETS_TO_PRODUCTS." where products_id =".$products_ids['products_id']; See the problem? with the space in products_id? Hope this helps.
  8. linuxdave

    osC_Categories MS2-2.2

    I found that disabling gZip compression may fix this. Try it out. And just out of curiosity, did you have STS Template installed?
  9. linuxdave

    Attribute Sets Contribution

    This is a serious bug, and it cost me a lot of time. I used the most recent version 5.5, and lost a lot of attributes because of this. The problem was that the code triggered upon editing the AS was not taking into account additinoal Attribute Sets installed on the products. Here is the quick fix, as requested. I am going to update the package once I make a few more changes to this contribution. In catalog/admin/products_attributes_sets.php, around line 231, find this: jjg_db_attributeSets( $arr_ProductsAttributeSetsIDs, $products_ids['products_id'], "update_product" ); and CHANGE it to this: $arr_NewProductsAttributeSetsIDs = array(); $products_attributes_sets_query_sql = "select products_attributes_sets_id from ".TABLE_PRODUCTS_ATTRIBUTES_SETS_TO_PRODUCTS." where products_ id =".$products_ids['products_id']; $products_attributes_sets_query = tep_db_query($products_attributes_sets_query_sql); $newcount = 0; while($fixed_products_attributes = tep_db_fetch_array($products_attributes_sets_query)) { $arr_NewProductsAttributeSetsIDs[$newcount] = $fixed_products_attributes['products_attributes_sets_id']; $newcount++; } jjg_db_attributeSets( $arr_NewProductsAttributeSetsIDs, $products_ids['products_id'], "update_product" ); If there are lingering problems after this, let me know. I'll see what I can do before repackaging. Feel free to aim me if you are still having problems and I'll try to help. LinuxDave
×