Jump to content

mmph

Members
  • Content count

    139
  • Joined

  • Last visited

Everything posted by mmph

  1. The issues are probably in my installation or database. In this USPS module package, there are some "files to modify" in two directories called 2.3.4 and 2.3.x.x. What are these directories referencing? The first of them appears to have a catalog side file and the other has an admin side file, this doesn't make sense to me. Is 2.3.4 an oscommerce release number and if so, what is 2.3.x.x? Also, everything in the "New_Files" directory of this downloaded package appears to be catalog side files, I make that assumption because the they are not packed in an "admin" directory and the instructions don't say otherwise. Are these meant for the catalog side? Also, why does the module have a readme.txt and an upgrade.txt which appear fairly similar yet have enough differences to confuse the heck out a person?
  2. All suggestions are appreciated, thanks Jim. Is the link you provided the same as USPS Rate V4 Intl Rate V2_r3.6? I am using this V2_r3.6.
  3. Hi Jim, I'm aware that other oscmax active developers are using this module, they've said the shipping module is 1-1 drop in with oscommerce. Is there a full and current list of the current USPS services? Looking at this module, it appears the list is: $services_list = " \'First-Class MailRM Stamped Letter\', \'First-Class MailRM Large Envelope\', \'First-Class Package Service - RetailTM', \'Media Mail Parcel\', \'Library Mail Parcel\', \'USPS Retail GroundTM\', \'Priority MailTM\', \'Priority MailTM Flat Rate Envelope\', \'Priority MailTM Legal Flat Rate Envelope\', \'Priority MailTM Padded Flat Rate Envelope\', \'Priority MailTM Small Flat Rate Box\', \'Priority MailTM Medium Flat Rate Box\', \'Priority MailTM Large Flat Rate Box\', \'Priority MailTM Regional Rate Box A\', \'Priority MailTM Regional Rate Box B\', \'Priority Mail ExpressTM\', \'Priority Mail ExpressTM Flat Rate Envelope\', \'Priority Mail ExpressTM Legal Flat Rate Envelope\', \'First-Class MailRM International Letter\', \'First-Class MailRM International Large Envelope\', \'First-Class Package International ServiceTM\', \'Priority Mail InternationalRM\', \'Priority Mail InternationalRM Flat Rate Envelope\', \'Priority Mail InternationalRM Small Flat Rate Box\', \'Priority Mail InternationalRM Medium Flat Rate Box\', \'Priority Mail InternationalRM Large Flat Rate Box\', \'Priority Mail Express InternationalTM\', \'Priority Mail Express InternationalTM Flat Rate Envelope\', \'USPS GXGTM Envelopes\', \'Global Express GuaranteedRM (GXG)\' "; Does this list look current? I've included the update at line 522 for First-Class Package Service - RetailTM
  4. Hi Folks, After some several attacks, my heavily modified oscommerce site was getting too much for me to maintain, I started over on oscmax which seems to be pretty darn close to oscommerce. I'm having some issues with USPS module which I believe are addressed in this thread. I have the latest installation of oscmax (2.5.4) and it appears my USPS is functional although I'm seeing "------" in place of the USPS service names. I uninstalled my USPS module and added this USPS Rate V4 module but I am not seeing any changes, all USPS services on admin and catalog side are still showing as "------" and do not post the weight. For example I have first class and priority mail enabled and I see this: I went back in to usps.php and updated line 522 for "First-Class Package Service - RetailTM", and did an uninstall/reinstall of the module but still no changes. Any suggestions on this? Thanks!
  5. mmph

    Contribution Tracker

    Hi Glen, When I open an existing contribution entry to edit it, the edit view opens with a blank comments field. If I save the edit with the blank field, the comment is erased. For now, I must copy my comment text before performing an edit and then paste it in to the blank comment field before saving my edit.
  6. mmph

    Contribution Tracker

    I just checked and found that my v1.7.13 is also giving this error when manual entry is attempted.
  7. Thanks Tristen, I am pretty well experienced with installing contributions and follow a very similar technique as you mention. I have winmerge and PHP designer for code edits which is very helpful. I am mostly looking for an over-all response to find out if this v1.1c is functional with respect to the suggested links. If it is, then if anyone well versed with this add-in may have a suggestion as to what part of the code may be the cause for the suggested links not showing on my install. I went through the full install twice and searched the forum before posting; it seems that the add-in is working for me with the exception of the plural "s" filter and not showing suggested alternate searches.
  8. mmph

    Contribution Tracker

    Once again, very useful add-in...thanks. I am updated to v1.7.13 and seem to be experiencing the following "non-documented features" *Cannot edit the date added to store *Comments are deleted when editing and entry
  9. I just installed V1.1c and it seems to have these same issues still. 1) Plural strips the whole word. When I add "s" to the end of any valid term in my shop the search results return an error stating the the fields were blank. 2) No Search suggestions. I've entered replacement search terms in the admin but they have no effect. Is this an installation problem on my end; in other words are any of you using this having success with returned search suggested words based on your admin entries?
  10. mmph

    Contribution Tracker

    Hi Lildog, Great work on this contribution. I am finding several things that I don't understand or don't seem to be working. I'm short on time right this moment but I'll make a list and post it soon; maybe you will be able to help work these things out. Thanks again. -Mark
  11. mmph

    Contribution Tracker

    Okay, I think those function files in 1.7.6 are complete now although they are swapped with each other. The larger file belongs in admin. The ...catalog/includes/functions/contrib_tracker.php and the catalog/admin/includes/functions/contrib_tracker.php files need to be swapped with each other. Can you also check the .sql file, I'm pretty sure it still has some errors in it. I had to change the semi colon for a comma where is says contrib_support VARCHAR( 55 ) NULL ; and I also added the table column for date_status_change because there are values for this column in the INSERT line at the bottom of the sql file; if this column is not needed and should be dropped, then the INSERT values need to be deleted as well. Here is the working SQL file I used with these changes: DROP TABLE IF EXISTS contrib_tracker; DROP TABLE IF EXISTS `date_status_change`; CREATE TABLE contrib_tracker ( contr_id int(11) NOT NULL auto_increment, contrib_osc_id int( 6 ) NOT NULL, contrib_name varchar(255) NOT NULL default '', contrib_link varchar(255) default '', config_comments longtext, status tinyint(1) NOT NULL default '2', date_status_change datetime NOT NULL default '0000-00-00 00:00:00', note_created datetime NOT NULL default '0000-00-00 00:00:00', contr_last_modified datetime NOT NULL default '0000-00-00 00:00:00', last_update datetime NOT NULL default '0000-00-00 00:00:00', contrib_vers varchar(7) default '', contrib_support VARCHAR( 55 ) NULL , KEY config_id (contr_id)) TYPE=MyISAM; INSERT INTO contrib_tracker (contr_id, contrib_osc_id, contrib_name,contrib_link, config_comments, status, date_status_change, note_created, contr_last_modified, last_update,contrib_vers) VALUES ('','4815','Contribution Tracker Now Installed','http://addons.oscommerce.com/info/4815', 'Congratulations! Contribution Tracker now installed! You may now delete this Contribution or use it to play around with and get the feel of your new osC contribution.', 1, '0000-00-00 00:00:00', '2005-04-15 12:55:45', '2005-04-15 12:55:45', '2005-04-15','1.6.6e'); INSERT INTO configuration (configuration_id, configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, last_modified, date_added) values ('', 'Last Contrib Check', 'LAST_CONFIG_CHECK', '', 'Last time checked the OSCommerce official contribution site. ', '0', '50', '2006-03-19 10:57:09', now()); Did or can you roll the changes of 1.7.5 in to this latest version as well? It would also be nice to clarify how to make the configuration ID changes to the ...catalog/admin/contrib_tracker.php file as well. maybe change the instructions and .php file to say something like: Thanks for this contribution, I think it is great! P.S. Let me know if you want a break and I can can roll these changes up and post them as 1.7.7
  12. mmph

    Contribution Tracker

    Any other ideas? I just double checked and I have all the files in thier respective directories and the …/admin/contrib_tracker.php is stock and does call the functions with require(DIR_WS_FUNCTIONS . 'contrib_tracker.php'); although I don’t see any reference to these two functions in the functions files: contrib_check() or old_to_new_url(). Shouldn't I see code for these in the functions file? Here is what I have in admin/includes/functions/contrib_tracker.php <?php /* $Id: contrib_tracker.php,v .9 2007/01/08 11:25:32 lildog Exp $ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003 osCommerce Released under the GNU General Public License _________________________________________________________________ Contribution Tracker Functions for osC Admin By Admin of www.silvermoon-jewelry.com Based on: Admin_notes: Original Code By: Robert Hellemans of www.RuddlesMills.com RSS News for OSC These are LIVE SHOPS - So please, no TEST accounts etc... We will report you to your ISP if you abuse our websites! */ function vWritePageToFile($sHTMLpage, $sTxtfile ) { $sh=curl_init($sHTMLpage); $hFile=FOpen($sTxtfile, 'w'); curl_setopt($sh, CURLOPT_FILE, $hFile); curl_setopt($sh, CURLOPT_HEADER, 0); curl_exec($sh); $aCURLinfo = curl_getInfo($sh); curl_close($sh); FClose($hFile); } function tep_set_contrib_query_status($contr_id, $status,$contr_last_modified) { // IF THERE IS NO LAST MODIFIED DATE USE NOW ELSE USE THE $contr_last_modified (LAST TIME THE CONTRIB APPEARED IN THE RSS FEED) if ($contr_last_modified == NULL){ $last_update_date= strftime($format,time()); }else{ $last_update_date= $contr_last_modified; } if ($status == '0') { return tep_db_query("update " . TABLE_CONTRIB_TRACKER . " set status = '0', date_status_change = NULL where contr_id = '" . $contr_id . "'"); } elseif ($status == '1') { return tep_db_query("update " . TABLE_CONTRIB_TRACKER . " set status = '1', date_status_change = now(), last_update='" .$contr_last_modified. "' where contr_id = '" . $contr_id . "'"); } elseif ($status == '2') { return tep_db_query("update " . TABLE_CONTRIB_TRACKER . " set status = '3', date_status_change = now(), last_update='" .$contr_last_modified. "' where contr_id = '" . $contr_id . "'"); } else { return -1; } } ?>
  13. mmph

    Contribution Tracker

    I have freshly installed 1.7.4 (no previous versions installed), I still had to modify the sql as the last modified date seemed to be dropped from the table but the values were still trying to inject. After working that out, I cannot edit or check for updates. I've double checked that I did all the install steps but I get this error when trying to check for updates: And when I try to save an edit, I get this error: Any ideas why? I did install the .../function/conrib_tracker.php files. I also don't clearly understand the instructions for editing the file for the config_ID. I do know what my value is from the database but I can't understand exactly how it should be entered in the .php file. Can someone post an example of there actual code from their working file based on these install instructions: Is it supposed to look like this: tep_db_query("update " . TABLE_CONFIGURATION . " set configuration_value = '" . $HTTP_POST_VARS['lastcheck'] . "', last_modified = now() where configuration_id = 3889"); with 3889 being the actaul config table value in my database? Also, what did you change in 1.7.5? It would be nice to know which file(s) were changed for an easier update. thanks, Mark
  14. mmph

    Official PayPal IPN Support Thread

    To all those who are having troubles and wondering why this IPN module exists, it does work. I have many other contributions installed and this v2.3.3 is working flawless on my godaddy hosted account. I had a very difficult time getting it to work correctly and I actually gave up at the point where everything worked except for IPN post back so I didn't get customer emails or stock updates. Then magically a month or two later without making any changes, it all started working. It must have been something on Godaddy's or PayPal's set up, I don't know. All I can say is that it has been working very well for me for a while now.
  15. mmph

    Official PayPal IPN Support Thread

    Ok, the first line in your who's online report of "Guest..." is PayPal attempting to post back information to your ipn file; so at least you know it's getting that far. I believe it's the ipn.php file its self that is supposed to be 644, all of it's parent directories up to the ext folder should be 755; that's how I have mine set and it is working correctly. The email should have data in it pertaining to th order if the ipn were working correctly.
  16. mmph

    Official PayPal IPN Support Thread

    Do you have your IPN folder permissions set correctly as described in the setup instructions and can you see the post-back from paypal hitting your ipn.php file in your who's online page?
  17. mmph

    Official PayPal IPN Support Thread

    I think some people successfully have it in the ext/payment/paypal_ipn folder while others have it in the root. You will need payment zone configured such as USA, Canada, International... then fill in all your settings in the PayPal IPN from Admin-->Modules-->Payment and then try it out. I set up a cheap test item in my shop and test live, this requires two real paypal accounts or one account and your credit card but you can even refund the transaction once done if you want. If you haven't set up a paypal sandbox account for testing yet it can be helpful for extended testing but I honestly found it to be kind of non-intuitive; there are threads around here on paypal sandbox setups as well. For starters, you need two test profiles in your sandbox account; one for the simulated buyer and one for the simulated seller. Another thing, and sorry but I don't have the exact file and location handy but it is posted somewhere back in this thread; the version I am using was hard coded to force PayPal to check the address against the address entered in your store, if the customer changed a single character you would get an error related to address at checkout, I just commented that line out and haven't had any problems since. If you run in to that address problem and can't find the fix back in this thread send me a PM and I'll dig it up.
  18. mmph

    Official PayPal IPN Support Thread

    For starters you need to put the renamed file "php.ini" in your root. Some folks have reported putting this fill deeper in the paypal_ipn folder, you will find a post not to far back in this thread where someone commented on putting it there.
  19. mmph

    Official PayPal IPN Support Thread

    Keith, My guess is that you missed a step in the installation. I would recommend that you un-install this module from your admin panel, revert to your back up filesdeleting this module completely and then start over carefully following the instructions. I typically print out the instructions, highlight the begining of each step and then check them off as I complete them to ensure I don't miss any and sometimes I still end up messing something up and have to revert to my back up files. -Markcm
  20. mmph

    Official PayPal IPN Support Thread

    FUNCTIONALITY UPDATE: Hi folks, I’ve noticed several people asking if this module has the capacity to work at all. This is a general comment of my current standing and operational condition of IPN 2.3 with is currently working without issue (although I have had many issues with it) I am hosted on Godaddy which has caused a lot of problems with order updating, stock level adjustment and lack of customer emails. I could always see the PayPal IPN hitting my ipn.php file right after an order was placed but it would only complete the update some of the time. I moved to godaddy and installed this update about the same time several months back. I battled the heck out of it and read nearly every single post on the internet related to Godaddy, Curl and PayPal IPN yet still only got about 20% success rate of the IPN return function working. Check out worked ok and I got all my order details recorded in my database but I had to manually reduce stock levels and send emails to my customers. I did have to make an edit to one of the files to over ride the address verification because it was causing nearly 100% rejections. I don’t have the exact file on hand right now but you can find it in this thread if you search. I have been using this IPN and manually updating stock and emailing customers for most orders until about 2 weeks ago, I did not make any changes to my files yet I began receiving 100% success with the IPN working. I have no idea if Godaddy, Paypal or both made changes or if it will continue to work but at this time all my orders are processing correctly. My posting here doesn’t offer any technical advise, it just lets you know that this module is capable of functioning (with Godaddy, none the less). I also have a heavily modified site with 15-20 or more other add-ins. Cheers, Markcm
  21. mmph

    Official PayPal IPN Support Thread

    If you search the contributions, I am pretty sure I have seen one specifically for this.
  22. mmph

    Official PayPal IPN Support Thread

    I can only say that I too am having the IPN trouble. I have not received any post-back information from PayPal in the past week although I can see PayPal's postback hitting my IPN.php file when I watch "who's online" so I would assume my problems are compatibility of my godaddy hosting account and the IPN.
  23. mmph

    PayPal

    More information on the problem you are having would be useful, but maybe this will get you started: Based on the info you did provide, it sounds like you might have the credit card payment module enabled; check your payment modules to see if it is enabled. The credit card module and the PayPal module are completely separate and different. If you have the credit card module enabled, it will simply collect the credit card information and then you must manually process the order some how, such as a virtual terminal with your merchant account. The order will not go through without you processing the credit card number provided. If you have the paypal module enabled, the customer will be passed to the paypal site along with their order details where they make payment with either funds from their paypal account or by using a credit card. At this point, the payment is in your PayPal account.
  24. mmph

    Official PayPal IPN Support Thread

    I'm not sure why you don't get the invoice number in your email from paypal; you might need to re-install the IPN. Make sure you read the instructions fully, there is a lot of information in them. You also need to un-install and re-install the module from your admin panel if you update the files on your server. Here is an example email I received from PayPal today for an order where you can see the invoice number posted, none of my IPN post backs have been making it through my Godaddy proxy recently so I have to manually process them all as described in my post before.
  25. mmph

    Order viewing problem

    ALL PRODUCT ID LINKS LEADING ME TO HOME PAGE After installing this, I found that the new link this provides on the orders page would always open my index (home) page rather than the specific product. I have an older version from February 2007 of Chemo’s SEO URL’s installed which might be the cause but I’m not sure. I made a very small change to this contribution which fixed it for me; now when I click the model number from the admin orders page, the product is opened in a new window. If you have installed this ADD-IN module and all the new product links from your orders.php page lead you to your home page (…/index.php) try this small edit to the admin/orders.php add-in around line 245: = = = = = = = = = = ORIGINAL ADD-IN CODE, around line 245 in …admin/orders.php = = = = = = = = = = <a href="'.HTTP_CATALOG_SERVER.DIR_WS_CATALOG.'product_info.php?products_id='.$order->products[$i]['id'] .'"target="_blank">'. $order->products[$i]['model'] . '</td>' . "\n" . = = = = = = = = = = MY ADJUSTED ADD-IN CODE = = = = = = = = = = <a href="'.HTTP_CATALOG_SERVER.DIR_WS_CATALOG.'-p-'.$order->products[$i]['id'] .'.html'.'"target="_blank">'. $order->products[$i]['model'] . '</td>' . "\n" . This works for me and has the “open in new window” function included.
×