Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

cardsup

Members
  • Content count

    43
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Vlad
  1. I am not sure how to use the ecommerce=X option. I have two rss links on the page. http://www.somesite.com/folder/rss.php?lan...e=&cPath=21 http://www.somesite.com/folder/rss.php?language=en Both return the same error message. I tired calling manually a link http://www.somesite.com/folder/rss.php?eco...e=&cPath=21 but it got the error too.
  2. THANKS! That worked. However, now I get this error: XML Parsing Error: xml declaration not at start of external entity Location: http://www.site.com/rss.php?language=&cPath=21 Line Number 2, Column 1:<?xml version="1.0" encoding="UTF-8" ?> ^ How can I fix it?
  3. Another thing... just tried to see if I can add the feed to feedburner.com. I got this error: The URL you entered does not appear to be a valid feed. We encountered the following problem: Error on line 2: The processing instruction target matching "[xX][mM][lL]" is not allowed. Sorry This feed does not validate. * line 2, column 0: XML parsing error: <unknown>:2:0: xml declaration not at start of external entity [help] <?xml version="1.0" encoding="UTF-8" ?>
  4. Thanks... but that does not work for me, since I do not have STS...
  5. No.. I do not have a template system like STS installed. It probably has something to do with the .htaccess, but I can not figure it out....
  6. Great contribution! Thanks! I installed it and it seems to b working, but whenever I click on the rss.php link, the pages is not displayed but a message pops up and tries to save it on the computer. Does anybody know why is that? How can I fix it?
  7. I am using to generate thumbnails on the fly. Is there a way to add dynamic keywords to the image alt description? For example, if someone searches for "Black shoes", the alt will have "Black shoes" in addition to the normal ' . htmlspecialchars(StripSlashes($alt)) . alt text? // Generate thumbnail on the fly $image = '<img src="product_thumb.php?img='.$src.'&w='.intval($width).'&h='.intval($height).'" border="0" alt=" ' . htmlspecialchars(StripSlashes($alt)) . ' "'; } else { $rx = $image_size[0] / $width; $ry = $image_size[1] / $height; if ($rx < $ry) { $width = $height / $ratio; } else { $height = $width * $ratio; } } } } if ( ($width) && ($height) ) { $image .= ' width="' . intval($width) . '" height="' . intval($height) . '"'; } if ($params != '') { $image .= ' ' . $params; }
  8. I installed the Article Manager and it works great...but I have a question: How can I make it use Clean URLs? I am using Seach Engine Friendly URL, not the Ultimate SEO mod.
  9. cardsup

    Article Manager v1.0

    I just installed the Article Manager and it works great...but I have a question: How can I make it use Clean URLs? I am using Seach Engine Friendly URL, not the Ultimate SEO mod.
  10. cardsup

    Seach Engine Friendly URL Support

    Thanks for the great contribution! I have installed it and it works great! I have a question - how can I achieve a short URL for a search? Right now when a search with keyword "bird" is made, the URL is: I need it to be: Can you please help me?
  11. cardsup

    Authorize.net problem

    We are using Authorize.net as a processor on our web site Most times there are no problems, however recently we got many complains from customers who can not place an order. The way the site is set up, on checkout the client goes to your site: https://secure.authorize.net/gateway/transact.dll where the problem seems to be occurring. Here is a description of the problem one of our clients gave us: "This is what happens when I try: - I have my shopping cart, and I click on "Checkout" - This brings me to "Payment Information" - I click on "Select Authorize.net" and then "Continue" - This brings me to "Order Confirmation" where I click "Confirm Order" - The next page appears to be the authorize.net page, where I enter all of the credit card information: https://secure.authorize.net/gateway/transact.dll - I click on "Submit Transaction" Yesterday I believe after I did this, I got some sort of confirmation page. Today, after I click "Submit Transaction" I am brought back to the "Payment Information" page where it prompts me to begin all over again. This new order is also not in my order history, so I'm assuming it did not go through." What could be causing the problem is and how it can be fixed?
  12. Any ideas how it can be fixed?
  13. I installed the script and everything looked ok, however I keep getting these error messages from the cron: Failed loading /usr/local/ioncube/ioncube_loader_lin_5.0.so: /usr/local/ioncube/ioncube_loader_lin_5.0.so: undefined symbol: zend_std_get_static_property PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php4/php_gd.dll' - /usr/lib/php4/php_gd.dll: cannot open shared object file: No such file or directory in Unknown on line 0 I talked to my tech guy and he said the ioncube is in place, but can not be loaded with a scrip, written in PHP5. Is this right? Is there a way to fix that?
  14. cardsup

    Adding Cafepress link to products

    OK, got it...it is defined in: <?php } else { $product_info_query = tep_db_query("select p.products_id, pd.products_name, pd.products_description, p.products_model, p.products_quantity, p.products_image, pd.products_url, p.products_price, p.products_tax_class_id, p.products_date_added, p.products_date_available, p.products_cafepress, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd where p.products_status = '1' and p.products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and pd.products_id = p.products_id and pd.language_id = '" . (int)$languages_id . "'"); Everything is fixed. :rolleyes:
  15. cardsup

    Adding Cafepress link to products

    Are the 'products' columns defined somewhere in the php code? I am creating the database, but 'products_cafepress' value does not work. If I add the value to any of the other existing columns, it works... DROP TABLE IF EXISTS products; CREATE TABLE `products` ( `products_id` int(11) NOT NULL auto_increment, `products_quantity` int(4) NOT NULL default '0', `products_model` varchar(12) default NULL, `products_image` varchar(64) default NULL, `products_price` decimal(15,4) NOT NULL default '0.0000', `products_date_added` datetime NOT NULL default '0000-00-00 00:00:00', `products_last_modified` datetime default NULL, `products_date_available` datetime default NULL, `products_weight` decimal(5,2) NOT NULL default '0.00', `products_status` tinyint(1) NOT NULL default '0', `products_tax_class_id` int(11) NOT NULL default '0', `manufacturers_id` int(11) default NULL, `products_cafepress` int(11) default NULL, `products_ordered` int(11) NOT NULL default '0', PRIMARY KEY (`products_id`), KEY `idx_products_date_added` (`products_date_added`) ) TYPE=MyISAM AUTO_INCREMENT=69 ; -- -- Dumping data for table `products` -- INSERT INTO `products` VALUES (1, 999999, 'Design', '1.jpg', 15, '2005-02-20 10:19:19', '2005-02-20 13:07:13', NULL, 0, 1, 0, 1, 694446, 0);
×