Jump to content
Latest News: (loading..)


  • Content count

  • Joined

  • Last visited

  • Days Won


Irin last won the day on October 14 2010

Irin had the most liked content!


Profile Information

  • Real Name
  • Gender
  • Location
  • Website
  1. FedEx - Web Services v9

    I changed the rate to List, and the error is gone. I'm getting the fedex rates now. So, the problem is somewhere in the code for the account rates: else // For ACCOUNT Discounted Rates, calculate the cost as below { $cost = ($rateReply->RatedShipmentDetails[0]->ShipmentRateDetail->TotalNetCharge->Amount)/MODULE_SHIPPING_FEDEX_WEB_SERVICES_CURRENCY; $cost = (float)round(preg_replace('/[^0-9.]/', '', $cost), 2); } // For ACCOUNT Discounted Rates, END $transitTime = ''; // 9.4.6 if (in_array($rateReply->ServiceType, array('GROUND_HOME_DELIVERY', 'FEDEX_GROUND', 'INTERNATIONAL_GROUND'))) { $transitTime = ' (' . str_replace(array('_', 'one', 'two', 'three', 'four', 'five', 'six', 'seven', 'eight', 'nine', 'ten', 'eleven', 'twelve', 'thirteen', 'fourteeen'), array(' ', 1,2,3,4,5,6,7,8,9,10,11,12,13,14), strtolower($rateReply->TransitTime)) . ')'; } if (isset($rateReply->DeliveryTimestamp)) { // $transitTime = ' (Estimated Delivery on: ' . date('l, F jS Y \a\t g:ia', strtotime($rateReply->DeliveryTimestamp)) . ') '; $transitTime = ' (Estimated Delivery Date: ' . date('l, F jS Y', strtotime($rateReply->DeliveryTimestamp)) . ') '; } $methods[] = array('id' => str_replace('_', '', $rateReply->ServiceType), 'title' => ucwords(strtolower(str_replace('_', ' ', $rateReply->ServiceType))) . $transitTime, 'cost' => $cost + (strpos($this->types[$rateReply->ServiceType]['handling_fee'], '%') ? ($cost * (float)$this->types[$rateReply->ServiceType]['handling_fee']/100) : (float)$this->types[$rateReply->ServiceType]['handling_fee'])); // } } }
  2. FedEx - Web Services v9

    I did google a lot about this error, but unfortunately, I couldn't find a solution. That's why I decided to post here in hopes that maybe someone else, smarter than me in php, could help me.
  3. FedEx - Web Services v9

    The two tests returned the following:
  4. FedEx - Web Services v9

    This always worked fine for me until recently. The problem is with that line that I referenced above. I'm working on the production server.
  5. FedEx - Web Services v9

    With this change, the error is gone but so are the FedEx rates. It's not showing any rates at all.
  6. FedEx - Web Services v9

    I'm getting this error when click on checkout button: Line 318 in fedexwebservices.php: $cost = ($rateReply->RatedShipmentDetails[0]->ShipmentRateDetail->TotalNetCharge->Amount)/MODULE_SHIPPING_FEDEX_WEB_SERVICES_CURRENCY;
  7. After upgrade to php7, I'm getting the following error in admin/categories.php: Line 178 in admin/includes/kiss_error_handler.php: self::$registry['errors'][$errno][] = array( 'type' => self::$error_types[$errno], 'string' => $errstr, 'file' => $errfile, 'line' => $errline ); Any idea how to fix that?
  8. Who's Online Enhancement 1.4

    If I change mysql to mysqli, the error is gone.
  9. If I change mysql to mysqli, the error is gone.
  10. I had to change class constructor to function __construct in almost every file in the below directories, and most of my deprecated errors are gone. Admin Side classes functions modules Shop Side classes functions modules/action_recorder modules/boxes modules/content modules/header_tags modules/navbar_modules modules/order_total modules/payment modules/shipping modules/social_bookmarks However, I still see a few errors left. Here are some of them:
  11. The reason I'm not updating to BS version is that I have a lot of add-ons installed, and the BS doesn't offer step-by-step update instructions. I didn't really find any good posts that offer update instructions.
  12. After enabling error_reporting, it's showing me whole bunch of deprecated errors:
  13. Who's Online Enhancement 1.4

    I enabled error reporting, and here is what I got:
  14. Hello, I'm having incompatibility issues with my osCommerce v2.3.4 and PHP v7.0. Many add-ons just stopped displaying after my hosting provider upgraded me to the latest PHP v7.0 and MariaDB 10.1. Are there any steps to upgrade my osc to support the latest versions of php and mariadb? Thanks in advance, Irina
  15. Who's Online Enhancement 1.4

    My hosting provider upgraded my site to PHP v7.0.19. Now, the add-on is not loading at all, just the left menu bar. Did anybody else ran into the incompatibility issues? Any proposed fixes to make it work again? Thanks.