Jump to content

warrenthewindmill

Members
  • Content count

    123
  • Joined

  • Last visited

1 Follower

Profile Information

  • Real Name
    Dave
  • Location
    Chester, England
  1. warrenthewindmill

    SecPay tips

    Hi Nick. My SECPay setup started giving me problems some time ago after running fine for a couple of years. I've just noticed your post on this which looks as if it might help me. Have you had any problems with any of your customer setups using -jredir? SECPay have been telling me I don't need it but if I remove it the callback errors out, althought the transaction is still successful. With the -jredir in place the checkout doesn't now work properly. It takes over one minute to return to my site, all the while displaying a "transaction complete" message on the screen. I and they have spent weeks trying to sort this out but still no success. I've replaced my secpay.php to ensure I had the latest version and that it wasn't corrupt in any way and I've replaced the template code but still nothing. Any thoughts?
  2. warrenthewindmill

    Problem with NewsBox !!

    Has anyone found a solution to the jerking problem with this contrib. I need a newsbox but this one is not working properly. Any news in the box just judders gently up and down and goes nowhere
  3. warrenthewindmill

    what did I do to paypalipn?

    I have the same problem. I am using 2.2MS2 Any help much appreciated
  4. warrenthewindmill

    PayPal IPN v0.98 for Milestone 2 released!

    Referring back to my problem earlier in this thread: I contacted Pablo, the author of this contribution and... Pablo is the Man!! He contacted me via msn messenger and solved the problem in less than 5 minutes. I would probably never have figured it out. As our site is still under construction I have URL security in place. Remove it and EVERYTHING WORKS FINE This thing has been consuming me for, well for the length of this thread and then some. the store goes live on Sunday Thanks again Pablo :D :D
  5. warrenthewindmill

    PayPal IPN v0.98 for Milestone 2 released!

    Can someone at least confirm they have a working version. At least then I know the problem is with my installation in some way? Thanks
  6. warrenthewindmill

    PayPal IPN v0.98 for Milestone 2 released!

    I'm using 2.2ms2 with PayPal IPN v0.981 and: All my orders are left at "PayPal Processing" A TXN Id is not created The shopping cart is not emptied No email is sent to the customer from the store The transactions ARE successful because Paypal emails both the store and the customer and debits and credits the right amounts. I have been trying to solve this for the last 2 days and having found this thread can see that someone with similar problems back in August did not appear to get an answer. I assumed (always a mistake) that Paypal IPN would be a working contribution? If so what I am doing wrong? I have this one problem to solve to get a live site. I have checked the addresses in osCommerce and in Paypal are set to paypal_notify.php and it seems to make no difference whether or not cURL is enabled. If all else fails who would you recommend as a card processor, with an interface contribution that I can install? Hoping someone can help please
  7. warrenthewindmill

    PayPal IPN?

    Hi I am trying to get Paypal IPN to work. Everything is fine except after processing the payment, the item purchased stays in the cart. I've read the whole of this thread and I have checked the notify URL which reads: Notify URL http://www.mysite.com/paypal_notify.php This is the last hurdle before I go live so help would be much appreciated Thanks
  8. I've got the same problem. Anyone know the answer?
  9. Hi Paul Thanks for the reply. I solved the problem. What I overlooked was that when I created the .tpl file I didn't remove the start and end HTML tags. When I embedded this the source HTML had 2 sets of start and end tags which confused it (and me) A bit more tinkering and it was sorted. Think I should be ok now adding new contributions to the BTS thanks again
  10. I'm trying to apply BTS to a contribution (printable catalog) that I added after installing BTS. I've got it nearly right but I can't get the bottom banner (the one with date and number of page views) to extend across the page. It starts in line with the start of the content of the printable catalog part of the page - that is the area under column left is blank. I've tried amending the table settings, which I reckon is the solution but cant get it right. The page has column left, then the printable catalog content, then column right. The banner only appears under the last 2 parts of the page. I've tried looking at the way other pages use main_page.tpl and can't see anything wrong. The relevant bit of code is: <!-- body //--> <table border="0" width="100%" cellspacing="3" cellpadding="3"> <tr> <td width="<?php echo BOX_WIDTH; ?>" valign="top"> <table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2"> <!-- left_navigation //--> <?php require(DIR_WS_INCLUDES . 'column_left.php'); ?> <!-- left_navigation_eof //--> </table></td> <!-- content //--> <td width="100%"valign="top"> <?php if (isset($content_template)) { require(DIR_WS_CONTENT . $content_template);} else { require(DIR_WS_CONTENT . $content . '.tpl.php'); } ?> </td> <!-- content_eof //--> <td width="<?php echo BOX_WIDTH; ?>" valign="top"> <table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2"> <!-- right_navigation //--> <?php require(DIR_WS_INCLUDES . 'column_right.php'); ?> <!-- right_navigation_eof //--> </table></td> </tr> </table> <!-- body_eof //--> and below that I have the following: <!-- footer //--> <table border="0" width="100%" cellspacing="0" cellpadding="1"> <tr class="footer"> <td class="footer"> Sunday 05 October, 2003 </td> <!--<td align="right" class="footer"> 2726 requests since Thursday 17 July, 2003 </td>--> <td align="right" class="headerNavigation"><a href="http://mystore.com/ship.php"class="headerNavigation">Delivery</a> | <a href="http://www.mystore.com/shipping.php"class="headerNavigation">Shipping</a> | <a href="http://www.mystore.com/privacy.php"class="headerNavigation">Privacy</a> | <a href="http://www.mystore.com/conditions.php"class="headerNavigation">Conditions</a> | <a href="http://www.mystore.com/contact_us.php"class="headerNavigation">Contact</a> | <a href="http://www.mystore.com/gv_faq.php"class="headerNavigation">Gift Voucher FAQ</a> | <a href="http://www.mystore.com/catalog_products_with_images.php"class="headerNavigation">Printable Catalog</a> | </a><br> </td> </tr> </table> Any ideas would be much appreciated
  11. warrenthewindmill

    User Tracking with Admin 1.31 Released

    I posted on this: Flags displaying incorrectly or not at all back down the thread and decided to wait till I had my shop on a remote server. Now I have I am seeing some, but not many flags. Some of the ones that are appearing are wrong. I connect at work from a .gov.uk address and it shows the stars and stripes. similarly someone testing for me logs on from a demon account and this also appears as a US Flag. Any ideas? If not I'll have a go myself when I get some time but I guess this must have happened to others. I have user tracking with my ISP but I'm sure I will still use this because it's all in the same place place with the admin module. Great contribution
  12. Paul Thanks for this. I will be installing it in the next few days. A couple of questions: First what is php cURL? I've searched to find help on this without success. Even a pointer to some info would be helpful. Second I thought the difference between Protx direct and Protx form is that Direct doesn't take the punter to the processors website wheras Form does? On that basis wouldn't CC details be held in the database? Or are you saying you are choosing not to hold that info and that it has nothing to do with the processing method? When testing, if I test just the checkout code is there an easy way to disable the protx bit or should I not add it until I am happy that the cart works ok? Any tips on testing appreciated as I haven't been through this yet Looking forward to getting this contrib up and running
  13. warrenthewindmill

    Kill Sid or not?

    I am using: html_output.php,v 1.8 2003/02/15 from Loaded 5. I'm interested to know what version works as I've seen so much discussion on this topic and I'm confused as to what works and what doesn't
  14. I've been working for too long today I think. Of course I now realise (you foooool) that the whole point of this contrib is that it allows a non registered person (visitor) to proceed to checkout without automatically forcing him/her to create an account :oops: looks good
  15. I've just installed and it seems the only difference between registering an account and going straight to checkout is that if you register an account you are asked to input a password. Surely I must be missing something?
×