Jump to content

osclover

Members
  • Content count

    221
  • Joined

  • Last visited

Profile Information

  • Real Name
    nadeem ali
  1. osclover

    Anyone Using "Bill Me Later" Service?

    No one?
  2. osclover

    Simple Template System (STS)

    I have installed STS (version 3.0 beta) on my local machine. But I have 2 problems: 1- The main page as well as the others show my STS-based template. But the pages other than the main one do not show the inherent items of osc. For example the login page doesn't show the login and password fields. Why is that so? 2- When I uploaded my work to the online space, it gives me the following errors: Template file doesn't exist: []Can't open Template file: [] Warning: fread(): supplied argument is not a valid stream resource in /www/l/lookgoodlaco/htdocs/includes/sts_display_output.php on line 163 Warning: fclose(): supplied argument is not a valid stream resource in /www/l/lookgoodlaco/htdocs/includes/sts_display_output.php on line 164 Fatal error: main(): Failed opening required '' (include_path='.:/usr/local/lib/php') in /www/l/lookgoodlaco/htdocs/includes/sts_display_output.php on line 183 My configure files contents are: <?php /* osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2003 osCommerce Released under the GNU General Public License */ // Define the webserver and path parameters // * DIR_FS_* = Filesystem directories (local/physical) // * DIR_WS_* = Webserver directories (virtual/URL) define('HTTP_SERVER', 'http://www.my_domain_name.com'); // eg, http://localhost - should not be empty for productive servers define('HTTPS_SERVER', 'https://www.my_domain_name.com'); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', true); // secure webserver for checkout procedure? define('HTTP_COOKIE_DOMAIN', 'my_domain_name.com'); define('HTTPS_COOKIE_DOMAIN', 'my_domain_name.com'); define('HTTP_COOKIE_PATH', '/'); define('HTTPS_COOKIE_PATH', '/'); define('DIR_WS_HTTP_CATALOG', '/'); define('DIR_WS_HTTPS_CATALOG', '/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/'); define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/'); define('DIR_FS_CATALOG', '/www/l/o/my_domain_name/htdocs/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); // define our database connection define('DB_SERVER', 'xxxxxxxxxxxxx); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', 'xxxxxx'); define('DB_SERVER_PASSWORD', 'xxxxxx'); define('DB_DATABASE', 'xxxxxx'); define('USE_PCONNECT', 'true'); // use persistent connections? define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql' // STS: ADD: Define Simple Template System files define('STS_START_CAPTURE', DIR_WS_INCLUDES . 'sts_start_capture.php'); define('STS_STOP_CAPTURE', DIR_WS_INCLUDES . 'sts_stop_capture.php'); define('STS_RESTART_CAPTURE', DIR_WS_INCLUDES . 'sts_restart_capture.php'); define('STS_TEMPLATE_DIR', DIR_WS_INCLUDES . 'sts_templates/'); define('STS_DEFAULT_TEMPLATE', DIR_WS_INCLUDES . 'sts_template.html'); define('STS_DISPLAY_OUTPUT', DIR_WS_INCLUDES . 'sts_display_output.php'); define('STS_USER_CODE', DIR_WS_INCLUDES . 'sts_user_code.php'); define('STS_PRODUCT_INFO', DIR_WS_INCLUDES . 'sts_product_info.php'); // STS: EOADD ?>
  3. osclover

    WYSIWYG SPAW EDITOR Support Thread

    Hi everone, I have a bit modded store. The main contribution is Admin Access Level. I installed SPAW EDITOR and when I tried to access the admin panel, I got this error: Warning: main(../../includes/edit-wysiwyg.php): failed to open stream: No such file or directory in c:\web\fardeen\fardeen5\admin\includes\functions\html_output.php on line 12 Warning: main(): Failed opening '../../includes/edit-wysiwyg.php' for inclusion (include_path='.;c:\php4\pear') in c:\web\fardeen\fardeen5\admin\includes\functions\html_output.php on line 12 Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at c:\web\fardeen\fardeen5\admin\includes\functions\html_output.php:12) in c:\web\fardeen\fardeen5\admin\includes\functions\sessions.php on line 67 Warning: Cannot modify header information - headers already sent by (output started at c:\web\fardeen\fardeen5\admin\includes\functions\html_output.php:12) in c:\web\fardeen\fardeen5\admin\includes\functions\general.php on line 88 Please help me out. Thanks.
  4. osclover

    Credit card merchant procesing

    Would someone be able to explain what 'credit card merchant procesing' is and how it works into osCommerce?
  5. osclover

    which shipping module for inside UK?

    No one? :(
  6. I have to configure 3 shipping options. Royal mail special delivery Royal mail standard parcel Parcel Force The store will be shipping inside UK only. I tried the Royal mail module. But the module is buggy. Then I tried the contribution 'addition shipping options for zone module with percentage'. I put GB in all the three zones which it provides. However when i log in as a customer, I see that only the first one of them is being displayed. Another problem is that the weight of the product is shown as 2.2 lbs although it is 1 lbs. My shipping/packaging settings are: Country of Origin United Kingdom Postal Code NONE Enter the Maximum Package Weight you will ship 50 Package Tare weight. 0 Larger packages - percentage increase. 10 Any help would be greatly appreciated. I have spent lot of time on figuring this problem out. I wonder how do the other uk based store owners operate. Regards, Nadeem
  7. osclover

    Help please

    Quite a few people have found Royal Mail Module to be buggy. How did you make it work correctly? Post it here, so that everyone else can benefit. Regards, oscLover
  8. osclover

    Wrong weights and prices of shipping

    Thanks terry. I am going to look at the thread. :thumbsup:
  9. osclover

    Wrong weights and prices of shipping

    Yes that might be the reason. Will check it out. But dont' you think 1-2 lbs are very small values?
  10. osclover

    Wrong weights and prices of shipping

    The zone rate is enabled in the admin. the countries in zone one are US, CA and GB. The rates are: 3:8.50,7:10.50,99:20.00 If you click on the item Laptop BackPack (the weight of which is set as 2lb in the admin) , you will see that in the checkout_shipping.php page, the weight jumps up to 2.2 lbs, and the shipping amonut is ....(amazed) now ok. :$ Why do the shipping weight jumps up from 2 lb to 2.2 lb? Many thanks,
  11. osclover

    Wrong weights and prices of shipping

    The website is : www.roseluggage.com
  12. osclover

    Wrong weights and prices of shipping

    Enter the Maximum Package Weight you will ship 50 Package Tare weight. 0 Larger packages - percentage increase. 10 Hope that helps. :)
  13. I have enabled the zones method in the shippping modules section. The values are: 3:8.50, 7:10.50, 99:20.00 I then insert an item 'A' in the catalog. No matter what its weight is while being adding/updating it to the catalog, in the checkout process, its weight as well as the shipping price is a bit higher. I have changed the weight a few times. But I am still getting the same error. :$ This zone's handling fee is set to 'zero'. The Package Tare Weight in Configuration-->Shipping/Packaging is also set to 'zero'. Any help?
  14. osclover

    Shipping Modules - Zone Based

    That royal module has bugs. You can view the problems people are facing by using it by going to its support forums. I also need royal mail shipping methods. After some search and reading, I came to know ( i might be wrong ) that I can use the Additional Shipping Zones contribution in some way to get my task done. Not too sure, but I'll give it a try. Again Royal mail module is buggy.
×