Jump to content

Highway of Life

Members
  • Content count

    32
  • Joined

  • Last visited

Everything posted by Highway of Life

  1. Highway of Life

    [Contribution] - USPS Methods

    Internet has been down for a week, I'll see if I have this problem.
  2. Highway of Life

    [Contribution] - USPS Methods

    It really just depends on how you want to ship. Typically its Express Priority First Class Parcel I have: Express Priority First Class
  3. Highway of Life

    [Contribution] - USPS Methods

    Call them directly. They switched me over while I was on the pnone with them.
  4. Highway of Life

    [Contribution] - USPS Methods

    Only got a second so I'll answer one question. You don't have to wait for USPS, all you have to do is call them, and in less than 10 minutes they will switch you to the production server. Check your order in the Admin panel, that might be the problem with the radio buttons. You can also try different orders
  5. Highway of Life

    [Contribution] - USPS Methods

    The radio buttons, or the options themselves?
  6. Highway of Life

    [Contribution] - USPS Methods

    Also, be specific about what you tried, and the errors you get. In addition to the two files you mentioned, there is code to add in these files: general.php and modules.php Let me know if that helps. Blessings, Dave
  7. Highway of Life

    [Contribution] - USPS Methods

    Install USPS Methods 2.7 Be sure to follow ALL the instructions. Then install USPS Methods 2.7d There are some essential files missing in 2.7d, but they are in the 2.7 version. I have not checked 2.8, so you will have to be more specific about what the problems are. Blessings, Dave
  8. Highway of Life

    [Contribution] - USPS Methods

    Should be catalog/includes/modules/shipping/usps.php But confirm by comparing the files. Highway
  9. Highway of Life

    [Contribution] - USPS Methods

    What files did you install/modify?
  10. Highway of Life

    USPS Module

    I would like to add that once you have finished the installation of the USPS module contribution, you must call USPS Web Tools, and they will switch your account over to the Production server. The USPS module WILL NOT work on the Test server. The official USPS module contribution support thread: http://forums.oscommerce.com/index.php?showtopic=146950&st=0 - David
  11. Highway of Life

    USPS Module

    In the instructions, I forgot to add the code for admin/includes/modules.php and admin/includes/functions/general.php For me help, go to: http://forums.oscommerce.com/index.php?showtopic=146950&st=0 Let me know if this helped you. Are you getting the same error? Billy: That was not the problem, my zip code was correct. - David
  12. Highway of Life

    [Contribution] - USPS Methods

    Mike: The USPS error looks like you don't have your store location and zone set up completely in your Admin area
  13. Highway of Life

    [Contribution] - USPS Methods

    Pounds decimalized. What are your defaults in the Configuration > Shipping / Packaging administration? And what is the product weight of your E DVD product?
  14. Highway of Life

    [Contribution] - USPS Methods

    What do people do if they want KGs? There must be a simpler way. Since you have so many items, you might check into easy populate. Blessings, Dave
  15. Highway of Life

    [Contribution] - USPS Methods

    Thanks, the extra info helps. I don't know where to change the default weight for calculation, but in shipping/usps.php on around line 82... if (in_array('Display weight', explode(', ', MODULE_SHIPPING_USPS_OPTIONS))) { $shiptitle = ' (' . $shipping_num_boxes . ' x ' . $shipping_weight . 'lbs)'; } else { $shiptitle = ''; } You can change the display there. Sorry I can't be of more help, I have not crossed that bridge myself. You might try calling USPS help. Good luck, Dave
  16. Highway of Life

    [Contribution] - USPS Methods

    My default is pounds, and in the checkout_shipping.php all the shipping modules display pounds in tenths. When you test buy an item that is .5lbs (8 oz), what does your shipping modules display? And remember, there is pre-defined packaging weight that it will add to your order. Are you trying to get it to display pounds or ounces?
  17. Highway of Life

    [Contribution] - USPS Methods

    Okay, calm down Christian. There is a reason there is a community, and that is to help. Individuals write the contributions, not huge companies. People sometimes make mistakes. You just have to live with that. This is one of the reasons we all do it ourselves = To save money. We expect that we will have to put the time and effort into it. That is a given. You just have to be patient and learn, or pay the mega-bucks for a shopping cart. The file that you are looking for is in the USPSMethods2.7 package, not the 2.7a, b, c, or d. Hope that helps. Blessings, Dave
  18. Highway of Life

    [Contribution] - USPS Methods

    Probably config.php
  19. Highway of Life

    [Contribution] - USPS Methods

    Jim, Be sure the path and name for the icon are correct... /catalog/images/icons/shipping_usps.gif Question, do you have another shipping method? i.e. UPS, FedEx, Free Shipping? If you do, are those icons showing up for you? When I downloaded this mod, I did not use the supplied icon because I had one already. I just checked the downloaded package, and I found no usps icon there, so the one I am using was already on my site. Let me know what you have. Dave
  20. Highway of Life

    [Contribution] - USPS Methods

    Ugh! it won't let me edit my post. Here are the other suggestions... Suggestions: in Admin > Configuration > Shipping / Packaging: Make sure your country of origin and postal code are correct. In Admin > Modules > Shipping > USPS: Server should be set to "production" Double check your USPS user ID and Password. Did you make the correct modifications to the general.php and modules.php files? When testing, try an address that is not your shipping address, but make sure it is not a 'junk' (fake) test address. Dave
  21. Highway of Life

    [Contribution] - USPS Methods

    This was the same problem I had, sounds like you don't have the USPS icon uploaded to your website, it should be showing up. Did you make the correct modifications to the general.php and modules.php files? Dave
  22. Highway of Life

    [Contribution] - USPS Methods

    Oh, problem solved. Thanks Forgot to add the code in the general.php and modules.php files.
  23. Highway of Life

    USPS Module

    Ah! found the problem, I forgot to add the supplied code from the mod to admin/includes/modules.php and admin/includes/functions/general.php Problems seems to be solved. Dave
  24. Highway of Life

    USPS Module

    An update: I uninstalled the old USPS mod, and installed this new one: http://www.oscommerce.com/community/contributions,487 But I am getting this error when I try to edit the information in the Admin: If any of you know how to fix this, let me know. In the meantime, I am using FedEx for my customers. Dave
  25. Highway of Life

    [Contribution] - USPS Methods

    Greetings! I had a USPS mod installed, that did not work, so I called USPS, and they switched me to Production server. However, I still got this error: So, I just removed (uninstalled) that mod, downloaded and installed this mod. When I clicked on "Edit" to edit my information, I got this error: Does anybody know what that means? Thanks! Dave
×