Jump to content

14steve14

♥Ambassador
  • Content count

    5,042
  • Joined

  • Last visited

  • Days Won

    58

Posts posted by 14steve14


  1. People have to learn to accept that not even Phoenix is standing still any longer. Oscommerce did that for many years and before forward movement it was considered a laughing stock  and dead in the water. With Garys input and the help of those that want to see it advance, everyone is getting a better code base. Addons can now be installed in a few clicks rather than a whole lot of manual code changes. Updating the store code is again very simple, and takes a few minutes. If you want old and outdated use an old and outdated version.

    Stop thinking what was, and start thinking what could be.


  2. Are there not already addons that allow multiple admin users. I seem to remember that this subject has arisen several times. The only thing that will need fixing is a way to split the payments between accounts without the main site owner being liable for addition personal and business taxes.

    I can see a potential use for something like this on my site a its hobby re;lated and people love selling what they own, but it is something that is way off in the distant time for now.


  3. 2 hours ago, JcMagpie said:

    Look's like "Money for old rope" to me.....

    Without that money the core code for oscommerce would not be changing. Its a shame that not everyone is behind moving the project forward and are out to spoil what some are working towards. But never mind, I fully understand that some people are like that, and that they, not necessarily you Zahid,  hold a grudge as they are excluded from the 'club' and don't want to help improve the core code. That's their choice of course but don't run down and insult those that want to help, and don't undermine the work of those that are working to improve the code by offering free code to those that do support. It will only drive a wedge between everyone and cause a split so that those on this forum will not benefit.


  4. 1 hour ago, valquiria23 said:

    Burt had to integrate this admin to phonix  for a long time ago and work to improve it. I don't see the reason for just now to start Bootstraping the admin ... but who knows the commercial interests that some have?? ... I think he was not interested in integrating Henry and @shetch into the project, it just my humble opinion.

    Gary asked Henry to do some coding but after waiting for a long time and taking a lot of abuse from henry in one of his drunken moments, nothing got done, and that was henry's fault and no one else's. Henry talked the talked, said that he could do lots but did nothing. There is a lot more to that story but I wont go into it here. No doubt he will come back here now under yet another username and start the abuse again.

    As for the boostrapped admin that shetch did, I think it was poorly coded so went no further. if it was good you would think that he or someone else would have continued with the development, but nothing has happened there. There could be an opportunity for someone to restart it again.


  5. Tell a Friend got removed from the latest versions of Phoenix. It has always been considered a security risk and when Gary asked, most said they never used it or had it turned off, so it got removed. You may need to look through a Phoenix version before 1.0.2.6 to find the relevant code and add it back into your version. You may also need some form of protection on the form as its a way for people to use as spam and other nasties as Jack says.


  6. The money is the stores currency. So euros or GBP it makes no different its the way they are entered that you are interested in. The 0.83 could be cents, euros or pounds. It would be 0.83 of a euro. One Euro will be wrote as 1.0 or even just 1.

    Again the weight makes no difference as nowhere in your store does it require a specific weight entry. If your shippers charge you in pounds rather in in kilogrammes use pounds. All my shippers use kilogrammes. but you have to figure out and stay consistent with the way you enter the weights throughout your store. Again 1 can be either 1kg or one pound, its what comes after the decimal point that will make the difference..

    What have you tied so far. Post how you have entered something in the shipping section to calculate the costs and may be I could see where you are going wrong.


  7. 7 hours ago, puggybelle said:

    Version checker really doesn't check anything, does it?

    - Andrea

    It used to before the community edition. Phoenix now shows the correct version.


  8. Here is how I enter it in my shipping modules.

    0.1:0.83,0.25:1.32,0.50:1.72,0.75:2.33,1:3.00,2:4.05,

    The first 0.1 is 100g so if you want 20g it will need to be 0.02 and 90g will need to be 0.09

    the next 0.83 is the cost in GBP that's 83p

    And so on. The 0.25 is 250g

    eventually getting to 2 which is 2kg

    Hopefully that makes sense.

    You will need to write yours as

    0.02:0.91,0.09:1.82, and continue adding the weight and the cost separated by a :

    I did also change the weight in the database to be something like decimal(5,3) wherever weight is mentioned (mainly product wieght), if its not already that so you get the correct places after the decimal point. 5:3 is five places before the decimal point and three after.  I think I seem to remember that in standard osc it may only be 5:2.

     


  9. 1 hour ago, mhsuffolk said:

    @14steve14 My experience is that the street address entered by the customer can have spelling mistakes, some people don't even know where they live!

    Suggest you run these excellent querys on the entry_postcode field instead. Customers tend to get their post code correct however some leave out the space before the last 3 characters which could be an issue. I believe there is an SQL query term "REPLACE" that would solve that problem but I am not sure how to implement it.

    I will try using the postcode in the query but I think it may throw some weird results as I know I have some customers who are neighbours. I will let you know how I get on so thanks for the suggestion.


  10. Before I upload all my customer data to a new version of Phoenix, I am having a bit of a clear out of old and inactive customers. The inactive customers was easy as there was an addon ( I deleted over 800 customers who have never bought anything going back 5 years). Finding duplicate customers is proving to be a bit harder. Customers sometimes cant get the forgotten password link to do anything so create another account using a different email address, and its these that I want to find. Once found I have the addon to link both accounts together.

    Does anyone know of an addon or a way to check database entries for the same 1st line of the address. Once I have the customers details I can manually check the rest is the same.


  11. I think language packs for shop and admin side should be addons and not part of core. There are too many languages to include otherwise. Some have already translated languages and uploaded them to the addons area so if they have not done all the admin then they eoither need to be told, or someone needs to update the package.

    I also think that language packs should include things like different address and date formats which are easily changed.


  12. I spoke to PayPal about this and was directed to a help page on their website. A user needs to activate one-touch from within their PayPal account security section. You have to confirm that you want to remain logged in to PayPal on your devices and everything should work.

    What they cant tell me is why nothing shows on my site without me being logged in to the site. Without being logged in, the site has no idea who I am. It also did not work on my site when they tried to test things so at that point I gave up, as they said it should be working on the product pages.


  13. 1 minute ago, raiwa said:

    Are you trying to pay on your site using the same account as your seller account? This won't work. You need a different account to test on your site.

    Rainer thanks for your patience.

    I have tried using my account without being logged on, and also someone else's account. Only thing being that both these people live in the same house and were using the same IP address. I have also tried it on my phone using my phone data rather than wifi, and on the wifi and still nothing. I am off next door to speak to a neighbour and see what happens after lunch.


  14. I recently installed the latest update and since then have noticed that on the store invoice the Total and figure are above the Shipping costs and the Sub total. Is it just me or should they be the other way around with the sub total, then the shipping then the total.  Looking back through previous orders with the Stripe payment module the order was correct. All other payment modules show correctly on my altered invoice layout.

    Image to show difference below.

    invoice-totals-latest.jpg

    invoice-totals-old.jpg


  15. 15 hours ago, TomB01 said:

    I have the same issue.  I simply loaded the Phoenix 1.0.4.0 Stripe module, input the correct information (a live API is still working on my 2.3.4 store), but testing doesn't work.  Stripe shows a 404 error from using a "GET" with the following string: /v1/charges/oscommerce_connection_test.

    I don't know if that will help someone find the issue, but I'm going to try the SCA, since the current Stripe module in Phoenix appears to use APIs that originated in 2014 and have been updated twice by Stripe since then, according to their site.

    I think this was mentioned somewhere else in another thread and the advice was to uload the latest Stripe SCA addon as you have suggested.

×