Latest News: (loading..)

yatahaze

Members
  • Content count

    164
  • Joined

  • Last visited

About yatahaze

Profile Information

  • Real Name
    Ryan
  • Location
    Canada
  • Website
  1. I just get redirected to the checkout_payment page after confirming my order, and the mail I receive contains no errors: Error Message(s): Address Verification Response: CVV2 Verification Response: Any idea what's wrong? The site is www.mostlymusic.biz.
  2. This module still is completely broken for me. It doesn't give errors anymore, but it also doesn't function properly. • Does not subtract stock from my inventory. I've seen it do it, but not every time. This is my major problem. • Doesn't change to the final status unless the user clicks the continue button on the checkout successful page. I can't guarantee every customer to click that.
  3. I fixed it! I compared through different versions of osCommerce and I figured it out, really easy too. The problem applied to other payment modules too, not just this one. You have to move this bit of code around: // load the before_process function from the payment modules $payment_modules->before_process(); in checkout_process.php. You have to move it from below where it includes order_total.php to above it. Here's a before and after: BEFORE: // load selected payment module require(DIR_WS_CLASSES . 'payment.php'); $payment_modules = new payment($payment); // load the selected shipping module require(DIR_WS_CLASSES . 'shipping.php'); $shipping_modules = new shipping($shipping); require(DIR_WS_CLASSES . 'order.php'); $order = new order; require(DIR_WS_CLASSES . 'order_total.php'); $order_total_modules = new order_total; // load the before_process function from the payment modules $payment_modules->before_process(); $order_totals = $order_total_modules->process(); AFTER: // load selected payment module require(DIR_WS_CLASSES . 'payment.php'); $payment_modules = new payment($payment); // load the selected shipping module require(DIR_WS_CLASSES . 'shipping.php'); $shipping_modules = new shipping($shipping); require(DIR_WS_CLASSES . 'order.php'); $order = new order; // load the before_process function from the payment modules $payment_modules->before_process(); require(DIR_WS_CLASSES . 'order_total.php'); $order_total_modules = new order_total; $order_totals = $order_total_modules->process();
  4. I am also getting this problem. Anyone know how to fix it?
  5. I figured out what the problem is, I'm just not sure how to solve it. It's all of the excess list items at the end of the menu. I was messing with the generated source code in dreamweaver. At the end of all the list items I changed the following from this: </li></ul></li><ul><ul></ul><ul></ul><ul></ul><ul></ul><ul></ul><ul></ul></ul></ul></div></td> to this: </li></ul></li></li></ul></div></td> The menu went back to functioning normally. Now the script that generates the menu needs to be fixed. I'm not quite sure how to do that.
  6. There is a firefox compatibility bug with this. If there is a category with only inactive items in it, the very first category in the menu will always list the subcategories, regardless of what category you are hovering over. I'm pretty sure this only happens when "hide empty categories" is turned on. Less important, but still viable: There is also lots of excess UL and LI openings and closings that cause there to be gaps where empty categories are. Basically they aren't being completely hidden. The W3C validator complains a lot about the code generated by this menu as well, mostly to do with the hidden empty categories.
  7. I'm using the KGT Discount Coupon addon, which as been mentioned here before. I'm having a problem, the order editor isnt calculating the taxes properly. Order Editor's tax formula: Subtotal * TaxPercentage Needed: (Subtotal - DiscountCouponAmount) * TaxPercentage Any idea how I can do this? I'm kinda new to php and struggling to figure out how to do this.
  8. I have a huge problem trying to use this contrib. How do you guys edit orders that have a discount coupon applied to them? The popular "Order Editor" contrib converts the discount into a positive and I don't think it can handle creating the discount from the result: "subtotal - discount = *result*", rather it takes the discount off the subtotal after changes are made to the order. Coupons work fine on their own, I just can't find a way to edit orders that have had coupons applied to them.
  9. Is there any version of this that works with the gift voucher / credit class mod? Whenever I update an order that has a discount on it, the discount gets turned into a positive.
  10. Instead of updating when I move my cursor away from the text i've changed, it gets stuck in an endless loop of asking me for my admin password and I can't get it to do anything. Also, some of the items I have in my order total list have html in them, and the order total box really hates that. The code isn't showing up inside editable text boxes, its showing outside.
  11. Ok here's the deal, this might have to do more with their system not with this contrib. I have a bubble envelope, medium box and big box, all with ample measurements for 2 of a certain item. I get a perfect shipping quote, it uses the bubble envelope and everything is good. When I add one more of that item to my cart, it still picks the bubble envelope but uses 3 boxes instead, and it picks the bubble envelope to use for all 3. It doesn't picks the medium box that has the perfect room for the items.
  12. Ok, I'm having a major problem with this contrib. I believe we are losing sales to US customers because the contrib is bad at calculating US shipping costs. Here is what is happening: A US customer places an order for something that is heavier than what the Small Packets service can handle. They end up ordering a certain weight or maybe amount of products that causes the contrib to offer them the option between 3 small packets boxes (which we would never do), or an inflated expedited option. It's inflated because I believe it also thinks it will be 3 boxes for expedited, which is really expensive. I'm not making stuff up, when I manually check the shipping cost with the canada post software when it's saying the order will be 3 boxes, the expedited shipping amount is completely different than the one the contrib offers. This is a big problem for us because not only are people seeing the wrong shipping amount, we are forced to rename it to "estimated shipping" and manually check shipping costs on all orders and change them, then manually send an invoice to the customer rather than just having the system deal with everything on its own like it's supposed to. If it helps, we have every item weighed in KG and we don't use the dimensions. We have box sizes entered into the canada post site as well. It doesn't make sense why this thing would pick more than one box when we don't have our products measured. Even when I put measurements in, it offers more boxes and inflates the expedited shipping amount. I guess I should summarize by saying the Expedited US Business amount is getting inflated when there is more than one box. The extra boxes are coming from limits of the Small Packets service I think. The only weird thing is the contrib doesn't know the dimensions of my products, so how could it possibly make the decision to use more than one box? Is there anything anyone can do out there? I know this forum thread has very little discussion but I hope someone has some feedback about this issue I'm having. I can't be the only one with this problem either.
  13. Is there anywhere to get support for this module? This doesn't seem to pick up the information about my box weights and stuff from their server. The shipping costs increase at weird weights like from .22 -> .23 kg, instead of what the rate sheet shows. I cant seem to find out whats going on with this thing and I cant find a place to get some help with it.
  14. We don't enter dimensions in (too much work), but I entered in some fake ones on the item I was testing and it said 1 box for 0.82kg, however when I made the order 1kg, it went straight back to the 3 boxes, with the small packets option still available and the expedited price wrong.
  15. I think I found a glitch, it applies to US customers only. Here is my theory: For the small packets option, when the customers order goes over the weight limit for one box for small packets, the calculator adds boxes instead of sticking with 1 box and showing expedited only. The expedited price gets messed up because it thinks theres 3 boxes when obviously the weight limit is a lot higher and we could easily fit everything in one box. Right now, every order equal or over 0.82kg (not sure why it's that strange of a number) will show up as 3 boxes, roughly 2kg will show 4 boxes, roughly 3kg will be 5 boxes, etc. One box expedited is WAY cheaper than multiple small packets shipments. Does anyone else have this problem? And what can I do to fix this?