Latest News: (loading..)

osCshop

Members
  • Content count

    153
  • Joined

  • Last visited

2 Followers

About osCshop

Profile Information

  • Real Name
    .
  • Location
    The Netherlands
  • Website
  1. I really would like to use this mod but would like to see an example first. Anybody a hyperlink to a shop who's using this?
  2. I would like to use the old 'Customer Review Image' contribution together with this Reviews in Product Display 2.3 contribution. I've got the Reviews in Product Display 2.3 work perfect together with the Review Approval and Allow Guest Reviews contribution. Could somebody please help me how to ad the following lines to the lines used for the Reviews in Product Display 2.3 contribution? Below the code that normally has to come in catalog/product_reviews.php // BOF Review Images $reviews_query_raw = "select r.reviews_id, left(rd.reviews_text, 100) as reviews_text, r.reviews_rating, r.date_added, r.customers_name, ri.reviews_image from " . TABLE_REVIEWS . " r, " . TABLE_REVIEWS_DESCRIPTION . " rd left join " . TABLE_REVIEWS_IMAGES . " ri on r.reviews_id = ri.reviews_id and ri.reviews_status = '1' where r.products_id = '" . (int)$product_info['products_id'] . "' and r.reviews_id = rd.reviews_id and rd.languages_id = '" . (int)$languages_id . "' and r.approved = '1' order by r.reviews_id desc"; // EOF Review Images <?php // BOF Review Images ?> <td valign="top" class="main"><?php echo (tep_not_null($reviews['reviews_image']) ? tep_image(DIR_WS_REVIEWS . $reviews['reviews_image'], $products_name, SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT, 'hspace="5" vspace="5" align="left"') : '') . tep_break_string(tep_output_string_protected($reviews['reviews_text']), 60, '-<br>') . ((strlen($reviews['reviews_text']) >= 100) ? '..' : '') . '<br><br><i>' . sprintf(TEXT_REVIEW_RATING, tep_image(DIR_WS_IMAGES . 'stars_' . $reviews['reviews_rating'] . '.gif', sprintf(TEXT_OF_5_STARS, $reviews['reviews_rating'])), sprintf(TEXT_OF_5_STARS, $reviews['reviews_rating'])) . '</i>'; ?></td> <?php // EOF Review Images ?> I gues I have to combine the above code with the code below(?) from product_info.php but have no idea how :huh: .. <?php // BEGIN PopTheTop Product Info Reviews ?> <?php $reviews_query = tep_db_query("select count(*) as count from " . TABLE_REVIEWS . " where products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "'"); $reviews = tep_db_fetch_array($reviews_query); $reviews_query_average = tep_db_query("select (avg(reviews_rating)) as average_rating from " . TABLE_REVIEWS . " where products_id = '" . (int)$HTTP_GET_VARS['products_id'] . "' and approved = 1"); $reviews_average = tep_db_fetch_array($reviews_query_average); $reveiws_stars = $reviews_average['average_rating']; $reveiws_rating = number_format($reveiws_stars,0); ?> <tr> <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '45'); ?></td> </tr> <?php if (MAX_REVIEWS_IN_PRODUCT_INFO > 0) { $reviews_query = tep_db_query("select r.reviews_id, rd.reviews_text, r.reviews_rating, r.date_added, r.customers_name from " . TABLE_REVIEWS . " r, " . TABLE_REVIEWS_DESCRIPTION . " rd where r.products_id = '" . $HTTP_GET_VARS['products_id'] . "' and rd.reviews_id = r.reviews_id and rd.languages_id = '" . $languages_id . "' and r.approved = '1' order by r.reviews_id DESC"); $num_rows = tep_db_num_rows($reviews_query); ?> <tr> <td> <table border="0" width="100%" cellspacing="0" cellpadding="0"> <tr> <td class="pageReviewHeading" valign="top"><?php echo BOX_HEADING_REVIEWS; ?></td> </tr> </table> </td> </tr> <?php if ($num_rows > 0) { $row = 0; while (($reviews_values = tep_db_fetch_array($reviews_query)) && ($row < MAX_REVIEWS_IN_PRODUCT_INFO)) { $row++; $date_added = tep_date_short($reviews_values['date_added']); // Write product reviews ?> <?php // END PopTheTop Product Info Reviews ?> I really hope someone could help me out with this one!!
  3. Or this one?: Customer Review Images http://www.oscommerce.com/community/contributions,4965
  4. OK, thanks for the reply. I'll check if there are better solutions then page2rss which I use now..
  5. If you mean the RSS Create function under Tools in admin; I've tried it but nothing happend (probably because I don't use the info box) So i'm not sure how it works but I don't think I can create a dynamic rss feed with that. I need a dynamic feed from the rss_reader page..
  6. Hi Jack, Long time ago but I have a new question. I'm using your RSS News 1.3 page on my website to show new items of my blog. What I would like to have is a RSS feed of the page showing the news on my own website. So I would like to have the traffic first on my website and from there to my blog. I'm using page2rss and twitterfeed to feed my Twitter but i'm not happy with it. All the traffic goes to page2rss instead of my website. Could you please help me to add an rss to the RSS News page? Greetings from Holland, osCshop
  7. Me again, beside a fix for not showing words with no results; how to fix the W3C error: The spaces should be replace by '%20' for W3C..
  8. :o It does show words with no results @ my site. How to filter this?
  9. :blush: I've found the answer to my question. You have to put the code instead of product listing to advanced search result before: $breadcrumb->add(NAVBAR_TITLE_1, tep_href_link(FILENAME_ADVANCED_SEARCH)); $breadcrumb->add(NAVBAR_TITLE_2, tep_href_link(FILENAME_ADVANCED_SEARCH_RESULT, tep_get_all_get_params(), 'NONSSL', true, false));
  10. Hi, I installed this nice little contribution, thanks! Is there still support? I ask this because there's no reply on the comment from ident/Dirk and because I have a question: I think this contribution works with words entered in the small search box. In my website I only use the advanced search page. How to adjust the code so it will work with words entered in this page? Hope someone can help me with this one :huh:
  11. Not sure what you mean with 'sub-feeds that was attached' Jack. I only use one feed..
  12. Strange, it works now without changing anything.. The '€' is presented as a '?'.
  13. Me again. I think it has something to do with a special character. In this feed. Could the '€' euro character cause the error? If I try another feed there's no problem. The feed I use works fine on my Netvibes page. So i would put my money on the '€' character. How to fix this?
  14. Hi Jack, Until today your contribution worked great! Now the page gives this error: Warning: fopen(http://www.rssdomain.com/rss/seat.rss) [function.fopen]: failed to open stream: Bad file descriptor in c:\domains\mydomain.nl\wwwroot\mydir\includes\modules\rss_reader.php on line 112 could not open XML input Any idea?
  15. Aha, I wasn't aware that RSS News v1.3 had a RSS news page :blush: I've installed it and it works great. Thank you! For W3C validation I only had to remove a '</tr>' ad line 69 in catalog/rss_reader.php Thanks again!