Jump to content

gameparts

Members
  • Content count

    34
  • Joined

  • Last visited

Everything posted by gameparts

  1. More information: If I simply delete the fedex1.php & flat.php files in both modules/shipping, and languages/english/modules/shipping, I get an error message when the checkout_shipping.php page comes up about that "class" not being found. There is no reference to these modules in the phpmyadmin configuration table once I have uninstalled them. That tells me (and I may be wrong) that somewhere there is a piece of code that is calling on these modules specifically. It is not checkout_shipping.php & it is not shipping.php, because I've replaced those with the original out of the box files and I see no reference to them in there. Where oh where are these modules being called upon and causing that error. My guess is that if I can find that piece of code, I can solve this problem about the other modules not showing up at checkout. Anyone?
  2. On OSCommerse Version 2.2 MS2 I have had various mods done over the years, and at this point am wanting to switch to a PER ITEM shipping charge. I install & enable the PER ITEM module, but it doesn't show up at all as an opiton duirng checkout. It is not a per item module problem because no other modules besides Fedex & Flat Rate show up, even after I install and enable them. USPS, UPS, Table, etc., will not show up at chekcout. At one point, Fedex & Flat Rate were the only options I wanted, and had someone do some coding to make those work together to allow either Fedex shipping or Free shipping. I don't know where the coding was changed, nor do I remember who did it. I have now replaced with the original (pre-mod) files all of the following without any change in this problem: All of the files under catalog/includes/modules/shipping All of the files under catalog/includes/languages/english/includes/modules/shipping Catalog/checkout_shipping.php Catalog/shipping.php Where else might this problem be happening? I have looked through endless files to try to find it, but no luck. I would guess there is a file somewhere with a piece of code that is only allowing display of the Fedex & Flat Rate shipping options, even if others shipping options are enabled in Admin. Where do you all think this might be??? Please help!!
  3. If we can't figure out the root of the problem, how would I modify the Flat rate module to instead be a Per Item module? In other words, it would use the same filenames as Flat, but the code itself would calculate a Per Item shipping charge (like $5 base + $4 per item). Sounds kind of silly to do that, but under the circumstances, I do get the Flat rate displayed on checkout, but nothing else, no matter what I have enabled. Can anyone help me rewrite the flat rate code to actually be a per item code but with all the same filenames as the flat rate option. Pleeeeaaaasssseeee!
  4. Ok, I went ahead and deleted all those references to shipping in the configuration table, and uninstalled all the shipping modules from the admin panel. Went back in to phpmyadmin and see no references to shipping mods at all in the config table. Then I reinstalled Flat & Item modules from Admin Panel and set those up. Those shipping mods now both appear in the config table. However, upon checkout it is still only displaying the Flat Rate Option for the customer. Even if I have the item rate set cheaper than the flat rate, the customer still only gets the Flat Rate Option. Any other ideas?
  5. OK, my bad, I didn't page forward in the "configuration" table. I found the shipping modules in there. There ARE some settings in there that are NOT what I currently have enabled from the Admin Panel. In phpmyadmin should I just delete those references to shipping methods that are not being used? For example, do I just delete these from the configuration table since I am not using Table2 module? 762 Tax Class MODULE_SHIPPING_TABLE2_TAX_CLASS 0 Use the following tax class on the shipping fee. 6 0 NULL 2006-04-13 01:16:51 tep_get_tax_class_title tep_cfg_pull_down_tax_classes( 763 Shipping Zone MODULE_SHIPPING_TABLE2_ZONE 0 If a zone is selected, only enable this shipping m... 6 0 NULL 2006-04-13 01:16:51 tep_get_zone_class_title tep_cfg_pull_down_zone_classes( 764 Sort Order MODULE_SHIPPING_TABLE2_SORT_ORDER 3 Sort order of display. 6 0 NULL 2006-04-13 01:16:51 NULL NULL
  6. Hmm, maybe I'm not looking in the right place. I am in phpmyadmin for that database. I see the tables "configuration" and "configuration_group" I select those tables separately, and browse them. They contain the same settings that I set up in my admin configuration panel. I don't see any reference to shipping modules at all in either table. I also don't see any other table in the database for shipping modules/options. Am I looking in the wrong place? Your help is greatly appreciated!!!
  7. Anyone ever figure this out? I've looked all through the posts and can't find a solution anywhere. Any of you figured out a way to use Easy Populate with digital download products? So that the filename of the product can be uploaded to the database as well? Plus the max days, max downloads, etc?? please help?
  8. gameparts

    PayPal WPP Direct Payments & Express Checkout Support

    Actually that does work! I just enabled the regular Paypal module that comes pre-packaged with OSCommerce. I processed a transaction through that mod, and also through the direct payment option, and they both work with no apparent conflicts. All I have to do now is make a button the same color as my background to replace the Paypal Express button, so it will be invisible on the login page. Or, if I can figure out where in the code to disable the display of that express button on the login.php page. Kind of crazy to do that, but if we can't get this thing to work properly, I see no problem doing it. Paypal may not like it, but maybe by the time Paypal notices that the express button is not there someone will have fixed the code.
  9. gameparts

    PayPal WPP Direct Payments & Express Checkout Support

    Another idea since I can't get this darn thing to work for express payments is to use the direct payment portion of this mod (since that part works), somehow disable/hide the express payments option, and then also install the Paypal IPN mod. Would that work or would there be some conflicts?
  10. gameparts

    PayPal WPP Direct Payments & Express Checkout Support

    So, Brian, what do you think about this redirect problem after coming back from Paypal on an express payment? (the error I posted about recently) I am switching over from Authorize.net to WPP and really need to get this thing working. Any help would be greatly appreciated. How much do you charge to install the module and get it working properly, if I have you do it? Thanks!
  11. gameparts

    PayPal WPP Direct Payments & Express Checkout Support

    MechBun, is your hosting on Godaddy too? Mine is. I'm just trying to figure out why we are having this problem and a few other people, but not everybody is having this problem.
  12. gameparts

    PayPal WPP Direct Payments & Express Checkout Support

    Dynamoeffects, I installed the mod once and had that problem. Thinking it was my mistake, I started all over again and did a clean install of OSCommerce, and reinstalled the WPP module, with the exact same error results! I don't think it is an incomplete install. I didn't even cut and past anything. I simply replaced my php files with your php files.
  13. gameparts

    PayPal WPP Direct Payments & Express Checkout Support

    I also had modified this piece of code prior to getting the "Plaese select a payment method for your order". I modified the below because I was previously getting the error about "trouble validating your account". Around line 516 change: //$_SESSION['paypal_ec_payer_info'] = $paypal_ec_payer_info; tep_session_register('paypal_ec_payer_info'); TO: tep_session_register('paypal_ec_payer_info'); $_SESSION['paypal_ec_payer_info'] = $paypal_ec_payer_info;
  14. gameparts

    PayPal WPP Direct Payments & Express Checkout Support

    I have register_globals on. At least that is the way it is set in my php.ini file.
  15. gameparts

    PayPal WPP Direct Payments & Express Checkout Support

    Need help with weird error: When customer uses Express Payments, he/she goes to Paypal to enter their info, and then is directed back to my webpage (checkout_payment.php), they then have to click the "continue" button, and then are taken to "checkout_payment.php?error_message=Please+select+a+payment+method+for+your+order." where it says "Please select a payment method for your order." message with a bright red border at the top of the page. What?????? However, if the customer processes their payment by logging in to my webpage, and entering their credit card info on my webpage (ie NOT using Paypal Express but payapl direct payment), it works fine, without a single problem! I have the latest OSCommerce, and the latest WPP Direct Mod. I am on Godaddy and have corrected the CURL problem. I have no other mods installed on my OSCommerce. In Paypal I have my return URL set to "http://www.everyinstruction.com/checkout_shipping.php?" but I also tried /checkout_confirmation.php?" with the same results. Please help!
  16. gameparts

    Automated FedEx Labels

    In addition to my post of erros above, also when I try to use the Automated Labels Module I get this error message: "This transaction could not be completed. Please note the error message below. ERROR: cURL ERROR: 1: libcurl was built with SSL disabled, https: not supported! unable to process ship_ground" Any help will be greatly appreciated. Thanks!
  17. gameparts

    Automated FedEx Labels

    I know this is more of a Fedex1.php problem, but you guys here are so good at this stuff and this is related to automated labels. I am now receiving this error as of Thur/Friday last week: "No response to CURL from Fedex server, check CURL availability, or maybe timeout was set too low, or maybe the Fedex site is down" I have changed absolutely nothing on my website in months. My hosting company claims to have changed nothing on my server in weeks with no updates, no modifications, nothing. So why all of a sudden am I getting this error? I tried deleting the meter ID and getting a new one by setting Meter ID to "NONE" but it never retrieves a new number from Fedex. For some reason the module is not communicating properly with Fedex. In debug mode all I get is this: Data sent to Fedex for Meter: 0,"211"10,"258793846"4003,"cmorgan"4007,"Vintage Game Store.com"4008,"asf"4009,"sdf"4011,"asf"4012,"CA"4013,"93313"4014,"US"4015,"3333333333"99,"" Data returned from Fedex for Meter: Nothing else! What happened??? Please help!!
  18. gameparts

    Automated FedEx Labels

    Thanks for the broken image fix!! I still have two concerns regarding other stuff. #1 I want to change my default delivery type to "Drop Off At BSC". I change that in the Fedex Control panel by setting that value to 4, but when I go to print the label, it has "Regular Pickup" as the default and I have to manually change that for each label. How do I change the default when the control panel setting makes no difference/doesn't seem to work? #2 How do I set the default shipping date to tomorrow's date instead of today's date, so I don't have to manually type in tomorrow's date every time? Thanks for all the help everyone does with this mod! I love it!! Charlie
  19. gameparts

    Automated FedEx Labels

    RE: Broken Image Error. I to now am experiencing this broken image error. I have all the latest updates. I've been running Fedex Labels for months now, and all of a sudden today I get broken png images. I am on the Production Server and have been for months. I have made absolutely NO changes to any of my files in weeks and it was working perfectly until today. I last successfully printed labels on Thursday evening. I can tell you this: It is not a browser problem, because when I go into my saved Fedex label files and export the png file (the fedex label) and then try to open it with Adobe Photoshop, it is a blank image....nothing on it. Also, if I go to display my old Fedex Labels, they do display WITHOUT problems. Soooo, Fedex must have changed something in the last few days that has created a communication problem in the Fedex Automated Labels mod. Please help!!!
  20. gameparts

    Automated FedEx Labels

    Dropoff Type Problem. I've installed all the mods including 1.07. I set the Dropoff Type to "4" (Drop at BSC) in the user module settings, but then when I go to the label setup screen for a particular shipment it has Dropoff Type as "Regular Pickup" (setting "1") as the default. It is not reading the user preference as I set up in the module. Any ideas? Thanks for your help. Charlie
  21. gameparts

    Automated FedEx Labels

    When trying to print a shipping label I get this error: ERROR: FedEx Return Error 1F30 : Recipient Phone must be 10 digits It happens when bozo customers put in weird stuff like / or * or other special characters instead of just numbers in the telephone number field. How do I filter those characters out just like it filters out ( ) and - ??? Where do I find that little piece of code? Thanks!
  22. gameparts

    Automated FedEx Labels

    No, unfortunately, they don't show up in your fedex.com shipping history. The only things that show up there are the shipments you created on the fedex.com website. The fedexdc.php shipments do show up on your bill though and on your online billing account with fedex eventually.
  23. gameparts

    Automated FedEx Labels

    Tracking Error: I have successfully shipped a package and get the tracking info correctly if I go to fedex.com to track it or if I hit the track button from the OSC order page. However, if I click on "track this shipment" as a customer on the order history page, "account_history_info.php", (after logging in as a customer) I get the following error: PACKAGE_ERRORFedEx Return Error 9982 : Invalid or missing Search Value. Looks like it is using "track_fedex.php". What is wrong that I am getting this error? Should I post my code for track_fedex.php? Thanks, Charlie
  24. gameparts

    Automated FedEx Labels

    Regarding certification. FYI, If you already have a Fedex Shipping manager account where you can print labels by logging into Fedex.com, you don't need to go through the certification process for fedexdc.php because your account is already on the production server! I just did it and sucessfully sent a package.
  25. gameparts

    Automated FedEx Labels

    Fabulous module! Two issues that apparently have not yet been resolved though: There are two issues in this Fedexdc.php string that I am particularly interested in getting resolved. Has anyone made any progress on these? 1. Fixing the cancel shipment so that it actually DOES cancel the shipment with Fedex? Also there was a problem with the date format for cancelling shipments. Anyone get that fixed? 2. Automatically emailing the customer the tracking number when a label is generated. I just generated a label to myself as the customer and the module didn't send me the tracking number via email. It is in the comments section of the order, but no email. Thanks! Charlie
×