Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Dacotah

Members
  • Content count

    44
  • Joined

  • Last visited

Everything posted by Dacotah

  1. 1. Andes1 answers this on page 3 of this thread. The confusing part is that the sql file wasn't actually included in the download I used. The command is: ALTER TABLE customers ADD fb_user_id VARCHAR(32); 2. Correct, your root directory, whatever that is. 3. I didn't have this issue, but they discuss it on page one. Whitespace is unseen tabs, line returns and spacebar spaces. Some text editors will let you view whitespace. In this case they are talking about the whitespace at the end of the file it looks like. Good Luck, and this extension works in my heavily modified store.
  2. You do have to enter your URL on your FB app. It is under the Web Site tab, fill in Site URL and Site Domain.
  3. Perfect! Simple and works well. Thanks Jason.
  4. Here is how to show a FB image, link and reminder on logoff.php for only those FB users. It does not log them out of FB, but redirects them so they can do so. In logoff.php, find and add the five "if" statement lines... $cart->reset(); //Facebook Connect include 'includes/classes/facebook.php'; include_once "fbconnect.php"; if ($fbme){ $fbuser = "<br><a href=\"http://www.facebook.com\"><img src=images/site/fb_logout.png></a><small> Remember to Logout out of Facebook if on a public computer.</small><br><br>"; } else { $fbuser = ""; } setcookie('fbs_'.$facebook->getAppId(), '', time()-100, '/', '.mydomain.com'); then add the line after infoBoxContents... <tr class="infoBoxContents"> <?php echo $fbuser; ?> and of course, edit your image path and upload your image to the appropriate directory. Here is the image I used... feel free to download.
  5. Thanks Andrea The link could either be just a simple link, or it could actually do a FB logout. I was hoping you had the code for the later. I think either would be ok, but I'll try to make the link show only if the customer is using FB Connect. My previous problem was just a stuck cookie. I used Developer Tools in Chrome to watch the cookie being created and deleted. Firefox has a similar plugin. So this is working just fine with PWA, Steve.
  6. So there is supposed to be a FB logout link in logout.php? Because mine is not showing. If it is not included in the contrib, can you share your code? There seems to be a lot of discussion on how to do this on non-osc forums. This is working with PWA as far as I can tell, but I seem to be having a cookie issue as sometimes I can log off FB and log off OSC... hit My Account and immediately be logged back in.
  7. So I need a new attribute_value_name column every time I want a new attribute? This will result in ten thousand columns, each of them used once since each attribute is unique and will only be used once. Just so I understand, in one attribute_value_name column, all entries in that column have to be identical?
  8. I'm testing EP on my dev server. I have a store with many attributes, and soon to be very many more since we need to add model numbers to each attribute. Products with a different attribute have a different model number, and I can't think of any other way to do it. Anyway, in the test upload file I have made a few changes and it seems to upload ok with the exception that it seems that in the attribute_value_name columns the names do not change unless I change the bottom entry of that column. I would like these columns to have all different attributes instead of being fill with "VHS" all the way down. I'd like them to have, for example, VHS 53789 then VHS 93848 under it and so on, so that in one attribute_value_name column each entry is different. Am I doing something wrong, or is this how it works? Thanks
  9. Dacotah

    Fundamental Easy Populate Problem

    This is what EasyPopulate is doing now on my dev server. I haven't gone live with it yet partially because of this. The partial downloads work for me, you might want to try that. In a different post I just read about the same problem, Mibble I believe, thought that the database was timing out. Possibly because of a large database. His suggestion was to use the partial downloads and splice them together. I know that isn't much help, but if you figure it out please post back.
  10. Dacotah

    Good commission-based CC acceptor??

    Thanks Chris. That confirms what I have been thinking, so last evening I bought an SSL cert and plan to get that up and running next which will give me a little more leway in deciding who to go with, plus it's a good idea anyway.
  11. Dacotah

    Good commission-based CC acceptor??

    Another little tidbit of info regarding PayPal is this... get the debit card and use that for your expenses. Then start an E-Bay account and sell something once every three weeks. It doesn't have to be much. Now you will receive 1.5% cash on all purchases made with the debit card and if you are using it to pay your supplier your cash rebate will be significant. My PayPal rate is 2.2% and everything we buy from our supplier goes onto the PayPal debit card thereby reducing each transaction cost to under 1%. Now for my own dilema, we're processing over $10k a month and I know I should get another gateway but I just can't let go of that <1% transaction cost. Plus I know if I add another I suspect over 50% of our sales will go to that payment process...I've heard it's about 70%. I suppose some could be made up with extra sales but I just don't know. Thoughts? Recommendations?
  12. Dacotah

    PayPal IPN doesn't include attributes

    That would work just fine for me. Could you post your ipn file? There are a lot of references to language and I'd much rather see a working file than start hacking myself (which I will do if I have to!) Thanks!
  13. Dacotah

    PayPal IPN doesn't include attributes

    I'm having this same problem and am having no luck in finding an answer. I actually tried the same thing you did, but haven't found the right combo yet. Anyone else?
  14. Dacotah

    Official PayPal IPN Support Thread

    OSC2.2 MS2 OSC PayPal IPN 12/20/2004 Exactly and it is a pain. Does anyone have this problem or better yet have a fix for it?
  15. Ok, that is the original OSC cache. Chemo's was installed and working. I didn't think so because I had 80 queries, then when I turned on the stock cache, it would drop to about 40. I reset the SEO Urls cache, reran the debug and seen I had 277 queries, refresh and it drops to 80 so it is working. Now to do something about that many queries...
  16. I've been using the SEO Ultimate Urls 2.0 for about a month and it is working very well. I just installed the Output Debug Queries contrib, and seen the the number of queries does not change if I refresh. Looks to me like the page cache wasn't working. So in the Admin -> Config -> Cache I set this to true and now it seems to be caching. I'd just like to confirm that this is where I can turn on and off Chemo's Page cache, or is this still the original cache?
  17. Dacotah

    Attribute Sets Contribution

    I ran into an issue today. I had about 90 products that had 5 attribute sets each. Four of the attribute sets were common to all 90 products. I edited one of the sets, just changed the name of an option, and it deleted all the attribute sets from all 90 products except for the one I edited. I then had to go back through all those products and reenter the sets. So obviously unless there is a fix, I don't dare change anything unless I want to reenter them all. Is there anyway to fix this in an upcoming release?
  18. Dacotah

    Attribute Sets Contribution

    Here's the full line on line# 703 : of /admin/products_attributes.php from the products_attributes.total_replacement.php file. $products_model_only = tep_get_products_model($attributes_values['products_id']);
  19. Dacotah

    Attribute Sets Contribution

    I'm using version 4 - Dec 27, 2004 release which is the latest.
  20. Dacotah

    Attribute Sets Contribution

    Ditto on this error exactly. Probably the way it is supposed to be, but I'd rather see a "This portion disabled by the Attributes Sets contrib" note instead of an error.
  21. Excellent, Bobby! 30 seconds max and it was fixed. A small (unfortunantely) donation coming your way. :thumbsup:
  22. I don't think I have enough sql experience to try #1 yet. So for option #2, I'm thinking I should disable the module, run install-seo.php and select uninstall. Then rerun it to do the install, and turn the module back on? This sound right? It's a live store. Thanks again
  23. Ok, my .htaccess didn't transfer correctly. Now the urls work just fine in redirect mode. Whew!!! I still have double listings in the Admin -> Configure panel. How can I get rid of the first one? I'm a new administrator on this site, and AFAIK there wasn't any SEO contribs installed previously. I checked to make sure SEF URLs was disabled before installing, and it said so, but maybe it had said SEO URls instead of SEF Urls? I'm confusing myself now. Thanks, Scott
  24. Hi all, I tried installing with the 2.0b Feb 7 release. I ended up with two listings of SEO URLs in the Admin Config. They both have the same added and modified date of today. When I enable the second listing, I can see it is changing the urls to .html however none of the urls exist. Enabling the first listing does nothing as far as I can tell. Since the second listing seems to be working, I changed to cName instead of Rewrite and it seems cName is working ok. Rewrite does not. I shut it back off. What do I need to check? Thanks, Scott
×