Jump to content

imagixx

Members
  • Content count

    96
  • Joined

  • Last visited

Posts posted by imagixx


  1. The only thing I've figured out so far is how to reproduce the error...

     

    Just change the gateway url (to anything) in the wsdl file - this will simulate "no reply" from the server.

     

    We needs some sort of if statement...but its beyond my skill...

     

    if ($client = "SoapFault") {

    echo "SoapFault: ";

     

    Is the best I could do...

     

    It would be preferred to disable the module wqhen the FedEx server is, for whatever reacxhable, not accessible. If someone could produce some code, it wopuld help out more than a few. Thanx.


  2. Ok, more talking to myself.

     

    To preserve paragraph breaks in your comment HTML status emails, in:

     

    $values=array(HTTP_CATALOG_SERVER,STORE_NAME,STORE_OWNER_EMAIL_ADDRESS, $name, $email_address, EMAIL_TEXT_SUBJECT, $order_no , $order_date, $status_newhtml , $status_newtxt, nl2br($comments), $invoice_url, EMAIL_SEPARATOR);

     

    added nl2br() to $comments. But this also adds html to your text message. So, strip html out of your text email as follows, in:

     

    tep_mm_sendmail($check_status['customers_name'], $check_status['customers_email_address'], STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, $output_subject, $output_content_html, strip_tags($output_content_txt));

     

    Added strip_tags() to $output_content_txt.

     

    You've been very helpful. Thank you! (Yes, I know, teach a man to fish.)


  3. Anyone here at all? This forum doesn't seem to be monitored. In any even, I'll cast this to the wind: Does anyone know how to keep paragraph breaks in the html email sent by status_update.php ? The comments all run together in HTML. Text outpuit retains the paragraph breaks.


  4. For anyone using Manual Order Entry, http://addons.oscommerce.com/info/1589

     

    Replace where necesary in file admn/create_account_process.php

     

    This generastes two emails, one for new password.

     

    //*******start mail manager

    if (file_exists(DIR_FS_CATALOG_MODULES.'mail_manager/create_account.php')){

    include(DIR_FS_CATALOG_MODULES.'mail_manager/password_forgotten.php');

    include(DIR_FS_CATALOG_MODULES.'mail_manager/create_account.php');

    }else{

    $email_text .= EMAIL_WELCOME . EMAIL_PASS_1 . $new_password . EMAIL_PASS_2 . EMAIL_TEXT . EMAIL_CONTACT . EMAIL_WARNING;

    tep_mail($name, $email_address, EMAIL_SUBJECT, $email_text, STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS);

    }

    tep_redirect(tep_href_link(FILENAME_CREATE_ACCOUNT_SUCCESS."?Customer=$customer_id", '', 'SSL'));

    }

    //*******end mail manager

     

    You need also to add, define in your admin/includes/languages/english/create_account_process.php:

     

    define('EMAIL_PASSWORD_REMINDER_SUBJECT', STORE_NAME . ' - New Password');

    define('EMAIL_PASSWORD_REMINDER_BODY', 'A new password was requested from ' . $REMOTE_ADDR . '.' . "\n\n" . 'Your new password to \'' . STORE_NAME . '\' is:' . "\n\n" . ' %s' . "\n\n");

     

    Works like a charm.

     

    Now have to figure out new order ...


  5. Hi Sam,

     

    Getting about 200+ these errors:

     

    Warning: strpos() [function.strpo: Empty delimiter in /path_to_admin/includes/functions/backup_site_functions.php on line 28

     

    before your report:

    Website size: 193.3 MB Estimated compressed file size: 131.44 MB Containing 291 folders with 12450 Files.

     

    Thanx.

     

    Martin

     

    I just added @ in

     

    foreach ($exclude as $remove) if (@strpos($dir_name.'/'.$file.'/', $remove) === 0 ) continue 2;

     

    which stopped the error. Donlt know if I merely cut the oil pressure light, leaving the unmderlying problem.

     

    Thanx.

     

    Martin


  6. yes, that's what I meant. The Real Time Quotes API module still works for most of the backend, just not the shipping rates.

     

    I do think that there's a way to cannibalize the old module and use the parts that currently work. If anyone would like to point me in the right direction (files, snippets of code), I will take a crack at improving this module.

     

    I think you'tre mistaken. I get only broken images for labels. Let me know if you have any luck. I am having to manually complete FedEx labels = a big PITA.


  7. post to the contributions!, or if its simple mods, post it here. Thanks for the efforts!

     

    Yes, please post to the contribution: http://www.oscommerce.com/community/contributions,2244

     

    You would be helping a lot of people. I'm surprised I haven;lt yet found a fix. It would save me some money, too, since I have it our for bid at: http://www.freelancer.com/projects/PHP-Javascript/Fedex-Automated-Label-for-oscommerce.1685280.html

     

    I'd post it for free.

     

    Thx.

     

    Martin


  8. Fixing 2 digit state.

     

    Add below //directory where all support files are

     

    //Gets the return & billing address two digit state code

    $shipping_zone_query = tep_db_query("select z.zone_code from " . TABLE_ZONES . " z, " . TABLE_COUNTRIES . " c where zone_name = '" . $order->delivery['state'] . "' AND c.countries_name = '" . $order->delivery['country'] . "' AND c.countries_id = z.zone_country_id");

    $shipping_zone = tep_db_fetch_array($shipping_zone_query);

    $shipping_zone_code = ($shipping_zone['zone_code'] == '' ? $order->delivery['state'] : $shipping_zone['zone_code']); // if the query result was empty, then use the state name

    if ($order->billing['state'] == $order->delivery['state']) { // if billing and shipping states are the same, then we can save a query

    $billing_zone_code = $shipping_zone_code;

    } else {

    $billing_zone_query = tep_db_query("select z.zone_code from " . TABLE_ZONES . " z, " . TABLE_COUNTRIES . " c where z.zone_name = '" . $order->billing['state'] . "' AND c.countries_name = '" . $order->billing['country'] . "' AND c.countries_id = z.zone_country_id");

    $billing_zone = tep_db_fetch_array($billing_zone_query);

    $billing_zone_code = ($billing_zone['zone_code'] == '' ? $order->billing['state'] : $billing_zone['zone_code']); // if the query result was empty, then use the state name

    }

     

    Replace

    <input type="hidden" name="form.deliveryState" value= "<?php echo $order->delivery['state'];?>" id="stateTo">

     

    With

    //State

    <input type="hidden" name="form.deliveryState" value= "<?php echo $shipping_zone_code;?>" id="stateTo">

     

    I haven't figured out the result if country is not us. But this fixes the immediate problem.


  9. OK, just add to uspslabelfix.php below global $db;

     

    require('includes/application_top.php');

    $oID = (int)tep_db_prepare_input($HTTP_GET_VARS['oID']);

    include(DIR_WS_CLASSES . 'order.php');

    $order = new order($oID);

     

    rename uspslabelfix.php usps_ship.php, drop into your admin folder, and you got the imported data.

     

    Now, to try my meager skills at fixing the two letter state.


  10. Thjis is a bog USPS f-up. No wonder they are going broke, an apparent lack of any customer consideration. What A-holes. I assume there are a lot of people that this will affect. Hope a fix comes soon. This seriously affects our business - but what does USPS care?


  11. I'm upgrading to Order Editor 5.061 from 2.9.1. I used Admin Comments Toolbar 4.0 extensively, and dread having to manually type each repetitive comment over and over again. Now, with the ability to edit the comments in 5.061, Admin Comments Toolbar puts its remarks into the first comments field. Naturally I want it to add it only to the New Comments textarea.

     

    I know its simply a matter vof identifying the appropriate field, but I have zip knowledge on dcument elements. Admin Toolbar seems fairly popular, and I'm sure the issue has been solved. But, I can't seem to find the specifics. Any help here?

     

    All Right, I'm thinking out loud. How do I designate the last element in the textareas array? If you change

     

    var myTextarea = textareas.item(0);

     

    you can designate the textarea where the comment will be placed:

     

    var myTextarea = textareas.item(5);

     

    will put it in the last textarea (if you have 3 comments 0, 1, 2, 3).

     

    So, how do I designate the last element number?

     

    TIA

     

    Martin


  12. I'm upgrading to Order Editor 5.061 from 2.9.1. I used Admin Comments Toolbar 4.0 extensively, anmd dread having to manually type each repetitive comment over and over again. Now, with the ability to edit the comments in 5.061, Admin Comments Too;lbar ptts its remarks into the first comments field. Naturally I want it to add it only to the New Comments textarea.

     

    I know its simply a matter vof identifying the appropriate field, but I have zip knowledge on dcument elements. Admin Toolbar seems fairly popular, and I'm sure the issue has been solved. But, I can't seem to find the specifics. Any help here? Martin

×