Jump to content

imagixx

Members
  • Content count

    96
  • Joined

  • Last visited

Everything posted by imagixx

  1. imagixx

    [contribution] Super Download Store

    I think there's a misunderstanding in communication here. I have a product and want to make a download available for that product. I'm at the admin/products_attributes.php page When I edit the product's attribute, the correct group is there, but the filename indicates: Group_Files-1 The file that I would like to make available within the group is not there; the filename is NOT retrieved and NOT retained when I try to include a download to a product with a group selected. However, if No File Group is elected, a filenanme can be entered, and is properly recalled when I come back to edit. Martin
  2. imagixx

    [contribution] Super Download Store

    OK, I got that. But when you assign an download to an attribute, I assume the way it works, you should have a scroll list of the files available as previously entered in the FileGroups. Instead of that list, you have only "Group_Files-1" in the box where the name of the file should be. I assume it's trying to call Group_Files-1. There's no choice for a file selection. Works fine if No File Group is the choice. I'll get this. Thanks for you patience. Martin
  3. imagixx

    [contribution] Super Download Store

    Here's my PhpAdmin for the table: Full Texts products_attributes_id products_attributes_filename products_attributes_filegroup_id products_attributes_maxdays products_attributes_maxcount Edit Delete 59 DD214_TRG.pdf 0 7 5 Edit Delete 58 201_TRG.pdf 0 3 3 Edit Delete 61 Group_Files-1 1 7 5 Doesn't the filename belong in products_attributes_filename, rather than Group_Files-1? Martin
  4. imagixx

    [contribution] Super Download Store

    Isn't the filename and group associated with the product at that point? I have the groups, filenames associated with within each group. I can't associate a group filename with a product. Martin
  5. imagixx

    [contribution] Super Download Store

    In other words, when I go to edit, update or change the filename, it pulls Group_Files-1 or Group_Files-2, rather than sowing a filename associated with that product if the Group is other than 0. At zero, the proper filename is returned. M
  6. imagixx

    [contribution] Super Download Store

    This is when I'm attaching attributes to products, a download file to a product when I'm at admin/products_attributes.php It has nothing to do whatsoever with checkout_process.php. I'm nowhere near there, yet ;-) Your products_attributes puts the name "Group_Files-1" or "Group_Files-2," whichever I choose for the specific file - instead of the actual filename - into your table products_attributes_downloads when the Group is not 0. When its 0 (no file group) the proper filename is entered. Cheers, Martin
  7. imagixx

    [contribution] Super Download Store

    I'm still installing this contrib. When I attempt to associate a download into a group (yes, the groups are there, files within their respective group directories within download directory all chmoded 777, all files indicated in the respective groups - thew filename will not be posted to the products attributes_download table, but only Group_Files-1 or Group_Files-2 is entered. This, of course, is returned when I attempt to edit the respective filename - as the filename. It does work, however, if no filegroup is selected. I'm using the products_attributes.php from your contrib unchanged in your most recent release. Any suggestions? Martin
  8. imagixx

    [contribution] Super Download Store

    Did that twice BEFORE posting here. I manually updated the Table: products_attributes_download with the correct filenames. I put the old download.php back, and at least we have the downloads. I think I can add a download, but also add another attribute such as differences in fees for shipping (without a related download) which, I believe, will make it non-virtual in osCommerce's mind. I think I had it working the way I wanted when I did that accidentally. Now I really got to get to bed. Thanx. Regards. Martin
  9. imagixx

    [contribution] Super Download Store

    On the same problem, the Table: products_attributes_download is not updating with the correct file name.
  10. imagixx

    [contribution] Super Download Store

    Geesh. New Problem. I get a blank page when clicking my Download Link. My phpAdmin has the proper groups and correctly spelled filenames. (Yes, I read this list before posting.) I did notice that, although my DB appears to be correct, when I go back to the webpage products_attributes.php all the filenames say "Group_Files-1" and not the filename that I entered and which is in the DB. Any help would be welcome, particularly on my live store. I'm also missing the filenames, file sizes and nice fancy download buttons that you have on your success page. I'm sure the problem is related. TIA Martin PS I think its time to hit the sack - a whole day on this.
  11. imagixx

    [contribution] Super Download Store

    OK, IGNORE ABOVE PREVIOUS POST; it was an ID 10 T problem. It was a define directory issue :blush: However, now that I'm up and running, how do I get osCommerce to recognize my products as non-virtual, to have a shipping address in the Invoice and Packing Slip? TIA
  12. imagixx

    [contribution] Super Download Store

    Hello all, I'm trying to install this contrib to do away with the lack of a shipping address in invoices. I provide a document delivery service. Once payment is received, the customer downloads a PDF Instruction/Form file. I receive the signed Instruction/Form file and ultimately send them their documents via FedEx. To get a FedEX Label, the invoice requires a shipping address which is absent because, as I understand it, downloads mark the product as "virtual" and, therefore, as far as osCommerce is concerned, since it's only a mere download, shipping is not required. I'm sure its some other mod that's interfering, but I have to start somewhere. Here's the error: "1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'MAX_ROW_LISTS_OPTIONS' at line 1 select * from products_options where language_id = '1' order by products_options_id LIMIT 0, MAX_ROW_LISTS_OPTIONS [TEP STOP] HEADING_TITLE_OPT Warning: Division by zero in /home/blahcom/public_html/catalog/admin/products_attributes.php on line 452 >> " Any help? TIA (I'm sure it's an ID 10 T problem, related to a PEBKAC situation.) Regards, Martin
  13. imagixx

    FedEx Direct 2.06 Support thread

    OK I think its a FedEx certification issue, Test Server whatnot thing. RTFMS Yes, call FedEx to set you up on their test server. So, please ignore for the time being. If there's a problem, I'll be back. Thanx.
  14. imagixx

    Automated FedEx Labels

    OK I think its a FedEx certification issue, Test Server whatnot thing. RTFMS Yes, call FedEx to set you up on their test server. So, please ignore for the time being. If there's a problem, I'll be back. Thanx.
  15. imagixx

    Automated FedEx Labels

    Hello all, What I'd like to do is get labels from FedEx without having to manually transpose the information for each order (what a drag). FedEx Labels seemed to be the ideal solution. My prices include shipping, so we don't seek shipping rate info for our orders. We just use FedEx envelops, shipping only documents, nextday, second day. Most of our requests are shipped FedEx. (We use USPS Priority Mail for one week delivery - that I'll do manually for the time being.) I first installed FedEx Labels 2.0. Of course, after running that, I noticed that Real Time Quotes is required. Duh. I then installed Fedex Real Time Quotes 2.07. Now, when I attempt a "ship" so that I can acquire a label (with default shipping parameters, FedEx Home Delivery), I get: ERROR: FedEx Return Error 110A : The login failed if I change the delivery to Standard Overnight, I get: ERROR: FedEx Return Error 803E : Recipient name and/or company required. Naturally, I don't know whether this is a Real Time Quotes issue, or a FedEx Label issue - or both. Is there something else I have to install? Any help would be appreciated. TIA. Martin
  16. imagixx

    FedEx Direct 2.06 Support thread

    Hello all, What I'd like to do is get labels from FedEx without having to manually transpose the information for each order (what a drag). FedEx Labels seemed to be the ideal solution. My prices include shipping, so we don't seek shipping rate info for our orders. We just use FedEx envelops, shipping only documents, nextday, second day. Most of our requests are shipped FedEx. (We use USPS Priority Mail for one weeek delivery - that I'll do manually for the time being.) I first installed FedEx Labels 2.0. Of course, after running that, I noticed that Real Time Quotes is required. Duh. I then installed Fedex Real Time Quotes 2.07. Now, when I attempt a "ship" so that I can acquire a label (with default shipping parameters, FedEx Home Delivery), I get: ERROR: FedEx Return Error 110A : The login failed if I change the delivery to Standard Overnight, I get: ERROR: FedEx Return Error 803E : Recipient name and/or company required. Naturally, I don't know whether this is a Real Time Quotes issue, or a FedEx Label issue - or both. Is there something else I have to install? Any help would be appreciated. TIA. Martin
  17. Your suggested replacement code worked, and fixed the problem. My zones weren't touched; they worked fine prior to and after your code replacement. Care to explain? Thanx for this very nice contrib. Martin
  18. Just upgraded to 3.0. Admin works fine, Created test coupon. When I enter the coupon code, I get the mySQl error: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'or z2g.zone_id = 0 or z2g.zone_id IS NULL ) ' at line 5 SELECT dc2z.geo_zone_id FROM discount_coupons_to_zones dc2z LEFT JOIN zones_to_geo_zones z2g USING( geo_zone_id ) WHERE ( z2g.zone_id= or z2g.zone_id = 0 or z2g.zone_id IS NULL ) AND ( z2g.zone_country_id= or z2g.zone_country_id = 0 ) AND dc2z.coupons_id="M2EZTC" Where did I go wrong? Martin >_<
  19. Hello All, I don't know whether this has been fixed, or not. But when you have a negative number for a product's option, this contrib adds the corresponding positive amount. For example, with a selection of a product's option, $4 is DEDUCTED, but this contrib adds $4.00. Negative value options work fine in the normal ordering process. It's not a big deal because I'm using this contrib for auctions, so I'm changing the pricing anyway. Also, after I've created the account and get a default Payment Method, when I update the Payment Method, I get: Warning: Invalid argument supplied for foreach() in /home/catalog/xxAdmin/edit_orders.php on line 222 Warning: Cannot modify header information - headers already sent by (output started at /home/catalog/xxAdmin/edit_orders.php:222) in /home/catalog/xxAdmin/includes/functions/general.php on line 18 The Payment Method IS updated when I click the back button, but it's just the "unpolished" effect. No big deal either. I think this is an important contrib, providing essential functionality. This is a diamond, but still "in the rough." Thanks.
  20. Hello all, I just installed your contribution step-by-step manual entry. I can manually add customers and orders. It all works fine ... except. I have one download product. Now, with every order for, say a hat, each Order Confirmation Page for every product includes a link, example "hat," that links to my download item!!! Any suggestions???? Marty
  21. Hello all, I just installed your contribution step-by-step. I can manually add accounts and orders. It all works fine ... except. I have one download product. Now, with every order for, say a hat, each Order Confirmation Page for every product includes a link, example "hat," that links to my download item!!! Any suggestions???? Marty
×